Update to new upstream.
Drop gcj. Rebuild docs.
This commit is contained in:
parent
4198983c0f
commit
3f098e5a69
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
xmlunit1.0.zip
|
xmlunit1.0.zip
|
||||||
|
xmlunit-1.3-src.zip
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
4f03206acc9ed18bc6cc23fd38b4fc82 xmlunit1.0.zip
|
8b23f360367f18f393559dc2f0640dbe xmlunit-1.3-src.zip
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- build.xml.orig 2007-03-12 21:31:05.000000000 -0400
|
|
||||||
+++ build.xml 2007-03-12 21:31:54.000000000 -0400
|
|
||||||
@@ -25,7 +25,7 @@
|
|
||||||
|
|
||||||
<target name="compile" depends="init">
|
|
||||||
<mkdir dir="${out.dir}"/>
|
|
||||||
- <javac srcdir="${src.dir}/java:${test.dir}/java" destdir="${out.dir}" debug="on" target="1.2">
|
|
||||||
+ <javac srcdir="${src.dir}/java:${test.dir}/java" destdir="${out.dir}" debug="on" target="1.2" source="1.2">
|
|
||||||
<classpath>
|
|
||||||
<pathelement location="${xmlxsl.lib}"/>
|
|
||||||
<pathelement location="${junit.lib}"/>
|
|
||||||
@@ -78,7 +78,7 @@
|
|
||||||
<mkdir dir="${docs.dir}"/>
|
|
||||||
<delete includeEmptyDirs="true" dir="${docs.dir}/org"/>
|
|
||||||
<javadoc destdir="${docs.dir}"
|
|
||||||
- overview="${src.dir}/java/overview.html"
|
|
||||||
+ source="1.4"
|
|
||||||
windowtitle="XMLUnit Documentation"
|
|
||||||
footer="<p><a href="http://xmlunit.sourceforge.net/">XMLUnit</a> is hosted by sourceforge.net</p>">
|
|
||||||
<group title="XMLUnit v${xmlunit.version}"
|
|
81
xmlunit.spec
81
xmlunit.spec
@ -28,17 +28,14 @@
|
|||||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
#
|
#
|
||||||
|
|
||||||
%define gcj_support 1
|
|
||||||
|
|
||||||
Name: xmlunit
|
Name: xmlunit
|
||||||
Version: 1.0
|
Version: 1.3
|
||||||
Release: 8.3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Summary: Provides classes to do asserts on xml
|
Summary: Provides classes to do asserts on xml
|
||||||
License: BSD
|
License: BSD
|
||||||
Source0: http://download.sourceforge.net/xmlunit/xmlunit1.0.zip
|
Source0: http://downloads.sourceforge.net/project/xmlunit/xmlunit%20for%20Java/XMLUnit%20for%20Java%201.3/xmlunit-1.3-src.zip
|
||||||
Source1: http://repo1.maven.org/maven2/xmlunit/xmlunit/1.0/xmlunit-1.0.pom
|
Source1: http://repo1.maven.org/maven2/xmlunit/xmlunit/1.0/xmlunit-1.0.pom
|
||||||
Patch0: xmlunit-build_xml.patch
|
|
||||||
URL: http://xmlunit.sourceforge.net/
|
URL: http://xmlunit.sourceforge.net/
|
||||||
BuildRequires: jpackage-utils >= 0:1.7.3
|
BuildRequires: jpackage-utils >= 0:1.7.3
|
||||||
BuildRequires: java-devel >= 1.4.2
|
BuildRequires: java-devel >= 1.4.2
|
||||||
@ -49,21 +46,14 @@ BuildRequires: junit >= 0:3.8.1
|
|||||||
BuildRequires: xalan-j2
|
BuildRequires: xalan-j2
|
||||||
BuildRequires: xerces-j2
|
BuildRequires: xerces-j2
|
||||||
BuildRequires: xml-commons-apis
|
BuildRequires: xml-commons-apis
|
||||||
|
BuildRequires: dblatex
|
||||||
|
BuildRequires: docbook5-style-xsl
|
||||||
Requires: junit >= 0:3.8
|
Requires: junit >= 0:3.8
|
||||||
Requires: xalan-j2
|
Requires: xalan-j2
|
||||||
Requires: xml-commons-apis
|
Requires: xml-commons-apis
|
||||||
Requires: jaxp_parser_impl
|
|
||||||
Requires: jpackage-utils
|
Requires: jpackage-utils
|
||||||
Group: Development/Testing
|
Group: Development/Tools
|
||||||
%if ! %{gcj_support}
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%endif
|
|
||||||
%if %{gcj_support}
|
|
||||||
BuildRequires: java-gcj-compat-devel
|
|
||||||
Requires(post): java-gcj-compat
|
|
||||||
Requires(postun): java-gcj-compat
|
|
||||||
%endif
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
XMLUnit extends JUnit to simplify unit testing of XML. It compares a control
|
XMLUnit extends JUnit to simplify unit testing of XML. It compares a control
|
||||||
@ -73,42 +63,43 @@ expressions.
|
|||||||
|
|
||||||
%package javadoc
|
%package javadoc
|
||||||
Summary: Javadoc for %{name}
|
Summary: Javadoc for %{name}
|
||||||
Group: Development/Documentation
|
Group: Documentation
|
||||||
Requires: jpackage-utils
|
Requires: jpackage-utils
|
||||||
|
|
||||||
%description javadoc
|
%description javadoc
|
||||||
Javadoc for %{name}
|
Javadoc for %{name}
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}
|
%setup -q
|
||||||
# remove all binary libs and javadocs
|
# remove all binary libs and javadocs
|
||||||
find . -name "*.jar" -exec rm -f {} \;
|
find . -name "*.jar" -exec rm -f {} \;
|
||||||
rm -rf doc
|
rm -rf doc
|
||||||
|
rm -rf userguide
|
||||||
|
|
||||||
cat >build.properties <<EOF
|
cat >build.properties <<EOF
|
||||||
junit.lib=$(build-classpath junit)
|
junit.lib=$(build-classpath junit)
|
||||||
xmlxsl.lib=$(build-classpath xalan-j2 xerces-j2)
|
xmlxsl.lib=$(build-classpath xalan-j2 xalan-j2-serializer xerces-j2)
|
||||||
test.report.dir=test
|
test.report.dir=test
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
%patch0
|
cat >docbook.properties <<EOF
|
||||||
|
db5.xsl=%{_datadir}/sgml/docbook/xsl-ns-stylesheets
|
||||||
|
EOF
|
||||||
|
|
||||||
#Fix wrong-file-end-of-line-encoding
|
#Fix wrong-file-end-of-line-encoding
|
||||||
sed -i 's/\r//g' README.txt example.html LICENSE.txt
|
sed -i 's/\r//g' README.txt LICENSE.txt
|
||||||
|
|
||||||
%build
|
%build
|
||||||
ant -Dbuild.compiler=modern jar test docs
|
export CLASSPATH=$(build-classpath xalan-j2-serializer)
|
||||||
|
ant -Dbuild.compiler=modern -Dfailonerror=false jar docs
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
install -m 0644 lib/%{name}%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
install -m 0644 build/lib/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||||
%add_to_maven_depmap %{name} %{name} %{version} JPP %{name}
|
%add_to_maven_depmap %{name} %{name} %{version} JPP %{name}
|
||||||
|
|
||||||
# Jar versioning
|
|
||||||
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
|
||||||
# poms
|
# poms
|
||||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
|
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
|
||||||
|
|
||||||
@ -118,53 +109,33 @@ install -m 644 %{SOURCE1} \
|
|||||||
|
|
||||||
# Javadoc
|
# Javadoc
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||||
cp -pr doc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
cp -pr build/doc/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||||
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
|
||||||
%if %{gcj_support}
|
|
||||||
export CLASSPATH=$(build-classpath gnu-crypto)
|
|
||||||
%{_bindir}/aot-compile-rpm
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%update_maven_depmap
|
%update_maven_depmap
|
||||||
%if %{gcj_support}
|
|
||||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
|
||||||
then
|
|
||||||
%{_bindir}/rebuild-gcj-db
|
|
||||||
fi
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%update_maven_depmap
|
%update_maven_depmap
|
||||||
%if %{gcj_support}
|
|
||||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
|
||||||
then
|
|
||||||
%{_bindir}/rebuild-gcj-db
|
|
||||||
fi
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(0644,root,root,0755)
|
%defattr(-,root,root,-)
|
||||||
%{_javadir}/*
|
%{_javadir}/*
|
||||||
%doc README.txt LICENSE.txt XMLUnit.pdf example.html
|
%doc README.txt LICENSE.txt build/doc/userguide/XMLUnit-Java.pdf
|
||||||
%{_datadir}/maven2/poms/*
|
%{_datadir}/maven2/poms/*
|
||||||
%{_mavendepmapfragdir}/*
|
%{_mavendepmapfragdir}/*
|
||||||
%if %{gcj_support}
|
|
||||||
%dir %attr(-,root,root) %{_libdir}/gcj/%{name}
|
|
||||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-%{version}.jar.*
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%files javadoc
|
%files javadoc
|
||||||
%defattr(0644,root,root,0755)
|
%defattr(-,root,root,-)
|
||||||
%doc %{_javadocdir}/%{name}-%{version}
|
%doc %{_javadocdir}/%{name}-%{version}
|
||||||
%doc %{_javadocdir}/%{name}
|
%doc %{_javadocdir}/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-1
|
||||||
|
- Update to new upstream.
|
||||||
|
- Drop gcj.
|
||||||
|
- Rebuild docs.
|
||||||
|
|
||||||
* Thu Mar 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:1.0-8.3
|
* Thu Mar 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:1.0-8.3
|
||||||
- Added missing Requires jpackage-utils
|
- Added missing Requires jpackage-utils
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user