Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/xmlunit.git#6a4380595912b75c352bb3bdd79f4fd6e3e81961
This commit is contained in:
parent
184c04e812
commit
10734f2285
12
xmlunit-2.7.0-ValueAssertTest-fix.patch
Normal file
12
xmlunit-2.7.0-ValueAssertTest-fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru ../xmlunit-2.7.0-src.ORIG/xmlunit-assertj/src/test/java/org/xmlunit/assertj/ValueAssertTest.java ./xmlunit-assertj/src/test/java/org/xmlunit/assertj/ValueAssertTest.java
|
||||
--- ../xmlunit-2.7.0-src.ORIG/xmlunit-assertj/src/test/java/org/xmlunit/assertj/ValueAssertTest.java 2020-04-28 03:09:04.000000000 -0500
|
||||
+++ ./xmlunit-assertj/src/test/java/org/xmlunit/assertj/ValueAssertTest.java 2021-01-29 13:24:38.101158331 -0600
|
||||
@@ -263,7 +263,7 @@
|
||||
@Test
|
||||
public void testIsEqualTo_withAttributeValueExpression_shouldFailed() {
|
||||
|
||||
- thrown.expectAssertionError("expected:<\"[something]\"> but was:<\"[abc]\">");
|
||||
+ thrown.expectAssertionError("Expecting:%n <\"abc\">%nto be equal to:%n <\"something\">%nbut was not.");
|
||||
|
||||
String xml = "<a><b attr=\"abc\"></b></a>";
|
||||
|
11
xmlunit.spec
11
xmlunit.spec
@ -32,7 +32,7 @@ Name: xmlunit
|
||||
Summary: Provides classes to do asserts on xml
|
||||
Epoch: 0
|
||||
Version: 2.7.0
|
||||
Release: 4%{?dist}
|
||||
Release: 6%{?dist}
|
||||
# xmlunit2 is licensed under ASL 2.0, xmlunit-legacy is still BSD-licensed
|
||||
License: ASL 2.0 and BSD
|
||||
|
||||
@ -40,6 +40,7 @@ URL: https://www.xmlunit.org/
|
||||
Source0: https://github.com/xmlunit/xmlunit/releases/download/v%{version}/%{name}-%{version}-src.tar.gz
|
||||
|
||||
Patch0: 0001-Disable-tests-requiring-network-access.patch
|
||||
Patch1: xmlunit-2.7.0-ValueAssertTest-fix.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -109,6 +110,7 @@ This package provides %{summary}.
|
||||
%setup -q -n %{name}-%{version}-src
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%pom_remove_plugin org.codehaus.mojo:buildnumber-maven-plugin
|
||||
%pom_remove_plugin :maven-assembly-plugin
|
||||
@ -141,6 +143,13 @@ This package provides %{summary}.
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 29 2021 Merlin Mathesius <mmathesi@redhat.com> - 0:2.7.0-6
|
||||
- Fix FTBFS by patchng ValueAssertTest to adjust for changed format of
|
||||
mismatched string exception
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user