fix cleaning up of temporary files with libpaper(Debian), fix xmllint
postvalid (added noent option), use nonet switch
This commit is contained in:
parent
3075a2307b
commit
fd7c5ff93c
28
xmlto-libpaper.patch
Normal file
28
xmlto-libpaper.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2009-01-28 12:32:29.000000000 +0100
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-01-28 12:35:10.000000000 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
#!@BASH@
|
||||
-#
|
||||
+#
|
||||
# @PACKAGE@ - apply an XSL stylesheet to an XML document
|
||||
# Copyright (C) 2001, 2002, 2003 Tim Waugh <twaugh@redhat.com>
|
||||
|
||||
@@ -106,6 +106,8 @@ then
|
||||
if [ -n "$paperheight" -a -n "$paperwidth" ]
|
||||
then
|
||||
papersizemod=$(${MKTEMP} ${TMPDIR:-/tmp}/@PACKAGE@-xsl.XXXXXX)
|
||||
+ CLEANFILES[$CLEANFILE_COUNT]="$papersizemod"
|
||||
+ CLEANFILE_COUNT=$(($CLEANFILE_COUNT + 1))
|
||||
cat << EOF > "$papersizemod"
|
||||
<?xml version='1.0'?>
|
||||
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
@@ -337,8 +339,6 @@ case "$DEST_FORMAT" in
|
||||
fo | pdf | ps | dvi)
|
||||
if [ -n "$papersizemod" ]
|
||||
then
|
||||
- CLEANFILES[$CLEANFILE_COUNT]="$papersizemod"
|
||||
- CLEANFILE_COUNT=$(($CLEANFILE_COUNT + 1))
|
||||
XSL_MODS[$XSL_MOD_COUNT]="$papersizemod"
|
||||
XSL_MOD_COUNT=$(($XSL_MOD_COUNT + 1))
|
||||
fi
|
16
xmlto-xmllintoptions.patch
Normal file
16
xmlto-xmllintoptions.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2009-01-28 12:51:19.000000000 +0100
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-01-28 12:54:35.000000000 +0100
|
||||
@@ -427,8 +427,10 @@ if [ "$SKIP_VALIDATION" -eq 0 ] && [ "$S
|
||||
then
|
||||
VALIDATION="${XSLT_PROCESSED_DIR}/validation-errors"
|
||||
[ "$VERBOSE" -ge 1 ] && \
|
||||
- echo >&2 "xmllint >/dev/null --xinclude --postvalid \"$INPUT_FILE\""
|
||||
- xmllint >/dev/null --xinclude --postvalid "$INPUT_FILE" 2>"${VALIDATION}"
|
||||
+ echo >&2 \
|
||||
+ "xmllint >/dev/null --nonet --xinclude --postvalid --noent \"$INPUT_FILE\""
|
||||
+ xmllint >/dev/null --nonet --xinclude --postvalid --noent \
|
||||
+ "$INPUT_FILE" 2>"${VALIDATION}"
|
||||
xmllint_status=$?
|
||||
if [ $xmllint_status -ne 0 ]
|
||||
then
|
11
xmlto.spec
11
xmlto.spec
@ -1,7 +1,7 @@
|
||||
Summary: A tool for converting XML files to various formats
|
||||
Name: xmlto
|
||||
Version: 0.0.21
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
#xmlto is released under GPLv2+ license, xmlif under GPL+ license
|
||||
License: GPLv2+ and GPL+
|
||||
Group: Applications/System
|
||||
@ -11,6 +11,8 @@ Group: Applications/System
|
||||
URL: https://fedorahosted.org/xmlto/
|
||||
Source0: https://fedorahosted.org/releases/x/m/%{name}/%{name}-%{version}.tar.bz2
|
||||
Patch0: xmlto-stringparam.patch
|
||||
Patch1: xmlto-libpaper.patch
|
||||
Patch2: xmlto-xmllintoptions.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -45,6 +47,8 @@ PassiveTeX/TeX for functionality.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .stringparam
|
||||
%patch1 -p1 -b .libpapercleanup
|
||||
%patch2 -p1 -b .xmllintoptions
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -77,6 +81,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/xmlto/format/fo/pdf
|
||||
|
||||
%changelog
|
||||
* Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> - 0.0.21-6
|
||||
- fix cleaning up of temporary files with libpaper(Debian)
|
||||
- fix xmllint postvalid (added noent option), use nonet
|
||||
switch
|
||||
|
||||
* Mon Jan 05 2009 Ondrej Vasik <ovasik@redhat.com> - 0.0.21-5
|
||||
- fix stringparam option functionality
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user