Apply upstream patches to support building in stricer C99 mode
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
07c2956e53
commit
571fc033c0
26
xmlto-c99-1.patch
Normal file
26
xmlto-c99-1.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
commit 1375e2df75530cd198bd16ac3de38e2b0d126276
|
||||||
|
Author: Thomas Kuehne <thomas@kuehne.cn>
|
||||||
|
Date: Sat Dec 11 21:10:41 2021 +0100
|
||||||
|
|
||||||
|
fix -Wimplicit-int for ifsense
|
||||||
|
|
||||||
|
fixes:
|
||||||
|
xmlif/xmlif.l:46:8: warning: type defaults to ‘int’ in declaration of ‘ifsense’ [-Wimplicit-int]
|
||||||
|
46 | static ifsense; /* sense of last `if' or unless seen */
|
||||||
|
| ^~~~~~~
|
||||||
|
|
||||||
|
Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
|
||||||
|
|
||||||
|
diff --git a/xmlif/xmlif.l b/xmlif/xmlif.l
|
||||||
|
index ac421367d47a2cd4..6e5970e147be21b1 100644
|
||||||
|
--- a/xmlif/xmlif.l
|
||||||
|
+++ b/xmlif/xmlif.l
|
||||||
|
@@ -43,7 +43,7 @@
|
||||||
|
|
||||||
|
static char **selections; /* selection tokens */
|
||||||
|
static int nselections; /* number of selections */
|
||||||
|
-static ifsense; /* sense of last `if' or unless seen */
|
||||||
|
+static int ifsense; /* sense of last `if' or unless seen */
|
||||||
|
static char *attribute; /* last attribute scanned */
|
||||||
|
|
||||||
|
struct stack_t {
|
35
xmlto-c99-2.patch
Normal file
35
xmlto-c99-2.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
commit 8e34f087bf410bcc5fe445933d6ad9bae54f24b5
|
||||||
|
Author: Thomas Kuehne <thomas@kuehne.cn>
|
||||||
|
Date: Sat Dec 11 21:54:50 2021 +0100
|
||||||
|
|
||||||
|
Fix return type of main function
|
||||||
|
|
||||||
|
Fixes:
|
||||||
|
xmlif/xmlif.l:242:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
|
||||||
|
242 | main(int argc, char *argv[])
|
||||||
|
| ^~~~
|
||||||
|
|
||||||
|
Signed-off-by: Thomas Kuehne <thomas@kuehne.cn>
|
||||||
|
|
||||||
|
diff --git a/xmlif/xmlif.l b/xmlif/xmlif.l
|
||||||
|
index 6e5970e147be21b1..8bcc59216d41a3cb 100644
|
||||||
|
--- a/xmlif/xmlif.l
|
||||||
|
+++ b/xmlif/xmlif.l
|
||||||
|
@@ -239,7 +239,7 @@ WS [ \t\n]*
|
||||||
|
|
||||||
|
int yywrap() {exit(0);};
|
||||||
|
|
||||||
|
-main(int argc, char *argv[])
|
||||||
|
+int main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
int i;
|
||||||
|
|
||||||
|
@@ -265,7 +265,7 @@ main(int argc, char *argv[])
|
||||||
|
exit(1);
|
||||||
|
}
|
||||||
|
|
||||||
|
- yylex();
|
||||||
|
+ return yylex();
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
11
xmlto.spec
11
xmlto.spec
@ -1,13 +1,15 @@
|
|||||||
Summary: A tool for converting XML files to various formats
|
Summary: A tool for converting XML files to various formats
|
||||||
Name: xmlto
|
Name: xmlto
|
||||||
Version: 0.0.28
|
Version: 0.0.28
|
||||||
Release: 18%{?dist}
|
Release: 19%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
#Older versions up to xmlto-0.0.20
|
#Older versions up to xmlto-0.0.20
|
||||||
#URL: http://cyberelk.net/tim/xmlto/
|
#URL: http://cyberelk.net/tim/xmlto/
|
||||||
#Source0: http://cyberelk.net/tim/data/xmlto/stable/%{name}-%{version}.tar.bz2
|
#Source0: http://cyberelk.net/tim/data/xmlto/stable/%{name}-%{version}.tar.bz2
|
||||||
URL: https://pagure.io/xmlto/
|
URL: https://pagure.io/xmlto/
|
||||||
Source0: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.bz2
|
Source0: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.bz2
|
||||||
|
Patch0: xmlto-c99-1.patch
|
||||||
|
Patch1: xmlto-c99-2.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: docbook-xsl
|
BuildRequires: docbook-xsl
|
||||||
@ -52,7 +54,7 @@ This subpackage contains xmlto backend scripts for processing
|
|||||||
xhtml1 source format.
|
xhtml1 source format.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure BASH=/bin/bash
|
%configure BASH=/bin/bash
|
||||||
@ -86,6 +88,9 @@ make check
|
|||||||
%{_datadir}/xmlto/format/xhtml1/*
|
%{_datadir}/xmlto/format/xhtml1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 24 2022 Florian Weimer <fweimer@redhat.com> - 0.0.28-19
|
||||||
|
- Apply upstream patches to support building in stricer C99 mode
|
||||||
|
|
||||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.28-18
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.28-18
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
@ -453,4 +458,4 @@ make check
|
|||||||
- Built for Red Hat Linux.
|
- Built for Red Hat Linux.
|
||||||
|
|
||||||
* Fri Nov 23 2001 Tim Waugh <twaugh@redhat.com>
|
* Fri Nov 23 2001 Tim Waugh <twaugh@redhat.com>
|
||||||
- Initial spec file.
|
- Initial spec file.
|
||||||
|
Loading…
Reference in New Issue
Block a user