make subpackages noarch, preserve timestamps - merge review (#226568)
This commit is contained in:
parent
a1d9e193a8
commit
08d01018c9
@ -1,28 +0,0 @@
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2009-01-28 12:32:29.000000000 +0100
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-01-28 12:35:10.000000000 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
#!@BASH@
|
||||
-#
|
||||
+#
|
||||
# @PACKAGE@ - apply an XSL stylesheet to an XML document
|
||||
# Copyright (C) 2001, 2002, 2003 Tim Waugh <twaugh@redhat.com>
|
||||
|
||||
@@ -106,6 +106,8 @@ then
|
||||
if [ -n "$paperheight" -a -n "$paperwidth" ]
|
||||
then
|
||||
papersizemod=$(${MKTEMP} ${TMPDIR:-/tmp}/@PACKAGE@-xsl.XXXXXX)
|
||||
+ CLEANFILES[$CLEANFILE_COUNT]="$papersizemod"
|
||||
+ CLEANFILE_COUNT=$(($CLEANFILE_COUNT + 1))
|
||||
cat << EOF > "$papersizemod"
|
||||
<?xml version='1.0'?>
|
||||
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
@@ -337,8 +339,6 @@ case "$DEST_FORMAT" in
|
||||
fo | pdf | ps | dvi)
|
||||
if [ -n "$papersizemod" ]
|
||||
then
|
||||
- CLEANFILES[$CLEANFILE_COUNT]="$papersizemod"
|
||||
- CLEANFILE_COUNT=$(($CLEANFILE_COUNT + 1))
|
||||
XSL_MODS[$XSL_MOD_COUNT]="$papersizemod"
|
||||
XSL_MOD_COUNT=$(($XSL_MOD_COUNT + 1))
|
||||
fi
|
@ -1,22 +0,0 @@
|
||||
diff -urNp xmlto-0.0.21-orig/THANKS xmlto-0.0.21/THANKS
|
||||
--- xmlto-0.0.21-orig/THANKS 2008-02-25 15:24:59.000000000 +0100
|
||||
+++ xmlto-0.0.21/THANKS 2009-01-05 17:55:58.000000000 +0100
|
||||
@@ -11,3 +11,4 @@ Shlomi Fish <shlomif@gmail.com>
|
||||
Braden McDaniel <braden@endoframe.com>
|
||||
Andreas Hoenen <andreas.hoenen@arcor.de>
|
||||
Graham Wilson <graham@debian.org>
|
||||
+Joseph Parmelee <jparmele@wildbear.com>
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2008-05-30 15:41:31.000000000 +0200
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-01-05 17:55:12.000000000 +0100
|
||||
@@ -273,8 +273,8 @@ while [ "$#" -gt "0" ]; do
|
||||
;;
|
||||
--stringparam)
|
||||
MYPARAM="$2"
|
||||
- XSLTPARAMS="XSLTPARAMS --stringparam ${MYPARAM%=*}"
|
||||
- XSLTPARAMS="XSLTPARAMS $MYPARAM#*=}"
|
||||
+ XSLTPARAMS="$XSLTPARAMS --stringparam ${MYPARAM%=*}"
|
||||
+ XSLTPARAMS="$XSLTPARAMS ${MYPARAM#*=}"
|
||||
shift 2
|
||||
;;
|
||||
--noclean)
|
@ -1,172 +0,0 @@
|
||||
diff -urNp xmlto-0.0.21-orig/format/xhtml1/dvi xmlto-0.0.21/format/xhtml1/dvi
|
||||
--- xmlto-0.0.21-orig/format/xhtml1/dvi 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ xmlto-0.0.21/format/xhtml1/dvi 2009-03-16 12:30:34.000000000 +0100
|
||||
@@ -0,0 +1,13 @@
|
||||
+case "$1" in
|
||||
+stylesheet)
|
||||
+ if [ "$VERBOSE" -ge 1 ]
|
||||
+ then
|
||||
+ echo >&2 "Convert to XSL-FO"
|
||||
+ fi
|
||||
+ echo "http://www.antennahouse.com/XSLsample/sample-xsl-xhtml2fo/xhtml2fo.xsl"
|
||||
+ ;;
|
||||
+post-process)
|
||||
+ # Get the FO format script to do the rest
|
||||
+ sh "$(dirname "$0")/../fo/$(basename "$0")" "$1"
|
||||
+ ;;
|
||||
+esac
|
||||
diff -urNp xmlto-0.0.21-orig/format/xhtml1/fo xmlto-0.0.21/format/xhtml1/fo
|
||||
--- xmlto-0.0.21-orig/format/xhtml1/fo 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ xmlto-0.0.21/format/xhtml1/fo 2009-03-16 12:30:34.000000000 +0100
|
||||
@@ -0,0 +1,12 @@
|
||||
+case "$1" in
|
||||
+stylesheet)
|
||||
+ if [ "$VERBOSE" -ge 1 ]
|
||||
+ then
|
||||
+ echo >&2 "Convert to XSL-FO"
|
||||
+ fi
|
||||
+ echo "http://www.antennahouse.com/XSLsample/sample-xsl-xhtml2fo/xhtml2fo.xsl"
|
||||
+ ;;
|
||||
+post-process)
|
||||
+ cp "$XSLT_PROCESSED" "$OUTPUT_DIR/$(basename ${XSLT_PROCESSED%.*}).fo"
|
||||
+ ;;
|
||||
+esac
|
||||
diff -urNp xmlto-0.0.21-orig/format/xhtml1/pdf xmlto-0.0.21/format/xhtml1/pdf
|
||||
--- xmlto-0.0.21-orig/format/xhtml1/pdf 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ xmlto-0.0.21/format/xhtml1/pdf 2009-03-16 12:30:34.000000000 +0100
|
||||
@@ -0,0 +1,13 @@
|
||||
+case "$1" in
|
||||
+stylesheet)
|
||||
+ if [ "$VERBOSE" -ge 1 ]
|
||||
+ then
|
||||
+ echo >&2 "Convert to XSL-FO"
|
||||
+ fi
|
||||
+ echo "http://www.antennahouse.com/XSLsample/sample-xsl-xhtml2fo/xhtml2fo.xsl"
|
||||
+ ;;
|
||||
+post-process)
|
||||
+ # Get the FO format script to do the rest
|
||||
+ sh "$(dirname "$0")/../fo/$(basename "$0")" "$1"
|
||||
+ ;;
|
||||
+esac
|
||||
diff -urNp xmlto-0.0.21-orig/format/xhtml1/ps xmlto-0.0.21/format/xhtml1/ps
|
||||
--- xmlto-0.0.21-orig/format/xhtml1/ps 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ xmlto-0.0.21/format/xhtml1/ps 2009-03-16 12:30:34.000000000 +0100
|
||||
@@ -0,0 +1,13 @@
|
||||
+case "$1" in
|
||||
+stylesheet)
|
||||
+ if [ "$VERBOSE" -ge 1 ]
|
||||
+ then
|
||||
+ echo >&2 "Convert to XSL-FO"
|
||||
+ fi
|
||||
+ echo "http://www.antennahouse.com/XSLsample/sample-xsl-xhtml2fo/xhtml2fo.xsl"
|
||||
+ ;;
|
||||
+post-process)
|
||||
+ # Get the FO format script to do the rest
|
||||
+ sh "$(dirname "$0")/../fo/$(basename "$0")" "$1"
|
||||
+ ;;
|
||||
+esac
|
||||
diff -urNp xmlto-0.0.21-orig/format/xhtml1/txt xmlto-0.0.21/format/xhtml1/txt
|
||||
--- xmlto-0.0.21-orig/format/xhtml1/txt 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ xmlto-0.0.21/format/xhtml1/txt 2009-03-16 12:30:34.000000000 +0100
|
||||
@@ -0,0 +1,27 @@
|
||||
+if [ -x /usr/bin/w3m ]
|
||||
+then
|
||||
+ CONVERT=/usr/bin/w3m
|
||||
+ ARGS="-T text/html -dump"
|
||||
+elif [ -x /usr/bin/lynx ]
|
||||
+then
|
||||
+ CONVERT=/usr/bin/lynx
|
||||
+ ARGS="-force_html -dump -nolist -width=72"
|
||||
+elif [ -x /usr/bin/links ]
|
||||
+then
|
||||
+ CONVERT=/usr/bin/links
|
||||
+ ARGS="-dump"
|
||||
+else
|
||||
+ echo >&2 "No way to convert HTML to text found."
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
+case "$1" in
|
||||
+post-process)
|
||||
+ if [ "$VERBOSE" -ge 1 ]
|
||||
+ then
|
||||
+ echo >&2 "Convert HTML to ASCII"
|
||||
+ fi
|
||||
+ ${CONVERT} ${ARGS} ${POSTARGS} ${XSLT_PROCESSED} > \
|
||||
+ "$OUTPUT_DIR/$(basename ${XSLT_PROCESSED%.*}).txt"
|
||||
+ ;;
|
||||
+esac
|
||||
diff -urNp xmlto-0.0.21-orig/Makefile.am xmlto-0.0.21/Makefile.am
|
||||
--- xmlto-0.0.21-orig/Makefile.am 2008-01-17 12:33:44.000000000 +0100
|
||||
+++ xmlto-0.0.21/Makefile.am 2009-03-16 12:49:27.000000000 +0100
|
||||
@@ -28,6 +28,11 @@ nobase_pkgdata_DATA = format/docbook/dvi
|
||||
format/fo/pcl \
|
||||
format/fo/svg \
|
||||
format/fo/txt \
|
||||
+ format/xhtml1/dvi \
|
||||
+ format/xhtml1/fo \
|
||||
+ format/xhtml1/pdf \
|
||||
+ format/xhtml1/ps \
|
||||
+ format/xhtml1/txt \
|
||||
xmlto.mak
|
||||
|
||||
EXTRA_DIST = xmlto.spec \
|
||||
@@ -56,6 +61,11 @@ EXTRA_DIST = xmlto.spec \
|
||||
format/fo/pcl \
|
||||
format/fo/svg \
|
||||
format/fo/txt \
|
||||
+ format/xhtml1/dvi \
|
||||
+ format/xhtml1/fo \
|
||||
+ format/xhtml1/pdf \
|
||||
+ format/xhtml1/ps \
|
||||
+ format/xhtml1/txt \
|
||||
doc/xmlto.xml \
|
||||
doc/xmlif.xml \
|
||||
xmlto.mak \
|
||||
diff -urNp xmlto-0.0.21-orig/Makefile.in xmlto-0.0.21/Makefile.in
|
||||
--- xmlto-0.0.21-orig/Makefile.in 2008-05-30 15:57:32.000000000 +0200
|
||||
+++ xmlto-0.0.21/Makefile.in 2009-03-16 12:50:52.000000000 +0100
|
||||
@@ -208,6 +208,11 @@ nobase_pkgdata_DATA = format/docbook/dvi
|
||||
format/fo/pcl \
|
||||
format/fo/svg \
|
||||
format/fo/txt \
|
||||
+ format/xhtml1/dvi \
|
||||
+ format/xhtml1/fo \
|
||||
+ format/xhtml1/pdf \
|
||||
+ format/xhtml1/ps \
|
||||
+ format/xhtml1/txt \
|
||||
xmlto.mak
|
||||
|
||||
EXTRA_DIST = xmlto.spec \
|
||||
@@ -236,6 +241,11 @@ EXTRA_DIST = xmlto.spec \
|
||||
format/fo/pcl \
|
||||
format/fo/svg \
|
||||
format/fo/txt \
|
||||
+ format/xhtml1/dvi \
|
||||
+ format/xhtml1/fo \
|
||||
+ format/xhtml1/pdf \
|
||||
+ format/xhtml1/ps \
|
||||
+ format/xhtml1/txt \
|
||||
doc/xmlto.xml \
|
||||
doc/xmlif.xml \
|
||||
xmlto.mak \
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2009-03-16 14:22:58.000000000 +0100
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-03-16 12:27:49.000000000 +0100
|
||||
@@ -351,12 +351,15 @@ esac
|
||||
# sed -e 's/^<?[^?>]*?>//g' -e 's/^<![^>]*>//g' -e 's/^<\([^ ]*\).*$/\1/')
|
||||
|
||||
# Seems reasonable fix the file command and teach it to identify the DTD/Schema but this is faster to write:
|
||||
-rootel=$(echo "xpath *" | xmllint --shell $INPUT_FILE 2> /dev/null |head -n 3 |tail -n 1 | cut -f 4 -d " " )
|
||||
+rootel=$(echo "xpath *" | xmllint --shell $INPUT_FILE 2> /dev/null | head -n 3 |tail -n 1 | cut -f 4 -d " " )
|
||||
|
||||
case $(echo $rootel) in
|
||||
fo:root)
|
||||
SOURCE_FORMAT="fo"
|
||||
;;
|
||||
+html)
|
||||
+ SOURCE_FORMAT="xhtml1"
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
[ "$VERBOSE" -ge 1 ] && echo >&2 "Source format: ${SOURCE_FORMAT} / root element: ${rootel} "
|
@ -1,16 +0,0 @@
|
||||
diff -urNp xmlto-0.0.21-orig/xmlto.in xmlto-0.0.21/xmlto.in
|
||||
--- xmlto-0.0.21-orig/xmlto.in 2009-01-28 12:51:19.000000000 +0100
|
||||
+++ xmlto-0.0.21/xmlto.in 2009-01-28 12:54:35.000000000 +0100
|
||||
@@ -427,8 +427,10 @@ if [ "$SKIP_VALIDATION" -eq 0 ] && [ "$S
|
||||
then
|
||||
VALIDATION="${XSLT_PROCESSED_DIR}/validation-errors"
|
||||
[ "$VERBOSE" -ge 1 ] && \
|
||||
- echo >&2 "xmllint >/dev/null --xinclude --postvalid \"$INPUT_FILE\""
|
||||
- xmllint >/dev/null --xinclude --postvalid "$INPUT_FILE" 2>"${VALIDATION}"
|
||||
+ echo >&2 \
|
||||
+ "xmllint >/dev/null --nonet --xinclude --postvalid --noent \"$INPUT_FILE\""
|
||||
+ xmllint >/dev/null --nonet --xinclude --postvalid --noent \
|
||||
+ "$INPUT_FILE" 2>"${VALIDATION}"
|
||||
xmllint_status=$?
|
||||
if [ $xmllint_status -ne 0 ]
|
||||
then
|
13
xmlto.spec
13
xmlto.spec
@ -1,7 +1,7 @@
|
||||
Summary: A tool for converting XML files to various formats
|
||||
Name: xmlto
|
||||
Version: 0.0.22
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
#Older versions up to xmlto-0.0.20
|
||||
@ -35,6 +35,8 @@ Summary: A set of xmlto backends with TeX requirements
|
||||
Requires: passivetex >= 1.11
|
||||
# We require main package
|
||||
Requires: xmlto = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
|
||||
%description tex
|
||||
This subpackage contains xmlto backend scripts which do require
|
||||
@ -48,6 +50,7 @@ Summary: A set of xmlto backends for xhtml1 source format
|
||||
Requires: xhtml2fo-style-xsl
|
||||
# We require main package
|
||||
Requires: xmlto = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description xhtml
|
||||
This subpackage contains xmlto backend scripts for processing
|
||||
@ -65,7 +68,7 @@ make check
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -96,10 +99,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 01 2009 Ondrej Vasik <ovasik@redhat.com> - 0.0.22-3
|
||||
- make subpackages noarch, preserve timestamps - merge
|
||||
review (#226568)
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Mar 25 2009 Ondrej Vasik <ovasik@redhat.com>
|
||||
* Wed Mar 25 2009 Ondrej Vasik <ovasik@redhat.com> - 0.0.22-1
|
||||
- New version 0.0.22
|
||||
- autodetection for tools/program paths, consolidated
|
||||
error code handling, build warnings cleanup
|
||||
|
Loading…
Reference in New Issue
Block a user