Update to 1.0.3, fixing patches and validation testing
This commit is contained in:
parent
75dbd54b60
commit
a03a18f667
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
xmlstarlet-1.0.1.tar.gz
|
||||
/xmlstarlet-1.0.2.tar.gz
|
||||
/xmlstarlet-1.0.3.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
cc6031201cb263ab364ee5bfbe503cb5 xmlstarlet-1.0.2.tar.gz
|
||||
ec9a39540b402affcb99a07f0a03d92a xmlstarlet-1.0.3.tar.gz
|
||||
|
@ -1,75 +0,0 @@
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/xmlstar/xmlstarlet/configure.in,v
|
||||
retrieving revision 1.58
|
||||
diff -u -p -r1.58 configure.in
|
||||
--- old/configure.in 19 Mar 2005 01:55:22 -0000 1.58
|
||||
+++ new/configure.in 21 Nov 2005 18:20:42 -0000
|
||||
@@ -31,7 +31,7 @@ AC_ARG_WITH(libxml-prefix,
|
||||
[ --with-libxml-prefix=[PFX] Specify location of libxml],
|
||||
LIBXML_PREFIX=$withval
|
||||
LIBXML_CFLAGS="-I$withval/include/libxml2 -I$withval/include/libxml"
|
||||
- LIBXML_LIBS="$withval/lib/libxml2.a -lz -lm -lpthread -ldl"
|
||||
+ LIBXML_LIBS="-L$withval/lib -lxml2 -lz -lm -ldl"
|
||||
)
|
||||
|
||||
AC_ARG_WITH(libxml-include-prefix,
|
||||
@@ -41,13 +41,13 @@ AC_ARG_WITH(libxml-include-prefix,
|
||||
|
||||
AC_ARG_WITH(libxml-libs-prefix,
|
||||
[ --with-libxml-libs-prefix=[PFX] Specify location of libxml libs],
|
||||
- LIBXML_LIBS="$withval/libxml2.a -lz -lm -lpthread -ldl"
|
||||
+ LIBXML_LIBS="-L$withval -lxml2 -lz -lm -ldl"
|
||||
)
|
||||
|
||||
AC_ARG_WITH(libxml-src,
|
||||
[ --with-libxml-src=[DIR] For libxml thats not installed yet (sets all three above)],
|
||||
LIBXML_SRC="$withval"
|
||||
- LIBXML_LIBS="$withval/.libs/libxml2.a -lz -lm -lpthread"
|
||||
+ LIBXML_LIBS="-L$withval/.libs -lxml2 -lz -lm"
|
||||
LIBXML_CFLAGS="-I$withval/include/libxml2 -I$withval/include/libxml -I$withval/include"
|
||||
)
|
||||
|
||||
@@ -74,7 +74,7 @@ AC_ARG_WITH(libxslt-prefix,
|
||||
[ --with-libxslt-prefix=[PFX] Specify location of libxslt],
|
||||
LIBXSLT_PREFIX=$withval
|
||||
LIBXSLT_CFLAGS="-I$withval/include/libxslt -I$withval/include/libexslt"
|
||||
- LIBXSLT_LIBS="$withval/lib/libxslt.a $withval/lib/libexslt.a -lz -lm -lpthread"
|
||||
+ LIBXSLT_LIBS="-L$withval/lib -lxslt -L$withval/lib -lexslt -lz -lm"
|
||||
)
|
||||
|
||||
AC_ARG_WITH(libxslt-include-prefix,
|
||||
@@ -84,13 +84,13 @@ AC_ARG_WITH(libxslt-include-prefix,
|
||||
|
||||
AC_ARG_WITH(libxslt-libs-prefix,
|
||||
[ --with-libxslt-libs-prefix=[PFX] Specify location of libxslt libs],
|
||||
- LIBXSLT_LIBS="$withval/libxslt.a $withval/libexslt.a -lz -lm -lpthread"
|
||||
+ LIBXSLT_LIBS="-L$withval -lxslt -L$withval -lexslt -lz -lm"
|
||||
)
|
||||
|
||||
AC_ARG_WITH(libxslt-src,
|
||||
[ --with-libxslt-src=[DIR] For libxslt thats not installed yet (sets all three above)],
|
||||
LIBXSLT_SRC="$withval"
|
||||
- LIBXSLT_LIBS="$withval/libxslt/.libs/libxslt.a $withval/libexslt/.libs/libexslt.a -lz -lm -lpthread"
|
||||
+ LIBXSLT_LIBS="-L$withval/libxslt/.libs -lxslt -L$withval/libexslt/.libs -lexslt -lz -lm"
|
||||
LIBXSLT_CFLAGS="-I$withval/libxslt -I$withval/libexslt -I$withval"
|
||||
)
|
||||
|
||||
@@ -236,7 +236,7 @@ dnl Set LIBXML libraries location
|
||||
dnl
|
||||
if test "x$LIBXML_LIBS" = "x"
|
||||
then
|
||||
- LIBXML_LIBS="${LIBXML_PREFIX}/lib/libxml2.a -lz -lm -lpthread -ldl"
|
||||
+ LIBXML_LIBS="-L${LIBXML_PREFIX}/lib -lxml2 -lz -lm -ldl"
|
||||
fi
|
||||
|
||||
dnl
|
||||
@@ -252,7 +252,7 @@ dnl Set LIBXSLT libraries location
|
||||
dnl
|
||||
if test "x$LIBXSLT_LIBS" = "x"
|
||||
then
|
||||
- LIBXSLT_LIBS="${LIBXSLT_PREFIX}/lib/libxslt.a ${LIBXSLT_PREFIX}/lib/libexslt.a -lz -lm -lpthread"
|
||||
+ LIBXSLT_LIBS="-L${LIBXSLT_PREFIX}/lib -lxslt -L${LIBXSLT_PREFIX}/lib -lexslt -lz -lm"
|
||||
fi
|
||||
|
||||
dnl
|
5
xmlstarlet-1.0.3-bigxmldtd-results.patch
Normal file
5
xmlstarlet-1.0.3-bigxmldtd-results.patch
Normal file
@ -0,0 +1,5 @@
|
||||
--- xmlstarlet-1.0.3-original/examples/results/bigxml-dtd.out 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/examples/results/bigxml-dtd.out 2010-12-18 08:10:21.257959145 -0500
|
||||
@@ -1 +1 @@
|
||||
--:7000x
|
||||
+-:6553x
|
@ -1,45 +1,24 @@
|
||||
Index: xmlstarlet.spec.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/xmlstar/xmlstarlet/xmlstarlet.spec.in,v
|
||||
retrieving revision 1.9
|
||||
diff -u -p -r1.9 xmlstarlet.spec.in
|
||||
--- old/xmlstarlet.spec.in 1 Feb 2004 23:21:25 -0000 1.9
|
||||
+++ new/xmlstarlet.spec.in 21 Nov 2005 18:20:42 -0000
|
||||
@@ -43,6 +43,6 @@ rm -fr %{buildroot}
|
||||
%doc AUTHORS ChangeLog NEWS README Copyright TODO doc/xmlstarlet.txt doc/xmlstarlet.pdf
|
||||
%doc %{_mandir}/man1/xmlstarlet.1*
|
||||
diff -uNr xmlstarlet-1.0.3-original/examples/xmlstarlet xmlstarlet-1.0.3/examples/xmlstarlet
|
||||
--- xmlstarlet-1.0.3-original/examples/xmlstarlet 2010-11-10 18:42:26.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/examples/xmlstarlet 2010-12-17 12:09:15.644655135 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
#!/bin/sh
|
||||
|
||||
-%{prefix}/bin/xml
|
||||
+%{prefix}/bin/xmlstarlet
|
||||
%changelog
|
||||
|
||||
Index: src/Makefile.am
|
||||
===================================================================
|
||||
RCS file: /cvsroot/xmlstar/xmlstarlet/src/Makefile.am,v
|
||||
retrieving revision 1.21
|
||||
diff -u -p -r1.21 Makefile.am
|
||||
--- old/src/Makefile.am 21 Nov 2004 20:18:49 -0000 1.21
|
||||
+++ new/src/Makefile.am 21 Nov 2005 18:20:42 -0000
|
||||
@@ -2,12 +2,12 @@ INCLUDES = -I. -I$(top_srcdir) -I$(top_s
|
||||
-I$(top_builddir) -I$(top_builddir)/src \
|
||||
$(LIBXML_CFLAGS) $(LIBXSLT_CFLAGS) $(LIBICONV_CFLAGS) $(CFLAGS)
|
||||
-../src/xml ${@+"$@"}
|
||||
+../src/xmlstarlet ${@+"$@"}
|
||||
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/Makefile.am xmlstarlet-1.0.3/src/Makefile.am
|
||||
--- xmlstarlet-1.0.3-original/src/Makefile.am 2010-11-16 20:43:53.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/Makefile.am 2010-12-17 12:08:55.760085370 -0500
|
||||
@@ -1,3 +1,3 @@
|
||||
-bin_PROGRAMS = xml
|
||||
+bin_PROGRAMS = xmlstarlet
|
||||
|
||||
-xml_SOURCES = xml.c xml_edit.c xml_ls.c xml_escape.c xml_pyx.c xml_depyx.c xml_select.c xml_trans.c xml_validate.c xml_format.c xml_elem.c xml_C14N.c trans.c binsert.c stack.c binsert.h stack.h trans.h escape.h strdup.h strdup.c
|
||||
-xml_LDFLAGS =
|
||||
-xml_DEPENDENCIES = $(DEPS)
|
||||
-xml_LDADD = $(LDADDS)
|
||||
+xmlstarlet_SOURCES = xml.c xml_edit.c xml_ls.c xml_escape.c xml_pyx.c xml_depyx.c xml_select.c xml_trans.c xml_validate.c xml_format.c xml_elem.c xml_C14N.c trans.c binsert.c stack.c binsert.h stack.h trans.h escape.h strdup.h strdup.c
|
||||
+xmlstarlet_LDFLAGS =
|
||||
+xmlstarlet_DEPENDENCIES = $(DEPS)
|
||||
+xmlstarlet_LDADD = $(LDADDS)
|
||||
|
||||
EXTRA_DIST = xml.c xml_edit.c xml_ls.c xml_escape.c xml_pyx.c xml_depyx.c xml_select.c xml_trans.c xml_validate.c xml_format.c xml_elem.c xml_C14N.c trans.c binsert.c stack.c binsert.h stack.h trans.h escape.h strdup.h strdup.c
|
||||
|
||||
--- xmlstarlet-1.0.1-original/src/xml.c 2004-11-10 22:39:34.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml.c 2005-11-22 18:29:58.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml.c xmlstarlet-1.0.3/src/xml.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml.c 2010-11-10 18:42:26.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml.c 2010-12-17 12:08:55.760085370 -0500
|
||||
@@ -49,7 +49,7 @@
|
||||
*/
|
||||
static const char usage_str_1[] =
|
||||
@ -58,8 +37,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
|
||||
|
||||
|
||||
--- xmlstarlet-1.0.1-original/src/xml_C14N.c 2004-11-23 22:00:10.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_C14N.c 2005-11-22 18:32:14.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_C14N.c xmlstarlet-1.0.3/src/xml_C14N.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_C14N.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_C14N.c 2010-12-17 12:08:55.761085249 -0500
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
static const char c14n_usage_str_1[] =
|
||||
@ -69,8 +49,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <xml-file> - input XML document file name (stdin is used if '-')\n"
|
||||
" <xpath-file> - XML file containing XPath expression for\n"
|
||||
--- xmlstarlet-1.0.1-original/src/xml_depyx.c 2005-03-11 22:24:23.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_depyx.c 2005-11-22 18:32:24.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_depyx.c xmlstarlet-1.0.3/src/xml_depyx.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_depyx.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_depyx.c 2010-12-17 12:08:55.762085127 -0500
|
||||
@@ -38,7 +38,7 @@
|
||||
|
||||
static const char depyx_usage_str[] =
|
||||
@ -80,9 +61,10 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <pyx-file> - input PYX document file name (stdin is used if missing)\n\n"
|
||||
"The PYX format is a line-oriented representation of\n"
|
||||
--- xmlstarlet-1.0.1-original/src/xml_edit.c 2005-01-07 19:07:03.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_edit.c 2005-11-22 18:32:36.000000000 -0500
|
||||
@@ -108,7 +108,7 @@
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_edit.c xmlstarlet-1.0.3/src/xml_edit.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_edit.c 2010-11-14 11:18:43.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_edit.c 2010-12-17 12:08:55.762085127 -0500
|
||||
@@ -109,7 +109,7 @@
|
||||
*/
|
||||
static const char edit_usage_str_1[] =
|
||||
"XMLStarlet Toolkit: Edit XML document(s)\n"
|
||||
@ -91,8 +73,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <global-options> - global options for editing\n"
|
||||
" <xml-file-or-uri> - input XML document file name/uri (stdin otherwise)\n\n";
|
||||
--- xmlstarlet-1.0.1-original/src/xml_elem.c 2004-11-21 18:40:40.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_elem.c 2005-11-22 18:32:45.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_elem.c xmlstarlet-1.0.3/src/xml_elem.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_elem.c 2010-11-10 18:42:26.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_elem.c 2010-12-17 12:08:55.763085005 -0500
|
||||
@@ -67,7 +67,7 @@
|
||||
|
||||
static const char elem_usage_str[] =
|
||||
@ -102,8 +85,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <xml-file> - input XML document file name (stdin is used if missing)\n"
|
||||
" <options> is one of:\n"
|
||||
--- xmlstarlet-1.0.1-original/src/xml_escape.c 2004-11-21 18:40:40.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_escape.c 2005-11-22 18:32:52.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_escape.c xmlstarlet-1.0.3/src/xml_escape.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_escape.c 2010-11-10 18:42:26.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_escape.c 2010-12-17 12:08:55.763085005 -0500
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
static const char escape_usage_str[] =
|
||||
@ -113,9 +97,10 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where <options> are\n"
|
||||
" --help - print usage\n"
|
||||
" (TODO: more to be added in future)\n"
|
||||
--- xmlstarlet-1.0.1-original/src/xml_format.c 2005-01-06 21:33:40.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_format.c 2005-11-22 18:32:59.000000000 -0500
|
||||
@@ -72,7 +72,7 @@
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_format.c xmlstarlet-1.0.3/src/xml_format.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_format.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_format.c 2010-12-17 12:08:55.764084881 -0500
|
||||
@@ -73,7 +73,7 @@
|
||||
*/
|
||||
static const char format_usage_str_1[] =
|
||||
"XMLStarlet Toolkit: Format XML document\n"
|
||||
@ -124,8 +109,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where <options> are\n"
|
||||
" -n or --noindent - do not indent\n"
|
||||
" -t or --indent-tab - indent output with tabulation\n"
|
||||
--- xmlstarlet-1.0.1-original/src/xml_ls.c 2005-03-11 22:49:41.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_ls.c 2005-11-22 18:33:07.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_ls.c xmlstarlet-1.0.3/src/xml_ls.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_ls.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_ls.c 2010-12-17 12:08:55.764084881 -0500
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
static const char ls_usage_str[] =
|
||||
@ -135,8 +121,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"Lists current directory in XML format.\n"
|
||||
"Time is shown per ISO 8601 spec.\n"
|
||||
"\n";
|
||||
--- xmlstarlet-1.0.1-original/src/xml_pyx.c 2005-03-11 22:24:23.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_pyx.c 2005-11-22 18:33:13.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_pyx.c xmlstarlet-1.0.3/src/xml_pyx.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_pyx.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_pyx.c 2010-12-17 12:08:55.765084757 -0500
|
||||
@@ -23,7 +23,7 @@
|
||||
*/
|
||||
static const char pyx_usage_str_1[] =
|
||||
@ -146,8 +133,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <xml-file> - input XML document file name (stdin is used if missing)\n\n";
|
||||
|
||||
--- xmlstarlet-1.0.1-original/src/xml_select.c 2005-01-06 21:02:13.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_select.c 2005-11-22 18:39:29.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_select.c xmlstarlet-1.0.3/src/xml_select.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_select.c 2010-11-13 11:56:13.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_select.c 2010-12-17 12:08:55.765084757 -0500
|
||||
@@ -65,7 +65,7 @@
|
||||
*/
|
||||
static const char select_usage_str_1[] =
|
||||
@ -168,8 +156,9 @@ diff -u -p -r1.21 Makefile.am
|
||||
|
||||
"is equivalent to applying the following XSLT\n\n";
|
||||
|
||||
--- xmlstarlet-1.0.1-original/src/xml_trans.c 2005-01-06 21:40:59.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_trans.c 2005-11-22 18:33:29.000000000 -0500
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_trans.c xmlstarlet-1.0.3/src/xml_trans.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_trans.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_trans.c 2010-12-17 12:08:55.767084511 -0500
|
||||
@@ -47,7 +47,7 @@
|
||||
*/
|
||||
static const char trans_usage_str_1[] =
|
||||
@ -179,9 +168,10 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where\n"
|
||||
" <xsl-file> - main XSLT stylesheet for transformation\n"
|
||||
" <xml-file> - input XML document file/URL (stdin is used if missing)\n";
|
||||
--- xmlstarlet-1.0.1-original/src/xml_validate.c 2005-01-06 20:52:43.000000000 -0500
|
||||
+++ xmlstarlet-1.0.1/src/xml_validate.c 2005-11-22 18:33:37.000000000 -0500
|
||||
@@ -68,7 +68,7 @@
|
||||
diff -uNr xmlstarlet-1.0.3-original/src/xml_validate.c xmlstarlet-1.0.3/src/xml_validate.c
|
||||
--- xmlstarlet-1.0.3-original/src/xml_validate.c 2010-11-14 10:47:45.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/src/xml_validate.c 2010-12-17 12:08:55.768084391 -0500
|
||||
@@ -78,7 +78,7 @@
|
||||
*/
|
||||
static const char validate_usage_str_1[] =
|
||||
"XMLStarlet Toolkit: Validate XML document(s)\n"
|
||||
@ -190,3 +180,14 @@ diff -u -p -r1.21 Makefile.am
|
||||
"where <options>\n"
|
||||
" -w or --well-formed - validate well-formedness only (default)\n"
|
||||
" -d or --dtd <dtd-file> - validate against DTD\n";
|
||||
diff -uNr xmlstarlet-1.0.3-original/xmlstarlet.spec.in xmlstarlet-1.0.3/xmlstarlet.spec.in
|
||||
--- xmlstarlet-1.0.3-original/xmlstarlet.spec.in 2010-11-10 18:42:26.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/xmlstarlet.spec.in 2010-12-17 12:08:55.768084391 -0500
|
||||
@@ -43,6 +43,6 @@
|
||||
%doc AUTHORS ChangeLog NEWS README Copyright TODO doc/xmlstarlet.txt doc/xmlstarlet.pdf
|
||||
%doc %{_mandir}/man1/xmlstarlet.1*
|
||||
|
||||
-%{prefix}/bin/xml
|
||||
+%{prefix}/bin/xmlstarlet
|
||||
%changelog
|
||||
|
28
xmlstarlet-1.0.3-nostatic.patch
Normal file
28
xmlstarlet-1.0.3-nostatic.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -uNr xmlstarlet-1.0.3-original/configure.ac xmlstarlet-1.0.3/configure.ac
|
||||
--- xmlstarlet-1.0.3-original/configure.ac 2010-11-17 14:47:55.000000000 -0500
|
||||
+++ xmlstarlet-1.0.3/configure.ac 2010-12-17 11:59:27.090514304 -0500
|
||||
@@ -29,18 +29,18 @@
|
||||
XSTAR_LIB_CHECK([LIBXML], [xml2-config])
|
||||
AS_IF([test "x$LIBXML_SRCDIR" != x],
|
||||
[LIBXML_INCDIR="$LIBXML_SRCDIR/include"],
|
||||
- [: ${LIBXML_INCDIR="$LIBXML_PREFIX/include/libxml2"}])
|
||||
-[LIBXML_LIBS="$LIBXML_LIBDIR/libxml2.a"]
|
||||
-[LIBXML_CPPFLAGS="-DLIBXML_STATIC -I$LIBXML_INCDIR"]
|
||||
+ [: ${LIBXML_INCDIR="`xml2-config --cflags`"}])
|
||||
+[LIBXML_LIBS="`xml2-config --libs`"]
|
||||
+[LIBXML_CPPFLAGS="-DLIBXML_STATIC $LIBXML_INCDIR"]
|
||||
|
||||
XSTAR_LIB_CHECK([LIBXSLT], [xslt-config])
|
||||
[: ${LIBXSLT_INCDIR="$LIBXSLT_PREFIX/include"}]
|
||||
AS_IF([test "x$LIBXSLT_SRCDIR" != x],
|
||||
[LIBXSLT_INCDIR="$LIBXSLT_SRCDIR"
|
||||
LIBXSLT_LIBS="$LIBXSLT_SRCDIR/libexslt/.libs/libexslt.a $LIBXSLT_SRCDIR/libxslt/.libs/libxslt.a"],
|
||||
- [LIBXSLT_LIBS="$LIBXSLT_LIBDIR/libexslt.a $LIBXSLT_LIBDIR/libxslt.a"])
|
||||
-[: ${LIBSLT_INCDIR="$LIBXSLT_PREFIX/include"}]
|
||||
-[LIBXSLT_CPPFLAGS="-I$LIBXSLT_INCDIR"]
|
||||
+ [LIBXSLT_LIBS="`xslt-config --libs` -lexslt"])
|
||||
+[: ${LIBSLT_INCDIR="`xslt-config --cflags`"}]
|
||||
+[LIBXSLT_CPPFLAGS="$LIBXSLT_INCDIR"]
|
||||
|
||||
[WIN32_EXTRA_LDFLAGS=]
|
||||
[WIN32_EXTRA_LIBS=]
|
@ -1,14 +1,15 @@
|
||||
Name: xmlstarlet
|
||||
Version: 1.0.2
|
||||
Version: 1.0.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Command Line XML Toolkit
|
||||
Group: Applications/Text
|
||||
License: MIT
|
||||
URL: http://xmlstar.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/xmlstar/%{name}-%{version}.tar.gz
|
||||
Patch0: xmlstarlet-1.0.1-nostatic.patch
|
||||
Patch1: xmlstarlet-1.0.1-cmdname.patch
|
||||
Patch0: xmlstarlet-1.0.3-nostatic.patch
|
||||
Patch1: xmlstarlet-1.0.3-cmdname.patch
|
||||
Patch2: xmlstarlet-1.0.1-docs.patch
|
||||
Patch3: xmlstarlet-1.0.3-bigxmldtd-results.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: xmlto automake autoconf libxml2-devel libxslt-devel
|
||||
@ -26,6 +27,8 @@ commands.
|
||||
%patch0 -p1 -b .nostatic
|
||||
%patch1 -p1 -b .cmdname
|
||||
%patch2 -p1 -b .docs
|
||||
# Refer to https://bugzilla.gnome.org/show_bug.cgi?id=325533
|
||||
%patch3 -p1 -b .bigxmldtd-results
|
||||
|
||||
%build
|
||||
autoreconf -i
|
||||
@ -42,6 +45,11 @@ rm -fr %{buildroot}
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%check
|
||||
cd tests
|
||||
./runTests
|
||||
|
||||
|
||||
%clean
|
||||
rm -fr %{buildroot}
|
||||
|
||||
@ -54,6 +62,10 @@ rm -fr %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 17 2010 Paul W. Frields <stickster@gmail.com> - 1.0.3-1
|
||||
- Update to new upstream 1.0.3
|
||||
- Add %%check section for validation testing
|
||||
|
||||
* Mon Nov 1 2010 Paul W. Frields <stickster@gmail.com> - 1.0.2-1
|
||||
- Update to new upstream 1.0.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user