- NSS has been split out of the mozilla package, so require that now and
update separate_nspr.patch to account for the new NSS as well
This commit is contained in:
parent
a80aea7110
commit
99d9b556de
61
separate_nspr_nss.patch
Normal file
61
separate_nspr_nss.patch
Normal file
@ -0,0 +1,61 @@
|
|||||||
|
--- xmlsec1-1.2.9/xmlsec-nss.pc.in.old 2005-12-15 23:36:20.000000000 -0500
|
||||||
|
+++ xmlsec1-1.2.9/xmlsec-nss.pc.in 2005-12-15 23:37:09.000000000 -0500
|
||||||
|
@@ -6,6 +6,6 @@
|
||||||
|
Name: xmlsec1-nss
|
||||||
|
Version: @VERSION@
|
||||||
|
Description: XML Security Library implements XML Signature and XML Encryption standards
|
||||||
|
-Requires: libxml-2.0 >= @LIBXML_MIN_VERSION@ libxslt >= @LIBXSLT_MIN_VERSION@ mozilla-nss >= @MOZILLA_MIN_VERSION@
|
||||||
|
+Requires: libxml-2.0 >= @LIBXML_MIN_VERSION@ libxslt >= @LIBXSLT_MIN_VERSION@ nss >= @NSS_MIN_VERSION@
|
||||||
|
Cflags: -DXMLSEC_CRYPTO=\\\"nss\\\" -DXMLSEC_CRYPTO_NSS=1 @XMLSEC_CORE_CFLAGS@
|
||||||
|
Libs: -L${libdir} -lxmlsec1-nss @XMLSEC_CORE_LIBS@
|
||||||
|
--- xmlsec1-1.2.9/configure.old 2005-12-16 00:51:22.000000000 -0500
|
||||||
|
+++ xmlsec1-1.2.9/configure 2005-12-16 00:52:02.000000000 -0500
|
||||||
|
@@ -25929,23 +25929,23 @@
|
||||||
|
else
|
||||||
|
PKG_CONFIG_MIN_VERSION=0.9.0
|
||||||
|
if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
|
||||||
|
- echo "$as_me:$LINENO: checking for mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION" >&5
|
||||||
|
-echo $ECHO_N "checking for mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION... $ECHO_C" >&6
|
||||||
|
+ echo "$as_me:$LINENO: checking for nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION" >&5
|
||||||
|
+echo $ECHO_N "checking for nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION... $ECHO_C" >&6
|
||||||
|
|
||||||
|
- if $PKG_CONFIG --exists "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION" ; then
|
||||||
|
+ if $PKG_CONFIG --exists "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION" ; then
|
||||||
|
echo "$as_me:$LINENO: result: yes" >&5
|
||||||
|
echo "${ECHO_T}yes" >&6
|
||||||
|
succeeded=yes
|
||||||
|
|
||||||
|
echo "$as_me:$LINENO: checking NSS_CFLAGS" >&5
|
||||||
|
echo $ECHO_N "checking NSS_CFLAGS... $ECHO_C" >&6
|
||||||
|
- NSS_CFLAGS=`$PKG_CONFIG --cflags "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
|
||||||
|
+ NSS_CFLAGS=`$PKG_CONFIG --cflags "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
|
||||||
|
echo "$as_me:$LINENO: result: $NSS_CFLAGS" >&5
|
||||||
|
echo "${ECHO_T}$NSS_CFLAGS" >&6
|
||||||
|
|
||||||
|
echo "$as_me:$LINENO: checking NSS_LIBS" >&5
|
||||||
|
echo $ECHO_N "checking NSS_LIBS... $ECHO_C" >&6
|
||||||
|
- NSS_LIBS=`$PKG_CONFIG --libs "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
|
||||||
|
+ NSS_LIBS=`$PKG_CONFIG --libs "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
|
||||||
|
echo "$as_me:$LINENO: result: $NSS_LIBS" >&5
|
||||||
|
echo "${ECHO_T}$NSS_LIBS" >&6
|
||||||
|
else
|
||||||
|
@@ -25953,7 +25953,7 @@
|
||||||
|
NSS_LIBS=""
|
||||||
|
## If we have a custom action on failure, don't print errors, but
|
||||||
|
## do set a variable so people can do so.
|
||||||
|
- NSS_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
|
||||||
|
+ NSS_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
--- xmlsec1-1.2.9/configure.in.old 2005-12-15 23:35:35.000000000 -0500
|
||||||
|
+++ xmlsec1-1.2.9/configure.in 2005-12-15 23:56:06.000000000 -0500
|
||||||
|
@@ -540,7 +540,7 @@
|
||||||
|
AC_MSG_RESULT(no)
|
||||||
|
NSS_FOUND="without"
|
||||||
|
elif test "z$with_nss" = "z" -a "z$with_nspr" = "z" -a "z$with_mozilla_ver" = "z" -a "z$PKG_CONFIG_ENABLED" = "zyes" ; then
|
||||||
|
- PKG_CHECK_MODULES(NSS, mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION,
|
||||||
|
+ PKG_CHECK_MODULES(NSS, nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION,
|
||||||
|
[NSS_FOUND=yes],
|
||||||
|
[NSS_FOUND=no])
|
||||||
|
fi
|
14
xmlsec1.spec
14
xmlsec1.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
||||||
Name: xmlsec1
|
Name: xmlsec1
|
||||||
Version: 1.2.9
|
Version: 1.2.9
|
||||||
Release: 3.1
|
Release: 4
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
|
Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
|
||||||
@ -13,7 +13,7 @@ BuildRequires: libxml2-devel >= 2.6.0
|
|||||||
BuildRequires: libxslt-devel >= 1.1.0
|
BuildRequires: libxslt-devel >= 1.1.0
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
Docdir: %{_docdir}
|
Docdir: %{_docdir}
|
||||||
Patch0: separate_nspr.patch
|
Patch0: separate_nspr_nss.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
||||||
@ -109,9 +109,9 @@ Group: Development/Libraries
|
|||||||
Requires: xmlsec1 = %{version}
|
Requires: xmlsec1 = %{version}
|
||||||
Requires: libxml2 >= 2.4.24
|
Requires: libxml2 >= 2.4.24
|
||||||
Requires: libxslt >= 1.0.20
|
Requires: libxslt >= 1.0.20
|
||||||
Requires: mozilla-nss >= 1.4
|
Requires: nss >= 3.2
|
||||||
Requires: nspr
|
Requires: nspr
|
||||||
BuildRequires: mozilla-nss-devel >= 1.4
|
BuildRequires: nss-devel >= 3.2
|
||||||
BuildRequires: nspr-devel
|
BuildRequires: nspr-devel
|
||||||
|
|
||||||
%description nss
|
%description nss
|
||||||
@ -126,7 +126,7 @@ Requires: xmlsec1-devel = %{version}
|
|||||||
Requires: xmlsec1-nss = %{version}
|
Requires: xmlsec1-nss = %{version}
|
||||||
Requires: libxml2-devel >= 2.4.24
|
Requires: libxml2-devel >= 2.4.24
|
||||||
Requires: libxslt-devel >= 1.0.20
|
Requires: libxslt-devel >= 1.0.20
|
||||||
Requires: mozilla-nss-devel >= 1.4
|
Requires: nss-devel >= 3.2
|
||||||
Requires: nspr-devel
|
Requires: nspr-devel
|
||||||
|
|
||||||
%description nss-devel
|
%description nss-devel
|
||||||
@ -227,6 +227,10 @@ rm -fr %{buildroot}
|
|||||||
%{prefix}/lib*/pkgconfig/xmlsec1-nss.pc
|
%{prefix}/lib*/pkgconfig/xmlsec1-nss.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
|
||||||
|
- NSS has been split out of the mozilla package, so require that now
|
||||||
|
and update separate_nspr.patch to account for the new NSS as well
|
||||||
|
|
||||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||||
- rebuilt
|
- rebuilt
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user