New upstream release
This commit is contained in:
parent
124ab2b26c
commit
37d17a5b08
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ xmlsec1-1.2.16.tar.gz
|
|||||||
/xmlsec1-1.2.20.tar.gz
|
/xmlsec1-1.2.20.tar.gz
|
||||||
/xmlsec1-1.2.23.tar.gz
|
/xmlsec1-1.2.23.tar.gz
|
||||||
/xmlsec1-1.2.25.tar.gz
|
/xmlsec1-1.2.25.tar.gz
|
||||||
|
/xmlsec1-1.2.27.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (xmlsec1-1.2.25.tar.gz) = ac61547a1cbf9016d7f75be3dc5249d6bc8a526bc51715e53ede13f056c1c72c57433a6be200c886000a25826c3e473954ded3ae988f25d37ac4ef4d777c66a6
|
SHA512 (xmlsec1-1.2.27.tar.gz) = 01f7231d7d7ac8037aecc1f922acc572cbfe0903abf5bd5879d836438c36684e23402b803d20806fff6b1cdc5ad9af114d1341b10b336f71c0bce28b4716f920
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
Please see this bug report for full details:
|
|
||||||
https://github.com/lsh123/xmlsec/issues/164
|
|
||||||
|
|
||||||
commit e303e077fb3e13654ba711b2816ff1a94247338b
|
|
||||||
Author: lsh123 <aleksey@aleksey.com>
|
|
||||||
Date: Wed Apr 11 17:13:43 2018 -1000
|
|
||||||
|
|
||||||
Add missing return(-1). (#165)
|
|
||||||
|
|
||||||
Fixed issue #164. All other crypto libraries are ok.
|
|
||||||
|
|
||||||
diff --git a/src/openssl/x509.c b/src/openssl/x509.c
|
|
||||||
index 15fe70db..b98e62d1 100644
|
|
||||||
--- a/src/openssl/x509.c
|
|
||||||
+++ b/src/openssl/x509.c
|
|
||||||
@@ -870,6 +870,7 @@ xmlSecOpenSSLX509DataNodeRead(xmlSecKeyDataPtr data, xmlNodePtr node, xmlSecKeyI
|
|
||||||
xmlSecInternalError2("xmlSecOpenSSLX509CertificateNodeRead",
|
|
||||||
xmlSecKeyDataGetName(data),
|
|
||||||
"node=%s", xmlSecErrorsSafeString(xmlSecNodeGetName(cur)));
|
|
||||||
+ return(-1);
|
|
||||||
}
|
|
||||||
} else if(xmlSecCheckNodeName(cur, xmlSecNodeX509SubjectName, xmlSecDSigNs)) {
|
|
||||||
ret = xmlSecOpenSSLX509SubjectNameNodeRead(data, cur, keyInfoCtx);
|
|
||||||
@@ -877,6 +878,7 @@ xmlSecOpenSSLX509DataNodeRead(xmlSecKeyDataPtr data, xmlNodePtr node, xmlSecKeyI
|
|
||||||
xmlSecInternalError2("xmlSecOpenSSLX509SubjectNameNodeRead",
|
|
||||||
xmlSecKeyDataGetName(data),
|
|
||||||
"node=%s", xmlSecErrorsSafeString(xmlSecNodeGetName(cur)));
|
|
||||||
+ return(-1);
|
|
||||||
}
|
|
||||||
} else if(xmlSecCheckNodeName(cur, xmlSecNodeX509IssuerSerial, xmlSecDSigNs)) {
|
|
||||||
ret = xmlSecOpenSSLX509IssuerSerialNodeRead(data, cur, keyInfoCtx);
|
|
||||||
@@ -884,6 +886,7 @@ xmlSecOpenSSLX509DataNodeRead(xmlSecKeyDataPtr data, xmlNodePtr node, xmlSecKeyI
|
|
||||||
xmlSecInternalError2("xmlSecOpenSSLX509IssuerSerialNodeRead",
|
|
||||||
xmlSecKeyDataGetName(data),
|
|
||||||
"node=%s", xmlSecErrorsSafeString(xmlSecNodeGetName(cur)));
|
|
||||||
+ return(-1);
|
|
||||||
}
|
|
||||||
} else if(xmlSecCheckNodeName(cur, xmlSecNodeX509SKI, xmlSecDSigNs)) {
|
|
||||||
ret = xmlSecOpenSSLX509SKINodeRead(data, cur, keyInfoCtx);
|
|
||||||
@@ -891,6 +894,7 @@ xmlSecOpenSSLX509DataNodeRead(xmlSecKeyDataPtr data, xmlNodePtr node, xmlSecKeyI
|
|
||||||
xmlSecInternalError2("xmlSecOpenSSLX509SKINodeRead",
|
|
||||||
xmlSecKeyDataGetName(data),
|
|
||||||
"node=%s", xmlSecErrorsSafeString(xmlSecNodeGetName(cur)));
|
|
||||||
+ return(-1);
|
|
||||||
}
|
|
||||||
} else if(xmlSecCheckNodeName(cur, xmlSecNodeX509CRL, xmlSecDSigNs)) {
|
|
||||||
ret = xmlSecOpenSSLX509CRLNodeRead(data, cur, keyInfoCtx);
|
|
||||||
@@ -898,6 +902,7 @@ xmlSecOpenSSLX509DataNodeRead(xmlSecKeyDataPtr data, xmlNodePtr node, xmlSecKeyI
|
|
||||||
xmlSecInternalError2("xmlSecOpenSSLX509CRLNodeRead",
|
|
||||||
xmlSecKeyDataGetName(data),
|
|
||||||
"node=%s", xmlSecErrorsSafeString(xmlSecNodeGetName(cur)));
|
|
||||||
+ return(-1);
|
|
||||||
}
|
|
||||||
} else if((keyInfoCtx->flags & XMLSEC_KEYINFO_FLAGS_X509DATA_STOP_ON_UNKNOWN_CHILD) != 0) {
|
|
||||||
/* laxi schema validation: ignore unknown nodes */
|
|
12
xmlsec1.spec
12
xmlsec1.spec
@ -1,9 +1,9 @@
|
|||||||
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
||||||
Name: xmlsec1
|
Name: xmlsec1
|
||||||
Version: 1.2.25
|
Version: 1.2.27
|
||||||
Release: 5%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: MIT
|
License: MIT
|
||||||
Source0: http://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
|
Source0: https://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
|
||||||
URL: http://www.aleksey.com/xmlsec/
|
URL: http://www.aleksey.com/xmlsec/
|
||||||
BuildRequires: pkgconfig(libxml-2.0) >= 2.8.0
|
BuildRequires: pkgconfig(libxml-2.0) >= 2.8.0
|
||||||
BuildRequires: pkgconfig(libxslt) >= 1.0.20
|
BuildRequires: pkgconfig(libxslt) >= 1.0.20
|
||||||
@ -19,8 +19,6 @@ BuildRequires: automake
|
|||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
|
|
||||||
Patch1: xmlSecOpenSSLX509DataNodeRead-error.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
||||||
The library was created with a goal to support major XML security
|
The library was created with a goal to support major XML security
|
||||||
@ -103,7 +101,6 @@ Libraries, includes, etc. for developing XML Security applications with NSS.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -vfi
|
autoreconf -vfi
|
||||||
@ -180,6 +177,9 @@ mv %{buildroot}%{_docdir}/xmlsec1/* __tmp_doc
|
|||||||
%{_libdir}/pkgconfig/xmlsec1-nss.pc
|
%{_libdir}/pkgconfig/xmlsec1-nss.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 23 2018 Simo Sorce <simo@redhat.com> - 1.2.27-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.25-5
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.25-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user