New upstream version 1.2.11 and rebuild for new gnutls, old patches are not

needed, integrated upstream, Daniel
This commit is contained in:
Daniel Veillard 2008-07-11 12:30:22 +00:00
parent 0f496080bb
commit 30bb7f9ce7
5 changed files with 28 additions and 125 deletions

View File

@ -2,3 +2,4 @@ xmlsec1-1.2.6.tar.gz
xmlsec1-1.2.7.tar.gz xmlsec1-1.2.7.tar.gz
xmlsec1-1.2.8.tar.gz xmlsec1-1.2.8.tar.gz
xmlsec1-1.2.9.tar.gz xmlsec1-1.2.9.tar.gz
xmlsec1-1.2.11.tar.gz

View File

@ -1,34 +0,0 @@
*** xmlsec/xmlsec-config.in.orig 2006-06-08 13:56:20.000000000 +0200
--- xmlsec/xmlsec-config.in 2006-06-08 14:01:10.000000000 +0200
***************
*** 4,9 ****
--- 4,15 ----
package="@PACKAGE@"
exec_prefix="@exec_prefix@"
exec_prefix_set=no
+ if [ "`ldd /bin/sh | grep lib64`" = "" ]
+ then
+ archlib=lib
+ else
+ archlib=lib64
+ fi
usage()
{
***************
*** 188,194 ****
# Assemble all the settings together
#
the_flags="$the_flags @XMLSEC_CORE_CFLAGS@ $the_xml_flags $the_xslt_flags $the_crypto_flags"
! the_libs="$the_libs -L${exec_prefix}/lib @XMLSEC_CORE_LIBS@ $the_xmlsec_crypto_lib -lxmlsec1 $the_xml_libs $the_xslt_libs $the_crypto_libs"
if $cflags; then
all_flags="$the_flags"
--- 194,200 ----
# Assemble all the settings together
#
the_flags="$the_flags @XMLSEC_CORE_CFLAGS@ $the_xml_flags $the_xslt_flags $the_crypto_flags"
! the_libs="$the_libs -L${exec_prefix}/$archlib @XMLSEC_CORE_LIBS@ $the_xmlsec_crypto_lib -lxmlsec1 $the_xml_libs $the_xslt_libs $the_crypto_libs"
if $cflags; then
all_flags="$the_flags"

View File

@ -1,61 +0,0 @@
--- xmlsec1-1.2.9/xmlsec-nss.pc.in.old 2005-12-15 23:36:20.000000000 -0500
+++ xmlsec1-1.2.9/xmlsec-nss.pc.in 2005-12-15 23:37:09.000000000 -0500
@@ -6,6 +6,6 @@
Name: xmlsec1-nss
Version: @VERSION@
Description: XML Security Library implements XML Signature and XML Encryption standards
-Requires: libxml-2.0 >= @LIBXML_MIN_VERSION@ libxslt >= @LIBXSLT_MIN_VERSION@ mozilla-nss >= @MOZILLA_MIN_VERSION@
+Requires: libxml-2.0 >= @LIBXML_MIN_VERSION@ libxslt >= @LIBXSLT_MIN_VERSION@ nss >= @NSS_MIN_VERSION@
Cflags: -DXMLSEC_CRYPTO=\\\"nss\\\" -DXMLSEC_CRYPTO_NSS=1 @XMLSEC_CORE_CFLAGS@
Libs: -L${libdir} -lxmlsec1-nss @XMLSEC_CORE_LIBS@
--- xmlsec1-1.2.9/configure.old 2005-12-16 00:51:22.000000000 -0500
+++ xmlsec1-1.2.9/configure 2005-12-16 00:52:02.000000000 -0500
@@ -25929,23 +25929,23 @@
else
PKG_CONFIG_MIN_VERSION=0.9.0
if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
- echo "$as_me:$LINENO: checking for mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION" >&5
-echo $ECHO_N "checking for mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION... $ECHO_C" >&6
+ echo "$as_me:$LINENO: checking for nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION" >&5
+echo $ECHO_N "checking for nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION... $ECHO_C" >&6
- if $PKG_CONFIG --exists "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION" ; then
+ if $PKG_CONFIG --exists "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION" ; then
echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
succeeded=yes
echo "$as_me:$LINENO: checking NSS_CFLAGS" >&5
echo $ECHO_N "checking NSS_CFLAGS... $ECHO_C" >&6
- NSS_CFLAGS=`$PKG_CONFIG --cflags "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
+ NSS_CFLAGS=`$PKG_CONFIG --cflags "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
echo "$as_me:$LINENO: result: $NSS_CFLAGS" >&5
echo "${ECHO_T}$NSS_CFLAGS" >&6
echo "$as_me:$LINENO: checking NSS_LIBS" >&5
echo $ECHO_N "checking NSS_LIBS... $ECHO_C" >&6
- NSS_LIBS=`$PKG_CONFIG --libs "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
+ NSS_LIBS=`$PKG_CONFIG --libs "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
echo "$as_me:$LINENO: result: $NSS_LIBS" >&5
echo "${ECHO_T}$NSS_LIBS" >&6
else
@@ -25953,7 +25953,7 @@
NSS_LIBS=""
## If we have a custom action on failure, don't print errors, but
## do set a variable so people can do so.
- NSS_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION"`
+ NSS_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION"`
fi
--- xmlsec1-1.2.9/configure.in.old 2005-12-15 23:35:35.000000000 -0500
+++ xmlsec1-1.2.9/configure.in 2005-12-15 23:56:06.000000000 -0500
@@ -540,7 +540,7 @@
AC_MSG_RESULT(no)
NSS_FOUND="without"
elif test "z$with_nss" = "z" -a "z$with_nspr" = "z" -a "z$with_mozilla_ver" = "z" -a "z$PKG_CONFIG_ENABLED" = "zyes" ; then
- PKG_CHECK_MODULES(NSS, mozilla-nspr >= $MOZILLA_MIN_VERSION mozilla-nss >= $MOZILLA_MIN_VERSION,
+ PKG_CHECK_MODULES(NSS, nspr >= $NSPR_MIN_VERSION nss >= $NSS_MIN_VERSION,
[NSS_FOUND=yes],
[NSS_FOUND=no])
fi

View File

@ -1 +1 @@
b378a076708766966724aaeba09e4607 xmlsec1-1.2.9.tar.gz 5652d44eec1375a399a6c61f5f6091f1 xmlsec1-1.2.11.tar.gz

View File

@ -1,11 +1,11 @@
Summary: Library providing support for "XML Signature" and "XML Encryption" standards Summary: Library providing support for "XML Signature" and "XML Encryption" standards
Name: xmlsec1 Name: xmlsec1
Version: 1.2.9 Version: 1.2.11
Release: 10.1 Release: 1
License: MIT License: MIT
Group: Development/Libraries Group: Development/Libraries
Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
URL: http://www.aleksey.com/xmlsec/ URL: http://www.aleksey.com/xmlsec/
Requires: libxml2 >= 2.6.0 Requires: libxml2 >= 2.6.0
Requires: libxslt >= 1.1.0 Requires: libxslt >= 1.1.0
@ -13,8 +13,6 @@ BuildRequires: libxml2-devel >= 2.6.0
BuildRequires: libxslt-devel >= 1.1.0 BuildRequires: libxslt-devel >= 1.1.0
Prefix: %{_prefix} Prefix: %{_prefix}
Docdir: %{_docdir} Docdir: %{_docdir}
Patch0: separate_nspr_nss.patch
Patch1: multilib.patch
%description %description
XML Security Library is a C library based on LibXML2 and OpenSSL. XML Security Library is a C library based on LibXML2 and OpenSSL.
@ -136,8 +134,6 @@ Libraries, includes, etc. for developing XML Security applications with NSS
%prep %prep
%setup -q %setup -q
%patch0 -p1
%patch1 -p1
%build %build
%configure %configure
@ -197,6 +193,7 @@ rm -fr %{buildroot}
%{prefix}/share/doc/xmlsec1/* %{prefix}/share/doc/xmlsec1/*
%doc AUTHORS HACKING ChangeLog NEWS README Copyright %doc AUTHORS HACKING ChangeLog NEWS README Copyright
%doc %{_mandir}/man1/xmlsec1-config.1* %doc %{_mandir}/man1/xmlsec1-config.1*
%{_datadir}/aclocal/xmlsec1.m4
%files openssl %files openssl
%defattr(-, root, root) %defattr(-, root, root)