Update to upstream 1.2.19 latest release
Had to patch to handle the fact taht we don't ship with ECDSA support Patch sent upstream
This commit is contained in:
parent
4e1ddbeae2
commit
217d1001e7
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
xmlsec1-1.2.16.tar.gz
|
xmlsec1-1.2.16.tar.gz
|
||||||
/xmlsec1-1.2.17.tar.gz
|
/xmlsec1-1.2.17.tar.gz
|
||||||
/xmlsec1-1.2.18.tar.gz
|
/xmlsec1-1.2.18.tar.gz
|
||||||
|
/xmlsec1-1.2.19.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
8694b4609aab647186607f79e1da7f1a xmlsec1-1.2.18.tar.gz
|
fe664ba5f01ebfaeb0ab5deeb0b2249e xmlsec1-1.2.19.tar.gz
|
||||||
|
25
xmlsec1-1.2.19-openssl-no-ecdsa.patch
Normal file
25
xmlsec1-1.2.19-openssl-no-ecdsa.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
--- configure.in.old 2013-03-25 20:12:45.641324517 +0800
|
||||||
|
+++ configure.in 2013-03-25 20:16:55.455082932 +0800
|
||||||
|
@@ -508,6 +508,22 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
if test "z$OPENSSL_FOUND" = "zyes" ; then
|
||||||
|
+ dnl Check availability of ECDSA
|
||||||
|
+ OLD_CPPFLAGS=$CPPFLAGS
|
||||||
|
+ CPPFLAGS="$OPENSSL_CFLAGS"
|
||||||
|
+
|
||||||
|
+ AC_EGREP_CPP(yes,[
|
||||||
|
+ #include <openssl/opensslconf.h>
|
||||||
|
+ #ifdef OPENSSL_NO_ECDSA
|
||||||
|
+ yes
|
||||||
|
+ #endif
|
||||||
|
+ ],[
|
||||||
|
+ OPENSSL_CFLAGS="$OPENSSL_CFLAGS -DXMLSEC_NO_ECDSA=1"
|
||||||
|
+ ])
|
||||||
|
+ CPPFLAGS=$OLD_CPPFLAGS
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "z$OPENSSL_FOUND" = "zyes" ; then
|
||||||
|
XMLSEC_NO_OPENSSL="0"
|
||||||
|
if test "z$OPENSSL_VERSION" = "z0.9.6" ; then
|
||||||
|
OPENSSL_CFLAGS="$OPENSSL_CFLAGS -DXMLSEC_OPENSSL_096=1 -DXMLSEC_NO_ECDSA=1"
|
16
xmlsec1.spec
16
xmlsec1.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
Summary: Library providing support for "XML Signature" and "XML Encryption" standards
|
||||||
Name: xmlsec1
|
Name: xmlsec1
|
||||||
Version: 1.2.18
|
Version: 1.2.19
|
||||||
Release: 4%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source0: http://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
|
Source0: http://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
|
||||||
@ -15,6 +15,13 @@ BuildRequires: gnutls-devel >= 1.0.20
|
|||||||
BuildRequires: nss-devel >= 3.2
|
BuildRequires: nss-devel >= 3.2
|
||||||
BuildRequires: nspr-devel
|
BuildRequires: nspr-devel
|
||||||
BuildRequires: libtool-ltdl-devel
|
BuildRequires: libtool-ltdl-devel
|
||||||
|
Patch1: xmlsec1-1.2.19-openssl-no-ecdsa.patch
|
||||||
|
# extra build deps needed for autoreconf after above patch
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: libtool
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
XML Security Library is a C library based on LibXML2 and OpenSSL.
|
||||||
@ -113,8 +120,10 @@ Libraries, includes, etc. for developing XML Security applications with NSS.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoreconf -if
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
@ -210,6 +219,9 @@ rm -fr %{buildroot}
|
|||||||
%{_libdir}/pkgconfig/xmlsec1-nss.pc
|
%{_libdir}/pkgconfig/xmlsec1-nss.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 25 2013 Daniel Veillard <veillard@redhat.com> - 1.2.19-1
|
||||||
|
- Update to upstream release 1.2.19
|
||||||
|
|
||||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.18-4
|
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.18-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user