087093797d
- patched the broken buildsystem - disabled libwww backend explicitely
33 lines
914 B
Plaintext
33 lines
914 B
Plaintext
From 68a7168a4324ab356e3992dfc182faf9d51ae821 Mon Sep 17 00:00:00 2001
|
|
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
|
Date: Sun, 17 Sep 2006 20:09:29 +0200
|
|
Subject: [PATCH] install libxmlrpc_util.so and set version-information
|
|
|
|
---
|
|
lib/libutil/CMakeLists.txt | 11 +++++++++++
|
|
1 files changed, 11 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/lib/libutil/CMakeLists.txt b/lib/libutil/CMakeLists.txt
|
|
index cc6ccab..5e5d382 100644
|
|
--- a/lib/libutil/CMakeLists.txt
|
|
+++ b/lib/libutil/CMakeLists.txt
|
|
@@ -8,4 +8,15 @@ add_library(xmlrpc_util SHARED
|
|
resource.c
|
|
sleep.c)
|
|
|
|
+set_target_properties(xmlrpc_util
|
|
+ PROPERTIES
|
|
+ LINK_FLAGS ${XMLRPC_LINKER_FLAGS}
|
|
+ VERSION ${XMLRPC_C_LIBVERSION}
|
|
+ SOVERSION ${XMLRPC_C_SOVERSION})
|
|
+
|
|
+install(TARGETS xmlrpc_util
|
|
+ RUNTIME DESTINATION ${_bin}
|
|
+ LIBRARY DESTINATION ${_lib}
|
|
+ ARCHIVE DESTINATION ${_lib})
|
|
+
|
|
ensc_pkgconfig(xmlrpc_util)
|
|
--
|
|
1.4.2
|
|
|