087093797d
- patched the broken buildsystem - disabled libwww backend explicitely
44 lines
1.3 KiB
Plaintext
44 lines
1.3 KiB
Plaintext
From 226f9e8336f203d89143bb89f0efa2909d268928 Mon Sep 17 00:00:00 2001
|
|
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
|
Date: Sun, 17 Sep 2006 19:59:50 +0200
|
|
Subject: [PATCH] Install xmlrpc-c-config and man-pages + added ${mandir} variable
|
|
|
|
---
|
|
CMakeLists.txt | 5 +++++
|
|
tools/xml-rpc-api2cpp/CMakeLists.txt | 3 +++
|
|
2 files changed, 8 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 1e86c61..a6b76b0 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -203,9 +203,14 @@ set(_bin bin CACHE STRING "Basenam
|
|
set(prefix ${CMAKE_INSTALL_PREFIX})
|
|
set(libdir "${prefix}/${_lib}")
|
|
set(bindir "${prefix}/${_bin}")
|
|
+set(mandir "${prefix}/share/man")
|
|
set(pkgconfdir "${libdir}/pkgconfig")
|
|
set(includedir "${prefix}/include")
|
|
|
|
+#############
|
|
+
|
|
+install(PROGRAMS xmlrpc-c-config DESTINATION ${_bin})
|
|
+
|
|
enable_testing()
|
|
|
|
add_subdirectory(lib)
|
|
diff --git a/tools/xml-rpc-api2cpp/CMakeLists.txt b/tools/xml-rpc-api2cpp/CMakeLists.txt
|
|
index a97e33c..c759dec 100644
|
|
--- a/tools/xml-rpc-api2cpp/CMakeLists.txt
|
|
+++ b/tools/xml-rpc-api2cpp/CMakeLists.txt
|
|
@@ -10,3 +10,6 @@ target_link_libraries(xml-rpc-api2cpp xm
|
|
|
|
install(TARGETS xml-rpc-api2cpp
|
|
RUNTIME DESTINATION bin)
|
|
+
|
|
+install(FILES xml-rpc-api2cpp.1
|
|
+ DESTINATION ${mandir}/man1)
|
|
--
|
|
1.4.2
|
|
|