xmlrpc-c/0004-added-multilib-stuff.txt
ensc 087093797d - updated to 1.06.04
- patched the broken buildsystem
- disabled libwww backend explicitely
2006-09-18 06:22:42 +00:00

80 lines
2.4 KiB
Plaintext

From 6ec81dc315d105d733e4be4cdd02ef324e587bbe Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sun, 17 Sep 2006 15:53:23 +0200
Subject: [PATCH] added multilib stuff
---
CMakeLists.txt | 5 ++++-
lib/abyss/src/CMakeLists.txt | 6 +++---
src/CMakeLists.txt | 4 ++--
src/cpp/CMakeLists.txt | 4 ++--
4 files changed, 11 insertions(+), 8 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 239a434..7c668d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,8 +190,11 @@ add_custom_target(dist
COMMAND cd _dist && tar cjf ../xmlrpc-c-${XMLRPC_C_VERSION}.tar.bz2 xmlrpc-c-${XMLRPC_C_VERSION} --exclude=.git --exclude=CVS --exclude=.svn
)
+set(_lib lib CACHE STRING "Basename of the library-directory; usually 'lib' or 'lib64' (on multilib archs)")
+set(_bin bin CACHE STRING "Basename of the bin-directory; usually 'bin'")
set(prefix ${CMAKE_INSTALL_PREFIX})
-set(libdir "${prefix}/lib")
+set(libdir "${prefix}/${_lib}")
+set(bindir "${prefix}/${_bin}")
set(pkgconfdir "${libdir}/pkgconfig")
set(includedir "${prefix}/include")
diff --git a/lib/abyss/src/CMakeLists.txt b/lib/abyss/src/CMakeLists.txt
index 4e18b81..a8fb5a9 100644
--- a/lib/abyss/src/CMakeLists.txt
+++ b/lib/abyss/src/CMakeLists.txt
@@ -49,9 +49,9 @@ if(ENABLE_ABYSS_THREADS)
endif(ENABLE_ABYSS_THREADS)
install(TARGETS xmlrpc_abyss
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib)
+ RUNTIME DESTINATION ${_bin}
+ LIBRARY DESTINATION ${_lib}
+ ARCHIVE DESTINATION ${_lib})
set_target_properties(xmlrpc_abyss
PROPERTIES
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bc0dce3..b201fa1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -93,8 +93,8 @@ ensc_pkgconfig(xmlrpc_server_cgi)
install(TARGETS ${lib_TARGETS}
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib)
+ RUNTIME DESTINATION ${_bin}
+ LIBRARY DESTINATION ${_lib})
set_target_properties(${lib_TARGETS}
PROPERTIES
diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
index 3dba3a7..9ab2530 100644
--- a/src/cpp/CMakeLists.txt
+++ b/src/cpp/CMakeLists.txt
@@ -38,8 +38,8 @@ ensc_pkgconfig(xmlrpc_client++)
install(TARGETS ${lib_TARGETS}
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib)
+ RUNTIME DESTINATION ${_bin}
+ LIBRARY DESTINATION ${_lib})
set_target_properties(${lib_TARGETS}
PROPERTIES
--
1.4.2