087093797d
- patched the broken buildsystem - disabled libwww backend explicitely
97 lines
2.9 KiB
Plaintext
97 lines
2.9 KiB
Plaintext
From 53ca6acb5c628f143894147e1c789de68defbc6d Mon Sep 17 00:00:00 2001
|
|
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
|
Date: Sun, 17 Sep 2006 16:54:15 +0200
|
|
Subject: [PATCH] added some tools-directories
|
|
|
|
- build 'xmlrpc' and 'xmlrpc_transport' tools
|
|
- build lib/util stuff as static library which is used internally
|
|
---
|
|
lib/util/CMakeLists.txt | 13 +++++++++++++
|
|
tools/xmlrpc/CMakeLists.txt | 19 +++++++++++++++++++
|
|
tools/xmlrpc/config.h | 1 +
|
|
tools/xmlrpc_transport/CMakeLists.txt | 14 ++++++++++++++
|
|
tools/xmlrpc_transport/config.h | 1 +
|
|
5 files changed, 48 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/lib/util/CMakeLists.txt b/lib/util/CMakeLists.txt
|
|
new file mode 100644
|
|
index 0000000..be6ded2
|
|
--- /dev/null
|
|
+++ b/lib/util/CMakeLists.txt
|
|
@@ -0,0 +1,13 @@
|
|
+## -*- cmake -*-
|
|
+
|
|
+set(util_SOURCES
|
|
+ casprintf.c
|
|
+ cmdline_parser.c
|
|
+ getoptx.c
|
|
+ getoptx.h)
|
|
+
|
|
+if(WIN32)
|
|
+ list(APPEND util_SOURCES pthreadx_win32.c)
|
|
+endif(WIN32)
|
|
+
|
|
+add_library(util STATIC ${util_SOURCES})
|
|
diff --git a/tools/xmlrpc/CMakeLists.txt b/tools/xmlrpc/CMakeLists.txt
|
|
new file mode 100644
|
|
index 0000000..e313e37
|
|
--- /dev/null
|
|
+++ b/tools/xmlrpc/CMakeLists.txt
|
|
@@ -0,0 +1,19 @@
|
|
+# -*- cmake -*-
|
|
+
|
|
+add_executable(tool-xmlrpc
|
|
+ xmlrpc.c
|
|
+ dumpvalue.c
|
|
+ dumpvalue.h)
|
|
+target_link_libraries(tool-xmlrpc xmlrpc_client util)
|
|
+
|
|
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/tool-xmlrpc
|
|
+ DESTINATION ${_bin}
|
|
+ PERMISSIONS WORLD_EXECUTE GROUP_EXECUTE OWNER_EXECUTE OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ WORLD_READ
|
|
+ RENAME xmlrpc)
|
|
+
|
|
+## HACK: libwww has broken inter-lib dependencies and '-Wl,--as-needed' fails with it
|
|
+if(NOT MUST_BUILD_LIBWWW_CLIENT)
|
|
+ set_target_properties(tool-xmlrpc
|
|
+ PROPERTIES
|
|
+ LINK_FLAGS ${XMLRPC_LINKER_FLAGS})
|
|
+endif(NOT MUST_BUILD_LIBWWW_CLIENT)
|
|
diff --git a/tools/xmlrpc/config.h b/tools/xmlrpc/config.h
|
|
new file mode 100644
|
|
index 0000000..7409aed
|
|
--- /dev/null
|
|
+++ b/tools/xmlrpc/config.h
|
|
@@ -0,0 +1 @@
|
|
+#include <xmlrpc_config.h>
|
|
diff --git a/tools/xmlrpc_transport/CMakeLists.txt b/tools/xmlrpc_transport/CMakeLists.txt
|
|
new file mode 100644
|
|
index 0000000..0575488
|
|
--- /dev/null
|
|
+++ b/tools/xmlrpc_transport/CMakeLists.txt
|
|
@@ -0,0 +1,14 @@
|
|
+# -*- cmake -*-
|
|
+
|
|
+add_executable(xmlrpc_transport xmlrpc_transport.c)
|
|
+target_link_libraries(xmlrpc_transport xmlrpc_client util)
|
|
+
|
|
+install(TARGETS xmlrpc_transport
|
|
+ DESTINATION ${_bin})
|
|
+
|
|
+## HACK: libwww has broken inter-lib dependencies and '-Wl,--as-needed' fails with it
|
|
+if(NOT MUST_BUILD_LIBWWW_CLIENT)
|
|
+ set_target_properties(xmlrpc_transport
|
|
+ PROPERTIES
|
|
+ LINK_FLAGS ${XMLRPC_LINKER_FLAGS})
|
|
+endif(NOT MUST_BUILD_LIBWWW_CLIENT)
|
|
diff --git a/tools/xmlrpc_transport/config.h b/tools/xmlrpc_transport/config.h
|
|
new file mode 100644
|
|
index 0000000..7409aed
|
|
--- /dev/null
|
|
+++ b/tools/xmlrpc_transport/config.h
|
|
@@ -0,0 +1 @@
|
|
+#include <xmlrpc_config.h>
|
|
--
|
|
1.4.2
|
|
|