updated to 1.25.0

This commit is contained in:
Enrico Scholz 2010-12-30 21:17:11 +01:00
parent e79cc94ef7
commit f4d24797e1
8 changed files with 96 additions and 32 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/xmlrpc-c-1.24.4.tar.xz
/xmlrpc-c-1.25.0.tar.xz

View File

@ -1 +1 @@
2042
2074

View File

@ -1 +1 @@
e494975dbf99d1638b3e835ad46b9249 xmlrpc-c-1.24.4.tar.xz
d5d017ea29dce470c82105fafaf8cae3 xmlrpc-c-1.25.0.tar.xz

View File

@ -1,7 +1,7 @@
From 122cc57fd2501cabdec64c56c01ebfd7d380cb72 Mon Sep 17 00:00:00 2001
From 80047d74644eeda55c451aea59951eb502649cf4 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Thu, 29 Jul 2010 19:43:08 +0200
Subject: [PATCH 7/7] check vasprintf return value
Subject: [PATCH 7/8] check vasprintf return value
---
lib/libutil/asprintf.c | 3 ++-
@ -9,10 +9,10 @@ Subject: [PATCH 7/7] check vasprintf return value
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/lib/libutil/asprintf.c b/lib/libutil/asprintf.c
index bb4ca56..2c5ce7f 100644
index a79cd81..5a06f0f 100644
--- a/lib/libutil/asprintf.c
+++ b/lib/libutil/asprintf.c
@@ -100,7 +100,8 @@ xmlrpc_vasprintf(const char ** const retvalP,
@@ -121,7 +121,8 @@ xmlrpc_vasprintf(const char ** const retvalP,
char * string;
#if HAVE_ASPRINTF
@ -37,5 +37,5 @@ index 643f145..9139253 100644
simpleVasprintf(&string, fmt, varargs);
#endif
--
1.7.2.1
1.7.3.4

View File

@ -1,8 +1,9 @@
From 6c47c68ec5ab953c9846a9bb83cbe598e1a5802c Mon Sep 17 00:00:00 2001
From 045f8f7a446ea738b229478ef618a2705ee19aef Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH 1/7] make -> cmake transition
Subject: [PATCH 1/8] make -> cmake transition
cmake: updated
---
CMakeLists.txt | 284 +++++++++++++++++++++++++++
cmake/try-attr.cc | 3 +
@ -24,7 +25,7 @@ Subject: [PATCH 1/7] make -> cmake transition
lib/expat/xmlparse/xmlrpc_xmlparse.pc.cmake | 12 ++
lib/expat/xmltok/CMakeLists.txt | 23 +++
lib/expat/xmltok/xmlrpc_xmltok.pc.cmake | 9 +
lib/libutil/CMakeLists.txt | 25 +++
lib/libutil/CMakeLists.txt | 26 +++
lib/libutil/xmlrpc_util.pc.cmake | 10 +
lib/libwww_transport/CMakeLists.txt | 7 +
lib/util/CMakeLists.txt | 17 ++
@ -61,8 +62,8 @@ Subject: [PATCH 1/7] make -> cmake transition
transport_config.h.cmake | 16 ++
version.h.cmake | 5 +
xmlrpc-c-config | 105 ++++++++++
xmlrpc_config.h.cmake | 145 ++++++++++++++
58 files changed, 1525 insertions(+), 0 deletions(-)
xmlrpc_config.h.cmake | 147 ++++++++++++++
58 files changed, 1528 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c
@ -124,7 +125,7 @@ Subject: [PATCH 1/7] make -> cmake transition
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2781200
index 0000000..c3204fe
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,284 @@
@ -142,8 +143,8 @@ index 0000000..2781200
+
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "24" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "4" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "25" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "0" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -920,10 +921,10 @@ index 0000000..88e7ad8
+Cflags:
diff --git a/lib/libutil/CMakeLists.txt b/lib/libutil/CMakeLists.txt
new file mode 100644
index 0000000..06136db
index 0000000..25ba487
--- /dev/null
+++ b/lib/libutil/CMakeLists.txt
@@ -0,0 +1,25 @@
@@ -0,0 +1,26 @@
+# -*- cmake -*-
+
+add_library(xmlrpc_util SHARED
@ -934,6 +935,7 @@ index 0000000..06136db
+ memblock.c
+ select.c
+ sleep.c
+ string_number.c
+ time.c
+ utf8.c)
+
@ -1846,10 +1848,10 @@ index 0000000..50577fd
+exec pkg-config "$@" $comp
diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake
new file mode 100644
index 0000000..bb5931a
index 0000000..2859749
--- /dev/null
+++ b/xmlrpc_config.h.cmake
@@ -0,0 +1,145 @@
@@ -0,0 +1,147 @@
+/* -*- c -*- */
+
+#ifndef H_XMLRPC_C_CONFIG_H
@ -1948,8 +1950,10 @@ index 0000000..bb5931a
+
+#if MSVCRT
+ #define XMLRPC_SOCKETPAIR xmlrpc_win32_socketpair
+ #define XMLRPC_CLOSESOCKET closesocket
+#else
+ #define XMLRPC_SOCKETPAIR socketpair
+ #define XMLRPC_CLOSESOCKET close
+#endif
+
+#if defined(_MSC_VER)
@ -1996,5 +2000,5 @@ index 0000000..bb5931a
+
+#endif
--
1.7.2.3
1.7.3.4

View File

@ -0,0 +1,32 @@
From df68067713ab58bf14ac1e75eace9fac45dba7d9 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Thu, 30 Dec 2010 20:44:06 +0100
Subject: [PATCH 8/8] include missing <xmlrpc-c/string_int.h>
gives
| /tmp/xmlrpc-c/src/xmlrpc_libxml2.c: In function 'end_element':
| /tmp/xmlrpc-c/src/xmlrpc_libxml2.c:303:2: warning: implicit declaration of function 'xmlrpc_streq'
| ...
| ../src/libxmlrpc.so.3.25: undefined reference to `xmlrpc_streq'
else.
---
src/xmlrpc_libxml2.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/xmlrpc_libxml2.c b/src/xmlrpc_libxml2.c
index 57ae06b..ef073d4 100644
--- a/src/xmlrpc_libxml2.c
+++ b/src/xmlrpc_libxml2.c
@@ -38,6 +38,7 @@
#include "xmlrpc-c/base.h"
#include "xmlrpc-c/base_int.h"
+#include "xmlrpc-c/string_int.h"
#include "xmlrpc-c/xmlparser.h"
/* Define the contents of our internal structure. */
--
1.7.3.4

View File

@ -1,7 +1,7 @@
From 0e7ced23676e93d0ce953f97eebab27911fce42f Mon Sep 17 00:00:00 2001
From b06183b4942036f06b560cdb18b9eac26d2be89a Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 11:41:34 +0200
Subject: [PATCH 3/5] Use proper datatypes for 'long long'
Subject: [PATCH 3/8] Use proper datatypes for 'long long'
xmlrpc-c uses 'long long' at some places (e.g. in printf
statements with PRId64) under the assumption that it has a
@ -16,12 +16,13 @@ It is arguable whether 'int_least64_t' (and 'int_least32_t')
would be a better choice for 'int64_t' (and 'int32_t'), but
for now, the patch uses datatypes with exact widths.
---
include/xmlrpc-c/base.h | 5 +++--
src/cpp/param_list.cpp | 8 ++++----
2 files changed, 7 insertions(+), 6 deletions(-)
include/xmlrpc-c/base.h | 7 ++++---
lib/libutil/string_number.c | 1 +
src/cpp/param_list.cpp | 8 ++++----
3 files changed, 9 insertions(+), 7 deletions(-)
diff --git a/include/xmlrpc-c/base.h b/include/xmlrpc-c/base.h
index 80d6252..43b13c2 100644
index 66bf3f2..b7b654a 100644
--- a/include/xmlrpc-c/base.h
+++ b/include/xmlrpc-c/base.h
@@ -5,6 +5,7 @@
@ -30,9 +31,9 @@ index 80d6252..43b13c2 100644
#include <stdarg.h>
+#include <stdint.h>
#include <time.h>
#include <xmlrpc-c/c_util.h>
#include <xmlrpc-c/util.h>
#include <xmlrpc-c/config.h>
@@ -40,9 +41,9 @@ extern unsigned int const xmlrpc_version_point;
@@ -50,9 +51,9 @@ xmlrpc_version(unsigned int * const majorP,
typedef signed int xmlrpc_int;
/* An integer of the type defined by XML-RPC <int>; i.e. 32 bit */
@ -44,6 +45,27 @@ index 80d6252..43b13c2 100644
/* An integer of the type defined by "XML-RPC" <i8>; i.e. 64 bit */
typedef int xmlrpc_bool;
/* A boolean (of the type defined by XML-RPC <boolean>, but there's
@@ -89,7 +90,7 @@ typedef int xmlrpc_socket;
#define XMLRPC_INT32_MAX 0x7fffffff
#define XMLRPC_INT32_MIN (-XMLRPC_INT32_MAX - 1)
-#define XMLRPC_INT64_MAX 0x7fffffffffffffffll
+#define XMLRPC_INT64_MAX ((xmlrpc_int64)0x7fffffffffffffffll)
#define XMLRPC_INT64_MIN (-XMLRPC_INT64_MAX - 1)
diff --git a/lib/libutil/string_number.c b/lib/libutil/string_number.c
index 0294526..eb3a3f9 100644
--- a/lib/libutil/string_number.c
+++ b/lib/libutil/string_number.c
@@ -7,6 +7,7 @@
#include <stdbool.h>
#include <stdlib.h>
#include <string.h>
+#include <inttypes.h>
#include <errno.h>
#include <xmlrpc-c/base.h>
diff --git a/src/cpp/param_list.cpp b/src/cpp/param_list.cpp
index 67c636b..60f7df9 100644
--- a/src/cpp/param_list.cpp
@ -72,5 +94,5 @@ index 67c636b..60f7df9 100644
if (longlongvalue < minimum)
--
1.7.1.1
1.7.3.4

View File

@ -1,11 +1,11 @@
%global advanced_branch 1
%global svnrev 2042
%global svnrev 2074
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c
Version: 1.24.4
Version: 1.25.0
Release: %release_func 1500.svn%svnrev
# See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
@ -27,6 +27,7 @@ Patch105: xmlrpc-c-longlong.patch
Patch107: xmlrpc-c-uninit-curl.patch
Patch108: xmlrpc-c-30x-redirect.patch
Patch109: xmlrpc-c-check-vasprintf-return-value.patch
Patch110: xmlrpc-c-include-string_int.h.patch
BuildRoot: %_tmppath/%name-%version-%release-root
@ -115,6 +116,7 @@ This package contains some handy XML-RPC demo applications.
%patch107 -p1
%patch108 -p1
%patch109 -p1
%patch110 -p1
## not needed...
rm doc/{INSTALL,configure_doc}
@ -123,7 +125,7 @@ rm doc/{INSTALL,configure_doc}
%build
mkdir -p fedora
cd fedora
export CFLAGS="$RPM_OPT_FLAGS -Wno-uninitialized"
export CFLAGS="$RPM_OPT_FLAGS -Wno-uninitialized -Wno-unknown-pragmas"
export CXXFLAGS="$RPM_OPT_FLAGS"
export LDFLAGS="-Wl,-as-needed"
cmake .. \
@ -233,6 +235,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Dec 30 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.25.0-1500.svn2074
- updated to 1.25.0
* Sun Nov 7 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.24.4-1500.svn2042
- updated to 1.24.4