updated to 1.30.4
This commit is contained in:
parent
c23389e325
commit
b6b7ab61c4
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/xmlrpc-c-1.30.1.tar.xz
|
||||
/xmlrpc-c-1.30.4.tar.xz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
d7e53ee09b03fe5768bc3d9c70da1b73 xmlrpc-c-1.30.1.tar.xz
|
||||
e04d4db00a29c47db2c5d641a7936929 xmlrpc-c-1.30.4.tar.xz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From b7d3b22233f50a881972720c42c3ae0226e4f63d Mon Sep 17 00:00:00 2001
|
||||
From c86fa6d2bef36617385aebda3ee55da9a782b4d1 Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 5 Apr 2008 10:55:02 +0200
|
||||
Subject: [PATCH 1/8] make -> cmake transition
|
||||
@ -13,7 +13,7 @@ cmake: updated
|
||||
examples/cpp/CMakeLists.txt | 34 +++
|
||||
include/CMakeLists.txt | 3 +
|
||||
include/xmlrpc-c/CMakeLists.txt | 74 +++++++
|
||||
include/xmlrpc-c/config.h.cmake | 32 +++
|
||||
include/xmlrpc-c/config.h.cmake | 34 +++
|
||||
lib/CMakeLists.txt | 12 +
|
||||
lib/abyss/CMakeLists.txt | 3 +
|
||||
lib/abyss/src/CMakeLists.txt | 70 +++++++
|
||||
@ -64,7 +64,7 @@ cmake: updated
|
||||
version.h.cmake | 5 +
|
||||
xmlrpc-c-config | 105 ++++++++++
|
||||
xmlrpc_config.h.cmake | 177 ++++++++++++++++
|
||||
59 files changed, 1585 insertions(+), 0 deletions(-)
|
||||
59 files changed, 1587 insertions(+), 0 deletions(-)
|
||||
create mode 100644 CMakeLists.txt
|
||||
create mode 100644 cmake/try-attr.cc
|
||||
create mode 100644 cmake/va-list-is-array.c
|
||||
@ -127,7 +127,7 @@ cmake: updated
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
new file mode 100644
|
||||
index 0000000..080b866
|
||||
index 0000000..f2f114c
|
||||
--- /dev/null
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -0,0 +1,288 @@
|
||||
@ -146,7 +146,7 @@ index 0000000..080b866
|
||||
+
|
||||
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_MINOR "30" CACHE STRING "Version (minor) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_POINT "1" CACHE STRING "Version (point) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_POINT "4" CACHE STRING "Version (point) of xmlrpc-c")
|
||||
+
|
||||
+set(XMLRPC_C_VERSION
|
||||
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
|
||||
@ -155,8 +155,8 @@ index 0000000..080b866
|
||||
+set(XMLRPC_C_LIBVERSION "3.${XMLRPC_C_VERSION_MINOR}")
|
||||
+set(XMLRPC_C_SOVERSION "3")
|
||||
+
|
||||
+set(XMLRPC_CXX_LIBVERSION "7.${XMLRPC_C_VERSION_MINOR}")
|
||||
+set(XMLRPC_CXX_SOVERSION "7")
|
||||
+set(XMLRPC_CXX_LIBVERSION "8.${XMLRPC_C_VERSION_MINOR}")
|
||||
+set(XMLRPC_CXX_SOVERSION "8")
|
||||
+
|
||||
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MAJOR_NUM "${XMLRPC_C_VERSION_MAJOR}")
|
||||
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MINOR_NUM "${XMLRPC_C_VERSION_MINOR}")
|
||||
@ -650,10 +650,10 @@ index 0000000..b9386b8
|
||||
+endforeach(ln)
|
||||
diff --git a/include/xmlrpc-c/config.h.cmake b/include/xmlrpc-c/config.h.cmake
|
||||
new file mode 100644
|
||||
index 0000000..8398370
|
||||
index 0000000..48f64be
|
||||
--- /dev/null
|
||||
+++ b/include/xmlrpc-c/config.h.cmake
|
||||
@@ -0,0 +1,32 @@
|
||||
@@ -0,0 +1,34 @@
|
||||
+/* --*- c -*-- */
|
||||
+#ifndef XMLRPC_C_CONFIG_H_INCLUDED
|
||||
+#define XMLRPC_C_CONFIG_H_INCLUDED
|
||||
@ -678,11 +678,13 @@ index 0000000..8398370
|
||||
+ #define XMLRPC_HAVE_TIMEVAL 0
|
||||
+ #define XMLRPC_HAVE_TIMESPEC 0
|
||||
+ #define XMLRPC_HAVE_PTHREAD 0
|
||||
+ #define XMLRPC_HAVE_WINTHREAD 1
|
||||
+#else
|
||||
+ #define XMLRPC_SOCKET int
|
||||
+ #define XMLRPC_HAVE_TIMEVAL 1
|
||||
+ #define XMLRPC_HAVE_TIMESPEC 1
|
||||
+ #define XMLRPC_HAVE_PTHREAD 1
|
||||
+ #define XMLRPC_HAVE_WINTHREAD 0
|
||||
+#endif
|
||||
+
|
||||
+#endif
|
||||
|
@ -1,11 +1,11 @@
|
||||
%global advanced_branch 1
|
||||
%global svnrev 2298
|
||||
%global svnrev 2318
|
||||
|
||||
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
|
||||
|
||||
Summary: A lightweight RPC library based on XML and HTTP
|
||||
Name: xmlrpc-c
|
||||
Version: 1.30.1
|
||||
Version: 1.30.4
|
||||
Release: %release_func 1800.svn%svnrev
|
||||
# See COPYING for details.
|
||||
# The Python 1.5.2 license used by a few files is just BSD.
|
||||
@ -202,7 +202,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files c++
|
||||
%defattr(-,root,root,-)
|
||||
%_libdir/*.so.7*
|
||||
%_libdir/*.so.8*
|
||||
%exclude %_libdir/libxmlrpc_client++.so*
|
||||
|
||||
|
||||
@ -236,6 +236,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat May 12 2012 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.30.4-1800.svn2318
|
||||
- updated to 1.30.4
|
||||
|
||||
* Thu Apr 5 2012 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.30.1-1800.svn2298
|
||||
- updated to 1.30.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user