Update to 1.51.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2018-01-01 17:32:46 +01:00
parent e1bf03ae31
commit b442cf537e
5 changed files with 27 additions and 22 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@
/xmlrpc-c-1.47.1.tar.xz
/xmlrpc-c-1.48.0.tar.xz
/xmlrpc-c-1.49.02.tar.xz
/xmlrpc-c-1.51.0.tar.xz

View File

@ -1,4 +1,4 @@
From 80c476f2e478df414dfba77a321353178315510f Mon Sep 17 00:00:00 2001
From 0fa42d185e8770a49df5c0820159a25cb402a0b8 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 18 Dec 2016 10:24:31 +0100
Subject: [PATCH 1/2] add meson buildsystem definitions
@ -23,7 +23,7 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
lib/openssl/meson.build | 27 +++++
lib/util/meson.build | 20 ++++
meson.build | 209 +++++++++++++++++++++++++++++++++
meson_options.txt | 12 ++
meson_options.txt | 13 +++
src/cpp/meson.build | 223 ++++++++++++++++++++++++++++++++++++
src/meson.build | 190 ++++++++++++++++++++++++++++++
tools/lib/meson.build | 5 +
@ -38,7 +38,7 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
tools/xmlrpc_transport/meson.build | 18 +++
transport_config.h.in | 4 +
xmlrpc-c-config | 114 ++++++++++++++++++
33 files changed, 1394 insertions(+)
33 files changed, 1395 insertions(+)
create mode 100644 include/meson.build
create mode 100644 include/xmlrpc-c/config.h.in
create mode 100755 include/xmlrpc-c/lnsfr.sh
@ -146,7 +146,7 @@ index 00000000..83f231b7
+ln -sfr "${DESTDIR}${tgt}" "${DESTDIR}${src}"
diff --git a/include/xmlrpc-c/meson.build b/include/xmlrpc-c/meson.build
new file mode 100644
index 00000000..2fe3cb90
index 00000000..761acfd4
--- /dev/null
+++ b/include/xmlrpc-c/meson.build
@@ -0,0 +1,87 @@
@ -224,7 +224,7 @@ index 00000000..2fe3cb90
+ ['server_cgi.h', 'xmlrpc_cgi.h'],
+ ]
+endif
+if openssl.found()
+if get_option('abyss-openssl')
+ hdrs += [
+ 'openssl_thread.h',
+ ]
@ -239,7 +239,7 @@ index 00000000..2fe3cb90
+endforeach
diff --git a/lib/abyss++/meson.build b/lib/abyss++/meson.build
new file mode 100644
index 00000000..69f97d7c
index 00000000..19f04cc3
--- /dev/null
+++ b/lib/abyss++/meson.build
@@ -0,0 +1,43 @@
@ -247,7 +247,7 @@ index 00000000..69f97d7c
+ abysspp_chan_switch = 'AbyssChanSwitchWin.cpp'
+else
+ abysspp_chan_switch = ['AbyssChanSwitchUnix.cpp']
+ if openssl.found()
+ if get_option('abyss-openssl')
+ abysspp_chan_switch += ['AbyssChanSwitchOpenSsl.cpp']
+ endif
+endif
@ -295,7 +295,7 @@ index 00000000..9537275d
+subdir('src')
diff --git a/lib/abyss/src/meson.build b/lib/abyss/src/meson.build
new file mode 100644
index 00000000..32ecdfca
index 00000000..daa91fce
--- /dev/null
+++ b/lib/abyss/src/meson.build
@@ -0,0 +1,66 @@
@ -306,7 +306,7 @@ index 00000000..32ecdfca
+ abyss_deps += [threads]
+else
+ abyss_socket = ['socket_unix.c']
+ if openssl.found()
+ if get_option('abyss-openssl')
+ abyss_socket += ['socket_openssl.c']
+ abyss_deps += [openssl]
+ endif
@ -658,12 +658,12 @@ index 00000000..4cae4926
+endif
diff --git a/meson.build b/meson.build
new file mode 100644
index 00000000..028a5791
index 00000000..52a0f0eb
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,209 @@
+project('xmlrpc-c', 'c',
+ version : '1.47.99',
+ version : '1.51.0',
+ default_options : [
+ 'b_asneeded=true',
+ 'b_lundef=true',
@ -801,11 +801,11 @@ index 00000000..028a5791
+ conf.set('DIRECTORY_SEPARATOR', '/')
+endif
+
+openssl = dependency('openssl', required : false)
+if openssl.found()
+ conf.set('HAVE_OPENSSL_DEFINE', 1)
+openssl = dependency('openssl', required : get_option('abyss-openssl'))
+if get_option('abyss-openssl')
+ conf.set('HAVE_ABYSS_OPENSSL_DEFINE', 1)
+else
+ conf.set('HAVE_OPENSSL_DEFINE', 0)
+ conf.set('HAVE_ABYSS_OPENSSL_DEFINE', 0)
+endif
+
+if get_option('libwww-ssl')
@ -873,16 +873,17 @@ index 00000000..028a5791
+install_data('xmlrpc-c-config', install_dir : get_option('bindir'))
diff --git a/meson_options.txt b/meson_options.txt
new file mode 100644
index 00000000..822e91e7
index 00000000..4e2c1607
--- /dev/null
+++ b/meson_options.txt
@@ -0,0 +1,12 @@
@@ -0,0 +1,13 @@
+option('wininet-client', type : 'boolean', value : false, description : 'Build the Wininet client XML transport')
+option('curl-client', type : 'boolean', value : true, description : 'Build the Curl client XML transport')
+option('libwww-client', type : 'boolean', value : false, description : 'Build the Libwww client XML transport')
+
+option('abyss-server', type : 'boolean', value : true, description : 'Build the Abyss server module')
+option('abyss-threads', type: 'boolean', value : true, description : 'Use fork in Abyss instead of pthreads')
+option('abyss-openssl', type: 'boolean', value : true, description : 'Build Abyss Openssl channel function')
+option('cgi-server', type : 'boolean', value : true, description : 'Build the CGI server module')
+
+option('cplusplus', type : 'boolean', value : true, description : 'Build the C++ wrapper classes or tools')

View File

@ -1,4 +1,4 @@
From 7f1365adb3f186f77fddceb30430fe438fab9fa6 Mon Sep 17 00:00:00 2001
From d97ec6e652690a321d7ce8c81aa30f87d9c0de8f Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Mon, 19 Dec 2016 21:33:47 +0100
Subject: [PATCH 2/2] chmod +x xml-rpc-api2txt

View File

@ -1 +1 @@
SHA512 (xmlrpc-c-1.49.02.tar.xz) = ba2e4ba2a1beac63ee9ca1e0652cea0f639b690c06e154daf5efaeb80fa9d6d20bab9cd35d6f586dc27d43d15b8c4f41e327dfc470c4b311b825ca94271c0058
SHA512 (xmlrpc-c-1.51.0.tar.xz) = 23b0a2fd15ee8ee48d19ed2e329d1a81d3f5ed9b9c0948da736202dddcada1c0fdd378013392ef8e1a2380a2e83ea779d4d3f4f925ca7aab82d335f5c74c211e

View File

@ -5,9 +5,9 @@
%bcond_with libxml2
Name: xmlrpc-c
Version: 1.49.02
Release: 2%{?dist}
Summary: A lightweight RPC library based on XML and HTTP
Version: 1.51.0
Release: 1%{?dist}
Summary: Lightweight RPC library based on XML and HTTP
# See doc/COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
License: BSD and MIT
@ -193,6 +193,9 @@ This package contains some handy XML-RPC demo applications.
%{_bindir}/xmlrpc_dumpserver
%changelog
* Mon Jan 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.51.0-1
- Update to 1.51.0
* Sun Oct 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.49.02-2
- Fix Requires.private in xmlrpc_server++.pc