updated to 1.13.01
This commit is contained in:
parent
041594ebc9
commit
9fd5dcb2dc
2
sources
2
sources
@ -1 +1 @@
|
||||
dcc57ac5af6d8d59549a68425267ad92 xmlrpc-c-1.22.01.tar.bz2
|
||||
6187e37798c741367723186f73feabb6 xmlrpc-c-1.23.01.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
From dcf6c3f2ee6b75441bf71df91b0999810e230423 Mon Sep 17 00:00:00 2001
|
||||
From 9e7ac208115346e42c70cd5c11f59898d2e3bda2 Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 5 Apr 2008 10:55:02 +0200
|
||||
Subject: [PATCH 1/5] make -> cmake transition
|
||||
Subject: [PATCH 1/7] make -> cmake transition
|
||||
|
||||
---
|
||||
CMakeLists.txt | 284 +++++++++++++++++++++++++++
|
||||
@ -31,7 +31,7 @@ Subject: [PATCH 1/5] make -> cmake transition
|
||||
lib/wininet_transport/CMakeLists.txt | 7 +
|
||||
src/CMakeLists.txt | 122 ++++++++++++
|
||||
src/cpp/CMakeLists.txt | 70 +++++++
|
||||
src/cpp/test/CMakeLists.txt | 17 ++
|
||||
src/cpp/test/CMakeLists.txt | 18 ++
|
||||
src/cpp/xmlrpc++.pc.cmake | 12 ++
|
||||
src/cpp/xmlrpc_client++.pc.cmake | 12 ++
|
||||
src/cpp/xmlrpc_cpp.pc.cmake | 12 ++
|
||||
@ -40,7 +40,7 @@ Subject: [PATCH 1/5] make -> cmake transition
|
||||
src/cpp/xmlrpc_server_abyss++.pc.cmake | 12 ++
|
||||
src/cpp/xmlrpc_server_cgi++.pc.cmake | 12 ++
|
||||
src/cpp/xmlrpc_server_pstream++.pc.cmake | 12 ++
|
||||
src/test/CMakeLists.txt | 37 ++++
|
||||
src/test/CMakeLists.txt | 39 ++++
|
||||
src/xmlrpc.pc.cmake | 12 ++
|
||||
src/xmlrpc_client.pc.cmake | 12 ++
|
||||
src/xmlrpc_server.pc.cmake | 12 ++
|
||||
@ -61,8 +61,8 @@ Subject: [PATCH 1/5] make -> cmake transition
|
||||
transport_config.h.cmake | 16 ++
|
||||
version.h.cmake | 5 +
|
||||
xmlrpc-c-config | 105 ++++++++++
|
||||
xmlrpc_config.h.cmake | 141 +++++++++++++
|
||||
58 files changed, 1517 insertions(+), 0 deletions(-)
|
||||
xmlrpc_config.h.cmake | 145 ++++++++++++++
|
||||
58 files changed, 1524 insertions(+), 0 deletions(-)
|
||||
create mode 100644 CMakeLists.txt
|
||||
create mode 100644 cmake/try-attr.cc
|
||||
create mode 100644 cmake/va-list-is-array.c
|
||||
@ -124,7 +124,7 @@ Subject: [PATCH 1/5] make -> cmake transition
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
new file mode 100644
|
||||
index 0000000..c51d35a
|
||||
index 0000000..88e70d3
|
||||
--- /dev/null
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -0,0 +1,284 @@
|
||||
@ -142,7 +142,7 @@ index 0000000..c51d35a
|
||||
+
|
||||
+
|
||||
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_MINOR "22" CACHE STRING "Version (minor) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_MINOR "23" CACHE STRING "Version (minor) of xmlrpc-c")
|
||||
+set(XMLRPC_C_VERSION_POINT "01" CACHE STRING "Version (point) of xmlrpc-c")
|
||||
+
|
||||
+set(XMLRPC_C_VERSION
|
||||
@ -1219,14 +1219,15 @@ index 0000000..3171156
|
||||
+ SOVERSION ${XMLRPC_CXX_SOVERSION})
|
||||
diff --git a/src/cpp/test/CMakeLists.txt b/src/cpp/test/CMakeLists.txt
|
||||
new file mode 100644
|
||||
index 0000000..5b046b4
|
||||
index 0000000..dffd36c
|
||||
--- /dev/null
|
||||
+++ b/src/cpp/test/CMakeLists.txt
|
||||
@@ -0,0 +1,17 @@
|
||||
@@ -0,0 +1,18 @@
|
||||
+# -*- cmake -*-
|
||||
+
|
||||
+set(test_SOURCES
|
||||
+ test.cpp registry.cpp server_abyss.cpp server_pstream.cpp tools.cpp)
|
||||
+ test.cpp base64.cpp registry.cpp server_abyss.cpp
|
||||
+ server_pstream.cpp tools.cpp value.cpp xml.cpp )
|
||||
+
|
||||
+if(MUST_BUILD_CLIENT)
|
||||
+ list(APPEND test_SOURCES testclient.cpp)
|
||||
@ -1386,10 +1387,10 @@ index 0000000..da5639d
|
||||
+Cflags: -I${includedir}
|
||||
diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
|
||||
new file mode 100644
|
||||
index 0000000..0859ccc
|
||||
index 0000000..fdc6869
|
||||
--- /dev/null
|
||||
+++ b/src/test/CMakeLists.txt
|
||||
@@ -0,0 +1,37 @@
|
||||
@@ -0,0 +1,39 @@
|
||||
+# -*- cmake -*-
|
||||
+
|
||||
+set(test_SOURCES
|
||||
@ -1402,6 +1403,8 @@ index 0000000..0859ccc
|
||||
+ serialize.c
|
||||
+ serialize_value.c
|
||||
+ server_abyss.c
|
||||
+ testtool.c
|
||||
+ testtool.h
|
||||
+ value.c
|
||||
+ value_datetime.c
|
||||
+ xml_data.c)
|
||||
@ -1417,8 +1420,8 @@ index 0000000..0859ccc
|
||||
+add_executable(src-test ${test_SOURCES})
|
||||
+target_link_libraries(src-test xmlrpc_server_abyss util ${test_LIBS})
|
||||
+
|
||||
+add_executable(cgitest1 cgitest1.c)
|
||||
+target_link_libraries(cgitest1 xmlrpc_server_cgi)
|
||||
+add_executable(src-cgitest1 cgitest1.c testtool.c testtool.h)
|
||||
+target_link_libraries(src-cgitest1 xmlrpc_server_cgi)
|
||||
+
|
||||
+add_custom_command(TARGET src-test
|
||||
+ POST_BUILD
|
||||
@ -1842,10 +1845,10 @@ index 0000000..50577fd
|
||||
+exec pkg-config "$@" $comp
|
||||
diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake
|
||||
new file mode 100644
|
||||
index 0000000..1665576
|
||||
index 0000000..bb5931a
|
||||
--- /dev/null
|
||||
+++ b/xmlrpc_config.h.cmake
|
||||
@@ -0,0 +1,141 @@
|
||||
@@ -0,0 +1,145 @@
|
||||
+/* -*- c -*- */
|
||||
+
|
||||
+#ifndef H_XMLRPC_C_CONFIG_H
|
||||
@ -1986,7 +1989,11 @@ index 0000000..1665576
|
||||
+ #define XMLRPC_STRTOULL _strtoui64 /* Windows MSVC */
|
||||
+#endif
|
||||
+
|
||||
+#define XMLRPC_INT64 int64_t
|
||||
+#define XMLRPC_PRId64 PRId64
|
||||
+
|
||||
+
|
||||
+#endif
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.1.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From b6be576a399456ad8c24c29d05d8f2145d54cbaf Mon Sep 17 00:00:00 2001
|
||||
From 0e7ced23676e93d0ce953f97eebab27911fce42f Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 5 Apr 2008 11:41:34 +0200
|
||||
Subject: [PATCH 3/5] Use proper datatypes for 'long long'
|
||||
@ -72,5 +72,5 @@ index 67c636b..60f7df9 100644
|
||||
|
||||
if (longlongvalue < minimum)
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.1.1
|
||||
|
||||
|
@ -1,272 +1,12 @@
|
||||
From f3bbca91caac29b6b8f332d92f06261e16c86ba2 Mon Sep 17 00:00:00 2001
|
||||
From ba314cf0305759708075fb52e67b4ac1183b02a8 Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Mon, 25 Feb 2008 17:48:25 +0100
|
||||
Subject: [PATCH 2/5] fixed broken format string modifiers for size_t typed arguments
|
||||
Subject: [PATCH 2/7] fixed broken format string modifiers for size_t typed arguments
|
||||
|
||||
---
|
||||
lib/abyss/src/socket_unix.c | 4 ++--
|
||||
lib/libutil/memblock.c | 2 +-
|
||||
lib/libutil/utf8.c | 4 ++--
|
||||
src/cpp/packetsocket.cpp | 6 +++---
|
||||
src/cpp/server_cgi.cpp | 2 +-
|
||||
src/parse_datetime.c | 2 +-
|
||||
src/xmlrpc_data.c | 2 +-
|
||||
src/xmlrpc_datetime.c | 2 +-
|
||||
src/xmlrpc_decompose.c | 4 ++--
|
||||
src/xmlrpc_parse.c | 8 ++++----
|
||||
src/xmlrpc_server_abyss.c | 2 +-
|
||||
src/xmlrpc_string.c | 8 ++++----
|
||||
tools/xmlrpc/xmlrpc.c | 2 +-
|
||||
tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 2 +-
|
||||
14 files changed, 25 insertions(+), 25 deletions(-)
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/lib/abyss/src/socket_unix.c b/lib/abyss/src/socket_unix.c
|
||||
index f58efeb..42c2174 100644
|
||||
--- a/lib/abyss/src/socket_unix.c
|
||||
+++ b/lib/abyss/src/socket_unix.c
|
||||
@@ -193,8 +193,8 @@ channelWrite(TChannel * const channelP,
|
||||
fprintf(stderr, "Abyss channel: send() failed. "
|
||||
"Socket closed.\n");
|
||||
else
|
||||
- fprintf(stderr, "Abyss channel: sent %u bytes: '%.*s'\n",
|
||||
- rc, rc, &buffer[len-bytesLeft]);
|
||||
+ fprintf(stderr, "Abyss channel: sent %zu bytes: '%.*s'\n",
|
||||
+ rc, (int)rc, &buffer[len-bytesLeft]);
|
||||
}
|
||||
if (rc <= 0)
|
||||
/* 0 means connection closed; < 0 means severe error */
|
||||
diff --git a/lib/libutil/memblock.c b/lib/libutil/memblock.c
|
||||
index 2993eae..9468217 100644
|
||||
--- a/lib/libutil/memblock.c
|
||||
+++ b/lib/libutil/memblock.c
|
||||
@@ -74,7 +74,7 @@ xmlrpc_mem_block_init(xmlrpc_env * const envP,
|
||||
|
||||
blockP->_block = (void*) malloc(blockP->_allocated);
|
||||
if (!blockP->_block)
|
||||
- xmlrpc_faultf(envP, "Can't allocate %u-byte memory block",
|
||||
+ xmlrpc_faultf(envP, "Can't allocate %zu-byte memory block",
|
||||
blockP->_allocated);
|
||||
}
|
||||
|
||||
diff --git a/lib/libutil/utf8.c b/lib/libutil/utf8.c
|
||||
index 520c292..d7a211e 100644
|
||||
--- a/lib/libutil/utf8.c
|
||||
+++ b/lib/libutil/utf8.c
|
||||
@@ -277,8 +277,8 @@ decode_utf8(xmlrpc_env * const envP,
|
||||
if (utf8Cursor + length > utf8_len) {
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
envP, XMLRPC_INVALID_UTF8_ERROR,
|
||||
- "Invalid UTF-8 sequence indicates a %u-byte sequence "
|
||||
- "when only %u bytes are left in the string",
|
||||
+ "Invalid UTF-8 sequence indicates a %zu-byte sequence "
|
||||
+ "when only %zu bytes are left in the string",
|
||||
length, utf8_len - utf8Cursor);
|
||||
} else {
|
||||
decodeMultibyte(envP, &utf8_data[utf8Cursor], length, &wc);
|
||||
diff --git a/src/cpp/packetsocket.cpp b/src/cpp/packetsocket.cpp
|
||||
index bed2385..8cf55e6 100644
|
||||
--- a/src/cpp/packetsocket.cpp
|
||||
+++ b/src/cpp/packetsocket.cpp
|
||||
@@ -307,7 +307,7 @@ packet::initialize(const unsigned char * const data,
|
||||
this->bytes = reinterpret_cast<unsigned char *>(malloc(dataLength));
|
||||
|
||||
if (this->bytes == NULL)
|
||||
- throwf("Can't get storage for a %u-byte packet.", dataLength);
|
||||
+ throwf("Can't get storage for a %zu-byte packet.", dataLength);
|
||||
|
||||
this->allocSize = dataLength;
|
||||
|
||||
@@ -359,7 +359,7 @@ packet::addData(const unsigned char * const data,
|
||||
realloc(this->bytes, neededSize));
|
||||
|
||||
if (this->bytes == NULL)
|
||||
- throwf("Can't get storage for a %u-byte packet.", neededSize);
|
||||
+ throwf("Can't get storage for a %zu-byte packet.", neededSize);
|
||||
|
||||
memcpy(this->bytes + this->length, data, dataLength);
|
||||
|
||||
@@ -610,7 +610,7 @@ packetSocket_impl::verifyNothingAccumulated() {
|
||||
|
||||
if (this->inPacket)
|
||||
throwf("Stream socket closed in the middle of a packet "
|
||||
- "(%u bytes of packet received; no END marker to mark "
|
||||
+ "(%zu bytes of packet received; no END marker to mark "
|
||||
"end of packet)", this->packetAccumP->getLength());
|
||||
}
|
||||
|
||||
diff --git a/src/cpp/server_cgi.cpp b/src/cpp/server_cgi.cpp
|
||||
index c476dae..65518c7 100644
|
||||
--- a/src/cpp/server_cgi.cpp
|
||||
+++ b/src/cpp/server_cgi.cpp
|
||||
@@ -241,7 +241,7 @@ writeNormalHttpResp(FILE * const fileP,
|
||||
fprintf(fileP, "Set-Cookie: auth=%s\n", authCookie.c_str());
|
||||
|
||||
fprintf(fileP, "Content-type: text/xml; charset=\"utf-8\"\n");
|
||||
- fprintf(fileP, "Content-length: %u\n", httpBody.size());
|
||||
+ fprintf(fileP, "Content-length: %zu\n", httpBody.size());
|
||||
fprintf(fileP, "\n");
|
||||
|
||||
// HTTP body
|
||||
diff --git a/src/parse_datetime.c b/src/parse_datetime.c
|
||||
index f764c6e..5f91494 100644
|
||||
--- a/src/parse_datetime.c
|
||||
+++ b/src/parse_datetime.c
|
||||
@@ -375,7 +375,7 @@ validateFormatNoRegex(xmlrpc_env * const envP,
|
||||
if (strlen(dt) < 17)
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
envP, XMLRPC_PARSE_ERROR,
|
||||
- "Invalid length of %u of datetime. "
|
||||
+ "Invalid length of %zu of datetime. "
|
||||
"Must be at least 17 characters",
|
||||
strlen(dt));
|
||||
else {
|
||||
diff --git a/src/xmlrpc_data.c b/src/xmlrpc_data.c
|
||||
index 2a6baea..c9fd75c 100644
|
||||
--- a/src/xmlrpc_data.c
|
||||
+++ b/src/xmlrpc_data.c
|
||||
@@ -221,7 +221,7 @@ xmlrpc_read_base64(xmlrpc_env * const envP,
|
||||
byteStringValue = malloc(size);
|
||||
if (byteStringValue == NULL)
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
- envP, XMLRPC_INTERNAL_ERROR, "Unable to allocate %u bytes "
|
||||
+ envP, XMLRPC_INTERNAL_ERROR, "Unable to allocate %zu bytes "
|
||||
"for byte string.", size);
|
||||
else {
|
||||
memcpy(byteStringValue, contents, size);
|
||||
diff --git a/src/xmlrpc_datetime.c b/src/xmlrpc_datetime.c
|
||||
index 2a43c41..06e1c50 100644
|
||||
--- a/src/xmlrpc_datetime.c
|
||||
+++ b/src/xmlrpc_datetime.c
|
||||
@@ -468,7 +468,7 @@ validateFormat(xmlrpc_env * const envP,
|
||||
|
||||
if (strlen(dt) < 17)
|
||||
xmlrpc_faultf(envP,
|
||||
- "Invalid length of %u of datetime string. "
|
||||
+ "Invalid length of %zu of datetime string. "
|
||||
"Must be at least 17 characters",
|
||||
strlen(dt));
|
||||
else {
|
||||
diff --git a/src/xmlrpc_decompose.c b/src/xmlrpc_decompose.c
|
||||
index eeb3414..36e62f6 100644
|
||||
--- a/src/xmlrpc_decompose.c
|
||||
+++ b/src/xmlrpc_decompose.c
|
||||
@@ -712,7 +712,7 @@ buildArrayDecompBranch(xmlrpc_env * const envP,
|
||||
if (itemCnt >= ARRAY_SIZE(decompNodeP->store.Tarray.itemArray))
|
||||
xmlrpc_faultf(envP, "Too many array items in format string. "
|
||||
"The most items you can have for an array in "
|
||||
- "a format string is %u.",
|
||||
+ "a format string is %zu.",
|
||||
ARRAY_SIZE(decompNodeP->store.Tarray.itemArray));
|
||||
else {
|
||||
struct decompTreeNode * itemNodeP;
|
||||
@@ -850,7 +850,7 @@ buildStructDecompBranch(xmlrpc_env * const envP,
|
||||
xmlrpc_faultf(envP,
|
||||
"Too many structure members in format string. "
|
||||
"The most members you can specify in "
|
||||
- "a format string is %u.",
|
||||
+ "a format string is %zu.",
|
||||
ARRAY_SIZE(decompNodeP->store.Tstruct.mbrArray));
|
||||
else {
|
||||
struct mbrDecomp * const mbrP =
|
||||
diff --git a/src/xmlrpc_parse.c b/src/xmlrpc_parse.c
|
||||
index ea01638..7debbf2 100644
|
||||
--- a/src/xmlrpc_parse.c
|
||||
+++ b/src/xmlrpc_parse.c
|
||||
@@ -59,7 +59,7 @@ setParseFault(xmlrpc_env * const envP,
|
||||
do \
|
||||
if (xml_element_children_size(elem) != (count)) \
|
||||
XMLRPC_FAIL3(env, XMLRPC_PARSE_ERROR, \
|
||||
- "Expected <%s> to have %d children, found %d", \
|
||||
+ "Expected <%s> to have %d children, found %zd", \
|
||||
xml_element_name(elem), (count), \
|
||||
xml_element_children_size(elem)); \
|
||||
while (0)
|
||||
@@ -298,7 +298,7 @@ xmlrpc_parse_call(xmlrpc_env * const envP,
|
||||
if (xmlDataLen > xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID))
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
envP, XMLRPC_LIMIT_EXCEEDED_ERROR,
|
||||
- "XML-RPC request too large. Max allowed is %u bytes",
|
||||
+ "XML-RPC request too large. Max allowed is %zu bytes",
|
||||
xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID));
|
||||
else {
|
||||
xml_element * callElemP;
|
||||
@@ -550,8 +550,8 @@ xmlrpc_parse_response2(xmlrpc_env * const envP,
|
||||
if (xmlDataLen > xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID))
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
envP, XMLRPC_LIMIT_EXCEEDED_ERROR,
|
||||
- "XML-RPC response too large. Our limit is %u characters. "
|
||||
- "We got %u characters",
|
||||
+ "XML-RPC response too large. Our limit is %zu characters. "
|
||||
+ "We got %zu characters",
|
||||
xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID), xmlDataLen);
|
||||
else {
|
||||
xmlrpc_env env;
|
||||
diff --git a/src/xmlrpc_server_abyss.c b/src/xmlrpc_server_abyss.c
|
||||
index 1001d15..50329c2 100644
|
||||
--- a/src/xmlrpc_server_abyss.c
|
||||
+++ b/src/xmlrpc_server_abyss.c
|
||||
@@ -485,7 +485,7 @@ processCall(TSession * const abyssSessionP,
|
||||
if (contentSize > xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID))
|
||||
xmlrpc_env_set_fault_formatted(
|
||||
&env, XMLRPC_LIMIT_EXCEEDED_ERROR,
|
||||
- "XML-RPC request too large (%d bytes)", contentSize);
|
||||
+ "XML-RPC request too large (%zd bytes)", contentSize);
|
||||
else {
|
||||
xmlrpc_mem_block * body;
|
||||
/* Read XML data off the wire. */
|
||||
diff --git a/src/xmlrpc_string.c b/src/xmlrpc_string.c
|
||||
index 89eb128..100cd77 100644
|
||||
--- a/src/xmlrpc_string.c
|
||||
+++ b/src/xmlrpc_string.c
|
||||
@@ -141,7 +141,7 @@ xmlrpc_read_string(xmlrpc_env * const envP,
|
||||
MALLOCARRAY(stringValue, length + 1);
|
||||
if (stringValue == NULL)
|
||||
xmlrpc_faultf(envP, "Unable to allocate space "
|
||||
- "for %u-character string", length);
|
||||
+ "for %zu-character string", length);
|
||||
else {
|
||||
memcpy(stringValue, contents, length);
|
||||
stringValue[length] = '\0';
|
||||
@@ -189,7 +189,7 @@ copyAndConvertLfToCrlf(xmlrpc_env * const envP,
|
||||
MALLOCARRAY(dst, dstLen + 1);
|
||||
if (dst == NULL)
|
||||
xmlrpc_faultf(envP, "Unable to allocate space "
|
||||
- "for %u-character string", dstLen + 1);
|
||||
+ "for %zu-character string", dstLen + 1);
|
||||
else {
|
||||
const char * p; /* source pointer */
|
||||
char * q; /* destination pointer */
|
||||
@@ -370,7 +370,7 @@ xmlrpc_read_string_w(xmlrpc_env * const envP,
|
||||
wchar_t * stringValue;
|
||||
MALLOCARRAY(stringValue, length + 1);
|
||||
if (stringValue == NULL)
|
||||
- xmlrpc_faultf(envP, "Unable to allocate space for %u-byte string",
|
||||
+ xmlrpc_faultf(envP, "Unable to allocate space for %zu-byte string",
|
||||
length);
|
||||
else {
|
||||
memcpy(stringValue, wcontents, length * sizeof(wchar_t));
|
||||
@@ -422,7 +422,7 @@ wCopyAndConvertLfToCrlf(xmlrpc_env * const envP,
|
||||
MALLOCARRAY(dst, dstLen + 1);
|
||||
if (dst == NULL)
|
||||
xmlrpc_faultf(envP, "Unable to allocate space "
|
||||
- "for %u-character string", dstLen + 1);
|
||||
+ "for %zu-character string", dstLen + 1);
|
||||
else {
|
||||
const wchar_t * p; /* source pointer */
|
||||
wchar_t * q; /* destination pointer */
|
||||
diff --git a/tools/xmlrpc/xmlrpc.c b/tools/xmlrpc/xmlrpc.c
|
||||
index 2cf4fee..93255f3 100644
|
||||
--- a/tools/xmlrpc/xmlrpc.c
|
||||
+++ b/tools/xmlrpc/xmlrpc.c
|
||||
@@ -295,7 +295,7 @@ buildBytestring(xmlrpc_env * const envP,
|
||||
|
||||
if (valueStringSize / 2 * 2 != valueStringSize)
|
||||
xmlrpc_faultf(envP, "Hexadecimal text is not an even "
|
||||
- "number of characters (it is %u characters)",
|
||||
+ "number of characters (it is %zu characters)",
|
||||
strlen(valueString));
|
||||
else {
|
||||
size_t const byteStringSize = strlen(valueString)/2;
|
||||
diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
||||
index 1417708..0d6ec11 100644
|
||||
--- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
||||
@ -281,5 +21,5 @@ index 1417708..0d6ec11 100644
|
||||
else {
|
||||
vector<unsigned char> byteString(valueString.length() / 2);
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.1.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 0b4f92b8ebaf4c6c57b5f68f7a944ee8f4b6e964 Mon Sep 17 00:00:00 2001
|
||||
From 6affc342b968ec042d9efe84ca0ea40c8d88e8bf Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 21 Nov 2009 14:12:41 +0100
|
||||
Subject: [PATCH 5/5] fixed unitialized variable
|
||||
Subject: [PATCH 4/5] fixed unitialized variable
|
||||
|
||||
Reported by Nikola Pajkovsky <npajkovs AT redhat.com>:
|
||||
|
||||
@ -12,10 +12,10 @@ Reported by Nikola Pajkovsky <npajkovs AT redhat.com>:
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
|
||||
index 019c401..4e592da 100644
|
||||
index 59cb6ab..3c75010 100644
|
||||
--- a/lib/curl_transport/curltransaction.c
|
||||
+++ b/lib/curl_transport/curltransaction.c
|
||||
@@ -605,6 +605,7 @@ curlTransaction_create(xmlrpc_env * const envP,
|
||||
@@ -641,6 +641,7 @@ curlTransaction_create(xmlrpc_env * const envP,
|
||||
curlTransactionP->curlSessionP = curlSessionP;
|
||||
curlTransactionP->userContextP = userContextP;
|
||||
curlTransactionP->progress = progress;
|
||||
@ -24,5 +24,5 @@ index 019c401..4e592da 100644
|
||||
curlTransactionP->serverUrl = strdup(serverP->serverUrl);
|
||||
if (curlTransactionP->serverUrl == NULL)
|
||||
--
|
||||
1.7.0.1
|
||||
1.7.1.1
|
||||
|
||||
|
@ -1,41 +0,0 @@
|
||||
From bcb249907be37baabdecc68b8f9889ddaeec21ba Mon Sep 17 00:00:00 2001
|
||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||
Date: Sat, 15 Nov 2008 12:07:25 +0100
|
||||
Subject: [PATCH 4/5] 'va_list' param must be non-const
|
||||
|
||||
vasprintf(3) uses a non-const 'va_list ap' parameter.
|
||||
Hence, do not accept a 'const' in the wrapper function.
|
||||
---
|
||||
include/xmlrpc-c/util.h | 2 +-
|
||||
lib/libutil/error.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/xmlrpc-c/util.h b/include/xmlrpc-c/util.h
|
||||
index 30689bc..777ee01 100644
|
||||
--- a/include/xmlrpc-c/util.h
|
||||
+++ b/include/xmlrpc-c/util.h
|
||||
@@ -140,7 +140,7 @@ void
|
||||
xmlrpc_set_fault_formatted_v(xmlrpc_env * const envP,
|
||||
int const code,
|
||||
const char * const format,
|
||||
- va_list const args);
|
||||
+ va_list args);
|
||||
|
||||
/* The same as the above, but using a printf-style format string. */
|
||||
void
|
||||
diff --git a/lib/libutil/error.c b/lib/libutil/error.c
|
||||
index 02e66c9..1e0ab12 100644
|
||||
--- a/lib/libutil/error.c
|
||||
+++ b/lib/libutil/error.c
|
||||
@@ -88,7 +88,7 @@ void
|
||||
xmlrpc_set_fault_formatted_v(xmlrpc_env * const envP,
|
||||
int const code,
|
||||
const char * const format,
|
||||
- va_list const args) {
|
||||
+ va_list args) {
|
||||
|
||||
const char * faultDescription;
|
||||
|
||||
--
|
||||
1.7.0.1
|
||||
|
@ -1,12 +1,12 @@
|
||||
%global advanced_branch 1
|
||||
%global svnrev 1907
|
||||
%global svnrev 1958
|
||||
|
||||
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
|
||||
%{!?release_func:%global release_func() %1%{?dist}}
|
||||
|
||||
Summary: A lightweight RPC library based on XML and HTTP
|
||||
Name: xmlrpc-c
|
||||
Version: 1.22.01
|
||||
Version: 1.23.01
|
||||
Release: %release_func 1400.svn%svnrev
|
||||
# See COPYING for details.
|
||||
# The Python 1.5.2 license used by a few files is just BSD.
|
||||
@ -25,7 +25,6 @@ Source101: dso-fixup
|
||||
Patch100: xmlrpc-c-cmake.patch
|
||||
Patch102: xmlrpc-c-printf-size_t.patch
|
||||
Patch105: xmlrpc-c-longlong.patch
|
||||
Patch106: xmlrpc-c-va_list.patch
|
||||
Patch107: xmlrpc-c-uninit-curl.patch
|
||||
|
||||
|
||||
@ -112,7 +111,6 @@ This package contains some handy XML-RPC demo applications.
|
||||
%patch100 -p1
|
||||
%patch102 -p1
|
||||
%patch105 -p1
|
||||
%patch106 -p1
|
||||
%patch107 -p1
|
||||
|
||||
## not needed...
|
||||
@ -232,6 +230,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 29 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.23.01-1400.svn1958
|
||||
- updated to 1.23.01
|
||||
|
||||
* Sun Apr 18 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.22.01-1400.svn1907
|
||||
- updated to 1.22.01 (svn 1907)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user