- fixed cmake quoting so that pkgconfig files get correct version number

- fixed handling of 'server-util' and '--cflags' within xmlrpc-c-config
This commit is contained in:
ensc 2008-03-17 20:00:13 +00:00
parent df96507784
commit 9b9905af7c
2 changed files with 16 additions and 9 deletions

View File

@ -1,4 +1,4 @@
From 47cfdb0901f76d8b571a3c8fb6fa251e779c587c Mon Sep 17 00:00:00 2001 From 91b0e8786c1231172fc43848cab83773ad603c59 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Mon, 25 Feb 2008 17:19:20 +0100 Date: Mon, 25 Feb 2008 17:19:20 +0100
Subject: [PATCH] make -> cmake transition Subject: [PATCH] make -> cmake transition
@ -56,9 +56,9 @@ Subject: [PATCH] make -> cmake transition
tools/xmlrpc_transport/config.h | 1 + tools/xmlrpc_transport/config.h | 1 +
transport_config.h.cmake | 16 ++ transport_config.h.cmake | 16 ++
version.h.cmake | 5 + version.h.cmake | 5 +
xmlrpc-c-config | 74 ++++++++ xmlrpc-c-config | 77 ++++++++
xmlrpc_config.h.cmake | 87 +++++++++ xmlrpc_config.h.cmake | 87 +++++++++
54 files changed, 1288 insertions(+), 0 deletions(-) 54 files changed, 1291 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c create mode 100644 cmake/va-list-is-array.c
@ -116,7 +116,7 @@ Subject: [PATCH] make -> cmake transition
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..b23f79e index 0000000..aa21f44
--- /dev/null --- /dev/null
+++ b/CMakeLists.txt +++ b/CMakeLists.txt
@@ -0,0 +1,261 @@ @@ -0,0 +1,261 @@
@ -131,7 +131,7 @@ index 0000000..b23f79e
+set(XMLRPC_C_VERSION_POINT "8" CACHE STRING "Version (point) of xmlrpc-c") +set(XMLRPC_C_VERSION_POINT "8" CACHE STRING "Version (point) of xmlrpc-c")
+ +
+set(XMLRPC_C_VERSION +set(XMLRPC_C_VERSION
+ "$XMLRPC_C_VERSION_MAJOR.$XMLRPC_C_VERSION_MINOR.$XMLRPC_C_VERSION_POINT" + "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
+ CACHE STRING "Version of xmlrpc-c") + CACHE STRING "Version of xmlrpc-c")
+ +
+set(XMLRPC_C_LIBVERSION "3.13") +set(XMLRPC_C_LIBVERSION "3.13")
@ -1555,10 +1555,10 @@ index 0000000..12ab86d
+#define XMLRPC_VERSION_POINT @XMLRPC_C_VERSION_POINT_NUM@ +#define XMLRPC_VERSION_POINT @XMLRPC_C_VERSION_POINT_NUM@
diff --git a/xmlrpc-c-config b/xmlrpc-c-config diff --git a/xmlrpc-c-config b/xmlrpc-c-config
new file mode 100755 new file mode 100755
index 0000000..971800f index 0000000..8915017
--- /dev/null --- /dev/null
+++ b/xmlrpc-c-config +++ b/xmlrpc-c-config
@@ -0,0 +1,74 @@ @@ -0,0 +1,77 @@
+#! /bin/sh +#! /bin/sh
+ +
+comp= +comp=
@ -1573,7 +1573,7 @@ index 0000000..971800f
+while test $# -gt 0; do +while test $# -gt 0; do
+ case $1 in + case $1 in
+ (c++) comp="$comp xmlrpc_cpp";; + (c++) comp="$comp xmlrpc_cpp";;
+ (server-util) comp="$comp xmlrpc_server_util";; + (server-util) comp="$comp xmlrpc_server";;
+ (cgi-server) comp="$comp xmlrpc_server_cgi";; + (cgi-server) comp="$comp xmlrpc_server_cgi";;
+ (c++2) need_cxx=1;; + (c++2) need_cxx=1;;
+ (abyss-server) need_abyss=1;; + (abyss-server) need_abyss=1;;
@ -1625,6 +1625,9 @@ index 0000000..971800f
+ (--ldadd) + (--ldadd)
+ set -- --libs-only-l + set -- --libs-only-l
+ ;; + ;;
+ (--cflags)
+ set -- "$1"
+ ;;
+ (*) + (*)
+ dummy_comp= + dummy_comp=
+ ;; + ;;

View File

@ -5,7 +5,7 @@
Summary: A lightweight RPC library based on XML and HTTP Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c Name: xmlrpc-c
Version: 1.13.8 Version: 1.13.8
Release: %release_func 1 Release: %release_func 2
License: BSD/PSF -- see COPYING License: BSD/PSF -- see COPYING
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://xmlrpc-c.sourceforge.net/ URL: http://xmlrpc-c.sourceforge.net/
@ -124,6 +124,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Mar 17 2008 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.13.8-2
- fixed cmake quoting so that pkgconfig files get correct version number
- fixed handling of 'server-util' and '--cflags' within xmlrpc-c-config
* Sun Mar 16 2008 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.13.8-1 * Sun Mar 16 2008 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.13.8-1
- updated to 1.13.8 - updated to 1.13.8
- removed some patches which were applied upstream - removed some patches which were applied upstream