updated to 1.30.1

This commit is contained in:
Enrico Scholz 2012-04-05 13:10:16 +02:00
parent 8f316e0746
commit 839b0f0f50
5 changed files with 74 additions and 33 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/xmlrpc-c-1.29.0.tar.xz /xmlrpc-c-1.30.1.tar.xz

View File

@ -1 +1 @@
2233 2298

View File

@ -1 +1 @@
43d36b8255c0aca641cc60d7796ca29f xmlrpc-c-1.29.0.tar.xz d7e53ee09b03fe5768bc3d9c70da1b73 xmlrpc-c-1.30.1.tar.xz

View File

@ -1,7 +1,7 @@
From 668427e2d8fff3e6b51b6bb3ca8339e47a472a04 Mon Sep 17 00:00:00 2001 From b7d3b22233f50a881972720c42c3ae0226e4f63d Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200 Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH] make -> cmake transition Subject: [PATCH 1/8] make -> cmake transition
cmake: updated cmake: updated
--- ---
@ -47,12 +47,13 @@ cmake: updated
src/xmlrpc_server_abyss.pc.cmake | 12 + src/xmlrpc_server_abyss.pc.cmake | 12 +
src/xmlrpc_server_cgi.pc.cmake | 12 + src/xmlrpc_server_cgi.pc.cmake | 12 +
test/CMakeLists.txt | 39 ++++ test/CMakeLists.txt | 39 ++++
tools/CMakeLists.txt | 21 ++ tools/CMakeLists.txt | 22 ++
tools/binmode-rpc-kit/CMakeLists.txt | 1 + tools/binmode-rpc-kit/CMakeLists.txt | 1 +
tools/lib/CMakeLists.txt | 1 + tools/lib/CMakeLists.txt | 1 +
tools/turbocharger/CMakeLists.txt | 1 + tools/turbocharger/CMakeLists.txt | 1 +
tools/xml-rpc-api2cpp/CMakeLists.txt | 15 ++ tools/xml-rpc-api2cpp/CMakeLists.txt | 15 ++
tools/xml-rpc-api2txt/CMakeLists.txt | 7 + tools/xml-rpc-api2txt/CMakeLists.txt | 7 +
tools/xml/CMakeLists.txt | 16 ++
tools/xmlrpc/CMakeLists.txt | 17 ++ tools/xmlrpc/CMakeLists.txt | 17 ++
tools/xmlrpc/config.h | 1 + tools/xmlrpc/config.h | 1 +
tools/xmlrpc_cpp_proxy/CMakeLists.txt | 17 ++ tools/xmlrpc_cpp_proxy/CMakeLists.txt | 17 ++
@ -62,8 +63,8 @@ cmake: updated
transport_config.h.cmake | 16 ++ transport_config.h.cmake | 16 ++
version.h.cmake | 5 + version.h.cmake | 5 +
xmlrpc-c-config | 105 ++++++++++ xmlrpc-c-config | 105 ++++++++++
xmlrpc_config.h.cmake | 165 +++++++++++++++ xmlrpc_config.h.cmake | 177 ++++++++++++++++
58 files changed, 1556 insertions(+), 0 deletions(-) 59 files changed, 1585 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c create mode 100644 cmake/va-list-is-array.c
@ -112,6 +113,7 @@ cmake: updated
create mode 100644 tools/turbocharger/CMakeLists.txt create mode 100644 tools/turbocharger/CMakeLists.txt
create mode 100644 tools/xml-rpc-api2cpp/CMakeLists.txt create mode 100644 tools/xml-rpc-api2cpp/CMakeLists.txt
create mode 100644 tools/xml-rpc-api2txt/CMakeLists.txt create mode 100644 tools/xml-rpc-api2txt/CMakeLists.txt
create mode 100644 tools/xml/CMakeLists.txt
create mode 100644 tools/xmlrpc/CMakeLists.txt create mode 100644 tools/xmlrpc/CMakeLists.txt
create mode 100644 tools/xmlrpc/config.h create mode 100644 tools/xmlrpc/config.h
create mode 100644 tools/xmlrpc_cpp_proxy/CMakeLists.txt create mode 100644 tools/xmlrpc_cpp_proxy/CMakeLists.txt
@ -125,7 +127,7 @@ cmake: updated
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..2d83ce2 index 0000000..080b866
--- /dev/null --- /dev/null
+++ b/CMakeLists.txt +++ b/CMakeLists.txt
@@ -0,0 +1,288 @@ @@ -0,0 +1,288 @@
@ -143,8 +145,8 @@ index 0000000..2d83ce2
+ +
+ +
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c") +set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "29" CACHE STRING "Version (minor) of xmlrpc-c") +set(XMLRPC_C_VERSION_MINOR "30" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "0" CACHE STRING "Version (point) of xmlrpc-c") +set(XMLRPC_C_VERSION_POINT "1" CACHE STRING "Version (point) of xmlrpc-c")
+ +
+set(XMLRPC_C_VERSION +set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}" + "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -279,19 +281,19 @@ index 0000000..2d83ce2
+ +
+########### +###########
+ +
+set(ENABLE_TOOLS 0 CACHE BOOL "Build the tools")
+pkg_check_modules(NCURSES ncurses) +pkg_check_modules(NCURSES ncurses)
+find_library(READLINE readline) +find_library(READLINE readline)
+ +
+if (ENABLE_TOOLS)
+ message(STATUS "Building tools")
+if (MUST_BUILD_LIBWWW_CLIENT OR MUST_BUILD_WININET_CLIENT OR MUST_BUILD_CURL_CLIENT) +if (MUST_BUILD_LIBWWW_CLIENT OR MUST_BUILD_WININET_CLIENT OR MUST_BUILD_CURL_CLIENT)
+ if (NCURSES_FOUND AND READLINE) + if (NCURSES_FOUND AND READLINE)
+ set(BUILD_XMLRPC_PSTREAM 1) + set(BUILD_XMLRPC_PSTREAM 1)
+ message(STATUS "Building xmlrpc_pstream tool") + message(STATUS "Building xmlrpc_pstream tool")
+ endif() + endif()
+ message(STATUS "Tools will be built")
+ set(BUILD_TOOLS 1) + set(BUILD_TOOLS 1)
+ endif() +else()
+ message(STATUS "Tools will not be built")
+ set(BUILD_TOOLS 0)
+endif() +endif()
+ +
+#### <wchar.h> tests +#### <wchar.h> tests
@ -648,7 +650,7 @@ index 0000000..b9386b8
+endforeach(ln) +endforeach(ln)
diff --git a/include/xmlrpc-c/config.h.cmake b/include/xmlrpc-c/config.h.cmake diff --git a/include/xmlrpc-c/config.h.cmake b/include/xmlrpc-c/config.h.cmake
new file mode 100644 new file mode 100644
index 0000000..80892e5 index 0000000..8398370
--- /dev/null --- /dev/null
+++ b/include/xmlrpc-c/config.h.cmake +++ b/include/xmlrpc-c/config.h.cmake
@@ -0,0 +1,32 @@ @@ -0,0 +1,32 @@
@ -667,7 +669,7 @@ index 0000000..80892e5
+ This file was created by a make rule. + This file was created by a make rule.
+*/ +*/
+#define XMLRPC_HAVE_WCHAR @HAVE_WCHAR_H@ +#define XMLRPC_HAVE_WCHAR @HAVE_WCHAR_H@
+#ifdef WIN32 +#ifdef _WIN32
+ /* SOCKET is a type defined by <winsock.h>. Anyone who + /* SOCKET is a type defined by <winsock.h>. Anyone who
+ uses XMLRPC_SOCKET on a WIN32 system must #include + uses XMLRPC_SOCKET on a WIN32 system must #include
+ <winsock.h> + <winsock.h>
@ -1029,7 +1031,7 @@ index 0000000..17535ab
+endif(MUST_BUILD_WININET_CLIENT) +endif(MUST_BUILD_WININET_CLIENT)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..4f760bc index 0000000..e3635d2
--- /dev/null --- /dev/null
+++ b/src/CMakeLists.txt +++ b/src/CMakeLists.txt
@@ -0,0 +1,121 @@ @@ -0,0 +1,121 @@
@ -1125,7 +1127,7 @@ index 0000000..4f760bc
+### libxmlrpc_server_abyss.so +### libxmlrpc_server_abyss.so
+if(ENABLE_ABYSS_SERVER) +if(ENABLE_ABYSS_SERVER)
+ add_library(xmlrpc_server_abyss SHARED + add_library(xmlrpc_server_abyss SHARED
+ xmlrpc_server_abyss.c) + xmlrpc_server_abyss.c abyss_handler.c)
+ target_link_libraries(xmlrpc_server_abyss xmlrpc_abyss xmlrpc_server) + target_link_libraries(xmlrpc_server_abyss xmlrpc_abyss xmlrpc_server)
+ list(APPEND lib_TARGETS xmlrpc_server_abyss) + list(APPEND lib_TARGETS xmlrpc_server_abyss)
+ ensc_pkgconfig(xmlrpc_server_abyss) + ensc_pkgconfig(xmlrpc_server_abyss)
@ -1535,15 +1537,16 @@ index 0000000..fdc6869
+add_test(runtests src-test) +add_test(runtests src-test)
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..0bc45a9 index 0000000..cd2a6d7
--- /dev/null --- /dev/null
+++ b/tools/CMakeLists.txt +++ b/tools/CMakeLists.txt
@@ -0,0 +1,21 @@ @@ -0,0 +1,22 @@
+# -*- cmake -*- +# -*- cmake -*-
+ +
+add_subdirectory(lib) +add_subdirectory(lib)
+add_subdirectory(binmode-rpc-kit) +add_subdirectory(binmode-rpc-kit)
+add_subdirectory(turbocharger) +add_subdirectory(turbocharger)
+add_subdirectory(xml)
+ +
+if (MUST_BUILD_CLIENT) +if (MUST_BUILD_CLIENT)
+ add_subdirectory(xmlrpc) + add_subdirectory(xmlrpc)
@ -1615,6 +1618,28 @@ index 0000000..5b01824
+ +
+install(FILES xml-rpc-api2txt.1 +install(FILES xml-rpc-api2txt.1
+ DESTINATION ${mandir}/man1) + DESTINATION ${mandir}/man1)
diff --git a/tools/xml/CMakeLists.txt b/tools/xml/CMakeLists.txt
new file mode 100644
index 0000000..0bab80c
--- /dev/null
+++ b/tools/xml/CMakeLists.txt
@@ -0,0 +1,16 @@
+# -*- cmake -*-
+
+add_executable(xmlrpc_parsecall
+ xmlrpc_parsecall.c
+ ../lib/dumpvalue.c)
+
+target_link_libraries(xmlrpc_parsecall
+ xmlrpc
+ util)
+
+install(TARGETS xmlrpc_parsecall
+ DESTINATION ${_bin})
+
+include_directories(../lib/include)
+
+ensc_set_link_exe_flags(xmlrpc_parsecall)
diff --git a/tools/xmlrpc/CMakeLists.txt b/tools/xmlrpc/CMakeLists.txt diff --git a/tools/xmlrpc/CMakeLists.txt b/tools/xmlrpc/CMakeLists.txt
new file mode 100644 new file mode 100644
index 0000000..da01ec3 index 0000000..da01ec3
@ -1858,10 +1883,10 @@ index 0000000..50577fd
+exec pkg-config "$@" $comp +exec pkg-config "$@" $comp
diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake
new file mode 100644 new file mode 100644
index 0000000..a1f56aa index 0000000..561afdc
--- /dev/null --- /dev/null
+++ b/xmlrpc_config.h.cmake +++ b/xmlrpc_config.h.cmake
@@ -0,0 +1,165 @@ @@ -0,0 +1,177 @@
+/* -*- c -*- */ +/* -*- c -*- */
+ +
+#ifndef H_XMLRPC_C_CONFIG_H +#ifndef H_XMLRPC_C_CONFIG_H
@ -2013,6 +2038,11 @@ index 0000000..a1f56aa
+ #define XMLRPC_STRTOULL _strtoui64 /* Windows MSVC */ + #define XMLRPC_STRTOULL _strtoui64 /* Windows MSVC */
+#endif +#endif
+ +
+#if MSVCRT
+ #define snprintf _snprintf
+ #define popen _popen
+#endif
+
+#define XMLRPC_INT64 int64_t +#define XMLRPC_INT64 int64_t
+#define XMLRPC_PRId64 PRId64 +#define XMLRPC_PRId64 PRId64
+ +
@ -2020,13 +2050,20 @@ index 0000000..a1f56aa
+ systems have S_IREAD instead. Most Unix today (2011) has both. In 2011, + systems have S_IREAD instead. Most Unix today (2011) has both. In 2011,
+ Android has S_IRUSR and not S_IREAD. + Android has S_IRUSR and not S_IREAD.
+ +
+ Some Windows has _S_IREAD.
+
+ We're ignoring S_IREAD now to see if anyone misses it. If there are still + We're ignoring S_IREAD now to see if anyone misses it. If there are still
+ users that need it, we can handle it here. + users that need it, we can handle it here.
+*/ +*/
+#if MSVCRT
+ #define XMLRPC_S_IWUSR _S_IWRITE
+ #define XMLRPC_S_IRUSR _S_IREAD
+#else
+ #define XMLRPC_S_IWUSR S_IWUSR + #define XMLRPC_S_IWUSR S_IWUSR
+ #define XMLRPC_S_IRUSR S_IRUSR + #define XMLRPC_S_IRUSR S_IRUSR
+#endif
+ +
+#endif +#endif
-- --
1.7.6 1.7.7.6

View File

@ -1,11 +1,11 @@
%global advanced_branch 1 %global advanced_branch 1
%global svnrev 2233 %global svnrev 2298
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}} %{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
Summary: A lightweight RPC library based on XML and HTTP Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c Name: xmlrpc-c
Version: 1.29.0 Version: 1.30.1
Release: %release_func 1701.svn%svnrev Release: %release_func 1701.svn%svnrev
# See COPYING for details. # See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD. # The Python 1.5.2 license used by a few files is just BSD.
@ -230,11 +230,15 @@ rm -rf $RPM_BUILD_ROOT
%_bindir/xml-rpc-api2cpp %_bindir/xml-rpc-api2cpp
%_bindir/xmlrpc_cpp_proxy %_bindir/xmlrpc_cpp_proxy
%_bindir/xmlrpc_pstream %_bindir/xmlrpc_pstream
%_bindir/xmlrpc_parsecall
%exclude %_bindir/xml-rpc-api2txt %exclude %_bindir/xml-rpc-api2txt
%changelog %changelog
* Thu Apr 5 2012 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.30.1-1701.svn2298
- updated to 1.30.1
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29.0-1701.svn2233 * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29.0-1701.svn2233
- Rebuilt for c++ ABI breakage - Rebuilt for c++ ABI breakage