updated to 1.27.3

This commit is contained in:
Enrico Scholz 2011-08-07 12:55:27 +02:00
parent d4aaad0037
commit 6f18c9002b
6 changed files with 12 additions and 61 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/xmlrpc-c-1.26.0.tar.xz
/xmlrpc-c-1.26.3.tar.xz
/xmlrpc-c-1.27.0.tar.xz
/xmlrpc-c-1.27.3.tar.xz

View File

@ -1 +1 @@
2145
2169

View File

@ -1 +1 @@
a6bf32e29353362cbc59f05d1cc5c8ad xmlrpc-c-1.27.0.tar.xz
b5a4e6a305b1eb6ff20511d0a01e2f2a xmlrpc-c-1.27.3.tar.xz

View File

@ -1,4 +1,4 @@
From c819f1eed7853ae0e8d2f9e53e69f4704f08da5f Mon Sep 17 00:00:00 2001
From 83e2c5826ba8500c15ea3532fcf421da6e04bd82 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH 1/8] make -> cmake transition
@ -125,7 +125,7 @@ cmake: updated
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..740a713
index 0000000..69c14dc
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,288 @@
@ -144,7 +144,7 @@ index 0000000..740a713
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "27" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "0" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "2" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -2018,5 +2018,5 @@ index 0000000..9594e69
+
+#endif
--
1.7.5.4
1.7.6

View File

@ -1,51 +0,0 @@
From 167f1ae31f84c34fbf6406cdd0cc20eb9c9d0916 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Mon, 27 Jun 2011 21:07:18 +0200
Subject: [PATCH 9/9] do not include <curl/types.h> anymore
header file was removed in 7.21.7 and was empty since 2004.
---
lib/curl_transport/curlmulti.c | 1 -
lib/curl_transport/curltransaction.c | 1 -
lib/curl_transport/xmlrpc_curl_transport.c | 1 -
3 files changed, 0 insertions(+), 3 deletions(-)
diff --git a/lib/curl_transport/curlmulti.c b/lib/curl_transport/curlmulti.c
index 8f985de..dbb5820 100644
--- a/lib/curl_transport/curlmulti.c
+++ b/lib/curl_transport/curlmulti.c
@@ -19,7 +19,6 @@
#endif
#include <curl/curl.h>
-#include <curl/types.h>
#include <curl/easy.h>
#include <curl/multi.h>
diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
index 061392b..774be8b 100644
--- a/lib/curl_transport/curltransaction.c
+++ b/lib/curl_transport/curltransaction.c
@@ -17,7 +17,6 @@
#include "version.h"
#include <curl/curl.h>
-#include <curl/types.h>
#include <curl/easy.h>
#include "curlversion.h"
diff --git a/lib/curl_transport/xmlrpc_curl_transport.c b/lib/curl_transport/xmlrpc_curl_transport.c
index fe705b9..1504cc9 100644
--- a/lib/curl_transport/xmlrpc_curl_transport.c
+++ b/lib/curl_transport/xmlrpc_curl_transport.c
@@ -85,7 +85,6 @@
#include "xmlrpc-c/time_int.h"
#include <curl/curl.h>
-#include <curl/types.h>
#include <curl/easy.h>
#include <curl/multi.h>
--
1.7.5.4

View File

@ -5,8 +5,8 @@
Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c
Version: 1.27.0
Release: %release_func 1600.svn%svnrev
Version: 1.27.3
Release: %release_func 1700.svn%svnrev
# See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
License: BSD and MIT
@ -28,7 +28,6 @@ Patch107: xmlrpc-c-uninit-curl.patch
Patch108: xmlrpc-c-30x-redirect.patch
Patch109: xmlrpc-c-check-vasprintf-return-value.patch
Patch110: xmlrpc-c-include-string_int.h.patch
Patch111: xmlrpc-c-curl-types.h.patch
BuildRoot: %_tmppath/%name-%version-%release-root
@ -118,7 +117,6 @@ This package contains some handy XML-RPC demo applications.
%patch108 -p1
%patch109 -p1
%patch110 -p1
%patch111 -p1
## not needed...
rm doc/{INSTALL,configure_doc}
@ -237,6 +235,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Sun Aug 7 2011 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.27.3-1700.svn2145
- updated to 1.27.3
* Mon Jun 27 2011 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.27.0-1600.svn2145
- updated to 1.27.0
- made it build with recent curl