This commit is contained in:
ensc 2008-12-11 08:38:54 +00:00
parent c6e1f2861c
commit 6d9bc11ad0
10 changed files with 58 additions and 95 deletions

View File

@ -1 +1 @@
xmlrpc-c-1.16.4.tar.bz2
xmlrpc-c-1.16.6.tar.bz2

View File

@ -1 +1 @@
1.16.04
1.16.06

View File

@ -1 +1 @@
6ed4d98efd574b6f430da5171aa3a860 xmlrpc-c-1.16.4.tar.bz2
8389b0e11d93a61d9bd130f0cb77eaa4 xmlrpc-c-1.16.6.tar.bz2

View File

@ -1,25 +0,0 @@
From 23e1abe53511c61f297a226c03ea9f09ff58c86a Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 15 Nov 2008 11:35:26 +0100
Subject: [PATCH] fixed c++ syntax
---
src/cpp/server_cgi.cpp | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/cpp/server_cgi.cpp b/src/cpp/server_cgi.cpp
index da4152d..7b5baa2 100644
--- a/src/cpp/server_cgi.cpp
+++ b/src/cpp/server_cgi.cpp
@@ -37,7 +37,7 @@ public:
bool authCookiePresent;
string authCookie;
- httpInfo::httpInfo() {
+ httpInfo() {
const char * const requestMethodC = getenv("REQUEST_METHOD");
const char * const contentTypeC = getenv("CONTENT_TYPE");
--
1.5.6.5

View File

@ -1,18 +1,18 @@
From 01430cca6884e144cc196fc2120a3d3c11e6189b Mon Sep 17 00:00:00 2001
From d446ef878fb5984180ecf15a961af9550ae4f1c8 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH] make -> cmake transition
---
CMakeLists.txt | 249 +++++++++++++++++++++++++++
CMakeLists.txt | 254 +++++++++++++++++++++++++++
cmake/try-attr.cc | 3 +
cmake/va-list-is-array.c | 9 +
examples/CMakeLists.txt | 57 ++++++
examples/config.h | 1 +
examples/cpp/CMakeLists.txt | 30 ++++
examples/cpp/CMakeLists.txt | 30 +++
include/CMakeLists.txt | 3 +
include/xmlrpc-c/CMakeLists.txt | 73 ++++++++
include/xmlrpc-c/config.h.cmake | 30 ++++
include/xmlrpc-c/config.h.cmake | 30 +++
lib/CMakeLists.txt | 12 ++
lib/abyss/CMakeLists.txt | 3 +
lib/abyss/src/CMakeLists.txt | 64 +++++++
@ -29,8 +29,8 @@ Subject: [PATCH] make -> cmake transition
lib/libwww_transport/CMakeLists.txt | 7 +
lib/util/CMakeLists.txt | 17 ++
lib/wininet_transport/CMakeLists.txt | 7 +
src/CMakeLists.txt | 118 +++++++++++++
src/cpp/CMakeLists.txt | 66 +++++++
src/CMakeLists.txt | 121 +++++++++++++
src/cpp/CMakeLists.txt | 70 ++++++++
src/cpp/test/CMakeLists.txt | 17 ++
src/cpp/xmlrpc++.pc.cmake | 12 ++
src/cpp/xmlrpc_client++.pc.cmake | 12 ++
@ -61,7 +61,7 @@ Subject: [PATCH] make -> cmake transition
version.h.cmake | 5 +
xmlrpc-c-config | 80 +++++++++
xmlrpc_config.h.cmake | 99 +++++++++++
57 files changed, 1367 insertions(+), 0 deletions(-)
57 files changed, 1379 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c
@ -122,10 +122,10 @@ Subject: [PATCH] make -> cmake transition
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..25474f4
index 0000000..800f7fd
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,249 @@
@@ -0,0 +1,254 @@
+## -*- cmake -*-
+project(xmlrpc-c)
+include(FindPkgConfig)
@ -134,7 +134,7 @@ index 0000000..25474f4
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "16" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "4" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "6" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -225,6 +225,10 @@ index 0000000..25474f4
+ensc_set_bool(MUST_BUILD_CURL_CLIENT ${CURL_FOUND} "Set iff Curl client transport shall be built")
+set(curl_srcdir ${xmlrpc-c_SOURCE_DIR}/lib/curl_transport)
+
+if(MUST_BUILD_CURL_CLIENT)
+ set(MUST_BUILD_CLIENT 1)
+endif(MUST_BUILD_CURL_CLIENT)
+
+###########
+find_program(LIBWWW_CONFIG_EXECUTABLE libwww-config)
+if(DEFINED MUST_BUILD_LIBWWW_CLIENT)
@ -253,6 +257,7 @@ index 0000000..25474f4
+set(ENABLE_CPLUSPLUS 1 CACHE BOOL "Set iff C++ part shall be enabled")
+set(ENABLE_ABYSS_SERVER 1 CACHE BOOL "Set iff Abyss server shall be enabled")
+set(ENABLE_LIBXML2_BACKEND 1 CACHE BOOL "Set iff libxml2 backend shall be used")
+set(ENABLE_ABYSS_SERVER 1 CACHE BOOL "Set iff abyss server shall be enabled")
+set(ENABLE_ABYSS_THREADS 1 CACHE BOOL "Use pthread")
+
+if(ENABLE_LIBXML2_BACKEND)
@ -963,10 +968,10 @@ index 0000000..17535ab
+endif(MUST_BUILD_WININET_CLIENT)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..80af5a6
index 0000000..8490f9d
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,118 @@
@@ -0,0 +1,121 @@
+# -*- cmake -*-
+
+if(ENABLE_LIBXML2_BACKEND)
@ -1057,21 +1062,24 @@ index 0000000..80af5a6
+
+
+### libxmlrpc_server_abyss.so
+if(ENABLE_ABYSS_SERVER)
+ add_library(xmlrpc_server_abyss SHARED
+ xmlrpc_server_abyss.c)
+ target_link_libraries(xmlrpc_server_abyss xmlrpc_abyss xmlrpc_server)
+ list(APPEND lib_TARGETS xmlrpc_server_abyss)
+ ensc_pkgconfig(xmlrpc_server_abyss)
+endif(ENABLE_ABYSS_SERVER)
+
+
+
+### libxmlrpc_server_cgi.so
+if(ENABLE_CGI_SERVER)
+ add_library(xmlrpc_server_cgi SHARED
+ xmlrpc_server_cgi)
+ target_link_libraries(xmlrpc_server_cgi xmlrpc_server)
+ list(APPEND lib_TARGETS xmlrpc_server_cgi)
+ ensc_pkgconfig(xmlrpc_server_cgi)
+
+endif(ENABLE_CGI_SERVER)
+
+install(TARGETS ${lib_TARGETS}
+ RUNTIME DESTINATION ${_bin}
@ -1087,10 +1095,10 @@ index 0000000..80af5a6
+enable_testing()
diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
new file mode 100644
index 0000000..6091e2b
index 0000000..8bfe077
--- /dev/null
+++ b/src/cpp/CMakeLists.txt
@@ -0,0 +1,66 @@
@@ -0,0 +1,70 @@
+# -*- cmake -*-
+
+####### libxmlrpc++.so
@ -1114,16 +1122,20 @@ index 0000000..6091e2b
+ensc_pkgconfig(xmlrpc_server++)
+
+####### libxmlrpc_server_abyss++.so
+if(ENABLE_ABYSS_SERVER)
+ add_library(xmlrpc_server_abyss++ SHARED server_abyss.cpp)
+ target_link_libraries(xmlrpc_server_abyss++ xmlrpc_server++ xmlrpc_server_abyss)
+ list(APPEND lib_TARGETS xmlrpc_server_abyss++)
+ ensc_pkgconfig(xmlrpc_server_abyss++)
+endif(ENABLE_ABYSS_SERVER)
+
+####### libxmlrpc_server_cgi++.so
+if(ENABLE_CGI_SERVER)
+ add_library(xmlrpc_server_cgi++ SHARED server_cgi.cpp)
+ target_link_libraries(xmlrpc_server_cgi++ xmlrpc_server++)
+ list(APPEND lib_TARGETS xmlrpc_server_cgi++)
+ ensc_pkgconfig(xmlrpc_server_cgi++)
+endif(ENABLE_CGI_SERVER)
+
+####### libxmlrpc_server_pstream++.so
+add_library(xmlrpc_server_pstream++ SHARED server_pstream.cpp)
@ -1830,5 +1842,5 @@ index 0000000..1c9ece8
+
+#endif
--
1.5.6.5
1.6.0.4

View File

@ -1,4 +1,4 @@
From 57ba0a3556f5180f5c7b9d793672c055ec373eb5 Mon Sep 17 00:00:00 2001
From c589ecbb9258837fa8825a004b98bf8a46b2381c Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 11:41:34 +0200
Subject: [PATCH] Use proper datatypes for 'long long'
@ -106,5 +106,5 @@ index ff3a011..9f2f88e 100644
xmlrpc_read_int(&env.env_c, this->cValueP, &retval);
--
1.5.6.5
1.6.0.4

View File

@ -1,4 +1,4 @@
From 29df0db1c131eb08cfd745003116dc4b63c81ff4 Mon Sep 17 00:00:00 2001
From f9eeb8d7996aa84456bd4ce1f17d71f7d65fc4da Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Mon, 25 Feb 2008 17:48:25 +0100
Subject: [PATCH] fixed broken format string modifiers for size_t typed arguments
@ -45,10 +45,10 @@ index d79d4ca..25992e8 100644
}
diff --git a/src/cpp/server_cgi.cpp b/src/cpp/server_cgi.cpp
index 15d3df3..c8bb41d 100644
index 5b8e9ef..15996a0 100644
--- a/src/cpp/server_cgi.cpp
+++ b/src/cpp/server_cgi.cpp
@@ -240,7 +240,7 @@ writeNormalHttpResp(FILE * const fileP,
@@ -241,7 +241,7 @@ writeNormalHttpResp(FILE * const fileP,
fprintf(fileP, "Set-Cookie: auth=%s\n", authCookie.c_str());
fprintf(fileP, "Content-type: text/xml; charset=\"utf-8\"\n");
@ -205,5 +205,5 @@ index 1bdc44c..c4e0618 100644
else {
size_t const byteStringSize = strlen(valueString)/2;
--
1.5.6.5
1.6.0.4

View File

@ -1,24 +0,0 @@
From fbab59e1bc20b9ae885c5cfe2f5c4e9b083ae5bc Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 15 Nov 2008 11:34:53 +0100
Subject: [PATCH] include missing <stdlib.h>
---
src/cpp/server_cgi.cpp | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/src/cpp/server_cgi.cpp b/src/cpp/server_cgi.cpp
index c8bb41d..da4152d 100644
--- a/src/cpp/server_cgi.cpp
+++ b/src/cpp/server_cgi.cpp
@@ -14,6 +14,7 @@
#include <memory>
#include <stdio.h>
+#include <stdlib.h>
#include "xmlrpc-c/girerr.hpp"
using girerr::throwf;
--
1.5.6.5

View File

@ -1,4 +1,4 @@
From 4a8a7e8161d0e0b362508a6e51abf18d50712968 Mon Sep 17 00:00:00 2001
From 9ea7a544eef6498ea061696a594c50acc137ab40 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 15 Nov 2008 12:07:25 +0100
Subject: [PATCH] 'va_list' param must be non-const
@ -37,5 +37,5 @@ index fd964d0..b182308 100644
const char * faultDescription;
--
1.5.6.5
1.6.0.4

View File

@ -208,7 +208,7 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Dec 11 2008 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.16.6-2.1582
* Thu Dec 11 2008 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.16.6-1.1582
- updated to 1.16.6; rediffed patches
- fixed client headers (bug #475887)