- updated to 1.05
- updated patches
This commit is contained in:
parent
87644e3f99
commit
4c4dfa4ddb
@ -1 +1 @@
|
|||||||
xmlrpc-c-1.04.tgz
|
xmlrpc-c-*.tgz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
fc96628803ca72ebd86527039e4155df xmlrpc-c-1.04.tgz
|
60d59b39f13d21c3db9285274ea23bab xmlrpc-c-1.05.tgz
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
--- xmlrpc-c-1.04/src/cpp/libwww.cpp.namespace 2005-11-10 03:24:26.000000000 +0100
|
|
||||||
+++ xmlrpc-c-1.04/src/cpp/libwww.cpp 2005-12-15 21:03:48.000000000 +0100
|
|
||||||
@@ -32,7 +32,7 @@
|
|
||||||
using namespace xmlrpc_c;
|
|
||||||
|
|
||||||
|
|
||||||
-namespace {
|
|
||||||
+namespace xmlrpc_c {
|
|
||||||
|
|
||||||
carriageParm_libwww0::carriageParm_libwww0(
|
|
||||||
string const serverUrl
|
|
||||||
--- xmlrpc-c-1.04/src/cpp/wininet.cpp.namespace 2005-11-10 03:24:26.000000000 +0100
|
|
||||||
+++ xmlrpc-c-1.04/src/cpp/wininet.cpp 2005-12-15 21:04:01.000000000 +0100
|
|
||||||
@@ -32,7 +32,7 @@
|
|
||||||
using namespace xmlrpc_c;
|
|
||||||
|
|
||||||
|
|
||||||
-namespace {
|
|
||||||
+namespace xmlrpc_c {
|
|
||||||
|
|
||||||
carriageParm_wininet0::carriageParm_wininet0(
|
|
||||||
string const serverUrl
|
|
15
xmlrpc-c-1.05-buildsys.patch
Normal file
15
xmlrpc-c-1.05-buildsys.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- xmlrpc-c-1.05/include/Makefile.buildsys 2005-11-22 18:22:57.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/include/Makefile 2006-06-04 16:06:58.000000000 +0200
|
||||||
|
@@ -45,10 +45,11 @@ HEADERINST_PREFIX = /xmlrpc-c
|
||||||
|
ifeq ($(MUST_BUILD_CLIENT),yes)
|
||||||
|
HEADERS_TO_INSTALL += \
|
||||||
|
xmlrpc-c/client.h \
|
||||||
|
+ xmlrpc-c/client_global.h \
|
||||||
|
xmlrpc-c/transport.h \
|
||||||
|
|
||||||
|
ifeq ($(ENABLE_CPLUSPLUS),yes)
|
||||||
|
- HEADERS_TO_INSTALL += xmlrpc-c/client.hpp xmlrpc-c/client_simple.hpp
|
||||||
|
+ HEADERS_TO_INSTALL += xmlrpc-c/client.hpp xmlrpc-c/client_simple.hpp xmlrpc-c/client_transport.hpp
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
ifeq ($(ENABLE_CGI_SERVER),yes)
|
41
xmlrpc-c-1.05-gcc41.patch
Normal file
41
xmlrpc-c-1.05-gcc41.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
2006-06-04 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||||
|
* include/xmlrpc-c/server_abyss.hpp: fixed compilation with
|
||||||
|
gcc41 by removing duplicate class-name in method declaration
|
||||||
|
|
||||||
|
* examples/cpp/xmlrpc_loop_server.cpp: added includes and
|
||||||
|
namespaces for std::cout + std::endl
|
||||||
|
|
||||||
|
--- xmlrpc-c-1.05/examples/cpp/xmlrpc_loop_server.cpp.gcc41 2006-01-09 00:36:06.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/examples/cpp/xmlrpc_loop_server.cpp 2006-06-04 14:24:28.000000000 +0200
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include <xmlrpc-c/base.hpp>
|
||||||
|
#include <xmlrpc-c/registry.hpp>
|
||||||
|
#include <xmlrpc-c/server_abyss.hpp>
|
||||||
|
+#include <iostream>
|
||||||
|
|
||||||
|
using namespace std;
|
||||||
|
|
||||||
|
@@ -55,7 +56,7 @@ main(int const,
|
||||||
|
);
|
||||||
|
|
||||||
|
while (true) {
|
||||||
|
- cout << "Waiting for next RPC..." << endl;
|
||||||
|
+ std::cout << "Waiting for next RPC..." << std::endl;
|
||||||
|
|
||||||
|
myAbyssServer.runOnce();
|
||||||
|
/* This waits for the next connection, accepts it, reads the
|
||||||
|
--- xmlrpc-c-1.05/include/xmlrpc-c/server_abyss.hpp.gcc41 2006-01-29 04:59:31.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/include/xmlrpc-c/server_abyss.hpp 2006-06-04 14:22:36.000000000 +0200
|
||||||
|
@@ -84,10 +84,10 @@ private:
|
||||||
|
TServer cServer;
|
||||||
|
|
||||||
|
void
|
||||||
|
- serverAbyss::setAdditionalServerParms(constrOpt const& opt);
|
||||||
|
+ setAdditionalServerParms(constrOpt const& opt);
|
||||||
|
|
||||||
|
void
|
||||||
|
- serverAbyss::initialize(constrOpt const& opt);
|
||||||
|
+ initialize(constrOpt const& opt);
|
||||||
|
};
|
||||||
|
|
||||||
|
|
72
xmlrpc-c-1.05-libtool.patch
Normal file
72
xmlrpc-c-1.05-libtool.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
--- xmlrpc-c-1.05/tools/xml-rpc-api2cpp/Makefile.libtool 2005-09-23 04:17:35.000000000 +0200
|
||||||
|
+++ xmlrpc-c-1.05/tools/xml-rpc-api2cpp/Makefile 2006-06-04 15:02:13.000000000 +0200
|
||||||
|
@@ -22,11 +22,11 @@ LDFLAGS = $(CLIENT_LDFLAGS)
|
||||||
|
all: xml-rpc-api2cpp
|
||||||
|
|
||||||
|
OBJECTS = \
|
||||||
|
- xml-rpc-api2cpp.o \
|
||||||
|
- DataType.o \
|
||||||
|
- XmlRpcFunction.o \
|
||||||
|
- XmlRpcClass.o \
|
||||||
|
- SystemProxy.o \
|
||||||
|
+ xml-rpc-api2cpp.lo \
|
||||||
|
+ DataType.lo \
|
||||||
|
+ XmlRpcFunction.lo \
|
||||||
|
+ XmlRpcClass.lo \
|
||||||
|
+ SystemProxy.lo \
|
||||||
|
|
||||||
|
xml-rpc-api2cpp: \
|
||||||
|
$(OBJECTS) \
|
||||||
|
@@ -38,7 +38,7 @@ xml-rpc-api2cpp: \
|
||||||
|
$(LIBXMLRPC_UTIL)
|
||||||
|
$(LIBTOOL) --mode=link $(CXXLD) -o $@ $(LDFLAGS) $^
|
||||||
|
|
||||||
|
-%.o:%.cpp
|
||||||
|
+%.lo:%.cpp
|
||||||
|
$(LIBTOOL) --mode=compile $(CXX) -c $(CXXFLAGS) $<
|
||||||
|
|
||||||
|
# This Makefile.config dependency makes sure the symlinks get built before
|
||||||
|
--- xmlrpc-c-1.05/tools/xmlrpc/Makefile.libtool 2006-01-13 18:19:35.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/tools/xmlrpc/Makefile 2006-06-04 15:00:48.000000000 +0200
|
||||||
|
@@ -17,17 +17,17 @@ CFLAGS = $(CFLAGS_COMMON) $(INCLUDES) $(
|
||||||
|
|
||||||
|
LDFLAGS = $(CLIENT_LDFLAGS) $(LADD)
|
||||||
|
|
||||||
|
-UTIL_OBJS = cmdline_parser.o getoptx.o casprintf.o
|
||||||
|
+UTIL_OBJS = cmdline_parser.lo getoptx.lo casprintf.lo
|
||||||
|
UTILS = $(UTIL_OBJS:%=$(UTIL_DIR)/%)
|
||||||
|
|
||||||
|
LIBS = $(LIBXMLRPC_CLIENT) $(LIBXMLRPC) $(LIBXMLRPC_UTIL) $(LIBXML) $(UTILS)
|
||||||
|
|
||||||
|
-XMLRPC_OBJS = xmlrpc.o dumpvalue.o
|
||||||
|
+XMLRPC_OBJS = xmlrpc.lo dumpvalue.lo
|
||||||
|
|
||||||
|
xmlrpc: $(XMLRPC_OBJS) $(LIBS)
|
||||||
|
$(LIBTOOL) --mode=link $(CCLD) -o $@ $(LDFLAGS) $^
|
||||||
|
|
||||||
|
-%.o:%.c
|
||||||
|
+%.lo:%.c
|
||||||
|
$(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $<
|
||||||
|
|
||||||
|
*.c: config.h
|
||||||
|
--- xmlrpc-c-1.05/tools/xmlrpc_transport/Makefile.libtool 2005-11-23 05:04:51.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/tools/xmlrpc_transport/Makefile 2006-06-04 15:01:32.000000000 +0200
|
||||||
|
@@ -17,15 +17,15 @@ CFLAGS = $(CFLAGS_COMMON) $(INCLUDES) $(
|
||||||
|
|
||||||
|
LDFLAGS = $(CLIENT_LDFLAGS) $(LADD)
|
||||||
|
|
||||||
|
-UTIL_OBJS = cmdline_parser.o getoptx.o casprintf.o
|
||||||
|
+UTIL_OBJS = cmdline_parser.lo getoptx.lo casprintf.lo
|
||||||
|
UTILS = $(UTIL_OBJS:%=$(UTIL_DIR)/%)
|
||||||
|
|
||||||
|
LIBS = $(LIBXMLRPC_CLIENT) $(LIBXMLRPC) $(LIBXML) $(LIBXMLRPC_UTIL) $(UTILS)
|
||||||
|
|
||||||
|
-xmlrpc_transport:%:%.o $(LIBS)
|
||||||
|
+xmlrpc_transport:%:%.lo $(LIBS)
|
||||||
|
$(LIBTOOL) --mode=link $(CCLD) -o $@ $(LDFLAGS) $^
|
||||||
|
|
||||||
|
-%.o:%.c
|
||||||
|
+%.lo:%.c
|
||||||
|
$(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) $<
|
||||||
|
|
||||||
|
*.c: config.h
|
26
xmlrpc-c-1.05-typo.patch
Normal file
26
xmlrpc-c-1.05-typo.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
2006-06-04 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||||
|
* include/xmlrpc-c/client.hpp, src/cpp/client.cpp: fixed typo
|
||||||
|
in paramlist of the virtual client_xml::start() method.
|
||||||
|
|
||||||
|
--- xmlrpc-c-1.05/include/xmlrpc-c/client.hpp.typo 2006-03-23 00:45:34.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/include/xmlrpc-c/client.hpp 2006-06-04 14:26:10.000000000 +0200
|
||||||
|
@@ -150,7 +150,7 @@ public:
|
||||||
|
|
||||||
|
void
|
||||||
|
start(xmlrpc_c::carriageParm * const carriageParmP,
|
||||||
|
- std::string const methodName,
|
||||||
|
+ std::string const& methodName,
|
||||||
|
xmlrpc_c::paramList const& paramList,
|
||||||
|
xmlrpc_c::clientTransactionPtr const& tranP);
|
||||||
|
|
||||||
|
--- xmlrpc-c-1.05/src/cpp/client.cpp.typo 2006-03-23 00:44:44.000000000 +0100
|
||||||
|
+++ xmlrpc-c-1.05/src/cpp/client.cpp 2006-06-04 14:27:40.000000000 +0200
|
||||||
|
@@ -585,7 +585,7 @@ client_xml::call(carriageParm * const c
|
||||||
|
|
||||||
|
void
|
||||||
|
client_xml::start(carriageParm * const carriageParmP,
|
||||||
|
- string const methodName,
|
||||||
|
+ string const& methodName,
|
||||||
|
paramList const& paramList,
|
||||||
|
clientTransactionPtr const& tranP) {
|
||||||
|
|
@ -4,14 +4,17 @@
|
|||||||
|
|
||||||
Summary: A lightweight RPC library based on XML and HTTP
|
Summary: A lightweight RPC library based on XML and HTTP
|
||||||
Name: xmlrpc-c
|
Name: xmlrpc-c
|
||||||
Version: 1.04
|
Version: 1.05
|
||||||
Release: %release_func 2
|
Release: %release_func 0.2
|
||||||
License: BSD/PSF -- see COPYING
|
License: BSD/PSF -- see COPYING
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://xmlrpc-c.sourceforge.net/
|
URL: http://xmlrpc-c.sourceforge.net/
|
||||||
Source0: http://dl.sourceforge.net/sourceforge/xmlrpc-c/%name-%version.tgz
|
Source0: http://dl.sourceforge.net/sourceforge/xmlrpc-c/%name-%version.tgz
|
||||||
Patch0: xmlrpc-c-1.04-libxml2.patch
|
Patch0: xmlrpc-c-1.04-libxml2.patch
|
||||||
Patch1: xmlrpc-c-1.04-namespace.patch
|
Patch2: xmlrpc-c-1.05-gcc41.patch
|
||||||
|
Patch3: xmlrpc-c-1.05-typo.patch
|
||||||
|
Patch4: xmlrpc-c-1.05-libtool.patch
|
||||||
|
Patch5: xmlrpc-c-1.05-buildsys.patch
|
||||||
BuildRoot: %_tmppath/%name-%version-%release-root
|
BuildRoot: %_tmppath/%name-%version-%release-root
|
||||||
#BuildRequires: w3c-libwww-devel
|
#BuildRequires: w3c-libwww-devel
|
||||||
BuildRequires: curl-devel libxml2-devel
|
BuildRequires: curl-devel libxml2-devel
|
||||||
@ -52,10 +55,10 @@ This package contains some handy XML-RPC demo applications.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .libxml2
|
%patch0 -p1 -b .libxml2
|
||||||
%patch1 -p1 -b .namespace
|
%patch2 -p1 -b .gcc41
|
||||||
|
%patch3 -p1 -b .typo
|
||||||
## workaround bugs in the buildsystem
|
%patch4 -p1 -b .libtool
|
||||||
rm -f src/cpp/srcdir transport_config.h
|
%patch5 -p1 -b .buildsys
|
||||||
|
|
||||||
## not needed...
|
## not needed...
|
||||||
rm doc/{INSTALL,configure_doc}
|
rm doc/{INSTALL,configure_doc}
|
||||||
@ -110,7 +113,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%_bindir/xmlrpc-c-config
|
%_bindir/xmlrpc-c-config
|
||||||
%_includedir
|
%_includedir
|
||||||
%_libdir/*.so
|
%_libdir/*.so
|
||||||
%_libdir/*.a
|
|
||||||
|
|
||||||
|
|
||||||
%files apps
|
%files apps
|
||||||
@ -124,6 +126,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jun 4 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.05-0
|
||||||
|
- updated to 1.05
|
||||||
|
- updated patches
|
||||||
|
|
||||||
* Sat Feb 18 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.04-2
|
* Sat Feb 18 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.04-2
|
||||||
- rebuilt for FC5
|
- rebuilt for FC5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user