updated to 1.28.1

This commit is contained in:
Enrico Scholz 2011-10-03 21:27:23 +02:00
parent 066519debf
commit 0c94a1bf13
6 changed files with 48 additions and 43 deletions

10
.gitignore vendored
View File

@ -1,9 +1 @@
/xmlrpc-c-1.24.4.tar.xz
/xmlrpc-c-1.25.0.tar.xz
/xmlrpc-c-1.25.1.tar.xz
/xmlrpc-c-1.26.0.tar.xz
/xmlrpc-c-1.26.3.tar.xz
/xmlrpc-c-1.27.0.tar.xz
/xmlrpc-c-1.27.3.tar.xz
/xmlrpc-c-1.27.4.tar.xz
/xmlrpc-c-1.27.5.tar.xz
/xmlrpc-c-1.28.1.tar.xz

View File

@ -1 +1 @@
2182
2203

View File

@ -1 +1 @@
0c22580e707bd91be2478e93ea8bce72 xmlrpc-c-1.27.5.tar.xz
64461b02285792e9623f0af522c301f5 xmlrpc-c-1.28.1.tar.xz

View File

@ -1,14 +1,14 @@
From 83e2c5826ba8500c15ea3532fcf421da6e04bd82 Mon Sep 17 00:00:00 2001
From 668427e2d8fff3e6b51b6bb3ca8339e47a472a04 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH 1/8] make -> cmake transition
Subject: [PATCH 1/9] make -> cmake transition
cmake: updated
---
CMakeLists.txt | 288 +++++++++++++++++++++++++++
cmake/try-attr.cc | 3 +
cmake/va-list-is-array.c | 9 +
examples/CMakeLists.txt | 62 ++++++
examples/CMakeLists.txt | 63 ++++++
examples/config.h | 1 +
examples/cpp/CMakeLists.txt | 34 +++
include/CMakeLists.txt | 3 +
@ -62,8 +62,8 @@ cmake: updated
transport_config.h.cmake | 16 ++
version.h.cmake | 5 +
xmlrpc-c-config | 105 ++++++++++
xmlrpc_config.h.cmake | 156 +++++++++++++++
58 files changed, 1546 insertions(+), 0 deletions(-)
xmlrpc_config.h.cmake | 165 +++++++++++++++
58 files changed, 1556 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c
@ -125,7 +125,7 @@ cmake: updated
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..69c14dc
index 0000000..2d83ce2
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,288 @@
@ -143,8 +143,8 @@ index 0000000..69c14dc
+
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "27" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "5" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "28" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "1" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -443,10 +443,10 @@ index 0000000..1ad0bab
+int main() {}
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..30d0db5
index 0000000..4011f11
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,62 @@
@@ -0,0 +1,63 @@
+# -*- cmake -*-
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
@ -473,6 +473,7 @@ index 0000000..30d0db5
+set(base_LIBS xmlrpc)
+ensc_add_example(json c base)
+ensc_add_example(gen_sample_add_xml c base)
+ensc_add_example(parse_xml c base)
+
+if(MUST_BUILD_CLIENT)
+ set(client_LIBS xmlrpc_client)
@ -1857,10 +1858,10 @@ index 0000000..50577fd
+exec pkg-config "$@" $comp
diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake
new file mode 100644
index 0000000..9594e69
index 0000000..a1f56aa
--- /dev/null
+++ b/xmlrpc_config.h.cmake
@@ -0,0 +1,156 @@
@@ -0,0 +1,165 @@
+/* -*- c -*- */
+
+#ifndef H_XMLRPC_C_CONFIG_H
@ -2015,6 +2016,15 @@ index 0000000..9594e69
+#define XMLRPC_INT64 int64_t
+#define XMLRPC_PRId64 PRId64
+
+/* S_IRUSR is POSIX, defined in <sys/stat.h> Some old BSD systems and Windows
+ systems have S_IREAD instead. Most Unix today (2011) has both. In 2011,
+ Android has S_IRUSR and not S_IREAD.
+
+ We're ignoring S_IREAD now to see if anyone misses it. If there are still
+ users that need it, we can handle it here.
+*/
+#define XMLRPC_S_IWUSR S_IWUSR
+#define XMLRPC_S_IRUSR S_IRUSR
+
+#endif
--

View File

@ -1,11 +1,11 @@
From c06a722a77198ae42fb79b67d185556ac6c1e246 Mon Sep 17 00:00:00 2001
From 25a777bb0ee2e2ee17d87006f76b3cea5d15a9f7 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Mon, 25 Feb 2008 17:48:25 +0100
Subject: [PATCH 2/7] fixed broken format string modifiers
Subject: [PATCH 2/9] fixed broken format string modifiers
---
examples/json.c | 4 ++--
tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 2 +-
examples/json.c | 4 ++--
examples/parse_xml.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/examples/json.c b/examples/json.c
@ -30,19 +30,19 @@ index 89fe82b..91ea50d 100644
XMLRPC_MEMBLOCK_CONTENTS(char, &out));
XMLRPC_MEMBLOCK_CLEAN(char, &out);
diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
index 1417708..0d6ec11 100644
--- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
+++ b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
@@ -103,7 +103,7 @@ bytestringValFromParm(string const& valueString) {
diff --git a/examples/parse_xml.c b/examples/parse_xml.c
index 2e6c508..4f6c308 100644
--- a/examples/parse_xml.c
+++ b/examples/parse_xml.c
@@ -58,7 +58,7 @@ describeXmlElement(const xml_element * const elemP,
printf("%sXML element type: '%s'\n",
prefix, xml_element_name(elemP));
if (valueString.length() / 2 * 2 != valueString.length())
throwf("Hexadecimal text is not an even "
- "number of characters (it is %u characters)",
+ "number of characters (it is %zu characters)",
valueString.length());
else {
vector<unsigned char> byteString(valueString.length() / 2);
- printf("%sNumber of child elements: %u\n",
+ printf("%sNumber of child elements: %zu\n",
prefix, xml_element_children_size(elemP));
for (i = 0; i < xml_element_children_size(elemP); ++i) {
--
1.7.2.3
1.7.6

View File

@ -1,12 +1,12 @@
%global advanced_branch 1
%global svnrev 2185
%global svnrev 2203
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c
Version: 1.27.5
Release: %release_func 1701.svn%svnrev
Version: 1.28.1
Release: %release_func 1700.svn%svnrev
# See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
License: BSD and MIT
@ -237,6 +237,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Oct 3 2011 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.28.1-1700.svn2203
- updated to 1.28.1
* Mon Oct 3 2011 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.27.5-1701.svn2185
- fixed error handling when transfering too large files (#741980)