import xml-stylebook-1.0-0.25.b3_xalan2.svn313293.module+el8.1.0+3366+6dfb954c
This commit is contained in:
commit
43cb88226e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/xml-stylebook-1.0.tar.gz
|
1
.xml-stylebook.metadata
Normal file
1
.xml-stylebook.metadata
Normal file
@ -0,0 +1 @@
|
||||
78d58cfe30b0ee3ca02026daabfc0a6fbe5d17dc SOURCES/xml-stylebook-1.0.tar.gz
|
65
SOURCES/xml-stylebook-build-javadoc.patch
Normal file
65
SOURCES/xml-stylebook-build-javadoc.patch
Normal file
@ -0,0 +1,65 @@
|
||||
--- build.xml.orig 2004-12-14 15:54:50.000000000 +0000
|
||||
+++ build.xml 2010-06-12 19:50:39.976589551 +0100
|
||||
@@ -54,17 +54,16 @@
|
||||
<property name="build.dir" value="./build"/>
|
||||
<property name="build.src" value="${build.dir}/src"/>
|
||||
<property name="build.dest" value="${build.dir}/classes"/>
|
||||
+ <property name="build.javadoc" value="${build.dir}/javadoc"/>
|
||||
<property name="src.dir" value="./src"/>
|
||||
<property name="bin.dir" value="./bin"/>
|
||||
- <condition property="sun.codec.present" >
|
||||
- <available classname="com.sun.image.codec.jpeg.JPEGCodec"/>
|
||||
- </condition>
|
||||
</target>
|
||||
|
||||
<target name="prepare" depends="init">
|
||||
<mkdir dir="${build.dir}"/>
|
||||
<mkdir dir="${build.src}"/>
|
||||
<mkdir dir="${build.dest}"/>
|
||||
+ <mkdir dir="${build.javadoc}"/>
|
||||
<copy todir="${build.src}">
|
||||
<fileset dir="${src.dir}"/>
|
||||
</copy>
|
||||
@@ -86,15 +85,14 @@
|
||||
|
||||
<!--Compile and Package to work with Xalan-J 2 -->
|
||||
<target name="compile2" depends="prepare">
|
||||
- <javac srcdir="${src.dir}" excludes="org/apache/stylebook/processors/XalanProcessor.java" destdir="${build.dest}" debug="${debug}">
|
||||
+ <javac srcdir="${src.dir}" excludes="org/apache/stylebook/processors/XalanProcessor.java" destdir="${build.dest}" debug="${debug}" classpath="${classpath}">
|
||||
<exclude name="**/org/apache/stylebook/processors/XalanProcessor.java"/>
|
||||
- <exclude name="**/org/apache/stylebook/printers/ImagePrinter.java" unless="sun.codec.present"/>
|
||||
</javac>
|
||||
<copy todir="${build.dest}/org/apache/stylebook/data">
|
||||
<fileset dir="${build.src}/org/apache/stylebook/data"/>
|
||||
</copy>
|
||||
</target>
|
||||
- <target name="package2" depends="compile2">
|
||||
+ <target name="package2" depends="compile2,javadoc">
|
||||
<replace file="${build.dest}/org/apache/stylebook/data/engine.xml" token="XalanProcessor" value="Xalan2Processor"/>
|
||||
<jar jarfile="${bin.dir}/${name}-${version-xalan-2}.jar" basedir="${build.dest}" includes="org/**"/>
|
||||
</target>
|
||||
@@ -103,4 +101,24 @@
|
||||
<deltree dir="${build.dir}"/>
|
||||
</target>
|
||||
|
||||
+ <target name="javadoc" depends="prepare">
|
||||
+ <javadoc destdir="${build.javadoc}"
|
||||
+ additionalparam="-Xdoclint:none"
|
||||
+ classpath="${classpath}"
|
||||
+ packagenames="*"
|
||||
+ noindex="false"
|
||||
+ splitindex="true"
|
||||
+ use="true"
|
||||
+ version="true"
|
||||
+ author="true"
|
||||
+ windowtitle="${name} ${version-xalan-2}"
|
||||
+ doctitle="${name} ${version-xalan-2} JavaDoc">
|
||||
+ <fileset dir="${build.src}">
|
||||
+ <exclude name="**/XalanProcessor.java"/>
|
||||
+ <exclude name="**/stylebook/data/*"/>
|
||||
+ </fileset>
|
||||
+ <link href="/usr/share/javadoc/java" offline="true" packagelistLoc="/usr/share/javadoc/java"/>
|
||||
+ </javadoc>
|
||||
+ </target>
|
||||
+
|
||||
</project>
|
35
SOURCES/xml-stylebook-image-printer.patch
Normal file
35
SOURCES/xml-stylebook-image-printer.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- src/org/apache/stylebook/printers/ImagePrinter.java 1999-11-30 07:28:54.000000000 -0500
|
||||
+++ src/org/apache/stylebook/printers/ImagePrinter.java 2009-01-07 17:00:13.802150149 -0500
|
||||
@@ -8,7 +8,10 @@
|
||||
package org.apache.stylebook.printers;
|
||||
|
||||
import org.apache.stylebook.*;
|
||||
-import com.sun.image.codec.jpeg.*;
|
||||
+import javax.imageio.*;
|
||||
+import javax.imageio.plugins.jpeg.*;
|
||||
+import javax.imageio.metadata.*;
|
||||
+import javax.imageio.stream.*;
|
||||
import java.io.IOException;
|
||||
import java.io.OutputStream;
|
||||
import java.io.PrintStream;
|
||||
@@ -144,11 +147,15 @@
|
||||
}
|
||||
}
|
||||
|
||||
- // Write out image (highest quality for jpeg data)
|
||||
- JPEGEncodeParam jpar=JPEGCodec.getDefaultJPEGEncodeParam(img);
|
||||
- jpar.setQuality(1,true);
|
||||
- JPEGImageEncoder jenc=JPEGCodec.createJPEGEncoder(out,jpar);
|
||||
- jenc.encode(img);
|
||||
+ ImageWriter encoder = (ImageWriter)ImageIO.getImageWritersByFormatName("JPEG").next();
|
||||
+ JPEGImageWriteParam param = new JPEGImageWriteParam(null);
|
||||
+
|
||||
+ param.setCompressionMode(ImageWriteParam.MODE_EXPLICIT);
|
||||
+ param.setCompressionQuality(1);
|
||||
+
|
||||
+ encoder.setOutput(ImageIO.createImageOutputStream(out));
|
||||
+ encoder.write((IIOMetadata) null, new IIOImage(img,null,null), param);
|
||||
+
|
||||
out.flush();
|
||||
}
|
||||
|
184
SPECS/xml-stylebook.spec
Normal file
184
SPECS/xml-stylebook.spec
Normal file
@ -0,0 +1,184 @@
|
||||
Name: xml-stylebook
|
||||
Version: 1.0
|
||||
Release: 0.25.b3_xalan2.svn313293%{?dist}
|
||||
Summary: Apache XML Stylebook
|
||||
License: ASL 1.1
|
||||
URL: http://xml.apache.org/
|
||||
|
||||
# How to generate this tarball:
|
||||
# $ svn export http://svn.apache.org/repos/asf/xml/stylebook/trunk/@313293 xml-stylebook-1.0
|
||||
# $ tar zcf xml-stylebook-1.0.tar.gz xml-stylebook-1.0
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
# Patch to fix an NPE in Xalan-J2's docs generation (from JPackage)
|
||||
Patch0: %{name}-image-printer.patch
|
||||
|
||||
# Patch the build script to build javadocs
|
||||
Patch1: %{name}-build-javadoc.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: java-devel >= 1:1.6.0
|
||||
BuildRequires: javapackages-local
|
||||
BuildRequires: ant
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: xerces-j2
|
||||
%if !0%{?_module_build}
|
||||
# Sans-serif font ("Arial") is required to build examples.
|
||||
# XXX In modular world lets disable building examples until some fonts
|
||||
# are properly modularized.
|
||||
BuildRequires: dejavu-sans-fonts
|
||||
%endif
|
||||
|
||||
Requires: java-headless
|
||||
Requires: xml-commons-apis
|
||||
Requires: xerces-j2
|
||||
|
||||
%description
|
||||
Apache XML Stylebook is a HTML documentation generator.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
%package demo
|
||||
Summary: Examples for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description demo
|
||||
Examples demonstrating the use of %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
|
||||
# Remove bundled binaries
|
||||
find -name *.jar -delete
|
||||
|
||||
# Don't include this sample theme because it contains an errant font
|
||||
rm -r styles/christmas/
|
||||
|
||||
%build
|
||||
ant -Dclasspath=$(build-classpath xml-commons-apis xerces-j2)
|
||||
|
||||
# Build the examples (this serves as a good test suite)
|
||||
%if !0%{?_module_build}
|
||||
pushd docs
|
||||
rm run.bat
|
||||
java -classpath "$(build-classpath xml-commons-apis xerces-j2):../bin/stylebook-%{version}-b3_xalan-2.jar" \
|
||||
org.apache.stylebook.StyleBook "targetDirectory=../results" book.xml ../styles/apachexml
|
||||
popd
|
||||
%endif
|
||||
|
||||
%install
|
||||
# jars
|
||||
install -pD -T bin/stylebook-%{version}-b3_xalan-2.jar \
|
||||
%{buildroot}%{_javadir}/%{name}.jar
|
||||
|
||||
# javadoc
|
||||
install -d %{buildroot}%{_javadocdir}/%{name}
|
||||
cp -pr build/javadoc/* %{buildroot}%{_javadocdir}/%{name}
|
||||
|
||||
# examples
|
||||
install -d %{buildroot}%{_datadir}/%{name}
|
||||
cp -pr docs %{buildroot}%{_datadir}/%{name}
|
||||
cp -pr styles %{buildroot}%{_datadir}/%{name}
|
||||
%if !0%{?_module_build}
|
||||
cp -pr results %{buildroot}%{_datadir}/%{name}
|
||||
%endif
|
||||
|
||||
%files
|
||||
%license LICENSE.txt
|
||||
%{_javadir}/*
|
||||
|
||||
%files javadoc
|
||||
%license LICENSE.txt
|
||||
%{_javadocdir}/%{name}
|
||||
|
||||
%files demo
|
||||
%{_datadir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-0.25.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Sep 23 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.24.b3_xalan2.svn313293
|
||||
- Fix modularized build
|
||||
|
||||
* Sat Sep 23 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.23.b3_xalan2.svn313293
|
||||
- Remove unneeded dependency on dejavu-sans-fonts
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-0.22.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Mar 30 2017 Mat Booth <mat.booth@redhat.com> - 1.0-0.21.b3_xalan2.svn313293
|
||||
- Fix FTBFS and javadoc linting errors
|
||||
- Adopt license macro
|
||||
|
||||
* Fri Mar 3 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-0.20.b3_xalan2.svn313293
|
||||
- Update to current packaging guidelines
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-0.19.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-0.18.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.17.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.16.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.0-0.15.b3_xalan2.svn313293
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Mon Aug 12 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.14.b3_xalan2.svn313293
|
||||
- Prefer xerces-j2 instead of gcj for providing jaxp_parser_impl
|
||||
|
||||
* Sat Aug 10 2013 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.13.b3_xalan2.svn313293
|
||||
- Update for newer guidelines
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.12.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.11.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.10.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.9.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.8.b3_xalan2.svn313293
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.7.b3_xalan2.svn313293
|
||||
- Really fix FTBFS this time.
|
||||
|
||||
* Sun Dec 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.6.b3_xalan2.svn313293
|
||||
- Fix FTBFS due to ant upgrade.
|
||||
|
||||
* Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.5.b3_xalan2.svn313293
|
||||
- Link to local java API docs properly and fix requires on javadoc package.
|
||||
- Build with source and target levels of 1.5 so we don't have to require 1.6.
|
||||
|
||||
* Thu Apr 22 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.4.b3_xalan2.svn313293
|
||||
- Remove font from demo package to comply with guidelines. RHBZ #567912
|
||||
|
||||
* Mon Jan 11 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.3.b3_xalan2.svn313293
|
||||
- Build the examples (this serves as a good test suite.)
|
||||
- Patch the build script to build javadocs.
|
||||
- Add a build dep on a font package because the JDK is missing a dependency
|
||||
to function correctly in headless mode. See RHBZ #478480 and #521523.
|
||||
|
||||
* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.2.b3_xalan2.svn313293
|
||||
- Add patch from JPackage to fix NPE in Xalan-J2 doc generation.
|
||||
|
||||
* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 1.0-0.1.b3_xalan2.svn313293
|
||||
- Initial stab at packaging trunk version of stylebook.
|
||||
|
Loading…
Reference in New Issue
Block a user