Restore the xorg ruleset, console-setup and possibly others are still
using those (#1951459)
This commit is contained in:
parent
08ab24a161
commit
f056665081
@ -0,0 +1,56 @@
|
||||
From 25fae9378d893ecf13f1054f8efa324fe2c3781a Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Tue, 20 Apr 2021 17:39:50 +1000
|
||||
Subject: [PATCH xkeyboard-config] meson.build: add option to install the
|
||||
legacy xorg symlinks
|
||||
|
||||
console-setup still relies on the xorg ruleset [1] and there may be other tools
|
||||
out there. Let's provide an equivalent option to our autotools build to
|
||||
install the xorg symlinks.
|
||||
|
||||
Note that unlike the autotools approach, only the "xorg" symlinks are
|
||||
provided, not the well and truly legacy "xfree86" ones.
|
||||
|
||||
[1] https://salsa.debian.org/installer-team/console-setup/-/merge_requests/7/
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
---
|
||||
meson_options.txt | 4 ++++
|
||||
rules/meson.build | 7 +++++++
|
||||
2 files changed, 11 insertions(+)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 1bee74b..912d21d 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -6,3 +6,7 @@ option('compat-rules',
|
||||
type: 'boolean',
|
||||
value: true,
|
||||
description: 'create compatibility rules [default=true]')
|
||||
+option('xorg-rules-symlinks',
|
||||
+ type: 'boolean',
|
||||
+ value: true,
|
||||
+ description: 'create "xorg" symlinks to the "base" rules files [default=false]')
|
||||
diff --git a/rules/meson.build b/rules/meson.build
|
||||
index c992f2e..7280560 100644
|
||||
--- a/rules/meson.build
|
||||
+++ b/rules/meson.build
|
||||
@@ -164,8 +164,15 @@ foreach ruleset: ['base', 'evdev']
|
||||
output: lst_file,
|
||||
install: true,
|
||||
install_dir: dir_xkb_rules)
|
||||
+
|
||||
endforeach
|
||||
|
||||
+if get_option('xorg-rules-symlinks')
|
||||
+ foreach suffix: ['', '.lst', '.xml']
|
||||
+ meson.add_install_script('sh', '-c',
|
||||
+ 'ln -s base@0@ $DESTDIR@1@/xorg@0@'.format(suffix, dir_xkb_rules))
|
||||
+ endforeach
|
||||
+endif
|
||||
# Copy the DTD to the build directory, the man page generation expects it in
|
||||
# the same directory as the input XML file.
|
||||
configure_file(output: 'xkb.dtd',
|
||||
--
|
||||
2.31.1
|
||||
|
@ -7,7 +7,7 @@
|
||||
Summary: X Keyboard Extension configuration data
|
||||
Name: xkeyboard-config
|
||||
Version: 2.32
|
||||
Release: 2%{?gitdate:.%{gitdate}git%{gitversion}}%{?dist}
|
||||
Release: 3%{?gitdate:.%{gitdate}git%{gitversion}}%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.freedesktop.org/wiki/Software/XKeyboardConfig
|
||||
|
||||
@ -19,6 +19,7 @@ Source2: commitid
|
||||
Source0: http://xorg.freedesktop.org/archive/individual/data/%{name}/%{name}-%{version}.tar.bz2
|
||||
%endif
|
||||
Patch01: 0001-rules-add-a-custom-layout-to-the-XML-file.patch
|
||||
Patch02: 0001-meson.build-add-option-to-install-the-legacy-xorg-sy.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -49,7 +50,7 @@ Development files for %{name}.
|
||||
%autosetup -S git
|
||||
|
||||
%build
|
||||
%meson -Dcompat-rules=true
|
||||
%meson -Dcompat-rules=true -Dxorg-rules-symlinks=true
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
@ -71,11 +72,18 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/X11/xkb/compiled
|
||||
%files -f files.list -f %{name}.lang
|
||||
%doc AUTHORS README NEWS COPYING docs/README.* docs/HOWTO.*
|
||||
%{_mandir}/man7/xkeyboard-config.*
|
||||
%{_datadir}/X11/xkb/rules/xorg
|
||||
%{_datadir}/X11/xkb/rules/xorg.lst
|
||||
%{_datadir}/X11/xkb/rules/xorg.xml
|
||||
|
||||
%files devel
|
||||
%{_datadir}/pkgconfig/xkeyboard-config.pc
|
||||
|
||||
%changelog
|
||||
* Tue Apr 20 2021 Peter Hutterer <peter.hutterer@redhat.com> 2.32-3
|
||||
- Restore the xorg ruleset, console-setup and possibly others are still
|
||||
using those (#1951459)
|
||||
|
||||
* Fri Apr 09 2021 Peter Hutterer <peter.hutterer@redhat.com> 2.32-2
|
||||
- Allow for a "custom" layout
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user