Add upstream patch to fix OLPC azerty keyboard
This commit is contained in:
parent
7182192bc0
commit
ee0bb78b7d
53
olpc-azerty-fixes.patch
Normal file
53
olpc-azerty-fixes.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From 5001e0b41a9ee22633b0a56571b2dc61bc55df4d Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Drake <dsd@laptop.org>
|
||||
Date: Thu, 17 May 2012 20:21:00 +0000
|
||||
Subject: Update FR OLPC layout
|
||||
|
||||
Some keys have only two characters printed: the unmodified character,
|
||||
and a character in the Shift+AltGr position (upper right).
|
||||
For such keys, users were confused why the "other" character could not
|
||||
be accessed with AltGr alone.
|
||||
|
||||
Make such keys behave shift-invariant to remove this confusion.
|
||||
|
||||
Also add some obvious omissions from the previous submission fixing
|
||||
various other keys that weren't working as printed.
|
||||
|
||||
The corresponding keyboard can be seen here:
|
||||
http://wiki.laptop.org/go/OLPC_Azerty_Keyboard
|
||||
|
||||
Investigation and original patch from Walter Bender.
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=50064
|
||||
---
|
||||
diff --git a/symbols/fr b/symbols/fr
|
||||
index 85bcd55..45ef6a4 100644
|
||||
--- a/symbols/fr
|
||||
+++ b/symbols/fr
|
||||
@@ -48,13 +48,17 @@ xkb_symbols "olpc" {
|
||||
|
||||
name[Group1]="French";
|
||||
|
||||
- key <AD02> { [ z, Z, VoidSymbol, guillemotleft ] };
|
||||
-
|
||||
- key <AC02> { [ s, S, VoidSymbol, ssharp ] };
|
||||
-
|
||||
- key <AB02> { [ x, X, VoidSymbol, guillemotright ] };
|
||||
-
|
||||
- key <I219> { [ less, greater ] };
|
||||
+ key <I219> { [ less, greater ] };
|
||||
+ key <AD11> { [ dead_circumflex, dead_diaeresis, notsign, dead_abovering ] };
|
||||
+ key <AB08> { [ semicolon, period, underscore, multiply ] };
|
||||
+ key <TLDE> { [ twosuperior, asciitilde, VoidSymbol, VoidSymbol ] };
|
||||
+
|
||||
+ // Some keys only have the Shift+AltGr character printed on them (alongside
|
||||
+ // the unmodified one). Make such keys shift-invariant so that the printed
|
||||
+ // value is achieved by pressing AltGr or Shift+AltGr.
|
||||
+ key <AB02> { [ x, X, guillemotright, guillemotright ] };
|
||||
+ key <AC02> { [ s, S, ssharp, ssharp ] };
|
||||
+ key <AD02> { [ z, Z, guillemotleft, guillemotleft ] };
|
||||
};
|
||||
|
||||
partial alphanumeric_keys
|
||||
--
|
||||
cgit v0.9.0.2-2-gbebe
|
@ -7,7 +7,7 @@
|
||||
Summary: X Keyboard Extension configuration data
|
||||
Name: xkeyboard-config
|
||||
Version: 2.5.1
|
||||
Release: 1%{?gitdate:.%{gitdate}git%{gitversion}}%{dist}
|
||||
Release: 2%{?gitdate:.%{gitdate}git%{gitversion}}%{dist}
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
URL: http://www.freedesktop.org/wiki/Software/XKeyboardConfig
|
||||
@ -18,6 +18,8 @@ Source2: commitid
|
||||
%else
|
||||
Source0: http://xorg.freedesktop.org/archive/individual/data/%{name}-%{version}.tar.bz2
|
||||
%endif
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=50064
|
||||
Patch0: olpc-azerty-fixes.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -69,6 +71,7 @@ git commit -a -q -m "%{name} %{version} baseline."
|
||||
%endif
|
||||
|
||||
#git am -p1 $(awk '/^Patch.*:/ { print "%{_sourcedir}/"$2 }' %{_specdir}/%{name}.spec)
|
||||
%patch0 -p1 -b .azerty
|
||||
|
||||
%build
|
||||
intltoolize
|
||||
@ -110,6 +113,9 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/X11/xkb/compiled
|
||||
%{_datadir}/pkgconfig/xkeyboard-config.pc
|
||||
|
||||
%changelog
|
||||
* Wed May 23 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.5.1-2
|
||||
- Add upstream patch to fix OLPC azerty keyboard
|
||||
|
||||
* Thu Feb 02 2012 Peter Hutterer <peter.hutterer@redhat.com> 2.5.1-1
|
||||
- xkeyboard-config 2.5.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user