diff --git a/xkeyboard-config-0.8-dell.patch b/xkeyboard-config-0.8-dell.patch
new file mode 100644
index 0000000..476c104
--- /dev/null
+++ b/xkeyboard-config-0.8-dell.patch
@@ -0,0 +1,419 @@
+--- xkeyboard-config-0.8/rules/base.dellm65 2006-02-27 18:14:28.000000000 -0500
++++ xkeyboard-config-0.8/rules/base 2006-08-24 20:09:46.000000000 -0400
+@@ -104,6 +104,7 @@
+ microsoftprousb = microsoft(natural)
+ microsoftprose = microsoft(natural)
+ dell101 = dell(dell101)
++ dellm65 = dell(dellm65)
+ flexpro = keytronic(FlexPro)
+ hp6000 = hp(omnibook)
+ omnikey101 = northgate(omnikey101)
+@@ -201,6 +202,7 @@
+ $mac $macvendorlayouts nodeadkeys = macintosh_vndr/us(extended)+macintosh_vndr/%l%(v)
+
+ ! model layout = symbols
++ dellm65 * = pc(pc104)+%l+inet(%m)
+ $pcmodels ar = pc(%m)+ara
+ * ar = pc(pc105)+ara
+ $pcmodels ben = pc(%m)+in(ben)
+--- xkeyboard-config-0.8/rules/base.xml.in.dellm65 2006-08-24 20:28:41.000000000 -0400
++++ xkeyboard-config-0.8/rules/base.xml.in 2006-08-24 20:29:08.000000000 -0400
+@@ -34,6 +34,12 @@
+
+
+
++ dellm65
++ <_description>Dell Precision M65
++
++
++
++
+ everex
+ <_description>Everex STEPnote
+
+--- xkeyboard-config-0.8/geometry/dell.dellm65 2006-08-24 20:03:12.000000000 -0400
++++ xkeyboard-config-0.8/geometry/dell 2006-08-24 20:03:20.000000000 -0400
+@@ -181,3 +181,362 @@
+ alias = ;
+
+ }; // End of "default" geometry
++
++
++xkb_geometry "dell65" {
++};
++
++xkb_geometry "dell65x" {
++
++ description= "Dell 101";
++ width= 470;
++ height= 210;
++ color="grey10";
++
++ shape.cornerRadius= 1;
++ shape "NORM" { { [ 18,18] }, { [2,1], [ 16,16] } };
++ shape "BKSP" { { [ 38,18] }, { [2,1], [ 36,16] } };
++ shape "TABK" { { [ 28,18] }, { [2,1], [ 26,16] } };
++ shape "BKSL" { { [ 28,18] }, { [2,1], [ 26,16] } };
++ shape "RTRN" { { [ 42,18] }, { [2,1], [ 40,16] } };
++ shape "CAPS" { { [ 33,18] }, { [ 28,18] }, { [2,1], [ 26,16] } };
++ shape "LFSH" { { [ 42,18] }, { [2,1], [ 40,16] } };
++ shape "RTSH" { { [ 52,18] }, { [2,1], [ 50,16] } };
++ shape "MODK" { { [ 27,18] }, { [2,1], [ 25,16] } };
++ shape "SPCE" { { [133,18] }, { [2,1], [131,16] } };
++ shape "KP0" { { [ 37,18] }, { [2,1], [ 35,16] } };
++ shape "KPAD" { { [ 18,37] }, { [2,1], [ 16,35] } };
++
++ shape "LEDS" { cornerRadius= 0, { [ 75 ,20 ] } };
++ shape "LED" { cornerRadius= 0, { [ 5, 1 ] } };
++ solid "LedPanel" {
++ shape= "LEDS";
++ top= 52;
++ left= 377;
++ color= "grey10";
++ };
++
++ shape "BACKGROUND" { cornerRadius=5, { [ 470, 210 ] } };
++ solid "Background" {
++ shape= "BACKGROUND";
++ top= 0;
++ left= 0;
++ color= "grey10";
++ };
++
++ indicator.onColor= "green";
++ indicator.offColor= "green30";
++ indicator.top= 67;
++ indicator.shape= "LED";
++ indicator "Num Lock" { left= 382; };
++ indicator "Caps Lock" { left= 407; };
++ indicator "Scroll Lock" { left= 433; };
++ text.top= 55;
++ text.color= "black";
++ text "NumLockLabel" { left= 378; text="Num\nLock"; };
++ text "CapsLockLabel" { left= 403; text="Caps\nLock"; };
++ text "ScrollLockLabel" { left= 428; text="Scroll\nLock"; };
++
++ section.left= 19;
++ row.left= 1;
++ key.shape= "NORM";
++ key.gap= 1;
++ section "Function" {
++ top= 52;
++ row {
++ top= 1;
++ keys { { , color="grey20" },
++ { , 20 }, , , ,
++ { , 11 }, , , ,
++ { , 11 }, , , ,
++ { , 8 }, ,
++ };
++ };
++ }; // End of "Function" section
++
++ section "Alpha" {
++ top= 91;
++ row {
++ top= 1;
++ keys { , , , , ,
++ , , , , ,
++ , , ,
++ { , "BKSP", color="grey20" }
++ };
++ };
++ row {
++ top= 20;
++ keys { { , "TABK", color="grey20" },
++ , , , , ,
++ , , , , ,
++ , , { , "BKSL" }
++ };
++ };
++ row {
++ top= 39;
++ keys { { , "CAPS", color="grey20" },
++ , , , , ,
++ , , , , ,
++ , { , "RTRN", color="grey20" }
++ };
++ };
++ row {
++ top= 58;
++ keys { { , "LFSH", color="grey20" },
++ , , , , ,
++ , , , , ,
++ { , "RTSH", color="grey20" }
++ };
++ };
++ row {
++ top= 77;
++ key.shape= "MODK";
++ key.color= "grey20";
++ keys { , { , 21 },
++ { , "SPCE", color="white" },
++ , { , 21 }
++ };
++ };
++ }; // End of "Alpha" section
++
++ section "Editing" {
++ top= 91;
++ left= 312;
++ key.color= "grey20";
++ row {
++ top= 1;
++ keys { , , };
++ };
++ row {
++ top= 20;
++ keys { , , };
++ };
++ row {
++ top= 58;
++ left= 20;
++ keys { };
++ };
++ row {
++ top= 77;
++ keys { , , };
++ };
++ }; // End of "Editing" section
++
++ section "Keypad" {
++ top= 91;
++ left= 376;
++ row {
++ top= 1;
++ key.color= "grey20";
++ keys { , , , };
++ };
++ row {
++ top= 20;
++ keys { , , , { , "KPAD", color="grey20" } };
++ };
++ row {
++ top= 39;
++ keys { , , };
++ };
++ row {
++ top= 58;
++ keys { , , , { , "KPAD", color="grey20" } };
++ };
++ row {
++ top= 77;
++ keys { { , "KP0" }, };
++ };
++ }; // End of "Keypad" section
++
++ alias = ;
++ alias = ;
++
++};
++
++
++//
++// Dell Precision M65
++//
++
++xkb_geometry "dellm65" {
++
++ description= "Dell Precision M65";
++ width= 308;
++ height= 152;
++ baseColor = "grey20";
++ labelColor = "white";
++
++ shape "BACKGROUND" { cornerRadius = 3, { [ 308, 152 ] } };
++ shape "BACKGROUND2" { cornerRadius = 2, { [ 7, 22 ],
++ [ 171, 22 ],
++ [ 171, 10 ],
++ [ 301, 10 ],
++ [ 301, 148 ],
++ [ 244, 148 ],
++ [ 244, 132 ],
++ [ 7, 132] } };
++ solid "Background" {
++ shape = "BACKGROUND";
++ top = 0;
++ left = 0;
++ color = "grey20";
++ };
++ solid "Background2" {
++ shape = "BACKGROUND2";
++ top = 0;
++ left = 0;
++ color = "black";
++ };
++
++ shape "LEDS" { cornerRadius = 4, { [ 26, 8 ] } };
++ shape "LED" { cornerRadius = 0, { [ 4, 4 ] } };
++ solid "LedPanel" {
++ shape = "LEDS";
++ top = 8;
++ left = 69;
++ color = "grey20";
++ };
++
++ indicator.onColor= "green";
++ indicator.offColor= "gray20";
++ indicator.top= 10;
++ indicator.shape= "LED";
++ indicator "Num Lock" { left= 72; };
++ indicator "Caps Lock" { left= 80; };
++ indicator "Scroll Lock" { left= 88; };
++
++ shape "MEDIA" { cornerRadius = 5, { [ 2, 2], [ 12, 12 ] } };
++ shape "POWER" { cornerRadius = 7, { [ 14, 14 ] } };
++
++ section "Media" {
++ top = 5;
++ left = 102;
++ width = 60;
++ height = 14;
++ key.color="grey30";
++ key.shape = "MEDIA";
++ row {
++ top = 0;
++ keys {
++ , , , { , shape = "POWER", gap = 3 }
++ };
++ };
++ };
++
++
++ shape "FKEY" { cornerRadius = 1, { [ 18, 12 ] }, { [ 1, 1 ], [ 17, 10 ] } };
++
++ section "Function" {
++ top = 12;
++ left = 8;
++ width = 290;
++ height = 24;
++ key.color = "grey80";
++ key.shape = "FKEY";
++ key.gap = 0;
++ row {
++ top = 0;
++ keys { {
++
++
++ kinesis
++ Kinesis Classic Keyboard
++
++
+
+
+
diff --git a/xkeyboard-config-0.8-thinkpad.patch b/xkeyboard-config-0.8-thinkpad.patch
new file mode 100644
index 0000000..069fab1
--- /dev/null
+++ b/xkeyboard-config-0.8-thinkpad.patch
@@ -0,0 +1,27 @@
+--- xkeyboard-config-0.8/rules/base.thinkpad 2006-08-24 19:42:40.000000000 -0400
++++ xkeyboard-config-0.8/rules/base 2006-08-24 19:42:54.000000000 -0400
+@@ -107,7 +107,8 @@
+ flexpro = keytronic(FlexPro)
+ hp6000 = hp(omnibook)
+ omnikey101 = northgate(omnikey101)
+- thinkpad = ibm_vndr/thinkpad(common)
++ thinkpad = ibm_vndr/thinkpad(us)
++ thinkpadintl = ibm_vndr/thinkpad(intl)
+ $pcmodels = pc(%m)
+ jp106 = pc(jp106)
+ everex = everex(STEPnote)
+--- xkeyboard-config-0.8/rules/base.xml.in.thinkpad 2006-08-24 19:43:03.000000000 -0400
++++ xkeyboard-config-0.8/rules/base.xml.in 2006-08-24 19:43:25.000000000 -0400
+@@ -400,6 +400,12 @@
+
+
+
++ thinkpadintl
++ <_description>IBM ThinkPad 560Z/600/600E/A22E, Intl
++
++
++
++
+ logiaccess
+ <_description>Logitech Access Keyboard
+
diff --git a/xkeyboard-config.spec b/xkeyboard-config.spec
index 872af5f..86f195c 100644
--- a/xkeyboard-config.spec
+++ b/xkeyboard-config.spec
@@ -4,7 +4,7 @@
Summary: xkeyboard-config alternative xkb data files
Name: xkeyboard-config
Version: 0.8
-Release: 3
+Release: 4
License: MIT
Group: User Interface/X
URL: http://www.x.org
@@ -13,6 +13,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://xlibs.freedesktop.org/xkbdesc/%{name}-%{version}.tar.bz2
Patch0: xkeyboard-config-0.8-composify-ralt.patch
+Patch1: xkeyboard-config-0.8-thinkpad.patch
+Patch2: xkeyboard-config-0.8-kinesis.patch
+Patch3: xkeyboard-config-0.8-dell.patch
+
BuildArch: noarch
BuildRequires: pkgconfig
@@ -41,6 +45,10 @@ xkeyboard-config alternative xkb data files
%setup -q
%patch0 -p1 -b .composify-ralt
+%patch1 -p1 -b .thinkpad
+%patch2 -p1 -b .kinesis
+%patch3 -p1 -b .dell
+
%build
%configure \
--enable-compat-rules \
@@ -76,6 +84,11 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/X11/xkb/rules/xorg.xml
%changelog
+* Thu Aug 22 2006 Matthias Clasen 0.8-4
+- Fix geometry description for Thinkpads
+- Add a Kinesis model
+- Add Dell Precision M65 geometry and model
+
* Tue Aug 22 2006 Adam Jackson 0.8-3
- Add Compose semantics to right Alt when that's ISO_Level3_Shift (#193922)