- xkeyboard-config-1.6-caps-super.patch: add caps:super option (#505187)

- xkeyboard-config-1.6-caps-hyper.patch: add caps:hyper option (#505187)
This commit is contained in:
Peter Hutterer 2009-08-17 23:16:56 +00:00
parent 214cdd291b
commit 3fb2f5d4c8
3 changed files with 129 additions and 2 deletions

View File

@ -0,0 +1,60 @@
From 6b99bd6e4dca53a7143b87f5f5a9026ed2a6f00e Mon Sep 17 00:00:00 2001
From: Peter Hutterer <peter.hutterer@who-t.net>
Date: Tue, 18 Aug 2009 09:04:11 +1000
Subject: [PATCH] add caps:hyper
http://bugs.freedesktop.org/show_bug.cgi?id=23356
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
---
rules/base.o_s.part | 1 +
rules/base.xml.in | 6 ++++++
symbols/capslock | 6 ++++++
3 files changed, 13 insertions(+), 0 deletions(-)
diff --git a/rules/base.o_s.part b/rules/base.o_s.part
index 175a214..8305bb6 100644
--- a/rules/base.o_s.part
+++ b/rules/base.o_s.part
@@ -54,6 +54,7 @@
caps:escape = +capslock(escape)
caps:backspace = +capslock(backspace)
caps:super = +capslock(super)
+ caps:hyper = +capslock(hyper)
ctrl:nocaps = +ctrl(nocaps)
ctrl:swapcaps = +ctrl(swapcaps)
ctrl:ctrl_ac = +ctrl(ctrl_ac)
diff --git a/rules/base.xml.in b/rules/base.xml.in
index 0958687..4628c4c 100644
--- a/rules/base.xml.in
+++ b/rules/base.xml.in
@@ -4774,6 +4774,12 @@
</option>
<option>
<configItem>
+ <name>caps:hyper</name>
+ <_description>Make CapsLock an additional Hyper</_description>
+ </configItem>
+ </option>
+ <option>
+ <configItem>
<name>caps:shiftlock</name>
<_description>CapsLock toggles Shift so all keys are affected</_description>
</configItem>
diff --git a/symbols/capslock b/symbols/capslock
index 9a2307e..9a01b4a 100644
--- a/symbols/capslock
+++ b/symbols/capslock
@@ -47,3 +47,9 @@ xkb_symbols "super" {
modifier_map Mod4 { <CAPS> };
};
+partial hidden modifier_keys
+xkb_symbols "hyper" {
+ key <CAPS> { [ Hyper_L ] };
+ modifier_map Mod4 { <CAPS> };
+};
+
--
1.6.3.rc1.2.g0164.dirty

View File

@ -0,0 +1,59 @@
From 0ba57d95704764f7c3d3fb9694e2479d98dac1b8 Mon Sep 17 00:00:00 2001
From: Sergey V. Udaltsov <svu@gnome.org>
Date: Fri, 12 Jun 2009 00:50:57 +0100
Subject: [PATCH] added caps:super
http://bugs.freedesktop.org/show_bug.cgi?id=22184
---
ChangeLog | 5 +++++
rules/base.o_s.part | 1 +
rules/base.xml.in | 6 ++++++
symbols/capslock | 6 ++++++
4 files changed, 18 insertions(+), 0 deletions(-)
diff --git a/rules/base.o_s.part b/rules/base.o_s.part
index d3078bf..175a214 100644
--- a/rules/base.o_s.part
+++ b/rules/base.o_s.part
@@ -53,6 +53,7 @@
caps:swapescape = +capslock(swapescape)
caps:escape = +capslock(escape)
caps:backspace = +capslock(backspace)
+ caps:super = +capslock(super)
ctrl:nocaps = +ctrl(nocaps)
ctrl:swapcaps = +ctrl(swapcaps)
ctrl:ctrl_ac = +ctrl(ctrl_ac)
diff --git a/rules/base.xml.in b/rules/base.xml.in
index aaf5358..f4d60e7 100644
--- a/rules/base.xml.in
+++ b/rules/base.xml.in
@@ -4775,6 +4775,12 @@
</option>
<option>
<configItem>
+ <name>caps:super</name>
+ <_description>Make CapsLock an additional Super</_description>
+ </configItem>
+ </option>
+ <option>
+ <configItem>
<name>caps:shiftlock</name>
<_description>CapsLock toggles Shift so all keys are affected</_description>
</configItem>
diff --git a/symbols/capslock b/symbols/capslock
index 58599c6..9a2307e 100644
--- a/symbols/capslock
+++ b/symbols/capslock
@@ -41,3 +41,9 @@ xkb_symbols "backspace" {
key <CAPS> { [ BackSpace ] };
};
+partial hidden modifier_keys
+xkb_symbols "super" {
+ key <CAPS> { [ Super_L ] };
+ modifier_map Mod4 { <CAPS> };
+};
+
--
1.6.3.rc1.2.g0164.dirty

View File

@ -4,7 +4,7 @@
Summary: X Keyboard Extension configuration data
Name: xkeyboard-config
Version: 1.6
Release: 2%{?dist}
Release: 3%{?dist}
License: MIT
Group: User Interface/X
URL: http://www.freedesktop.org/wiki/Software/XKeyboardConfig
@ -12,6 +12,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://xlibs.freedesktop.org/xkbdesc/%{name}-%{version}.tar.bz2
# Both upstream
Patch1: xkeyboard-config-1.6-caps-super.patch
Patch2: xkeyboard-config-1.6-caps-hyper.patch
BuildArch: noarch
BuildRequires: pkgconfig
@ -52,7 +56,7 @@ fi
git add .
git commit -a -q -m "%{version} baseline."
#git am -p1 $(awk '/^Patch.*:/ { print "%{_sourcedir}/"$2 }' %{_specdir}/%{name}.spec)
git am -p1 $(awk '/^Patch.*:/ { print "%{_sourcedir}/"$2 }' %{_specdir}/%{name}.spec)
%build
%configure \
@ -92,6 +96,10 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/X11/xkb/rules/xorg.xml
%changelog
* Tue Aug 18 2009 Peter Hutterer <peter.hutterer@redhat.com> 1.6-3
- xkeyboard-config-1.6-caps-super.patch: add caps:super option (#505187)
- xkeyboard-config-1.6-caps-hyper.patch: add caps:hyper option (#505187)
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild