diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..d27bb0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/xhtml1-dtds-20020801.tar.xz
diff --git a/EMPTY b/EMPTY
deleted file mode 100644
index 0519ecb..0000000
--- a/EMPTY
+++ /dev/null
@@ -1 +0,0 @@
-
\ No newline at end of file
diff --git a/sources b/sources
new file mode 100644
index 0000000..58b2547
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (xhtml1-dtds-20020801.tar.xz) = c3d4934dbdb3720a100186d053ee6c9ed474ab1c2ddc271a4ce18ad0bc00a35c335f8f1625e8be3e20006feb05db6ce6170aa596b2252d73653d0ac8ca20dd91
diff --git a/xhtml1-dtds-prepare-tarball.sh b/xhtml1-dtds-prepare-tarball.sh
new file mode 100755
index 0000000..67fdc4d
--- /dev/null
+++ b/xhtml1-dtds-prepare-tarball.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+set -e
+
+# Prune content from upstream tarball:
+# https://www.redhat.com/archives/fedora-legal-list/2009-February/msg00015.html
+
+# While at it, prune docs as well; the W3C Documentation License is not an
+# acceptable one per Fedora licensing guidelines.
+
+date="20020801"
+url="http://www.w3.org/TR/2002/REC-xhtml1-$date/xhtml1.tgz"
+
+curl -O $url
+tar zxf $(basename $url)
+find xhtml1-$date -type f | grep -vF /DTD/ | xargs rm
+rm $(basename $url)
+
+tar Jcvf xhtml1-dtds-$date.tar.xz xhtml1-$date
+rm -r xhtml1-$date
diff --git a/xhtml1-dtds-sgml-catalog.patch b/xhtml1-dtds-sgml-catalog.patch
new file mode 100644
index 0000000..10950e0
--- /dev/null
+++ b/xhtml1-dtds-sgml-catalog.patch
@@ -0,0 +1,29 @@
+--- DTD/xhtml.soc~ 2002-08-01 21:23:08.000000000 +0300
++++ DTD/xhtml.soc 2004-06-20 01:13:52.351585517 +0300
+@@ -1,14 +1,24 @@
+-OVERRIDE YES
+ -- Oasis entity catalog for Extensible HTML 1.0 --
+
++-- Fedora change: use DTDDECLs instead of SGMLDECL to avoid affecting --
++-- other things included in the central system catalog --
++
++OVERRIDE YES
++
+ PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "xhtml1-strict.dtd"
+ PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "xhtml1-transitional.dtd"
+ PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "xhtml1-frameset.dtd"
++DTDDECL "-//W3C//DTD XHTML 1.0 Strict//EN" "xhtml1.dcl"
++DTDDECL "-//W3C//DTD XHTML 1.0 Transitional//EN" "xhtml1.dcl"
++DTDDECL "-//W3C//DTD XHTML 1.0 Frameset//EN" "xhtml1.dcl"
+
+ -- ISO latin 1 entity set for Extensible HTML (XML 1.0 format) --
+
+ PUBLIC "-//W3C//ENTITIES Latin 1 for XHTML//EN" "xhtml-lat1.ent"
+ PUBLIC "-//W3C//ENTITIES Symbols for XHTML//EN" "xhtml-symbol.ent"
+ PUBLIC "-//W3C//ENTITIES Special for XHTML//EN" "xhtml-special.ent"
++DTDDECL "-//W3C//ENTITIES Latin 1 for XHTML//EN" "xhtml1.dcl"
++DTDDECL "-//W3C//ENTITIES Symbols for XHTML//EN" "xhtml1.dcl"
++DTDDECL "-//W3C//ENTITIES Special for XHTML//EN" "xhtml1.dcl"
+
+-SGMLDECL "xhtml1.dcl"
++-- SGMLDECL "xhtml1.dcl" --
diff --git a/xhtml1-dtds-sgml-dcl.patch b/xhtml1-dtds-sgml-dcl.patch
new file mode 100644
index 0000000..9a4761e
--- /dev/null
+++ b/xhtml1-dtds-sgml-dcl.patch
@@ -0,0 +1,22 @@
+Changes from validator.w3.org's xml.dcl.
+
+diff -up xhtml1-20020801/DTD/xhtml1.dcl.orig xhtml1-20020801/DTD/xhtml1.dcl
+--- xhtml1-20020801/DTD/xhtml1.dcl.orig 2002-08-01 21:23:08.000000000 +0300
++++ xhtml1-20020801/DTD/xhtml1.dcl 2008-02-28 22:43:22.000000000 +0200
+@@ -22,13 +22,13 @@
+ 13 1 13
+ 14 18 UNUSED
+ 32 95 32
+- 127 1 UNUSED
+- 128 32 UNUSED
++ 127 1 127 -- DEL, legal in XML 1.0 --
++ 128 32 128 -- C1 controls, legal in XML 1.0 --
+ 160 55136 160
+ 55296 2048 UNUSED -- surrogates --
+ 57344 8190 57344
+ 65534 2 UNUSED -- FFFE and FFFF --
+- 65536 1048576 65536
++ 65536 1048576 65536 -- 16 planes outside BMP --
+
+ CAPACITY NONE -- Capacities are not restricted in XML --
+
diff --git a/xhtml1-dtds.catalog.xml b/xhtml1-dtds.catalog.xml
new file mode 100644
index 0000000..050d3b8
--- /dev/null
+++ b/xhtml1-dtds.catalog.xml
@@ -0,0 +1,14 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/xhtml1-dtds.spec b/xhtml1-dtds.spec
new file mode 100644
index 0000000..7fa3e54
--- /dev/null
+++ b/xhtml1-dtds.spec
@@ -0,0 +1,204 @@
+%global date 20020801
+
+Name: xhtml1-dtds
+Version: 1.0
+Release: %{date}.13%{?dist}.4
+Summary: XHTML 1.0 document type definitions
+
+Group: Applications/Text
+# W3C Software License for DTDs etc:
+# http://www.w3.org/Consortium/Legal/IPR-FAQ-20000620#DTD
+License: W3C
+URL: http://www.w3.org/TR/2002/REC-xhtml1-%{date}/
+# Source0 generated with Source99, see comments in the script
+Source0: %{name}-%{date}.tar.xz
+Source1: %{name}.catalog.xml
+Source99: %{name}-prepare-tarball.sh
+Patch0: %{name}-sgml-catalog.patch
+Patch1: %{name}-sgml-dcl.patch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: libxml2 >= 2.4.8
+Requires: libxml2 >= 2.4.8
+Requires: xml-common
+Requires: sgml-common
+Requires(post): /usr/bin/xmlcatalog
+Requires(preun): /usr/bin/xmlcatalog
+
+%description
+This provides the DTDs of the Second Edition of XHTML 1.0, a reformulation
+of HTML 4 as an XML 1.0 application, and three DTDs corresponding to the
+ones defined by HTML 4. The semantics of the elements and their attributes
+are defined in the W3C Recommendation for HTML 4. These semantics provide
+the foundation for future extensibility of XHTML.
+
+
+%prep
+%setup -q -n xhtml1-20020801
+%patch0 -p0
+%patch1 -p1
+cp -p %{SOURCE1} DTD/catalog.xml
+
+
+%build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+# Note: documentation is not shipped; the W3C Documentation License is not an
+# acceptable one per Fedora licensing guidelines.
+
+mkdir -p $RPM_BUILD_ROOT%{_datadir}/xml/xhtml/1.0
+cp -p DTD/* $RPM_BUILD_ROOT%{_datadir}/xml/xhtml/1.0
+
+# XML catalog:
+
+xpkg() {
+ xmlcatalog --noout --add "$1" "$2" \
+ file://%{_datadir}/xml/xhtml/1.0/catalog.xml \
+ $RPM_BUILD_ROOT%{_sysconfdir}/xml/%{name}-%{version}-%{release}.xml
+}
+
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xml
+xmlcatalog --noout --create \
+ $RPM_BUILD_ROOT%{_sysconfdir}/xml/%{name}-%{version}-%{release}.xml
+xpkg delegatePublic "-//W3C//DTD XHTML 1.0 "
+xpkg delegatePublic "-//W3C//ENTITIES Latin 1 for XHTML"
+xpkg delegatePublic "-//W3C//ENTITIES Special for XHTML"
+xpkg delegatePublic "-//W3C//ENTITIES Symbols for XHTML"
+for i in xhtml1 2002/REC-xhtml1-%{date} ; do
+ xpkg delegateSystem http://www.w3.org/TR/$i/DTD/
+ xpkg delegateURI http://www.w3.org/TR/$i/DTD/
+done
+ln -s %{name}-%{version}-%{release}.xml \
+ $RPM_BUILD_ROOT%{_sysconfdir}/xml/%{name}.xml
+
+# SGML catalog:
+
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sgml
+cd $RPM_BUILD_ROOT%{_sysconfdir}/sgml
+touch %{name}-%{version}-%{release}.soc
+ln -s %{name}-%{version}-%{release}.soc %{name}.soc
+cd -
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%post
+cd %{_sysconfdir}/xml
+[ -e catalog ] || /usr/bin/xmlcatalog --noout --create catalog
+/usr/bin/xmlcatalog --noout --add \
+ nextCatalog %{name}-%{version}-%{release}.xml "" catalog >/dev/null
+cd - >/dev/null
+/usr/bin/xmlcatalog --sgml --noout --add \
+ %{_sysconfdir}/sgml/%{name}-%{version}-%{release}.soc \
+ %{_datadir}/xml/xhtml/1.0/xhtml.soc >/dev/null
+:
+
+%preun
+/usr/bin/xmlcatalog --noout --del \
+ %{name}-%{version}-%{release}.xml \
+ %{_sysconfdir}/xml/catalog >/dev/null
+/usr/bin/xmlcatalog --sgml --noout --del \
+ %{_sysconfdir}/sgml/%{name}-%{version}-%{release}.soc \
+ %{_datadir}/xml/xhtml/1.0/xhtml.soc >/dev/null
+:
+
+
+%files
+%defattr(644,root,root,755)
+%ghost %{_sysconfdir}/sgml/%{name}-%{version}-%{release}.soc
+%{_sysconfdir}/sgml/%{name}.soc
+%{_sysconfdir}/xml/%{name}*.xml
+%{_datadir}/xml/xhtml/
+
+
+%changelog
+* Fri Feb 09 2018 Fedora Release Engineering - 1.0-20020801.13.4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Thu Jul 27 2017 Fedora Release Engineering - 1.0-20020801.13.3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Sat Feb 11 2017 Fedora Release Engineering - 1.0-20020801.13.2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Fri Feb 05 2016 Fedora Release Engineering - 1.0-20020801.13.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Thu Jul 2 2015 Ville Skyttä - 1.0-20020801.13
+- Add %%{?dist} to release (#1237194)
+- Compress tarball with xz
+
+* Fri Jun 19 2015 Fedora Release Engineering - 1.0-20020801.12
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Sun Jun 08 2014 Fedora Release Engineering - 1.0-20020801.11
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Sun Aug 04 2013 Fedora Release Engineering - 1.0-20020801.10
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Fri Feb 15 2013 Fedora Release Engineering - 1.0-20020801.9
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Sun Jul 22 2012 Fedora Release Engineering - 1.0-20020801.8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jan 14 2012 Fedora Release Engineering - 1.0-20020801.7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Mon Feb 07 2011 Fedora Release Engineering - 1.0-20020801.6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Mon Jul 27 2009 Fedora Release Engineering - 1.0-20020801.5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Thu Feb 26 2009 Fedora Release Engineering - 1.0-20020801.4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Fri Feb 20 2009 Ville Skyttä - 1.0-20020801.3
+- Prune nondistributable content from source tarball.
+
+* Fri Dec 12 2008 Ville Skyttä - 1.0-20020801.2
+- Drop no longer needed upgrade quirks.
+
+* Thu Feb 28 2008 Ville Skyttä - 1.0-20020801.1
+- Major spec file rewrite (#226559), most visible changes:
+- Various XML cataloguing improvements.
+- Register to SGML catalogs in addition to XML.
+- Install to %%{_datadir}/xml per the FHS.
+- Sync with Fedora packaging guidelines.
+- Silence post-install scriptlet.
+
+* Wed Jul 12 2006 Jesse Keating - 1.0-7.1.1
+- rebuild
+
+* Fri Dec 09 2005 Jesse Keating
+- rebuilt
+
+* Wed Jun 2 2004 Daniel Veillard 1.0-7
+- add BuildRequires: libxml2, fixes 125030
+
+* Mon Feb 23 2004 Tim Waugh
+- Use ':' instead of '.' as separator for chown.
+
+* Fri Feb 13 2004 Elliot Lee
+- rebuilt
+
+* Tue Oct 21 2003 Florian La Roche
+- add %%clean specfile target
+
+* Wed Jan 22 2003 Tim Powers
+- rebuilt
+
+* Fri Dec 13 2002 Daniel Veillard 1.0-4
+- Prepare for inclusion, Prereq xml-common, fix the uninstall
+ for upgrades of the package
+
+* Thu Dec 12 2002 Daniel Veillard 1.0-1
+- Creation, based on Tim Waugh docbook-dtd package