diff --git a/20AE1692E13DDEE0.asc b/20AE1692E13DDEE0.asc index 9644d2d..27900de 100644 --- a/20AE1692E13DDEE0.asc +++ b/20AE1692E13DDEE0.asc @@ -1,295 +1,7 @@ - - - -20AE1692E13DDEE0.asc « keys - kernel/pgpkeys.git - Kernel developers PGP keys - - - - - - - - - - -
- - - - -
-aboutsummaryrefslogtreecommitdiffstats
- - - -
-
-
path: root/keys/20AE1692E13DDEE0.asc
blob: d70667e6e405661f1854681e564a78e189eb9dd6 (plain) - - -
1
-2
-3
-4
-5
-6
-7
-8
-9
-10
-11
-12
-13
-14
-15
-16
-17
-18
-19
-20
-21
-22
-23
-24
-25
-26
-27
-28
-29
-30
-31
-32
-33
-34
-35
-36
-37
-38
-39
-40
-41
-42
-43
-44
-45
-46
-47
-48
-49
-50
-51
-52
-53
-54
-55
-56
-57
-58
-59
-60
-61
-62
-63
-64
-65
-66
-67
-68
-69
-70
-71
-72
-73
-74
-75
-76
-77
-78
-79
-80
-81
-82
-83
-84
-85
-86
-87
-88
-89
-90
-91
-92
-93
-94
-95
-96
-97
-98
-99
-100
-101
-102
-103
-104
-105
-106
-107
-108
-109
-110
-111
-112
-113
-114
-115
-116
-117
-118
-119
-120
-121
-122
-123
-124
-125
-126
-127
-128
-129
-130
-131
-132
-133
-134
-135
-136
-137
-138
-139
-140
-141
-142
-143
-144
-145
-146
-147
-148
-149
-150
-151
-152
-153
-154
-155
-156
-157
-158
-159
-160
-161
-162
-163
-164
-165
-166
-167
-168
-169
-170
-171
-172
-173
-174
-175
-176
-177
-178
-179
-180
-181
-182
-183
-184
-185
-
pub   rsa4096 2011-11-03 [SC]
+pub   rsa4096 2011-11-03 [SC]
       2B8185919E8D248981869DED20AE1692E13DDEE0
-uid                      Eric R. Sandeen <sandeen@sandeen.net>
-uid                      Eric R. Sandeen <sandeen@redhat.com>
+uid                      Eric R. Sandeen 
+uid                      Eric R. Sandeen 
 sub   rsa4096 2011-11-03 [E]
       048CA40C8F5B5507E3A6CD6BE2C297037B26BEB4
 
@@ -471,10 +183,3 @@ UXe9i92UTina2zWaaLEwXspqM338TlFC2JICu8pNt+wHpPCjgy2Ei4u5/4zSYjiA
 4NMMCC8gkONe4tek
 =EFoy
 -----END PGP PUBLIC KEY BLOCK-----
-
-
-
- -
- - diff --git a/xfsprogs-5.12.0-default-bigtime-inobtcnt-on.patch b/xfsprogs-5.12.0-default-bigtime-inobtcnt-on.patch index 59421df..5a70307 100644 --- a/xfsprogs-5.12.0-default-bigtime-inobtcnt-on.patch +++ b/xfsprogs-5.12.0-default-bigtime-inobtcnt-on.patch @@ -1,8 +1,8 @@ -diff --git a/man/man8/mkfs.xfs.8 b/man/man8/mkfs.xfs.8 -index a7f70285..3db89895 100644 ---- a/man/man8/mkfs.xfs.8 -+++ b/man/man8/mkfs.xfs.8 -@@ -203,7 +203,7 @@ December 1901 to January 2038, and quota timers from January 1970 to February +Index: xfsprogs-5.12.0/man/man8/mkfs.xfs.8 +=================================================================== +--- xfsprogs-5.12.0.orig/man/man8/mkfs.xfs.8 ++++ xfsprogs-5.12.0/man/man8/mkfs.xfs.8 +@@ -203,7 +203,7 @@ December 1901 to January 2038, and quota .IP By default, .B mkfs.xfs @@ -11,7 +11,7 @@ index a7f70285..3db89895 100644 If the option .B \-m crc=0 is used, the large timestamp feature is not supported and is disabled. -@@ -256,7 +256,7 @@ This can be used to reduce mount times when the free inode btree is enabled. +@@ -256,7 +256,7 @@ This can be used to reduce mount times w .IP By default, .B mkfs.xfs @@ -20,11 +20,44 @@ index a7f70285..3db89895 100644 This feature is only available for filesystems created with the (default) .B \-m finobt=1 option set. -diff --git a/mkfs/xfs_mkfs.c b/mkfs/xfs_mkfs.c -index 36b274d5..02efca81 100644 ---- a/mkfs/xfs_mkfs.c -+++ b/mkfs/xfs_mkfs.c -@@ -3842,11 +3842,11 @@ main( +Index: xfsprogs-5.12.0/mkfs/xfs_mkfs.c +=================================================================== +--- xfsprogs-5.12.0.orig/mkfs/xfs_mkfs.c ++++ xfsprogs-5.12.0/mkfs/xfs_mkfs.c +@@ -12,6 +12,8 @@ + #include "libfrog/topology.h" + #include "libfrog/convert.h" + #include ++#include ++#include + + #define TERABYTES(count, blog) ((uint64_t)(count) << (40 - (blog))) + #define GIGABYTES(count, blog) ((uint64_t)(count) << (30 - (blog))) +@@ -3795,6 +3797,23 @@ cfgfile_parse( + cli->cfgfile); + } + ++static unsigned int get_system_kver(void) ++{ ++ const char *kver = getenv("KVER"); ++ struct utsname utsname; ++ int a, b, c; ++ ++ if (!kver) { ++ uname(&utsname); ++ kver = utsname.release; ++ } ++ ++ if (sscanf(kver, "%d.%d.%d", &a, &b, &c) != 3) ++ return LINUX_VERSION_CODE; ++ ++ return KERNEL_VERSION(a,b,c); ++} ++ + int + main( + int argc, +@@ -3848,17 +3867,25 @@ main( .spinodes = true, .rmapbt = false, .reflink = true, @@ -38,3 +71,17 @@ index 36b274d5..02efca81 100644 }, }; + struct list_head buffer_list; ++ unsigned int kver; + int error; + ++ /* turn bigtime & inobtcnt back off if running under older kernels */ ++ kver = get_system_kver(); ++ if (kver < KERNEL_VERSION(5,10,0)) { ++ dft.sb_feat.inobtcnt = false; ++ dft.sb_feat.bigtime = false; ++ } ++ + platform_uuid_generate(&cli.uuid); + progname = basename(argv[0]); + setlocale(LC_ALL, ""); diff --git a/xfsprogs.spec b/xfsprogs.spec index d61ab7e..f927024 100644 --- a/xfsprogs.spec +++ b/xfsprogs.spec @@ -1,14 +1,14 @@ Summary: Utilities for managing the XFS filesystem Name: xfsprogs Version: 5.12.0 -Release: 2%{?dist} +Release: 3%{?dist} License: GPL+ and LGPLv2+ URL: https://xfs.wiki.kernel.org Source0: http://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.xz Source1: http://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.sign -Source2: https://git.kernel.org/pub/scm/docs/kernel/pgpkeys.git/tree/keys/20AE1692E13DDEE0.asc +Source2: https://git.kernel.org/pub/scm/docs/kernel/pgpkeys.git/plain/keys/20AE1692E13DDEE0.asc Requires: util-linux -BuildRequires: make +BuildRequires: make BuildRequires: gcc BuildRequires: libtool, gettext, libattr-devel, libuuid-devel BuildRequires: libedit-devel, libblkid-devel >= 2.17-0.1.git5e51568 @@ -127,6 +127,9 @@ rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/xfsprogs/ %{_libdir}/*.so %changelog +* Wed Jun 16 2021 Eric Sandeen 5.12.0-3 +- Local change to default bigtime & inobtcnt to off under older kernels + * Thu Jun 03 2021 Eric Sandeen 5.12.0-2 - Turn on bigtime (y2038) and inobtcnt features by default