New upstream release v3.1.8
This commit is contained in:
parent
7853d7d6af
commit
ff7e60bd24
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ xfsdump-3.0.4.tar.gz
|
||||
/xfsdump-3.1.3.tar.gz
|
||||
/xfsdump-3.1.4.tar.gz
|
||||
/xfsdump-3.1.6.tar.gz
|
||||
/xfsdump-3.1.8.tar.xz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
50353cd4f4b435685955363e6044f4d1 xfsdump-3.1.6.tar.gz
|
||||
SHA512 (xfsdump-3.1.8.tar.xz) = 84720c83627647c75b42c59d180bb31cbb6e064568bef18b73641cf821fa7d39e6f7e0df4a6c7ffd36fba63296ab88cb83f0effdb1f6aa98f4b593ca0e658e0b
|
||||
|
@ -1,226 +0,0 @@
|
||||
--- a/configure.orig 2017-06-08 21:34:45.283790661 -0500
|
||||
+++ b/configure 2017-06-08 21:34:57.982321113 -0500
|
||||
@@ -772,6 +772,7 @@
|
||||
enable_libtool_lock
|
||||
enable_gettext
|
||||
enable_lib64
|
||||
+enable_largefile
|
||||
'
|
||||
ac_precious_vars='build_alias
|
||||
host_alias
|
||||
@@ -1404,6 +1405,7 @@
|
||||
--enable-shared=yes/no Enable use of shared libraries default=yes
|
||||
--enable-gettext=yes/no Enable alternate language support default=yes
|
||||
--enable-lib64=yes/no Enable lib64 support default=yes
|
||||
+ --disable-largefile omit support for large files
|
||||
|
||||
Optional Packages:
|
||||
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
|
||||
@@ -13026,6 +13028,207 @@
|
||||
|
||||
|
||||
|
||||
+# Check whether --enable-largefile was given.
|
||||
+if test "${enable_largefile+set}" = set; then :
|
||||
+ enableval=$enable_largefile;
|
||||
+fi
|
||||
+
|
||||
+if test "$enable_largefile" != no; then
|
||||
+
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for special C compiler options needed for large files" >&5
|
||||
+$as_echo_n "checking for special C compiler options needed for large files... " >&6; }
|
||||
+if ${ac_cv_sys_largefile_CC+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ ac_cv_sys_largefile_CC=no
|
||||
+ if test "$GCC" != yes; then
|
||||
+ ac_save_CC=$CC
|
||||
+ while :; do
|
||||
+ # IRIX 6.2 and later do not support large files by default,
|
||||
+ # so use the C compiler's -n32 option if that helps.
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#include <sys/types.h>
|
||||
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
+ since some C++ compilers masquerading as C compilers
|
||||
+ incorrectly reject 9223372036854775807. */
|
||||
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||
+ ? 1 : -1];
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+ if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext
|
||||
+ CC="$CC -n32"
|
||||
+ if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ac_cv_sys_largefile_CC=' -n32'; break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext
|
||||
+ break
|
||||
+ done
|
||||
+ CC=$ac_save_CC
|
||||
+ rm -f conftest.$ac_ext
|
||||
+ fi
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_largefile_CC" >&5
|
||||
+$as_echo "$ac_cv_sys_largefile_CC" >&6; }
|
||||
+ if test "$ac_cv_sys_largefile_CC" != no; then
|
||||
+ CC=$CC$ac_cv_sys_largefile_CC
|
||||
+ fi
|
||||
+
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _FILE_OFFSET_BITS value needed for large files" >&5
|
||||
+$as_echo_n "checking for _FILE_OFFSET_BITS value needed for large files... " >&6; }
|
||||
+if ${ac_cv_sys_file_offset_bits+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ while :; do
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#include <sys/types.h>
|
||||
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
+ since some C++ compilers masquerading as C compilers
|
||||
+ incorrectly reject 9223372036854775807. */
|
||||
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||
+ ? 1 : -1];
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ac_cv_sys_file_offset_bits=no; break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#define _FILE_OFFSET_BITS 64
|
||||
+#include <sys/types.h>
|
||||
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
+ since some C++ compilers masquerading as C compilers
|
||||
+ incorrectly reject 9223372036854775807. */
|
||||
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||
+ ? 1 : -1];
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ac_cv_sys_file_offset_bits=64; break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ ac_cv_sys_file_offset_bits=unknown
|
||||
+ break
|
||||
+done
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_file_offset_bits" >&5
|
||||
+$as_echo "$ac_cv_sys_file_offset_bits" >&6; }
|
||||
+case $ac_cv_sys_file_offset_bits in #(
|
||||
+ no | unknown) ;;
|
||||
+ *)
|
||||
+cat >>confdefs.h <<_ACEOF
|
||||
+#define _FILE_OFFSET_BITS $ac_cv_sys_file_offset_bits
|
||||
+_ACEOF
|
||||
+;;
|
||||
+esac
|
||||
+rm -rf conftest*
|
||||
+ if test $ac_cv_sys_file_offset_bits = unknown; then
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _LARGE_FILES value needed for large files" >&5
|
||||
+$as_echo_n "checking for _LARGE_FILES value needed for large files... " >&6; }
|
||||
+if ${ac_cv_sys_large_files+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ while :; do
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#include <sys/types.h>
|
||||
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
+ since some C++ compilers masquerading as C compilers
|
||||
+ incorrectly reject 9223372036854775807. */
|
||||
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||
+ ? 1 : -1];
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ac_cv_sys_large_files=no; break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#define _LARGE_FILES 1
|
||||
+#include <sys/types.h>
|
||||
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||
+ since some C++ compilers masquerading as C compilers
|
||||
+ incorrectly reject 9223372036854775807. */
|
||||
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||
+ ? 1 : -1];
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ac_cv_sys_large_files=1; break
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ ac_cv_sys_large_files=unknown
|
||||
+ break
|
||||
+done
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_large_files" >&5
|
||||
+$as_echo "$ac_cv_sys_large_files" >&6; }
|
||||
+case $ac_cv_sys_large_files in #(
|
||||
+ no | unknown) ;;
|
||||
+ *)
|
||||
+cat >>confdefs.h <<_ACEOF
|
||||
+#define _LARGE_FILES $ac_cv_sys_large_files
|
||||
+_ACEOF
|
||||
+;;
|
||||
+esac
|
||||
+rm -rf conftest*
|
||||
+ fi
|
||||
+
|
||||
+
|
||||
+fi
|
||||
+
|
||||
+
|
||||
for ac_header in uuid.h sys/uuid.h uuid/uuid.h
|
||||
do :
|
||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
12
xfsdump.spec
12
xfsdump.spec
@ -1,20 +1,18 @@
|
||||
Summary: Administrative utilities for the XFS filesystem
|
||||
Name: xfsdump
|
||||
Version: 3.1.6
|
||||
Release: 6%{?dist}
|
||||
Version: 3.1.8
|
||||
Release: 1%{?dist}
|
||||
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
||||
# in source, with no mention of version.
|
||||
License: GPL+
|
||||
Group: System Environment/Base
|
||||
URL: http://oss.sgi.com/projects/xfs/
|
||||
Source0: ftp://oss.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
|
||||
Source0: http://kernel.org/pub/linux/utils/fs/xfs/%{name}/%{name}-%{version}.tar.xz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libtool, gettext, gawk
|
||||
BuildRequires: xfsprogs-devel, libuuid-devel, libattr-devel ncurses-devel
|
||||
Requires: xfsprogs >= 2.6.30, attr >= 2.0.0
|
||||
|
||||
Patch0: xfsdump-largefile.patch
|
||||
|
||||
%description
|
||||
The xfsdump package contains xfsdump, xfsrestore and a number of
|
||||
other utilities for administering XFS filesystems.
|
||||
@ -34,7 +32,6 @@ subtrees may be restored from full or partial backups.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -68,6 +65,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_sharedstatedir}/xfsdump/inventory
|
||||
|
||||
%changelog
|
||||
* Thu Sep 21 2017 Eric Sandeen <sandeen@redhat.com> 3.1.8-1
|
||||
- New upstream release
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user