Fix FTBFS - required LFS to function with xfsprogs-devel
Patched configure script directly for now, upstream will get config.ac fix
This commit is contained in:
parent
c066535c09
commit
802bf2ea1c
226
xfsdump-largefile.patch
Normal file
226
xfsdump-largefile.patch
Normal file
@ -0,0 +1,226 @@
|
|||||||
|
--- a/configure.orig 2017-06-08 21:34:45.283790661 -0500
|
||||||
|
+++ b/configure 2017-06-08 21:34:57.982321113 -0500
|
||||||
|
@@ -772,6 +772,7 @@
|
||||||
|
enable_libtool_lock
|
||||||
|
enable_gettext
|
||||||
|
enable_lib64
|
||||||
|
+enable_largefile
|
||||||
|
'
|
||||||
|
ac_precious_vars='build_alias
|
||||||
|
host_alias
|
||||||
|
@@ -1404,6 +1405,7 @@
|
||||||
|
--enable-shared=yes/no Enable use of shared libraries default=yes
|
||||||
|
--enable-gettext=yes/no Enable alternate language support default=yes
|
||||||
|
--enable-lib64=yes/no Enable lib64 support default=yes
|
||||||
|
+ --disable-largefile omit support for large files
|
||||||
|
|
||||||
|
Optional Packages:
|
||||||
|
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
|
||||||
|
@@ -13026,6 +13028,207 @@
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
+# Check whether --enable-largefile was given.
|
||||||
|
+if test "${enable_largefile+set}" = set; then :
|
||||||
|
+ enableval=$enable_largefile;
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$enable_largefile" != no; then
|
||||||
|
+
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for special C compiler options needed for large files" >&5
|
||||||
|
+$as_echo_n "checking for special C compiler options needed for large files... " >&6; }
|
||||||
|
+if ${ac_cv_sys_largefile_CC+:} false; then :
|
||||||
|
+ $as_echo_n "(cached) " >&6
|
||||||
|
+else
|
||||||
|
+ ac_cv_sys_largefile_CC=no
|
||||||
|
+ if test "$GCC" != yes; then
|
||||||
|
+ ac_save_CC=$CC
|
||||||
|
+ while :; do
|
||||||
|
+ # IRIX 6.2 and later do not support large files by default,
|
||||||
|
+ # so use the C compiler's -n32 option if that helps.
|
||||||
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
+/* end confdefs.h. */
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||||
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||||
|
+ since some C++ compilers masquerading as C compilers
|
||||||
|
+ incorrectly reject 9223372036854775807. */
|
||||||
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||||
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||||
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||||
|
+ ? 1 : -1];
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+
|
||||||
|
+ ;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+_ACEOF
|
||||||
|
+ if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext
|
||||||
|
+ CC="$CC -n32"
|
||||||
|
+ if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ ac_cv_sys_largefile_CC=' -n32'; break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext
|
||||||
|
+ break
|
||||||
|
+ done
|
||||||
|
+ CC=$ac_save_CC
|
||||||
|
+ rm -f conftest.$ac_ext
|
||||||
|
+ fi
|
||||||
|
+fi
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_largefile_CC" >&5
|
||||||
|
+$as_echo "$ac_cv_sys_largefile_CC" >&6; }
|
||||||
|
+ if test "$ac_cv_sys_largefile_CC" != no; then
|
||||||
|
+ CC=$CC$ac_cv_sys_largefile_CC
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _FILE_OFFSET_BITS value needed for large files" >&5
|
||||||
|
+$as_echo_n "checking for _FILE_OFFSET_BITS value needed for large files... " >&6; }
|
||||||
|
+if ${ac_cv_sys_file_offset_bits+:} false; then :
|
||||||
|
+ $as_echo_n "(cached) " >&6
|
||||||
|
+else
|
||||||
|
+ while :; do
|
||||||
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
+/* end confdefs.h. */
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||||
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||||
|
+ since some C++ compilers masquerading as C compilers
|
||||||
|
+ incorrectly reject 9223372036854775807. */
|
||||||
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||||
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||||
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||||
|
+ ? 1 : -1];
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+
|
||||||
|
+ ;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+_ACEOF
|
||||||
|
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ ac_cv_sys_file_offset_bits=no; break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
+/* end confdefs.h. */
|
||||||
|
+#define _FILE_OFFSET_BITS 64
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||||
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||||
|
+ since some C++ compilers masquerading as C compilers
|
||||||
|
+ incorrectly reject 9223372036854775807. */
|
||||||
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||||
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||||
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||||
|
+ ? 1 : -1];
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+
|
||||||
|
+ ;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+_ACEOF
|
||||||
|
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ ac_cv_sys_file_offset_bits=64; break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
+ ac_cv_sys_file_offset_bits=unknown
|
||||||
|
+ break
|
||||||
|
+done
|
||||||
|
+fi
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_file_offset_bits" >&5
|
||||||
|
+$as_echo "$ac_cv_sys_file_offset_bits" >&6; }
|
||||||
|
+case $ac_cv_sys_file_offset_bits in #(
|
||||||
|
+ no | unknown) ;;
|
||||||
|
+ *)
|
||||||
|
+cat >>confdefs.h <<_ACEOF
|
||||||
|
+#define _FILE_OFFSET_BITS $ac_cv_sys_file_offset_bits
|
||||||
|
+_ACEOF
|
||||||
|
+;;
|
||||||
|
+esac
|
||||||
|
+rm -rf conftest*
|
||||||
|
+ if test $ac_cv_sys_file_offset_bits = unknown; then
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for _LARGE_FILES value needed for large files" >&5
|
||||||
|
+$as_echo_n "checking for _LARGE_FILES value needed for large files... " >&6; }
|
||||||
|
+if ${ac_cv_sys_large_files+:} false; then :
|
||||||
|
+ $as_echo_n "(cached) " >&6
|
||||||
|
+else
|
||||||
|
+ while :; do
|
||||||
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
+/* end confdefs.h. */
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||||
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||||
|
+ since some C++ compilers masquerading as C compilers
|
||||||
|
+ incorrectly reject 9223372036854775807. */
|
||||||
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||||
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||||
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||||
|
+ ? 1 : -1];
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+
|
||||||
|
+ ;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+_ACEOF
|
||||||
|
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ ac_cv_sys_large_files=no; break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
+/* end confdefs.h. */
|
||||||
|
+#define _LARGE_FILES 1
|
||||||
|
+#include <sys/types.h>
|
||||||
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
||||||
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
||||||
|
+ since some C++ compilers masquerading as C compilers
|
||||||
|
+ incorrectly reject 9223372036854775807. */
|
||||||
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
||||||
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
||||||
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
||||||
|
+ ? 1 : -1];
|
||||||
|
+int
|
||||||
|
+main ()
|
||||||
|
+{
|
||||||
|
+
|
||||||
|
+ ;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+_ACEOF
|
||||||
|
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
+ ac_cv_sys_large_files=1; break
|
||||||
|
+fi
|
||||||
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
+ ac_cv_sys_large_files=unknown
|
||||||
|
+ break
|
||||||
|
+done
|
||||||
|
+fi
|
||||||
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_sys_large_files" >&5
|
||||||
|
+$as_echo "$ac_cv_sys_large_files" >&6; }
|
||||||
|
+case $ac_cv_sys_large_files in #(
|
||||||
|
+ no | unknown) ;;
|
||||||
|
+ *)
|
||||||
|
+cat >>confdefs.h <<_ACEOF
|
||||||
|
+#define _LARGE_FILES $ac_cv_sys_large_files
|
||||||
|
+_ACEOF
|
||||||
|
+;;
|
||||||
|
+esac
|
||||||
|
+rm -rf conftest*
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+
|
||||||
|
for ac_header in uuid.h sys/uuid.h uuid/uuid.h
|
||||||
|
do :
|
||||||
|
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
14
xfsdump.spec
14
xfsdump.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Administrative utilities for the XFS filesystem
|
Summary: Administrative utilities for the XFS filesystem
|
||||||
Name: xfsdump
|
Name: xfsdump
|
||||||
Version: 3.1.6
|
Version: 3.1.6
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
||||||
# in source, with no mention of version.
|
# in source, with no mention of version.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
@ -13,6 +13,8 @@ BuildRequires: libtool, gettext, gawk
|
|||||||
BuildRequires: xfsprogs-devel, libuuid-devel, libattr-devel ncurses-devel
|
BuildRequires: xfsprogs-devel, libuuid-devel, libattr-devel ncurses-devel
|
||||||
Requires: xfsprogs >= 2.6.30, attr >= 2.0.0
|
Requires: xfsprogs >= 2.6.30, attr >= 2.0.0
|
||||||
|
|
||||||
|
Patch0: xfsdump-largefile.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The xfsdump package contains xfsdump, xfsrestore and a number of
|
The xfsdump package contains xfsdump, xfsrestore and a number of
|
||||||
other utilities for administering XFS filesystems.
|
other utilities for administering XFS filesystems.
|
||||||
@ -32,11 +34,12 @@ subtrees may be restored from full or partial backups.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make V=1 %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -65,6 +68,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_sharedstatedir}/xfsdump/inventory
|
%{_sharedstatedir}/xfsdump/inventory
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 08 2017 Eric Sandeen <sandeen@redhat.com> 3.1.6-4
|
||||||
|
- Build with largefile support on 32-bit platforms
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.6-3
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.6-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
@ -171,7 +177,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
* Thu May 31 2007 Eric Sandeen <sandeen@redhat.com> - 2.2.45-1
|
* Thu May 31 2007 Eric Sandeen <sandeen@redhat.com> - 2.2.45-1
|
||||||
- Update to xfsdump 2.2.45
|
- Update to xfsdump 2.2.45
|
||||||
|
|
||||||
* Wed Aug 31 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.42-2
|
* Thu Aug 31 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.42-2
|
||||||
- Remove Distribution: tag
|
- Remove Distribution: tag
|
||||||
|
|
||||||
* Wed Aug 23 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.42-1
|
* Wed Aug 23 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.42-1
|
||||||
@ -182,7 +188,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
- Add the Distribution tag
|
- Add the Distribution tag
|
||||||
- Add ncurses-devel to buildrequires
|
- Add ncurses-devel to buildrequires
|
||||||
|
|
||||||
* Tue Aug 16 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.38-2
|
* Wed Aug 16 2006 Russell Cattelan <cattelan@thebarn.com> - 2.2.38-2
|
||||||
- install removes the makefile installed version of the docs
|
- install removes the makefile installed version of the docs
|
||||||
package the docs based in the version specfic directory
|
package the docs based in the version specfic directory
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user