-New upstream release
This commit is contained in:
parent
58af504b96
commit
147fcf4d12
@ -1 +1 @@
|
||||
xfsdump_2.2.48-1.tar.gz
|
||||
xfsdump-3.0.0.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
46412a9dabb8c9f84cd1d9ff1cda64a6 xfsdump_2.2.48-1.tar.gz
|
||||
63f05d3d131cedae2a1cdf78b47e448d xfsdump-3.0.0.tar.gz
|
||||
|
@ -1,159 +0,0 @@
|
||||
(oops, cvs version)
|
||||
|
||||
I got tired of waiting for xfsdump to build
|
||||
serially...
|
||||
|
||||
On a 16p altix, make -j16 (excluding the configure
|
||||
phase) went from 55s to 12s.
|
||||
|
||||
Signed-off-by: Eric Sandeen <sandeen@sandeen.net>
|
||||
---
|
||||
|
||||
Index: xfsdump-2.2.48/Makefile
|
||||
===================================================================
|
||||
--- xfsdump-2.2.48.orig/Makefile 2007-09-10 21:01:10.000000000 -0500
|
||||
+++ xfsdump-2.2.48/Makefile 2008-11-12 11:17:09.751001665 -0600
|
||||
@@ -15,23 +15,28 @@ LSRCFILES = configure configure.in acloc
|
||||
LDIRT = config.log .dep config.status config.cache confdefs.h conftest* \
|
||||
Logs/* built .census install.* install-dev.* *.gz
|
||||
|
||||
-SUBDIRS = include librmt \
|
||||
- common estimate fsr inventory invutil dump restore \
|
||||
+LIB_SUBDIRS = include librmt
|
||||
+TOOL_SUBDIRS = common estimate fsr inventory invutil dump restore \
|
||||
m4 man doc po debian build
|
||||
|
||||
+SUBDIRS = $(LIB_SUBDIRS) $(TOOL_SUBDIRS)
|
||||
+
|
||||
default: $(CONFIGURE)
|
||||
ifeq ($(HAVE_BUILDDEFS), no)
|
||||
$(MAKE) -C . $@
|
||||
else
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+ $(MAKE) $(SUBDIRS)
|
||||
endif
|
||||
|
||||
+$(TOOL_SUBDIRS) : $(LIB_SUBDIRS)
|
||||
+
|
||||
ifeq ($(HAVE_BUILDDEFS), yes)
|
||||
include $(BUILDRULES)
|
||||
else
|
||||
clean: # if configure hasn't run, nothing to clean
|
||||
endif
|
||||
|
||||
+.NOTPARALLEL: $(CONFIGURE)
|
||||
$(CONFIGURE):
|
||||
autoconf
|
||||
./configure \
|
||||
@@ -51,13 +56,17 @@ $(CONFIGURE):
|
||||
aclocal.m4::
|
||||
aclocal --acdir=`pwd`/m4 --output=$@
|
||||
|
||||
-install: default
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+install: default $(addsuffix -install,$(SUBDIRS))
|
||||
$(INSTALL) -m 755 -d $(PKG_DOC_DIR)
|
||||
$(INSTALL) -m 644 README $(PKG_DOC_DIR)
|
||||
|
||||
-install-dev: default
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+%-install:
|
||||
+ $(MAKE) -C $* install
|
||||
+
|
||||
+install-dev: default $(addsuffix -install-dev,$(SUBDIRS))
|
||||
+
|
||||
+%-install-dev:
|
||||
+ $(MAKE) -C $* install-dev
|
||||
|
||||
realclean distclean: clean
|
||||
rm -f $(LDIRT) $(CONFIGURE)
|
||||
Index: xfsdump-2.2.48/include/buildmacros
|
||||
===================================================================
|
||||
--- xfsdump-2.2.48.orig/include/buildmacros 2007-09-10 21:01:12.000000000 -0500
|
||||
+++ xfsdump-2.2.48/include/buildmacros 2008-11-12 11:16:13.008002065 -0600
|
||||
@@ -123,14 +123,6 @@ INSTALL_LINGUAS = \
|
||||
done
|
||||
endif
|
||||
|
||||
-SUBDIRS_MAKERULE = \
|
||||
- @for d in $(SUBDIRS) ""; do \
|
||||
- if test -d "$$d" -a ! -z "$$d"; then \
|
||||
- $(ECHO) === $$d ===; \
|
||||
- $(MAKEF) -C $$d $@ || exit $$?; \
|
||||
- fi; \
|
||||
- done
|
||||
-
|
||||
MAN_MAKERULE = \
|
||||
@for f in *.[12345678] ""; do \
|
||||
if test ! -z "$$f"; then \
|
||||
Index: xfsdump-2.2.48/include/buildrules
|
||||
===================================================================
|
||||
--- xfsdump-2.2.48.orig/include/buildrules 2007-09-10 21:01:12.000000000 -0500
|
||||
+++ xfsdump-2.2.48/include/buildrules 2008-11-12 11:16:13.034000928 -0600
|
||||
@@ -6,18 +6,23 @@ _BUILDRULES_INCLUDED_ = 1
|
||||
|
||||
include $(TOPDIR)/include/builddefs
|
||||
|
||||
-clean clobber : $(SUBDIRS)
|
||||
+clean clobber: $(addsuffix -clean,$(SUBDIRS))
|
||||
rm -f $(DIRT)
|
||||
@rm -fr .libs
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+
|
||||
+%-clean::
|
||||
+ $(MAKE) -C $* clean
|
||||
|
||||
# Never blow away subdirs
|
||||
ifdef SUBDIRS
|
||||
.PRECIOUS: $(SUBDIRS)
|
||||
-$(SUBDIRS):
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
endif
|
||||
|
||||
+.PHONY: $(SUBDIRS)
|
||||
+
|
||||
+$(SUBDIRS):
|
||||
+ $(MAKE) -C $@
|
||||
+
|
||||
#
|
||||
# Standard targets
|
||||
#
|
||||
@@ -68,11 +73,13 @@ ifdef LTLIBRARY
|
||||
DEPENDSCRIPT := $(DEPENDSCRIPT) | $(SED) -e 's,^\([^:]*\)\.o,\1.lo,'
|
||||
endif
|
||||
|
||||
-depend : $(CFILES) $(HFILES)
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+depend : $(CFILES) $(HFILES) $(addsuffix -depend,$(SUBDIRS))
|
||||
$(DEPENDSCRIPT) > .dep
|
||||
test -s .dep || rm -f .dep
|
||||
|
||||
+%-depend:
|
||||
+ $(MAKE) -C $* depend
|
||||
+
|
||||
# Include dep, but only if it exists
|
||||
ifeq ($(shell test -f .dep && echo .dep), .dep)
|
||||
include .dep
|
||||
Index: xfsdump-2.2.48/man/Makefile
|
||||
===================================================================
|
||||
--- xfsdump-2.2.48.orig/man/Makefile 2007-09-10 21:01:13.000000000 -0500
|
||||
+++ xfsdump-2.2.48/man/Makefile 2008-11-12 11:16:13.051001065 -0600
|
||||
@@ -7,7 +7,16 @@ include $(TOPDIR)/include/builddefs
|
||||
|
||||
SUBDIRS = man8
|
||||
|
||||
-default install install-dev : $(SUBDIRS)
|
||||
- $(SUBDIRS_MAKERULE)
|
||||
+default : $(SUBDIRS)
|
||||
+
|
||||
+install : $(addsuffix -install,$(SUBDIRS))
|
||||
+
|
||||
+install-dev : $(addsuffix -install-dev,$(SUBDIRS))
|
||||
+
|
||||
+%-install:
|
||||
+ $(MAKE) -C $* install
|
||||
+
|
||||
+%-install-dev:
|
||||
+ $(MAKE) -C $* install-dev
|
||||
|
||||
include $(BUILDRULES)
|
12
xfsdump.spec
12
xfsdump.spec
@ -1,20 +1,18 @@
|
||||
Summary: Administrative utilities for the XFS filesystem
|
||||
Name: xfsdump
|
||||
Version: 2.2.48
|
||||
Release: 2%{?dist}
|
||||
Version: 3.0.0
|
||||
Release: 1%{?dist}
|
||||
# Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
|
||||
# in source, with no mention of version.
|
||||
License: GPL+
|
||||
Group: System Environment/Base
|
||||
URL: http://oss.sgi.com/projects/xfs/
|
||||
Source0: ftp://oss.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
|
||||
Source0: ftp://oss.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: autoconf, libtool, gettext, gawk
|
||||
BuildRequires: xfsprogs-devel, e2fsprogs-devel, libattr-devel ncurses-devel
|
||||
Requires: xfsprogs >= 2.6.30, attr >= 2.0.0
|
||||
|
||||
Patch0: xfsdump-parallel-build.patch
|
||||
|
||||
%description
|
||||
The xfsdump package contains xfsdump, xfsrestore and a number of
|
||||
other utilities for administering XFS filesystems.
|
||||
@ -34,7 +32,6 @@ subtrees may be restored from full or partial backups.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -64,6 +61,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
/sbin/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 04 2009 Eric Sandeen <sandeen@redhat.com> 3.0.0-1
|
||||
-New upstream release
|
||||
|
||||
* Wed Nov 12 2008 Eric Sandeen <sandeen@redhat.com> 2.2.48-2
|
||||
- Enable parallel builds
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user