- Merge with upstream version
This commit is contained in:
parent
1738f5b898
commit
64a26418cf
@ -1,5 +1,5 @@
|
||||
--- build.xml.orig 2005-06-25 16:25:27.000000000 -0400
|
||||
+++ build.xml 2005-07-26 19:46:47.000000000 -0400
|
||||
--- build.xml.orig 2005-07-26 16:09:07.000000000 -0400
|
||||
+++ build.xml 2006-08-11 17:57:09.000000000 -0400
|
||||
@@ -19,7 +19,8 @@
|
||||
<project default="usage" basedir=".">
|
||||
|
||||
@ -64,7 +64,7 @@
|
||||
debug="${debug}"
|
||||
includeAntRuntime="false"
|
||||
includeJavaRuntime="true"/>
|
||||
@@ -354,7 +333,7 @@
|
||||
@@ -354,9 +333,10 @@
|
||||
<target name="docs" depends="prepare, prepare-docs">
|
||||
<echo message="Building docs for ${parser.Name} ${parser.Version} ..." />
|
||||
<java fork="yes"
|
||||
@ -72,8 +72,11 @@
|
||||
+ classpath="${java.class.path}:${doc.generator.package}:${tools.dir}/xalan.jar"
|
||||
classname="${doc.generator}"
|
||||
failOnError="yes">
|
||||
+ <jvmarg value="-Djava.awt.headless=true"/>
|
||||
<arg value="targetDirectory=${build.docs}"/>
|
||||
@@ -997,20 +976,6 @@
|
||||
<arg value="${build.dir}/xdocs/docs-book.xml"/>
|
||||
<arg value="${build.dir}/xdocs/style"/>
|
||||
@@ -997,20 +977,6 @@
|
||||
<replace file="${build.dir}/src/org/apache/xerces/parsers/AbstractSAXParser.java"
|
||||
token="return (fConfiguration instanceof XML11Configurable);" value="return false;"/>
|
||||
|
||||
|
178
xerces-j2.spec
178
xerces-j2.spec
@ -1,16 +1,47 @@
|
||||
%define name xerces-j2
|
||||
%define version 2.7.1
|
||||
# Copyright (c) 2000-2005, JPackage Project
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
#
|
||||
# 1. Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 2. Redistributions in binary form must reproduce the above copyright
|
||||
# notice, this list of conditions and the following disclaimer in the
|
||||
# documentation and/or other materials provided with the
|
||||
# distribution.
|
||||
# 3. Neither the name of the JPackage Project nor the names of its
|
||||
# contributors may be used to endorse or promote products derived
|
||||
# from this software without specific prior written permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
#%define _with_gcj_support 1
|
||||
|
||||
%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
|
||||
|
||||
%define cvs_version 2_7_1
|
||||
%define release 6jpp_9fc
|
||||
%define section free
|
||||
|
||||
Name: %{name}
|
||||
Version: %{version}
|
||||
Release: %{release}
|
||||
Name: xerces-j2
|
||||
Version: 2.7.1
|
||||
Release: 7jpp.1
|
||||
Epoch: 0
|
||||
Summary: Java XML parser
|
||||
License: Apache Software License
|
||||
URL: http://xml.apache.org/xerces2-j/
|
||||
URL: http://xerces.apache.org/
|
||||
Group: Text Processing/Markup/XML
|
||||
Source0: http://www.apache.org/dist/xml/xerces-j/Xerces-J-src.%{version}.tar.gz
|
||||
Source1: %{name}-version.sh
|
||||
@ -18,24 +49,32 @@ Source2: %{name}-constants.sh
|
||||
Source3: XJavac.java
|
||||
Patch0: %{name}-build.patch
|
||||
Patch1: %{name}-libgcj.patch
|
||||
Obsoletes: xerces-j2-dom3
|
||||
Provides: jaxp_parser_impl
|
||||
Requires: xml-commons-apis
|
||||
Provides: xerces-j2-dom3
|
||||
Requires: xml-commons-apis >= 0:1.3
|
||||
Requires: xml-commons-resolver >= 1.1
|
||||
Requires: /usr/sbin/update-alternatives
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: ant >= 0:1.5
|
||||
BuildRequires: jpackage-utils >= 0:1.5
|
||||
BuildRequires: ant >= 0:1.6
|
||||
BuildRequires: jpackage-utils >= 0:1.6
|
||||
BuildRequires: jaxp_parser_impl
|
||||
BuildRequires: xml-commons-resolver >= 0:1.1
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: xml-commons-apis >= 0:1.3
|
||||
# xml-stylbook is not yet in FC
|
||||
#BuildRequires: xml-stylebook
|
||||
Requires(post): /usr/sbin/update-alternatives jaxp_parser_impl
|
||||
Requires(preun): /usr/sbin/update-alternatices jaxp_parser_impl
|
||||
|
||||
%if ! %{gcj_support}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
# RHEL3 and FC2
|
||||
Obsoletes: xerces-j <= 0:2.2
|
||||
# libgcj aot-compiled native libraries
|
||||
BuildRequires: java-gcj-compat-devel >= 1.0.31
|
||||
Requires(post): java-gcj-compat >= 1.0.31
|
||||
Requires(postun): java-gcj-compat >= 1.0.31
|
||||
|
||||
%if %{gcj_support}
|
||||
BuildRequires: java-gcj-compat-devel >= 1.0.31
|
||||
Requires(post): java-gcj-compat >= 1.0.31
|
||||
Requires(postun): java-gcj-compat >= 1.0.31
|
||||
%endif
|
||||
|
||||
%description
|
||||
Welcome to the future! Xerces2 is the next generation of high
|
||||
@ -60,7 +99,7 @@ page.
|
||||
%package javadoc-impl
|
||||
Summary: Javadoc for %{name} implementation
|
||||
Group: Development/Documentation
|
||||
Prereq: coreutils
|
||||
Requires(post): /bin/rm /bin/ln
|
||||
|
||||
%description javadoc-impl
|
||||
Javadoc for %{name} implementation.
|
||||
@ -68,7 +107,8 @@ Javadoc for %{name} implementation.
|
||||
%package javadoc-apis
|
||||
Summary: Javadoc for %{name} apis
|
||||
Group: Development/Documentation
|
||||
Prereq: coreutils
|
||||
Obsoletes: xerces-j2-dom3-javadoc
|
||||
Requires(post): /bin/rm /bin/ln
|
||||
|
||||
%description javadoc-apis
|
||||
Javadoc for %{name} apis.
|
||||
@ -76,7 +116,7 @@ Javadoc for %{name} apis.
|
||||
%package javadoc-xni
|
||||
Summary: Javadoc for %{name} xni
|
||||
Group: Development/Documentation
|
||||
Prereq: coreutils
|
||||
Requires(post): /bin/rm /bin/ln
|
||||
|
||||
%description javadoc-xni
|
||||
Javadoc for %{name} xni.
|
||||
@ -84,7 +124,7 @@ Javadoc for %{name} xni.
|
||||
%package javadoc-other
|
||||
Summary: Javadoc for other %{name} components
|
||||
Group: Development/Documentation
|
||||
Prereq: coreutils
|
||||
Requires(post): /bin/rm /bin/ln
|
||||
|
||||
%description javadoc-other
|
||||
Javadoc for other %{name} components.
|
||||
@ -93,8 +133,12 @@ Javadoc for other %{name} components.
|
||||
Summary: Demo for %{name}
|
||||
Group: Development/Testing
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires(post): java-gcj-compat >= 1.0.31
|
||||
Requires(postun): java-gcj-compat >= 1.0.31
|
||||
|
||||
%if %{gcj_support}
|
||||
BuildRequires: java-gcj-compat-devel >= 1.0.31
|
||||
Requires(post): java-gcj-compat >= 1.0.31
|
||||
Requires(postun): java-gcj-compat >= 1.0.31
|
||||
%endif
|
||||
|
||||
%description demo
|
||||
Demonstrations and samples for %{name}.
|
||||
@ -103,15 +147,14 @@ Demonstrations and samples for %{name}.
|
||||
Summary: Additional utility scripts for %{name}
|
||||
Group: Text Processing/Markup/XML
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires: jpackage-utils >= 0:1.5
|
||||
Requires: jpackage-utils >= 0:1.6
|
||||
|
||||
%description scripts
|
||||
Additional utility scripts for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n xerces-%{cvs_version}
|
||||
%patch0 -p0 -b .build
|
||||
%patch0 -b .build
|
||||
|
||||
mkdir -p tools/org/apache/xerces/util
|
||||
cp -a %{SOURCE3} tools/org/apache/xerces/util
|
||||
@ -120,19 +163,23 @@ cp -a %{SOURCE3} tools/org/apache/xerces/util
|
||||
|
||||
%build
|
||||
pushd tools
|
||||
export GCJ_PROPERTIES="gnu.gcj.precompiled.db.path=/tmp"
|
||||
javac -classpath $(build-classpath ant) org/apache/xerces/util/XJavac.java
|
||||
mkdir bin && jar cf bin/xjavac.jar org/apache/xerces/util/XJavac.class
|
||||
ln -sf $(build-classpath xml-commons-apis) .
|
||||
ln -sf $(build-classpath xml-commons-resolver) .
|
||||
popd
|
||||
|
||||
unset CLASSPATH
|
||||
%if ! %{gcj_support}
|
||||
export CLASSPATH=$(build-classpath xml-stylebook):tools/bin/xjavac.jar
|
||||
export ANT_OPTS="-Xmx256m -Djava.endorsed.dirs=$(pwd)/tools -Djava.awt.headless=true -Dbuild.sysclasspath=first -Ddisconnected=true"
|
||||
%endif
|
||||
ant \
|
||||
-Dbuild.compiler=modern \
|
||||
-Dtools.dir=%{_javadir} \
|
||||
-Djar.apis=xml-commons-apis.jar \
|
||||
-Djar.resolver=xml-commons-resolver.jar \
|
||||
clean jars javadocs
|
||||
unset GCJ_PROPERTIES
|
||||
clean jars javadocs sampjar
|
||||
#docs cannot be built due missing xml-stylebook in FC
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -140,6 +187,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
# jars
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||
cp -p build/xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *.jar; do ln -sf ${jar} dom3-${jar}; done)
|
||||
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
||||
|
||||
# javadoc
|
||||
@ -180,14 +228,14 @@ cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
|
||||
ln -s %{_sysconfdir}/alternatives \
|
||||
$RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
|
||||
|
||||
aot-compile-rpm
|
||||
|
||||
%if %{gcj_support}
|
||||
%{_bindir}/aot-compile-rpm
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%pre
|
||||
rm -f %{_javadir}/xerces.jar
|
||||
|
||||
%post javadoc-apis
|
||||
rm -f %{_javadocdir}/%{name}-apis
|
||||
@ -208,7 +256,13 @@ ln -s %{name}-xni-%{version} %{_javadocdir}/%{name}-xni
|
||||
%post
|
||||
update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
|
||||
jaxp_parser_impl %{_javadir}/%{name}.jar 40
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
|
||||
%if %{gcj_support}
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
|
||||
%preun
|
||||
{
|
||||
@ -217,21 +271,39 @@ update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
|
||||
} >/dev/null 2>&1 || :
|
||||
|
||||
%postun
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
%if %{gcj_support}
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
|
||||
%post demo
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
%if %{gcj_support}
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
|
||||
%postun demo
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
%if %{gcj_support}
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ]
|
||||
then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
%endif
|
||||
|
||||
%files
|
||||
%defattr(0644,root,root,0755)
|
||||
%doc LICENSE README ISSUES STATUS TODO
|
||||
%{_javadir}/%{name}*.jar
|
||||
%{_javadir}/dom3-%{name}*.jar
|
||||
%ghost %{_javadir}/jaxp_parser_impl.jar
|
||||
%dir %{_libdir}/gcj/%{name}
|
||||
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-%{version}.jar.*
|
||||
%endif
|
||||
|
||||
%files javadoc-impl
|
||||
%defattr(0644,root,root,0755)
|
||||
@ -256,7 +328,10 @@ update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
|
||||
%files demo
|
||||
%defattr(0644,root,root,0755)
|
||||
%{_datadir}/%{name}
|
||||
|
||||
%if %{gcj_support}
|
||||
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-samples.jar.*
|
||||
%endif
|
||||
|
||||
%files scripts
|
||||
%defattr(0755,root,root,0755)
|
||||
@ -264,12 +339,28 @@ update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
|
||||
- Merge with upstream version
|
||||
|
||||
* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
|
||||
- Add conditional native compiling
|
||||
- Add missing requires for javadocs
|
||||
- Add missing requires for post and preun
|
||||
- Update version to 7jpp at Fedora's request
|
||||
|
||||
* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
|
||||
- Rebuilt
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
|
||||
- rebuild
|
||||
|
||||
* Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
|
||||
- Add missing BR for xml-stylebook
|
||||
|
||||
* Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
|
||||
- First JPP-1.7 release
|
||||
- use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
|
||||
|
||||
* Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
|
||||
- stop scriptlet spew
|
||||
|
||||
@ -294,6 +385,13 @@ update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
|
||||
* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt for new gcj
|
||||
|
||||
* Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
|
||||
- Upgrade to 2.7.1
|
||||
|
||||
* Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
|
||||
- Include target jars-dom3
|
||||
- Create new subpackage dom3
|
||||
|
||||
* Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
|
||||
- Build on ia64, ppc64, s390 and s390x.
|
||||
- Switch to aot-compile-rpm (also BC-compiles samples).
|
||||
|
Loading…
Reference in New Issue
Block a user