xdp-tools/SOURCES/xdp-tools-configure-Don-t-f...

112 lines
3.5 KiB
Diff

From 06f6eb8596cd4feb52f4c3aed7aa0e2d8b3353a7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Toke=20H=C3=B8iland-J=C3=B8rgensen?= <toke@redhat.com>
Date: Thu, 9 Feb 2023 17:57:41 +0100
Subject: [PATCH] configure: Don't fail on missing bpftool
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Instead of bailing out of configure if bpftool is not found, just disable
compilation of the tools that require it (i.e., xdp-bench, xdp-monitor and
xdp-trafficgen which use BPF skeletons).
Signed-off-by: Toke Høiland-Jørgensen <toke@redhat.com>
---
Makefile | 8 +++++++-
configure | 9 +++++----
lib/testing/test-tool.c | 2 ++
lib/util/util.mk | 12 ++++++++++--
4 files changed, 24 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
index 5c22e854db8d..d5dc21fb076c 100644
--- a/Makefile
+++ b/Makefile
@@ -14,8 +14,14 @@ MAKEFLAGS += --no-print-directory
endif
include version.mk
+include config.mk
+
+UTILS := xdp-filter xdp-loader xdp-dump
+
+ifneq ($(BPFTOOL),)
+UTILS += xdp-bench xdp-monitor xdp-trafficgen
+endif
-UTILS := xdp-filter xdp-loader xdp-dump xdp-bench xdp-monitor xdp-trafficgen
SUBDIRS := lib $(UTILS)
.PHONY: check_submodule help clobber distclean clean install test libxdp $(SUBDIRS)
diff --git a/configure b/configure
index 016c5bbd682e..581cd77d996f 100755
--- a/configure
+++ b/configure
@@ -71,7 +71,7 @@ check_toolchain()
CLANG=$(find_tool clang "$CLANG")
LLC=$(find_tool llc "$LLC")
- for TOOL in $PKG_CONFIG $CC $LD $OBJCOPY $CLANG $LLC $M4 $BPFTOOL; do
+ for TOOL in $PKG_CONFIG $CC $LD $OBJCOPY $CLANG $LLC $M4; do
if [ ! $(command -v ${TOOL} 2>/dev/null) ]; then
echo "*** ERROR: Cannot find tool ${TOOL}" ;
exit 1;
@@ -108,12 +108,12 @@ check_toolchain()
exit 1
fi
- if $BPFTOOL gen help 2>&1 | grep 'gen help' > /dev/null; then
+ if command -v $BPFTOOL &>/dev/null && $BPFTOOL gen help 2>&1 | grep 'gen help' > /dev/null; then
bpftool_version=$($BPFTOOL version | head -n 1)
echo "using $bpftool_version"
else
- echo "bpftool doesn't support skeleton generation"
- exit 1
+ echo "bpftool not found or doesn't support skeleton generation; not building all tools"
+ BPFTOOL=
fi
if [ -z "$ARCH_INCLUDES" ]; then
@@ -134,6 +134,7 @@ check_toolchain()
echo "EMACS:=${EMACS}" >>$CONFIG
echo "ARCH_INCLUDES:=$ARCH_INCLUDES" >> $CONFIG
echo "BPFTOOL:=${BPFTOOL}" >> $CONFIG
+ [ -n "$BPFTOOL" ] && echo "HAVE_FEATURES+=BPFTOOL" >>"$CONFIG"
}
check_zlib()
diff --git a/lib/testing/test-tool.c b/lib/testing/test-tool.c
index 7e2a82890f68..30acb835f9c3 100644
--- a/lib/testing/test-tool.c
+++ b/lib/testing/test-tool.c
@@ -212,7 +212,9 @@ int do_probe(const void *cfg, __unused const char *pin_root_path)
switch (opt->action) {
case PROBE_CPUMAP_PROGRAM:
+#ifdef HAVE_BPFTOOL
res = sample_probe_cpumap_compat();
+#endif
break;
default:
return EXIT_FAILURE;
diff --git a/lib/util/util.mk b/lib/util/util.mk
index 7fc3b4345c34..7059cdd5e7dc 100644
--- a/lib/util/util.mk
+++ b/lib/util/util.mk
@@ -1,2 +1,10 @@
-UTIL_OBJS := params.o logging.o util.o stats.o xpcapng.o xdp_sample.o
-UTIL_BPF_OBJS := xdp_sample.bpf.o
+LIB_DIR ?= ..
+include $(LIB_DIR)/defines.mk
+
+UTIL_OBJS := params.o logging.o util.o stats.o xpcapng.o
+UTIL_BPF_OBJS :=
+
+ifneq ($(BPFTOOL),)
+UTIL_OBJS += xdp_sample.o
+UTIL_BPF_OBJS += xdp_sample.bpf.o
+endif
--
2.39.1