xdg-utils/0003-xdg-terminal-incompatible-.-BR44357.patch
Rex Dieter 82f4a464bd 1.1.0-0.21.rc2
- .spec housecleaning (remove deprecated stuff)
- pull in latest upstream fixes, including...
- xdg-open does not substitute all field codes in Exec key (#1056431, fdo#49204)
2014-03-30 17:40:51 -05:00

56 lines
2.1 KiB
Diff

From 495fa68306f6f5b0c0bb312e92f0f2a0e35fa567 Mon Sep 17 00:00:00 2001
From: Rex Dieter <rdieter@math.unl.edu>
Date: Fri, 7 Feb 2014 10:56:17 -0600
Subject: [PATCH 3/9] xdg-terminal incompatible ... (BR44357)
fix harder! put the code in the right place this time.
---
scripts/xdg-terminal.in | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/scripts/xdg-terminal.in b/scripts/xdg-terminal.in
index 614dacf..21d8309 100644
--- a/scripts/xdg-terminal.in
+++ b/scripts/xdg-terminal.in
@@ -38,17 +38,7 @@ terminal_kde()
if [ x"$1" = x"" ]; then
$terminal_exec
else
- # screen and urxvt won't do their own parsing of quoted arguments
- if [ x"$TERM" = x"screen" ]; then
- # screen has an incompatible meaning for -e
- sh -c "exec $terminal_exec $1"
- elif [ x"$TERM" = x"urxvt" ] || [ x"$TERM" = x"rxvt-unicode" ] || [ x"$TERM" = x"rxvt" ]; then
- #TODO: Use whatever mechanism dash supports to test for
- # rxvt-* to match things like rxvt-unicode-256color
- sh -c "exec $terminal_exec -e $1"
- else
- $terminal_exec -e "$1"
- fi
+ $terminal_exec -e "$1"
fi
if [ $? -eq 0 ]; then
@@ -120,7 +110,17 @@ terminal_generic()
if [ x"$1" = x"" ]; then
$terminal_exec
else
- $terminal_exec -e "$1"
+ # screen and urxvt won't do their own parsing of quoted arguments
+ if [ x"$TERM" = x"screen" ]; then
+ # screen has an incompatible meaning for -e
+ sh -c "exec $terminal_exec $1"
+ elif [ x"$TERM" = x"urxvt" ] || [ x"$TERM" = x"rxvt-unicode" ] || [ x"$TERM" = x"rxvt" ]; then
+ #TODO: Use whatever mechanism dash supports to test for
+ # rxvt-* to match things like rxvt-unicode-256color
+ sh -c "exec $terminal_exec -e $1"
+ else
+ $terminal_exec -e "$1"
+ fi
fi
if [ $? -eq 0 ]; then
--
1.9.0