82f4a464bd
- .spec housecleaning (remove deprecated stuff) - pull in latest upstream fixes, including... - xdg-open does not substitute all field codes in Exec key (#1056431, fdo#49204)
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From cba39e7a00abe27b3bff49e2d455bb30ad33dde6 Mon Sep 17 00:00:00 2001
|
|
From: Rex Dieter <rdieter@math.unl.edu>
|
|
Date: Fri, 7 Feb 2014 10:51:10 -0600
|
|
Subject: [PATCH 2/9] Improvement of detecting KDE session (BR63157)
|
|
|
|
---
|
|
ChangeLog | 3 +++
|
|
scripts/xdg-utils-common.in | 2 +-
|
|
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/ChangeLog b/ChangeLog
|
|
index 8b35df0..b7fcf86 100644
|
|
--- a/ChangeLog
|
|
+++ b/ChangeLog
|
|
@@ -1,5 +1,8 @@
|
|
=== xdg-utils 1.1.x ===
|
|
|
|
+2014-02-07 Rex Dieter <rdieter@fedoraproject.org>
|
|
+ * Improvement of detecting KDE session (BR63157)
|
|
+
|
|
2013-10-24 Rex Dieter <rdieter@fedoraproject.org>
|
|
* xdg-desktop-menu: improperly check for vendor prefix on Estonian locale (BR70742)
|
|
|
|
diff --git a/scripts/xdg-utils-common.in b/scripts/xdg-utils-common.in
|
|
index 5b50f9b..c365cca 100644
|
|
--- a/scripts/xdg-utils-common.in
|
|
+++ b/scripts/xdg-utils-common.in
|
|
@@ -279,7 +279,7 @@ detectDE()
|
|
|
|
if [ x"$DE" = x"" ]; then
|
|
# classic fallbacks
|
|
- if [ x"$KDE_FULL_SESSION" = x"true" ]; then DE=kde;
|
|
+ if [ x"$KDE_FULL_SESSION" != x"" ]; then DE=kde;
|
|
elif [ x"$GNOME_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;
|
|
elif [ x"$MATE_DESKTOP_SESSION_ID" != x"" ]; then DE=mate;
|
|
elif `dbus-send --print-reply --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.GetNameOwner string:org.gnome.SessionManager > /dev/null 2>&1` ; then DE=gnome;
|
|
--
|
|
1.9.0
|
|
|