auto-import xdg-utils-1.0-0.4.20060721 on branch devel from
xdg-utils-1.0-0.4.20060721.src.rpm
This commit is contained in:
parent
298ddc2a65
commit
12fa9939ea
@ -0,0 +1 @@
|
||||
xdg-utils-20060721.tgz
|
40
xdg-utils-20060721-optgnome.patch
Normal file
40
xdg-utils-20060721-optgnome.patch
Normal file
@ -0,0 +1,40 @@
|
||||
--- xdg-utils-20060721/scripts/xdg-icon-resource.optgnome 2006-07-21 18:26:31.000000000 -0500
|
||||
+++ xdg-utils-20060721/scripts/xdg-icon-resource 2006-07-24 13:31:42.000000000 -0500
|
||||
@@ -315,16 +315,13 @@
|
||||
|
||||
update_icon_database()
|
||||
{
|
||||
- IFS_save=$IFS
|
||||
- IFS=":"
|
||||
- for x in $PATH:/opt/gnome/bin; do
|
||||
+ for x in `echo $PATH | sed 's/:/ /g'` /opt/gnome/bin ; do
|
||||
if [ -x $x/gtk-update-icon-cache ] ; then
|
||||
DEBUG 1 "Running $x/gtk-update-icon-cache -f -t \"$1\""
|
||||
eval '$x/gtk-update-icon-cache -f -t "$1"'$xdg_redirect_output
|
||||
return
|
||||
fi
|
||||
done
|
||||
- IFS=$IFS_save
|
||||
}
|
||||
|
||||
[ x"$1" != x"" ] || exit_failure_syntax
|
||||
--- xdg-utils-20060721/scripts/xdg-mime.optgnome 2006-07-21 18:26:31.000000000 -0500
|
||||
+++ xdg-utils-20060721/scripts/xdg-mime 2006-07-24 13:31:12.000000000 -0500
|
||||
@@ -344,16 +344,13 @@
|
||||
|
||||
update_mime_database()
|
||||
{
|
||||
- IFS_save=$IFS
|
||||
- IFS=":"
|
||||
- for x in $PATH:/opt/gnome/bin; do
|
||||
+ for x in `echo $PATH | sed 's/:/ /g'` /opt/gnome/bin ; do
|
||||
if [ -x $x/update-mime-database ] ; then
|
||||
DEBUG 1 "Running $x/update-mime-database $1"
|
||||
eval '$x/update-mime-database $1'$xdg_redirect_output
|
||||
return
|
||||
fi
|
||||
done
|
||||
- IFS=$IFS_save
|
||||
}
|
||||
|
||||
info_kde()
|
97
xdg-utils.spec
Normal file
97
xdg-utils.spec
Normal file
@ -0,0 +1,97 @@
|
||||
|
||||
%define beta 20060721
|
||||
|
||||
Summary: Basic desktop integration functions
|
||||
Name: xdg-utils
|
||||
Version: 1.0
|
||||
Release: 0.4.%{beta}
|
||||
|
||||
URL: http://portland.freedesktop.org/
|
||||
#Source0: http://portland.freedesktop.org/download/xdg-utils-%{version}%{?beta}.tgz
|
||||
Source0: http://portland.freedesktop.org/download/xdg-utils-%{beta}.tgz
|
||||
License: MIT
|
||||
Group: System Environment/Base
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
|
||||
# upstream patches
|
||||
Patch1: xdg-utils-20060721-optgnome.patch
|
||||
|
||||
# Not really used (yet)
|
||||
#BuildRequires: xmlto
|
||||
|
||||
Requires: desktop-file-utils
|
||||
## kde-config
|
||||
#Requires: kdelibs
|
||||
# update-gtk-icon-cache
|
||||
#Requires: gtk2
|
||||
|
||||
|
||||
%description
|
||||
The xdg-utils package is a set of simple scripts that provide basic
|
||||
desktop integration functions for any Free Desktop, such as Linux.
|
||||
They are intended to provide a set of defacto standards.
|
||||
This means that:
|
||||
* Third party software developers can rely on these xdg-utils
|
||||
for all of their simple integration needs.
|
||||
* Developers of desktop environments can make sure that their
|
||||
environments are well supported
|
||||
* Distribution vendors can provide custom versions of these utilities
|
||||
|
||||
The following scripts are provided at this time:
|
||||
* xdg-menu Place a menu into the users menu structure
|
||||
* xdg-mime Gather mime information about a file
|
||||
* xdg-open Open a URL in the user's preferred application that
|
||||
handles the respective URL or file type
|
||||
* xdg-email Open the users preferred email client,
|
||||
potentially with subject and other info filled in
|
||||
* xdg-copy Copy one URI to another
|
||||
* xdg-su Run a command as a different (usually root) user
|
||||
* xdg-screensaver Enable, disable, or suspend the screensaver
|
||||
|
||||
|
||||
%prep
|
||||
#setup -q -n %{name}-%{version}%{?beta}
|
||||
%setup -q -n %{name}-%{beta}
|
||||
|
||||
%patch1 -p1 -b .optgnome
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog LICENSE README TODO
|
||||
%{_bindir}/xdg-*
|
||||
%{_mandir}/man1/xdg-*
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0-0.4.20060721
|
||||
- specfile cosmetics, tabs -> spaces
|
||||
- %%makeinstall -> make install DESTDIR=...
|
||||
|
||||
* Mon Jul 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0-0.3.20060721
|
||||
- 20060721 snapshot
|
||||
- optgnome.patch
|
||||
|
||||
* Mon Jul 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0-0.2.beta1
|
||||
- Requires: desktop-file-utils
|
||||
|
||||
* Mon Jul 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0-0.1.beta1
|
||||
- 1.0beta1
|
||||
|
Loading…
Reference in New Issue
Block a user