- Update to 0.12 which only has a few new translations of Downloads
- Use fuzzy translations (for Downloads) (#532399) - Fix a typo in README
This commit is contained in:
parent
3c2e5c3d4b
commit
e910d30c35
2
sources
2
sources
@ -1 +1 @@
|
|||||||
19f2a928fd5069e4cc927ba009ff74d7 xdg-user-dirs-0.11.tar.gz
|
c3a78a12bd02a5dd461c3d49f9abdd18 xdg-user-dirs-0.12.tar.gz
|
||||||
|
7
typo.patch
Normal file
7
typo.patch
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
diff -up xdg-user-dirs-0.11/README.typo xdg-user-dirs-0.11/README
|
||||||
|
--- xdg-user-dirs-0.11/README.typo 2009-11-03 01:13:00.592863477 -0500
|
||||||
|
+++ xdg-user-dirs-0.11/README 2009-11-03 01:13:20.565861652 -0500
|
||||||
|
@@ -1,2 +1,2 @@
|
||||||
|
See info at:
|
||||||
|
-http://freedesktop.org/wiki/Software_2fxdg_2duser_2ddirs
|
||||||
|
+http://freedesktop.org/wiki/Software/xdg-user-dirs
|
22
use-fuzzy.patch
Normal file
22
use-fuzzy.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff -up xdg-user-dirs-0.11/po/Makefile.in.in.use-fuzzy xdg-user-dirs-0.11/po/Makefile.in.in
|
||||||
|
--- xdg-user-dirs-0.11/po/Makefile.in.in.use-fuzzy 2008-10-24 04:17:03.000000000 -0400
|
||||||
|
+++ xdg-user-dirs-0.11/po/Makefile.in.in 2009-11-03 00:57:15.319114230 -0500
|
||||||
|
@@ -61,14 +61,14 @@ CATALOGS = @CATALOGS@
|
||||||
|
.SUFFIXES: .po .gmo .mo .sed .sin .nop .po-create .po-update
|
||||||
|
|
||||||
|
.po.mo:
|
||||||
|
- @echo "$(MSGFMT) -c -o $@ $<"; \
|
||||||
|
- $(MSGFMT) -c -o t-$@ $< && mv t-$@ $@
|
||||||
|
+ @echo "$(MSGFMT) -c -f -o $@ $<"; \
|
||||||
|
+ $(MSGFMT) -c -f -o t-$@ $< && mv t-$@ $@
|
||||||
|
|
||||||
|
.po.gmo:
|
||||||
|
@lang=`echo $* | sed -e 's,.*/,,'`; \
|
||||||
|
test "$(srcdir)" = . && cdcmd="" || cdcmd="cd $(srcdir) && "; \
|
||||||
|
- echo "$${cdcmd}rm -f $${lang}.gmo && $(GMSGFMT) -c --statistics -o $${lang}.gmo $${lang}.po"; \
|
||||||
|
- cd $(srcdir) && rm -f $${lang}.gmo && $(GMSGFMT) -c --statistics -o t-$${lang}.gmo $${lang}.po && mv t-$${lang}.gmo $${lang}.gmo
|
||||||
|
+ echo "$${cdcmd}rm -f $${lang}.gmo && $(GMSGFMT) -c -f --statistics -o $${lang}.gmo $${lang}.po"; \
|
||||||
|
+ cd $(srcdir) && rm -f $${lang}.gmo && $(GMSGFMT) -c -f --statistics -o t-$${lang}.gmo $${lang}.po && mv t-$${lang}.gmo $${lang}.gmo
|
||||||
|
|
||||||
|
.sin.sed:
|
||||||
|
sed -e '/^#/d' $< > t-$@
|
@ -1,5 +1,5 @@
|
|||||||
Name: xdg-user-dirs
|
Name: xdg-user-dirs
|
||||||
Version: 0.11
|
Version: 0.12
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Handles user special directories
|
Summary: Handles user special directories
|
||||||
|
|
||||||
@ -8,6 +8,13 @@ License: GPLv2+ and MIT
|
|||||||
URL: http://freedesktop.org/wiki/Software/xdg-user-dirs
|
URL: http://freedesktop.org/wiki/Software/xdg-user-dirs
|
||||||
Source0: http://user-dirs.freedesktop.org/releases/%{name}-%{version}.tar.gz
|
Source0: http://user-dirs.freedesktop.org/releases/%{name}-%{version}.tar.gz
|
||||||
Source1: xdg-user-dirs.sh
|
Source1: xdg-user-dirs.sh
|
||||||
|
|
||||||
|
# use fuzzy translations (for Downloads)
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=532399
|
||||||
|
Patch0: use-fuzzy.patch
|
||||||
|
# fix a typo in README
|
||||||
|
Patch1: typo.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -19,11 +26,17 @@ homedirectory based on the defaults configured by the administrator.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .use-fuzzy
|
||||||
|
%patch1 -p1 -b .typo
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
cd po
|
||||||
|
touch *.po
|
||||||
|
make update-gmo
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
@ -45,6 +58,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_sysconfdir}/X11/xinit/xinitrc.d/*
|
%{_sysconfdir}/X11/xinit/xinitrc.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 24 2010 Tomas Bzatek <tbzatek@redhat.com> - 0.12-1
|
||||||
|
- Update to 0.12 which only has a few new translations of Downloads
|
||||||
|
- Use fuzzy translations (for Downloads) (#532399)
|
||||||
|
- Fix a typo in README
|
||||||
|
|
||||||
* Fri Sep 25 2009 Alexander Larsson <alexl@redhat.com> - 0.11-1
|
* Fri Sep 25 2009 Alexander Larsson <alexl@redhat.com> - 0.11-1
|
||||||
- Update to 0.11
|
- Update to 0.11
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user