Properly patch for libpipewire-0.2

This commit is contained in:
Jan Grulich 2018-08-01 10:20:02 +02:00
parent a46f4b041b
commit dd35d793cb

View File

@ -1,19 +1,54 @@
From 7fe4cbe6d42d1358980464c70bba445a2c4695bb Mon Sep 17 00:00:00 2001 diff --git a/configure b/configure
From: Jan Grulich <jgrulich@redhat.com> index 921cce5..e292e2a 100755
Date: Wed, 1 Aug 2018 09:15:57 +0200 --- a/configure
Subject: Depend on current PipeWire library and API +++ b/configure
@@ -15516,12 +15516,12 @@ if test -n "$PIPEWIRE_CFLAGS"; then
pkg_cv_PIPEWIRE_CFLAGS="$PIPEWIRE_CFLAGS"
diff --git a/configure.ac b/configure.ac elif test -n "$PKG_CONFIG"; then
index 0f2f275..a3d02aa 100644 if test -n "$PKG_CONFIG" && \
--- a/configure.ac - { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libpipewire-0.1 >= 0.1.8\""; } >&5
+++ b/configure.ac - ($PKG_CONFIG --exists --print-errors "libpipewire-0.1 >= 0.1.8") 2>&5
@@ -67,7 +67,7 @@ AC_ARG_ENABLE(pipewire, + { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libpipewire-0.2 >= 0.2.2\""; } >&5
[AS_HELP_STRING([--enable-pipewire],[Enable PipeWire support. Needed for screen cast portal])], + ($PKG_CONFIG --exists --print-errors "libpipewire-0.2 >= 0.2.2") 2>&5
enable_pipewire=$enableval, enable_pipewire=yes) ac_status=$?
if test x$enable_pipewire = xyes ; then $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- PKG_CHECK_MODULES(PIPEWIRE, [libpipewire-0.1 >= 0.1.8]) test $ac_status = 0; }; then
+ PKG_CHECK_MODULES(PIPEWIRE, [libpipewire-0.2 >= 0.2.2]) - pkg_cv_PIPEWIRE_CFLAGS=`$PKG_CONFIG --cflags "libpipewire-0.1 >= 0.1.8" 2>/dev/null`
AC_DEFINE([HAVE_PIPEWIRE],[1], [Define to enable PipeWire support]) + pkg_cv_PIPEWIRE_CFLAGS=`$PKG_CONFIG --cflags "libpipewire-0.2 >= 0.2.2" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
@@ -15533,12 +15533,12 @@ if test -n "$PIPEWIRE_LIBS"; then
pkg_cv_PIPEWIRE_LIBS="$PIPEWIRE_LIBS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libpipewire-0.1 >= 0.1.8\""; } >&5
- ($PKG_CONFIG --exists --print-errors "libpipewire-0.1 >= 0.1.8") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libpipewire-0.2 >= 0.2.2\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "libpipewire-0.2 >= 0.2.2") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_PIPEWIRE_LIBS=`$PKG_CONFIG --libs "libpipewire-0.1 >= 0.1.8" 2>/dev/null`
+ pkg_cv_PIPEWIRE_LIBS=`$PKG_CONFIG --libs "libpipewire-0.2 >= 0.2.2" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
@@ -15559,14 +15559,14 @@ else
_pkg_short_errors_supported=no
fi fi
AM_CONDITIONAL([HAVE_PIPEWIRE],[test "$enable_pipewire" = "yes"]) if test $_pkg_short_errors_supported = yes; then
- PIPEWIRE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libpipewire-0.1 >= 0.1.8" 2>&1`
+ PIPEWIRE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libpipewire-0.2 >= 0.2.2" 2>&1`
else
- PIPEWIRE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libpipewire-0.1 >= 0.1.8" 2>&1`
+ PIPEWIRE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libpipewire-0.2 >= 0.2.2" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$PIPEWIRE_PKG_ERRORS" >&5
- as_fn_error $? "Package requirements (libpipewire-0.1 >= 0.1.8) were not met:
+ as_fn_error $? "Package requirements (libpipewire-0.2 >= 0.2.2) were not met:
$PIPEWIRE_PKG_ERRORS