Update to 1.5.0
This commit is contained in:
parent
dc245b55ca
commit
1468862de7
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@
|
|||||||
/xdg-desktop-portal-gtk-1.1.1.tar.xz
|
/xdg-desktop-portal-gtk-1.1.1.tar.xz
|
||||||
/xdg-desktop-portal-gtk-1.2.0.tar.xz
|
/xdg-desktop-portal-gtk-1.2.0.tar.xz
|
||||||
/xdg-desktop-portal-gtk-1.4.0.tar.xz
|
/xdg-desktop-portal-gtk-1.4.0.tar.xz
|
||||||
|
/xdg-desktop-portal-gtk-1.5.0.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (xdg-desktop-portal-gtk-1.4.0.tar.xz) = 200fa490c486fbd61279cd6786b55b7ae85d88026d13b3d2d337d69d5d0c0f56babc9c0a8217b26e4771cd8d77c05871b9689e42b170a413083c4004d62db9ed
|
SHA512 (xdg-desktop-portal-gtk-1.5.0.tar.xz) = 44e16161edac74a0a870a1dfa15eaad14eaa778abbaa48c11bb690b73fb250b3fd9326f7caf8cb797b4a7c3fa945adf3dee8c328631b1589e46773e3fd8f227b
|
||||||
|
26
xdg-desktop-portal-gtk-1.5.0-fix-build-libx11.patch
Normal file
26
xdg-desktop-portal-gtk-1.5.0-fix-build-libx11.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From a2dd7a680cdec4b804beaf22482ece03fc49efcb Mon Sep 17 00:00:00 2001
|
||||||
|
From: David King <dking@redhat.com>
|
||||||
|
Date: Fri, 4 Oct 2019 20:58:07 +0100
|
||||||
|
Subject: [PATCH] build: require x11 for remote display monitor
|
||||||
|
|
||||||
|
---
|
||||||
|
configure.ac | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 88a9cba..d2b4d54 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -57,7 +57,8 @@ AC_SUBST([DBUS_INTERFACES_DIR], [`$PKG_CONFIG --variable=interfaces_dir dbus-1`]
|
||||||
|
AC_SUBST([GDBUS_CODEGEN], [`$PKG_CONFIG --variable gdbus_codegen gio-2.0`])
|
||||||
|
AC_SUBST([GLIB_COMPILE_RESOURCES], [`$PKG_CONFIG --variable glib_compile_resources gio-2.0`])
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(GTK, [xdg-desktop-portal >= 1.0 glib-2.0 >= 2.44 gio-unix-2.0 gtk+-3.0 >= 3.14 gtk+-unix-print-3.0 fontconfig])
|
||||||
|
+PKG_CHECK_MODULES(GTK, [xdg-desktop-portal >= 1.0 glib-2.0 >= 2.44 gio-unix-2.0
|
||||||
|
+gtk+-3.0 >= 3.14 gtk+-unix-print-3.0 fontconfig x11])
|
||||||
|
AC_SUBST(GTK_CFLAGS)
|
||||||
|
AC_SUBST(GTK_LIBS)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.23.0
|
||||||
|
|
@ -1,20 +1,24 @@
|
|||||||
%global xdg_desktop_portal_version 1.1.1
|
%global xdg_desktop_portal_version 1.1.1
|
||||||
|
|
||||||
Name: xdg-desktop-portal-gtk
|
Name: xdg-desktop-portal-gtk
|
||||||
Version: 1.4.0
|
Version: 1.5.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Backend implementation for xdg-desktop-portal using GTK+
|
Summary: Backend implementation for xdg-desktop-portal using GTK+
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/flatpak/%{name}
|
URL: https://github.com/flatpak/%{name}
|
||||||
Source0: https://github.com/flatpak/%{name}/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/flatpak/%{name}/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
|
Patch0: xdg-desktop-portal-gtk-1.5.0-fix-build-libx11.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
|
BuildRequires: pkgconfig(fontconfig)
|
||||||
BuildRequires: pkgconfig(gtk+-unix-print-3.0)
|
BuildRequires: pkgconfig(gtk+-unix-print-3.0)
|
||||||
BuildRequires: pkgconfig(xdg-desktop-portal) >= %{xdg_desktop_portal_version}
|
BuildRequires: pkgconfig(xdg-desktop-portal) >= %{xdg_desktop_portal_version}
|
||||||
%{?systemd_requires}
|
%{?systemd_requires}
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
|
# For Patch0.
|
||||||
|
BuildRequires: autoconf automake gettext-devel libtool
|
||||||
Requires: dbus
|
Requires: dbus
|
||||||
Requires: xdg-desktop-portal >= %{xdg_desktop_portal_version}
|
Requires: xdg-desktop-portal >= %{xdg_desktop_portal_version}
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
@ -29,10 +33,11 @@ org.gnome.SessionManager D-Bus interfaces.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoreconf --force --install
|
||||||
%configure --disable-silent-rules
|
%configure --disable-silent-rules
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
@ -61,6 +66,9 @@ org.gnome.SessionManager D-Bus interfaces.
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 04 2019 David King <amigadave@amigadave.com> - 1.5.0-1
|
||||||
|
- Update to 1.5.0
|
||||||
|
|
||||||
* Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 1.4.0-1
|
* Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 1.4.0-1
|
||||||
- Update to 1.4.0
|
- Update to 1.4.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user