diff --git a/.gitignore b/.gitignore
index 8903676..7aafb65 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
-xbean-3.7.tar.xz
+/results_*
+/*.src.rpm
+
+/xbean-3.7.tar.xz
/xbean-3.8.tar.xz
/xbean-3.11.1.tar.xz
/xbean-3.13-source-release.zip
diff --git a/xbean.spec b/xbean.spec
index 7cc45a5..b6f1249 100644
--- a/xbean.spec
+++ b/xbean.spec
@@ -1,25 +1,25 @@
-# Conditionals to help breaking eclipse <-> xbean dependency cycle
-# when bootstrapping for new architectures
-%bcond_with equinox
-%bcond_without groovy
-%bcond_without spring
+%bcond_with equinox
+%bcond_with groovy
+%bcond_with spring
Name: xbean
-Version: 4.9
-Release: 4%{?dist}
Summary: Java plugin based web server
+Version: 4.9
+Release: 5%{?dist}
License: ASL 2.0
-URL: http://geronimo.apache.org/xbean/
-BuildArch: noarch
+URL: http://geronimo.apache.org/xbean/
Source0: http://repo2.maven.org/maven2/org/apache/%{name}/%{name}/%{version}/%{name}-%{version}-source-release.zip
# Compatibility with Eclipse Luna (rhbz#1087461)
Patch1: 0002-Port-to-Eclipse-Luna-OSGi.patch
Patch2: 0003-Port-to-QDox-2.0.patch
+BuildArch: noarch
+
BuildRequires: maven-local
BuildRequires: mvn(commons-logging:commons-logging-api)
+BuildRequires: mvn(junit:junit)
BuildRequires: mvn(log4j:log4j:1.2.12)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
@@ -63,15 +63,14 @@ support for running with no IoC system, JMX without JMX code,
lifecycle and class loader management, and a rock solid Spring
integration.
+
%if %{with spring}
-# For now blueprint module fails to compile. Disable it.
-%if 0
+# blueprint module fails to compile
%package blueprint
Summary: Schema-driven namespace handler for Apache Aries Blueprint
%description blueprint
This package provides %{summary}.
-%endif
%package classloader
Summary: A flexibie multi-parent classloader
@@ -93,12 +92,14 @@ Summary: XBean plugin for Apache Maven
This package provides %{summary}.
%endif
+
%package javadoc
Summary: API documentation for %{name}
%description javadoc
This package provides %{summary}.
+
%prep
%setup -q
# build failing on this due to doxia-sitetools problems
@@ -157,21 +158,22 @@ sed -i 's/org\.apache\.xbean\.asm6/org.objectweb.asm/g' `find xbean-reflect -nam
sed -i "s|||" xbean-blueprint/pom.xml
+
%build
-%mvn_build -f
+%mvn_build
+
%install
%mvn_install
+
%files -f .mfiles
%doc LICENSE NOTICE
%dir %{_javadir}/%{name}
%if %{with spring}
-%if 0
%files blueprint -f .mfiles-blueprint
%doc LICENSE NOTICE %{name}-blueprint/target/restaurant.xsd*
-%endif
%files classloader -f .mfiles-classloader
%doc LICENSE NOTICE
@@ -186,7 +188,11 @@ sed -i "s|||" xbean-blueprint/pom.xml
%files javadoc -f .mfiles-javadoc
%doc LICENSE NOTICE
+
%changelog
+* Sun Jul 28 2019 Fabio Valentini - 4.9-5
+- Disable support for spring and groovy.
+
* Sat Jul 27 2019 Fedora Release Engineering - 4.9-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
@@ -369,3 +375,4 @@ sed -i "s|||" xbean-blueprint/pom.xml
* Mon Jun 21 2010 Stanislav Ochotnicky - 3.7-1
- First release
+