- updated to 3.5ga8 (#1335153)
This commit is contained in:
parent
d48cd63bcc
commit
4bf03f13db
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ suite3270-3.3.10ga4-src.tgz
|
|||||||
/suite3270-3.3.15ga7-src.tgz
|
/suite3270-3.3.15ga7-src.tgz
|
||||||
/suite3270-3.3.15ga8-src.tgz
|
/suite3270-3.3.15ga8-src.tgz
|
||||||
/suite3270-3.3.15ga9-src.tgz
|
/suite3270-3.3.15ga9-src.tgz
|
||||||
|
/suite3270-3.5ga8-src.tgz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
e8106ab4240d996bd2cea53df14634ae suite3270-3.3.15ga9-src.tgz
|
4fa6a20c899d233e0778c0ab6fdd0f85 suite3270-3.5ga8-src.tgz
|
||||||
|
@ -1,18 +0,0 @@
|
|||||||
diff -up x3270-3.3.10ga4/x3270-3.3/Examples/peer_script.expect.expectpath x3270-3.3.10ga4/x3270-3.3/Examples/peer_script.expect
|
|
||||||
--- x3270-3.3.10ga4/x3270-3.3/Examples/peer_script.expect.expectpath 2009-12-04 13:56:39.000000000 +0100
|
|
||||||
+++ x3270-3.3.10ga4/x3270-3.3/Examples/peer_script.expect 2009-12-04 13:56:44.000000000 +0100
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#! /usr/local/bin/expect
|
|
||||||
+#! /usr/bin/expect
|
|
||||||
# TSO login script, which runs as a peer of x3270.
|
|
||||||
# expect version
|
|
||||||
|
|
||||||
diff -up x3270-3.3.10ga4/x3270-3.3/Examples/cms_logon.bash.bashpath x3270-3.3.10ga4/x3270-3.3/Examples/cms_logon.bash
|
|
||||||
--- x3270-3.3.10ga4/x3270-3.3/Examples/cms_logon.bash.bashpath 2009-12-04 13:58:21.000000000 +0100
|
|
||||||
+++ x3270-3.3.10ga4/x3270-3.3/Examples/cms_logon.bash 2009-12-04 13:59:25.000000000 +0100
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#! /usr/local/bin/bash
|
|
||||||
+#! /bin/bash
|
|
||||||
|
|
||||||
# Copyright (c) 1995-2009, Paul Mattes.
|
|
||||||
# All rights reserved.
|
|
@ -1,166 +0,0 @@
|
|||||||
diff -up x3270-3.3.13ga6/c3270-3.3/c3270.man.ibmhosts x3270-3.3.13ga6/c3270-3.3/c3270.man
|
|
||||||
--- x3270-3.3.13ga6/c3270-3.3/c3270.man.ibmhosts 2013-09-08 03:01:54.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/c3270-3.3/c3270.man 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -3386,7 +3386,7 @@ backslash character.
|
|
||||||
If more than one \fB\-xrm\fP option is given for the same resource,
|
|
||||||
the last one on the command line is used.
|
|
||||||
.SH "FILES"
|
|
||||||
-/usr/local/lib/x3270/ibm_hosts
|
|
||||||
+/etc/ibm_hosts
|
|
||||||
.br
|
|
||||||
$HOME/.c3270pro
|
|
||||||
|
|
||||||
diff -up x3270-3.3.13ga6/c3270-3.3/host.c.ibmhosts x3270-3.3.13ga6/c3270-3.3/host.c
|
|
||||||
--- x3270-3.3.13ga6/c3270-3.3/host.c.ibmhosts 2013-07-12 00:03:24.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/c3270-3.3/host.c 2013-09-10 16:41:13.000000000 +0200
|
|
||||||
@@ -130,7 +130,7 @@ hostfile_init(void)
|
|
||||||
hostfile_initted = True;
|
|
||||||
hostfile_name = appres.hostsfile;
|
|
||||||
if (hostfile_name == CN)
|
|
||||||
- hostfile_name = xs_buffer("%s/ibm_hosts", appres.conf_dir);
|
|
||||||
+ hostfile_name = xs_buffer("%s/ibm_hosts", "/etc");
|
|
||||||
else
|
|
||||||
hostfile_name = do_subst(appres.hostsfile, DS_VARS | DS_TILDE);
|
|
||||||
hf = fopen(hostfile_name, "r");
|
|
||||||
diff -up x3270-3.3.13ga6/c3270-3.3/Makefile.in.ibmhosts x3270-3.3.13ga6/c3270-3.3/Makefile.in
|
|
||||||
--- x3270-3.3.13ga6/c3270-3.3/Makefile.in.ibmhosts 2013-07-12 00:03:25.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/c3270-3.3/Makefile.in 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -94,10 +94,10 @@ install:: c3270 x3270if
|
|
||||||
$(INSTALL_PROGRAM) c3270 $(DESTDIR)$(BINDIR)/c3270
|
|
||||||
$(INSTALL_PROGRAM) x3270if $(DESTDIR)$(BINDIR)/x3270if
|
|
||||||
install::
|
|
||||||
- [ -d $(DESTDIR)$(LIBX3270DIR) ] || \
|
|
||||||
- mkdir -p $(DESTDIR)$(LIBX3270DIR)
|
|
||||||
- [ -r $(DESTDIR)$(LIBX3270DIR)/ibm_hosts ] || \
|
|
||||||
- $(INSTALL_DATA) ibm_hosts $(DESTDIR)$(LIBX3270DIR)/ibm_hosts
|
|
||||||
+ [ -d $(DESTDIR)/etc ] || \
|
|
||||||
+ mkdir -p $(DESTDIR)/etc
|
|
||||||
+ [ -r $(DESTDIR)/etc/ibm_hosts ] || \
|
|
||||||
+ $(INSTALL_DATA) ibm_hosts $(DESTDIR)/etc/ibm_hosts
|
|
||||||
@PR@install::
|
|
||||||
|
|
||||||
install.man:
|
|
||||||
diff -up x3270-3.3.13ga6/s3270-3.3/host.c.ibmhosts x3270-3.3.13ga6/s3270-3.3/host.c
|
|
||||||
--- x3270-3.3.13ga6/s3270-3.3/host.c.ibmhosts 2013-07-12 00:03:24.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/s3270-3.3/host.c 2013-09-10 16:41:23.000000000 +0200
|
|
||||||
@@ -130,7 +130,7 @@ hostfile_init(void)
|
|
||||||
hostfile_initted = True;
|
|
||||||
hostfile_name = appres.hostsfile;
|
|
||||||
if (hostfile_name == CN)
|
|
||||||
- hostfile_name = xs_buffer("%s/ibm_hosts", appres.conf_dir);
|
|
||||||
+ hostfile_name = xs_buffer("%s/ibm_hosts", "/etc");
|
|
||||||
else
|
|
||||||
hostfile_name = do_subst(appres.hostsfile, DS_VARS | DS_TILDE);
|
|
||||||
hf = fopen(hostfile_name, "r");
|
|
||||||
diff -up x3270-3.3.13ga6/s3270-3.3/s3270.man.ibmhosts x3270-3.3.13ga6/s3270-3.3/s3270.man
|
|
||||||
--- x3270-3.3.13ga6/s3270-3.3/s3270.man.ibmhosts 2013-09-08 03:01:52.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/s3270-3.3/s3270.man 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -2103,7 +2103,7 @@ the \fBtraceDir\fP resource.
|
|
||||||
If more than one \fB\-xrm\fP option is given for the same resource,
|
|
||||||
the last one on the command line is used.
|
|
||||||
.SH "FILES"
|
|
||||||
-/usr/local/lib/x3270/ibm_hosts
|
|
||||||
+/etc/ibm_hosts
|
|
||||||
.br
|
|
||||||
|
|
||||||
.SH "SEE ALSO"
|
|
||||||
diff -up x3270-3.3.13ga6/s3270-3.3/X3270.xad.ibmhosts x3270-3.3.13ga6/s3270-3.3/X3270.xad
|
|
||||||
--- x3270-3.3.13ga6/s3270-3.3/X3270.xad.ibmhosts 2013-09-06 22:52:05.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/s3270-3.3/X3270.xad 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -221,7 +221,7 @@ x3270.charsetList: U.S. English (CP 03
|
|
||||||
! x3270.doConfirms: true
|
|
||||||
! x3270.debugTracing: true
|
|
||||||
! x3270.disconnectClear: false
|
|
||||||
-! x3270.hostsFile: /usr/lib/X11/x3270/ibm_hosts
|
|
||||||
+! x3270.hostsFile: /etc/ibm_hosts
|
|
||||||
! x3270.highlightSelect: true
|
|
||||||
! x3270.idleCommand:
|
|
||||||
! x3270.idleTimeout: ~7m
|
|
||||||
diff -up x3270-3.3.13ga6/x3270-3.3/ibm_hosts.man.ibmhosts x3270-3.3.13ga6/x3270-3.3/ibm_hosts.man
|
|
||||||
--- x3270-3.3.13ga6/x3270-3.3/ibm_hosts.man.ibmhosts 2013-09-08 03:01:49.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/x3270-3.3/ibm_hosts.man 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -3,7 +3,7 @@
|
|
||||||
.SH "NAME"
|
|
||||||
ibm_hosts \- host database for x3270 and c3270
|
|
||||||
.SH "SYNOPSIS"
|
|
||||||
-/usr/lib/X11/x3270/ibm_hosts
|
|
||||||
+/etc/ibm_hosts
|
|
||||||
.SH "DESCRIPTION"
|
|
||||||
The \fBibm_hosts\fP
|
|
||||||
file contains information regarding IBM hosts on the network.
|
|
||||||
@@ -82,7 +82,7 @@ The name \fBvm\fP will cause the 3270 em
|
|
||||||
enter the string `3' on the second data-entry field on the screen, and
|
|
||||||
send the Enter \s-1AID\s+1 sequence.
|
|
||||||
.SH "FILES"
|
|
||||||
-/usr/lib/X11/x3270/ibm_hosts
|
|
||||||
+/etc/ibm_hosts
|
|
||||||
.SH "SEE ALSO"
|
|
||||||
x3270(1),
|
|
||||||
c3270(1)
|
|
||||||
diff -up x3270-3.3.13ga6/x3270-3.3/Imakefile.in.ibmhosts x3270-3.3.13ga6/x3270-3.3/Imakefile.in
|
|
||||||
--- x3270-3.3.13ga6/x3270-3.3/Imakefile.in.ibmhosts 2013-07-12 00:03:27.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/x3270-3.3/Imakefile.in 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -191,8 +191,8 @@ $(DESTDIR)$(FONTINSTDIR)/fonts.dir::
|
|
||||||
/* Extra install rule for the sample ibm_hosts file (runs only if there is
|
|
||||||
no ibm_hosts file installed yet). */
|
|
||||||
install:: $(HOSTSFILE)
|
|
||||||
- @[ -r $(DESTDIR)$(LIBX3270DIR)/$(HOSTSFILE) ] || \
|
|
||||||
- $(INSTALL) -c $(INSTDATFLAGS) $(HOSTSFILE) $(DESTDIR)$(LIBX3270DIR)/$(HOSTSFILE)
|
|
||||||
+ @[ -r $(DESTDIR)/etc/$(HOSTSFILE) ] || \
|
|
||||||
+ $(INSTALL) -c $(INSTDATFLAGS) $(HOSTSFILE) $(DESTDIR)/etc/$(HOSTSFILE)
|
|
||||||
|
|
||||||
/*
|
|
||||||
* Install rules for x3270if, x3270-script and ibm_hosts man pages.
|
|
||||||
@@ -221,8 +221,8 @@ install.byprefix::
|
|
||||||
$(MKFONTDIR) $(DESTDIR)$(autoconf_fontinstdir)
|
|
||||||
chmod u=rwx,go=rx $(DESTDIR)$(autoconf_fontinstdir)
|
|
||||||
chmod a=r $(DESTDIR)$(autoconf_fontinstdir)/fonts.dir
|
|
||||||
- @[ -r $(DESTDIR)$(LIBX3270DIR)/$(HOSTSFILE) ] || \
|
|
||||||
- (set -x; $(INSTALL) -c $(INSTDATFLAGS) $(HOSTSFILE) $(DESTDIR)$(LIBX3270DIR)/$(HOSTSFILE))
|
|
||||||
+ @[ -r $(DESTDIR)/etc/$(HOSTSFILE) ] || \
|
|
||||||
+ (set -x; $(INSTALL) -c $(INSTDATFLAGS) $(HOSTSFILE) $(DESTDIR)/etc/$(HOSTSFILE))
|
|
||||||
|
|
||||||
/******************************************************************************
|
|
||||||
* Clean rules. *
|
|
||||||
diff -up x3270-3.3.13ga6/x3270-3.3/Makefile.in.ibmhosts x3270-3.3.13ga6/x3270-3.3/Makefile.in
|
|
||||||
--- x3270-3.3.13ga6/x3270-3.3/Makefile.in.ibmhosts 2013-07-12 00:03:27.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/x3270-3.3/Makefile.in 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -128,10 +128,10 @@ install:: x3270 x3270if
|
|
||||||
$(INSTALL_PROGRAM) x3270 $(DESTDIR)$(BINDIR)/x3270
|
|
||||||
$(INSTALL_PROGRAM) x3270if $(DESTDIR)$(BINDIR)/x3270if
|
|
||||||
install::
|
|
||||||
- [ -d $(DESTDIR)$(LIBX3270DIR) ] || \
|
|
||||||
- mkdir -p $(DESTDIR)$(LIBX3270DIR)
|
|
||||||
- [ -r $(DESTDIR)$(LIBX3270DIR)/ibm_hosts ] || \
|
|
||||||
- $(INSTALL_DATA) ibm_hosts $(DESTDIR)$(LIBX3270DIR)/ibm_hosts
|
|
||||||
+ [ -d $(DESTDIR)/etc ] || \
|
|
||||||
+ mkdir -p $(DESTDIR)/etc
|
|
||||||
+ [ -r $(DESTDIR)/etc/ibm_hosts ] || \
|
|
||||||
+ $(INSTALL_DATA) ibm_hosts $(DESTDIR)/etc/ibm_hosts
|
|
||||||
install::
|
|
||||||
[ -d $(DESTDIR)$(CIFONTDIR) ] || \
|
|
||||||
mkdir -p $(DESTDIR)$(CIFONTDIR)
|
|
||||||
diff -up x3270-3.3.13ga6/x3270-3.3/x3270.man.ibmhosts x3270-3.3.13ga6/x3270-3.3/x3270.man
|
|
||||||
--- x3270-3.3.13ga6/x3270-3.3/x3270.man.ibmhosts 2013-09-08 03:01:49.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/x3270-3.3/x3270.man 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -5102,7 +5102,7 @@ T}
|
|
||||||
The special types \fBsocks4a\fP and \fBsocks5d\fP can also be used to force
|
|
||||||
the proxy server to do the hostname resolution for the SOCKS protocol.
|
|
||||||
.SH "FILES"
|
|
||||||
-/usr/lib/X11/x3270/ibm_hosts
|
|
||||||
+/etc/ibm_hosts
|
|
||||||
.br
|
|
||||||
$HOME/.x3270pro
|
|
||||||
|
|
||||||
diff -up x3270-3.3.13ga6/x3270-3.3/X3270.xad.ibmhosts x3270-3.3.13ga6/x3270-3.3/X3270.xad
|
|
||||||
--- x3270-3.3.13ga6/x3270-3.3/X3270.xad.ibmhosts 2013-09-06 22:52:05.000000000 +0200
|
|
||||||
+++ x3270-3.3.13ga6/x3270-3.3/X3270.xad 2013-09-10 16:40:57.000000000 +0200
|
|
||||||
@@ -221,7 +221,7 @@ x3270.charsetList: U.S. English (CP 03
|
|
||||||
! x3270.doConfirms: true
|
|
||||||
! x3270.debugTracing: true
|
|
||||||
! x3270.disconnectClear: false
|
|
||||||
-! x3270.hostsFile: /usr/lib/X11/x3270/ibm_hosts
|
|
||||||
+! x3270.hostsFile: /etc/ibm_hosts
|
|
||||||
! x3270.highlightSelect: true
|
|
||||||
! x3270.idleCommand:
|
|
||||||
! x3270.idleTimeout: ~7m
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -up x3270-3.3.15ga8/s3270-3.3/Makefile.in.rule x3270-3.3.15ga8/s3270-3.3/Makefile.in
|
|
||||||
--- x3270-3.3.15ga8/s3270-3.3/Makefile.in.rule 2015-06-19 22:51:14.000000000 +0200
|
|
||||||
+++ x3270-3.3.15ga8/s3270-3.3/Makefile.in 2015-06-19 23:00:44.000000000 +0200
|
|
||||||
@@ -78,8 +78,8 @@ fallbacks.c: mkfb X3270.xad
|
|
||||||
|
|
||||||
s3270: $(OBJS1)
|
|
||||||
$(CC) -o $@ $(OBJS1) $(LDFLAGS) $(LIBS)
|
|
||||||
-x3270if: x3270if.c
|
|
||||||
- $(CC) -o $@ x3270if.c $(LDFLAGS) $(LIBS)
|
|
||||||
+x3270if: x3270if.o
|
|
||||||
+ $(CC) -o $@ x3270if.o $(LDFLAGS) $(LIBS)
|
|
||||||
|
|
||||||
install:: s3270 x3270if
|
|
||||||
[ -d $(DESTDIR)$(BINDIR) ] || \
|
|
66
x3270-3.5-ibmhostpath.patch
Normal file
66
x3270-3.5-ibmhostpath.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
diff -up suite3270-3.5/c3270/c3270.man.ibmhosts suite3270-3.5/c3270/c3270.man
|
||||||
|
--- suite3270-3.5/c3270/c3270.man.ibmhosts 2016-05-16 10:54:55.000000000 +0200
|
||||||
|
+++ suite3270-3.5/c3270/c3270.man 2016-05-16 10:55:03.000000000 +0200
|
||||||
|
@@ -3403,7 +3403,7 @@ backslash character.
|
||||||
|
If more than one \fB\-xrm\fP option is given for the same resource,
|
||||||
|
the last one on the command line is used.
|
||||||
|
.SH "FILES"
|
||||||
|
-/usr/local/lib/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.br
|
||||||
|
$HOME/.c3270pro
|
||||||
|
|
||||||
|
diff -up suite3270-3.5/c3270/ibm_hosts.man.ibmhosts suite3270-3.5/c3270/ibm_hosts.man
|
||||||
|
--- suite3270-3.5/c3270/ibm_hosts.man.ibmhosts 2016-05-16 10:53:16.000000000 +0200
|
||||||
|
+++ suite3270-3.5/c3270/ibm_hosts.man 2016-05-16 10:53:38.000000000 +0200
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
.SH "NAME"
|
||||||
|
ibm_hosts \- host database for x3270 and c3270
|
||||||
|
.SH "SYNOPSIS"
|
||||||
|
-/usr/lib/X11/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.SH "DESCRIPTION"
|
||||||
|
The \fBibm_hosts\fP
|
||||||
|
file contains information regarding IBM hosts on the network.
|
||||||
|
@@ -82,7 +82,7 @@ The name \fBvm\fP will cause the 3270 em
|
||||||
|
enter the string `3' on the second data-entry field on the screen, and
|
||||||
|
send the Enter \s-1AID\s+1 sequence.
|
||||||
|
.SH "FILES"
|
||||||
|
-/usr/lib/X11/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.SH "SEE ALSO"
|
||||||
|
x3270(1),
|
||||||
|
c3270(1)
|
||||||
|
diff -up suite3270-3.5/x3270/ibm_hosts.man.ibmhosts suite3270-3.5/x3270/ibm_hosts.man
|
||||||
|
--- suite3270-3.5/x3270/ibm_hosts.man.ibmhosts 2016-05-16 10:54:26.000000000 +0200
|
||||||
|
+++ suite3270-3.5/x3270/ibm_hosts.man 2016-05-16 10:54:40.000000000 +0200
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
.SH "NAME"
|
||||||
|
ibm_hosts \- host database for x3270 and c3270
|
||||||
|
.SH "SYNOPSIS"
|
||||||
|
-/usr/lib/X11/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.SH "DESCRIPTION"
|
||||||
|
The \fBibm_hosts\fP
|
||||||
|
file contains information regarding IBM hosts on the network.
|
||||||
|
@@ -82,7 +82,7 @@ The name \fBvm\fP will cause the 3270 em
|
||||||
|
enter the string `3' on the second data-entry field on the screen, and
|
||||||
|
send the Enter \s-1AID\s+1 sequence.
|
||||||
|
.SH "FILES"
|
||||||
|
-/usr/lib/X11/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.SH "SEE ALSO"
|
||||||
|
x3270(1),
|
||||||
|
c3270(1)
|
||||||
|
diff -up suite3270-3.5/x3270/x3270.man.ibmhosts suite3270-3.5/x3270/x3270.man
|
||||||
|
--- suite3270-3.5/x3270/x3270.man.ibmhosts 2016-05-16 10:53:50.000000000 +0200
|
||||||
|
+++ suite3270-3.5/x3270/x3270.man 2016-05-16 10:54:00.000000000 +0200
|
||||||
|
@@ -5275,7 +5275,7 @@ T}
|
||||||
|
The special types \fBsocks4a\fP and \fBsocks5d\fP can also be used to force
|
||||||
|
the proxy server to do the hostname resolution for the SOCKS protocol.
|
||||||
|
.SH "FILES"
|
||||||
|
-/usr/lib/X11/x3270/ibm_hosts
|
||||||
|
+/etc/ibm_hosts
|
||||||
|
.br
|
||||||
|
$HOME/.x3270pro
|
||||||
|
|
18
x3270-3.5-paths.patch
Normal file
18
x3270-3.5-paths.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -up suite3270-3.5/x3270/Examples/cms_logon.bash.paths suite3270-3.5/x3270/Examples/cms_logon.bash
|
||||||
|
--- suite3270-3.5/x3270/Examples/cms_logon.bash.paths 2015-09-20 01:04:56.000000000 +0200
|
||||||
|
+++ suite3270-3.5/x3270/Examples/cms_logon.bash 2016-05-12 12:00:57.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/local/bin/bash
|
||||||
|
+#! /bin/bash
|
||||||
|
|
||||||
|
# Copyright (c) 1995-2009, Paul Mattes.
|
||||||
|
# All rights reserved.
|
||||||
|
diff -up suite3270-3.5/x3270/Examples/peer_script.expect.paths suite3270-3.5/x3270/Examples/peer_script.expect
|
||||||
|
--- suite3270-3.5/x3270/Examples/peer_script.expect.paths 2015-09-20 01:04:56.000000000 +0200
|
||||||
|
+++ suite3270-3.5/x3270/Examples/peer_script.expect 2016-05-12 12:00:57.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#! /usr/local/bin/expect
|
||||||
|
+#! /usr/bin/expect
|
||||||
|
# TSO login script, which runs as a peer of x3270.
|
||||||
|
# expect version
|
||||||
|
|
133
x3270.spec
133
x3270.spec
@ -1,29 +1,25 @@
|
|||||||
%global fontdir %{_datadir}/x3270/fonts
|
|
||||||
%global catalogue /etc/X11/fontpath.d
|
%global catalogue /etc/X11/fontpath.d
|
||||||
|
|
||||||
%global majorver 3.3
|
%global majorver 3.5
|
||||||
Summary: An X Window System based IBM 3278/3279 terminal emulator
|
Summary: An X Window System based IBM 3278/3279 terminal emulator
|
||||||
Name: x3270
|
Name: x3270
|
||||||
Version: 3.3.15ga9
|
Version: 3.5ga8
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
URL: http://x3270.sourceforge.net/
|
URL: http://x3270.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/suite3270-%{version}-src.tgz
|
Source0: http://downloads.sourceforge.net/%{name}/suite3270-%{version}-src.tgz
|
||||||
# c3270-3.3 pr3287-3.3 s3270-3.3 tcl3270-3.3 wc3270-3.3 wpr3287-3.3 ws3270-3.3 x3270-3.3
|
|
||||||
#
|
|
||||||
Source1: x3270.png
|
Source1: x3270.png
|
||||||
Source2: x3270.desktop
|
Source2: x3270.desktop
|
||||||
Patch0: x3270-3.3.10-paths.patch
|
Patch0: x3270-3.5-paths.patch
|
||||||
Patch1: x3270-3.3.13-ibmhostpath.patch
|
Patch1: x3270-3.5-ibmhostpath.patch
|
||||||
# update Makefile rule for x3270if in s3270
|
|
||||||
Patch2: x3270-3.3.15-rule.patch
|
|
||||||
|
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: fontpackages-devel
|
||||||
|
|
||||||
%package x11
|
%package x11
|
||||||
Summary: IBM 3278/3279 terminal emulator for the X Window System
|
Summary: IBM 3278/3279 terminal emulator for the X Window System
|
||||||
@ -67,140 +63,93 @@ Install the %{name}-text package if you need to access IBM hosts using an IBM
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -c
|
%setup -q -n suite3270-%{majorver}
|
||||||
# delete windows and tcl sources:
|
|
||||||
rm -rf wpr3287* wc3270* ws3270* tcl3270*
|
|
||||||
%patch0 -p1 -b .paths
|
%patch0 -p1 -b .paths
|
||||||
%patch1 -p1 -b .ibmhosts
|
%patch1 -p1 -b .ibmhosts
|
||||||
%patch2 -p1 -b .rule
|
|
||||||
|
|
||||||
# update for aarch64 (#926737)
|
for d in c3270 pr3287 s3270 x3270; do
|
||||||
for i in x3270-%{majorver} c3270-%{majorver} pr3287-%{majorver} s3270-%{majorver}; do
|
for f in LICENSE README html; do
|
||||||
( cd $i
|
mv $d/$f $f.$d
|
||||||
cp -p %{_datadir}/automake-*/config.{guess,sub} .
|
done
|
||||||
autoconf
|
|
||||||
)
|
|
||||||
done
|
done
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Fix end of line encodings
|
%configure --enable-x3270 --enable-c3270 --enable-s3270 --enable-pr3287
|
||||||
perl -pi -e "s/
|
make %{?_smp_mflags} CCOPTIONS="$RPM_OPT_FLAGS" LIBX3270DIR=%{_sysconfdir}
|
||||||
//" */html/Keymap.html */html/Build.html
|
|
||||||
# Set LIBX3270DIR to something we can share with x3270-text
|
|
||||||
perl -pi -e "s,LIBX3270DIR =.*,LIBX3270DIR = %{_datadir}/x3270,g" x3270-%{majorver}/Imakefile.in
|
|
||||||
# use rpmoptflags for x3270if
|
|
||||||
perl -pi -e 's/ -o x3270if x3270if.c/ \$(CCOPTIONS) -o x3270if x3270if.c/g' x3270-%{majorver}/Imakefile.in
|
|
||||||
|
|
||||||
for i in x3270-%{majorver} c3270-%{majorver} pr3287-%{majorver} s3270-%{majorver}; do
|
|
||||||
( cd $i
|
|
||||||
%configure --with-fontdir=%{fontdir} --x-includes=/usr/include/X11 --x-libraries=/%{_libdir}/X11 --enable-app-defaults
|
|
||||||
make %{?_smp_mflags} CCOPTIONS="$RPM_OPT_FLAGS"
|
|
||||||
)
|
|
||||||
done
|
|
||||||
|
|
||||||
# build playback tool
|
# build playback tool
|
||||||
( cd Playback; make CFLAGS="$RPM_OPT_FLAGS" )
|
( cd Playback; make CFLAGS="$RPM_OPT_FLAGS" )
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/x3270
|
make install DESTDIR=$RPM_BUILD_ROOT CIFONTDIR=%{_fontdir} LIBX3270DIR=%{_sysconfdir}
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
make install.man DESTDIR=$RPM_BUILD_ROOT
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/x3270
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{fontdir}
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/48x48/apps
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{catalogue}
|
mkdir -p $RPM_BUILD_ROOT%{catalogue}
|
||||||
|
ln -sf %{_fontdir} $RPM_BUILD_ROOT%{catalogue}/x3270
|
||||||
install -p -m755 x3270-%{majorver}/x3270 $RPM_BUILD_ROOT%{_bindir}
|
|
||||||
install -p -m755 x3270-%{majorver}/x3270if $RPM_BUILD_ROOT%{_bindir}
|
|
||||||
install -p -m644 x3270-%{majorver}/*pcf.gz $RPM_BUILD_ROOT%{fontdir}
|
|
||||||
install -p -m644 x3270-%{majorver}/ibm_hosts $RPM_BUILD_ROOT%{_sysconfdir}/
|
|
||||||
install -p -m644 x3270-%{majorver}/X3270.ad $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/X3270
|
|
||||||
install -p -m644 x3270-%{majorver}/x3270.man $RPM_BUILD_ROOT%{_mandir}/man1/x3270.1
|
|
||||||
install -p -m644 x3270-%{majorver}/x3270if.man $RPM_BUILD_ROOT%{_mandir}/man1/x3270if.1
|
|
||||||
install -p -m644 x3270-%{majorver}/x3270-script.man $RPM_BUILD_ROOT%{_mandir}/man1/x3270-script.1
|
|
||||||
install -p -m644 x3270-%{majorver}/ibm_hosts.man $RPM_BUILD_ROOT%{_mandir}/man5/ibm_hosts.5
|
|
||||||
|
|
||||||
install -p -m755 pr3287-%{majorver}/pr3287 $RPM_BUILD_ROOT%{_bindir}
|
|
||||||
install -p -m644 pr3287-%{majorver}/pr3287.man $RPM_BUILD_ROOT%{_mandir}/man1/pr3287.1x
|
|
||||||
|
|
||||||
install -p -m755 c3270-%{majorver}/c3270 $RPM_BUILD_ROOT%{_bindir}
|
|
||||||
install -p -m644 c3270-%{majorver}/c3270.man $RPM_BUILD_ROOT%{_mandir}/man1/c3270.1
|
|
||||||
|
|
||||||
install -p -m755 s3270-%{majorver}/s3270 $RPM_BUILD_ROOT%{_bindir}
|
|
||||||
install -p -m644 s3270-%{majorver}/s3270.man $RPM_BUILD_ROOT%{_mandir}/man1/s3270.1
|
|
||||||
|
|
||||||
install -p -m755 Playback/playback $RPM_BUILD_ROOT%{_bindir}
|
install -p -m755 Playback/playback $RPM_BUILD_ROOT%{_bindir}
|
||||||
install -p -m644 Playback/playback.man $RPM_BUILD_ROOT%{_mandir}/man1/playback.1
|
install -p -m644 Playback/playback.man $RPM_BUILD_ROOT%{_mandir}/man1/playback.1
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
|
||||||
install -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/icons/hicolor/48x48/apps
|
install -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/icons/hicolor/48x48/apps
|
||||||
ln -sf %{fontdir} $RPM_BUILD_ROOT%{catalogue}/x3270
|
|
||||||
mv x3270-%{majorver}/README* x3270-%{majorver}/LICENSE x3270-%{majorver}/Examples x3270-%{majorver}/html .
|
|
||||||
mv c3270-%{majorver}/README README.c3270
|
|
||||||
mv c3270-%{majorver}/html html_c3270
|
|
||||||
mv pr3287-%{majorver}/README README.pr3287
|
|
||||||
mv pr3287-%{majorver}/html html_pr3287
|
|
||||||
mv s3270-%{majorver}/README README.s3270
|
|
||||||
mv s3270-%{majorver}/html html_s3270
|
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications
|
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
--dir $RPM_BUILD_ROOT/%{_datadir}/applications \
|
--dir $RPM_BUILD_ROOT/%{_datadir}/applications \
|
||||||
%{SOURCE2}
|
%{SOURCE2}
|
||||||
|
|
||||||
rm -f */Examples/*.rh */Examples/*.orig
|
|
||||||
chmod -x Examples/* html*/*
|
|
||||||
|
|
||||||
|
|
||||||
%post x11
|
%post x11
|
||||||
cd %{fontdir} && %{_prefix}/bin/mkfontdir
|
cd %{_fontdir} && %{_prefix}/bin/mkfontdir
|
||||||
touch --no-create %{_datadir}/icons/hicolor
|
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
|
||||||
gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
|
||||||
fi
|
|
||||||
|
|
||||||
%postun x11
|
%postun x11
|
||||||
if [ "$1" = "0" ]; then
|
if [ "$1" -eq "0" ]; then
|
||||||
cd %{fontdir} && %{_prefix}/bin/mkfontdir
|
cd %{_fontdir} && %{_prefix}/bin/mkfontdir
|
||||||
fi
|
|
||||||
touch --no-create %{_datadir}/icons/hicolor
|
touch --no-create %{_datadir}/icons/hicolor
|
||||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
%posttrans x11
|
||||||
|
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README* LICENSE Examples html*
|
%doc LICENSE.s3270 README.s3270 html.s3270
|
||||||
|
%doc LICENSE.pr3287 README.pr3287 html.pr3287
|
||||||
%{_bindir}/s3270
|
%{_bindir}/s3270
|
||||||
%{_bindir}/pr3287
|
%{_bindir}/pr3287
|
||||||
%{_bindir}/x3270if
|
%{_bindir}/x3270if
|
||||||
%{_bindir}/playback
|
%{_bindir}/playback
|
||||||
%exclude %{_mandir}/man1/c3270.1*
|
%{_mandir}/man1/s3270.1*
|
||||||
%exclude %{_mandir}/man1/x3270.1*
|
%{_mandir}/man1/pr3287.1*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/x3270if.1*
|
||||||
%{_mandir}/man5/*
|
%{_mandir}/man1/x3270-script.1*
|
||||||
%dir %{_datadir}/x3270
|
%{_mandir}/man1/playback.1*
|
||||||
|
%{_mandir}/man5/ibm_hosts.5*
|
||||||
%config(noreplace) %{_sysconfdir}/ibm_hosts
|
%config(noreplace) %{_sysconfdir}/ibm_hosts
|
||||||
|
|
||||||
%files x11
|
%files x11
|
||||||
|
%doc LICENSE.x3270 README.x3270 html.x3270
|
||||||
%{_bindir}/x3270
|
%{_bindir}/x3270
|
||||||
%dir %{fontdir}
|
%{_fontdir}/
|
||||||
%{fontdir}/*
|
|
||||||
%{catalogue}/x3270
|
%{catalogue}/x3270
|
||||||
%{_mandir}/man1/x3270.1*
|
%{_mandir}/man1/x3270.1*
|
||||||
%{_datadir}/icons/hicolor/48x48/apps/x3270.png
|
%{_datadir}/icons/hicolor/48x48/apps/x3270.png
|
||||||
%{_datadir}/X11/app-defaults/X3270
|
%{_datadir}/applications/x3270.desktop
|
||||||
%{_datadir}/applications/*
|
|
||||||
|
|
||||||
%files text
|
%files text
|
||||||
|
%doc LICENSE.c3270 README.c3270 html.c3270
|
||||||
%{_bindir}/c3270
|
%{_bindir}/c3270
|
||||||
%{_mandir}/man1/c3270.1*
|
%{_mandir}/man1/c3270.1*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 16 2016 Dan Horák <dan[at]danny.cz> - 3.5ga8-1
|
||||||
|
- updated to 3.5ga8 (#1335153)
|
||||||
|
|
||||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.15ga9-2
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.15ga9-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user