Linked pthread in a Makefile to prevent build failures.
This commit is contained in:
parent
9dd9b23dc7
commit
a3578169be
12
missing-pthread-symbols.patch
Normal file
12
missing-pthread-symbols.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up wsmancli-2.1.0/examples/cpp/Makefile.in.old wsmancli-2.1.0/examples/cpp/Makefile.in
|
||||||
|
--- wsmancli-2.1.0/examples/cpp/Makefile.in.old 2009-11-06 10:29:49.000000000 -0600
|
||||||
|
+++ wsmancli-2.1.0/examples/cpp/Makefile.in 2009-11-06 10:29:20.000000000 -0600
|
||||||
|
@@ -158,7 +158,7 @@ target_alias = @target_alias@
|
||||||
|
top_builddir = @top_builddir@
|
||||||
|
top_srcdir = @top_srcdir@
|
||||||
|
LDADD = \
|
||||||
|
- -lwsman -lwsman_clientpp
|
||||||
|
+ -lwsman -lpthread -lwsman_clientpp
|
||||||
|
|
||||||
|
EnumInstance_SOURCES = \
|
||||||
|
EnumInstance.cpp
|
@ -1,6 +1,6 @@
|
|||||||
Name: wsmancli
|
Name: wsmancli
|
||||||
Version: 2.1.0
|
Version: 2.1.0
|
||||||
Release: 3%{dist}
|
Release: 4%{dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.openwsman.org/
|
Url: http://www.openwsman.org/
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||||
@ -8,6 +8,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
|||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
BuildRequires: openwsman-devel >= 2.1.0 pkgconfig curl-devel
|
BuildRequires: openwsman-devel >= 2.1.0 pkgconfig curl-devel
|
||||||
Requires: openwsman curl
|
Requires: openwsman curl
|
||||||
|
Patch0: missing-pthread-symbols.patch
|
||||||
Summary: WS-Management-Command line Interface
|
Summary: WS-Management-Command line Interface
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -16,6 +17,7 @@ systems using Web Services Management protocol.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-more-warnings
|
%configure --disable-more-warnings
|
||||||
@ -35,6 +37,8 @@ rm -rf %{buildroot}
|
|||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 6 2009 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.1.0-4
|
||||||
|
- Missing symbols from pthread library.
|
||||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
|
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user