import wsmancli-2.6.0-8.el8

This commit is contained in:
CentOS Sources 2019-08-01 12:27:48 -04:00 committed by Stepan Oksanichenko
commit 625677d16a
7 changed files with 381 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/wsmancli-2.6.0.tar.gz

1
.wsmancli.metadata Normal file
View File

@ -0,0 +1 @@
128159204ab22b58a67c92827ced67e70cd2e1f2 SOURCES/wsmancli-2.6.0.tar.gz

17
SOURCES/AUTHORS Normal file
View File

@ -0,0 +1,17 @@
Maintainer:
Anas Nashif, Intel Corp.
Developers:
Anas Nashif, Intel Corp.
Hou Liang, Intel Corp.
Code originally from:
Eugene Yarmosh, Intel Corp.
Contributions and Patches by:
Viktor Mihajlovski, IBM
Klaus Kaempf, Novell
If you think you name should be here and I forgot it, please let me know.

27
SOURCES/COPYING Normal file
View File

@ -0,0 +1,27 @@
Copyright (C) 2004-2006 Intel Corp. All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
- Neither the name of Intel Corp. nor the names of its
contributors may be used to endorse or promote products derived from this
software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS''
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL Intel Corp. OR THE CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

195
SOURCES/README Normal file
View File

@ -0,0 +1,195 @@
How to compile and run openwsman from Subversion?
===============================
After checking out the project from subversion run ./autoconfiscate in the TOP directory and
follow that by running ./configure <options>.
If you download a packaged version, then there is no need to run ./autoconfiscate and you will
be able to run ./configure directly.
Most likely you will need to install some of the packages, depending on the distribution
you are running.
Packages and other software needed:
- libxml2
- sfcc (from the sblim project)
- swig and python for python binding support
- other development packages like autoconf, automake etc.
After all packages are installed, compile everything and install. The server can run as
a daemon, which would require root access; But it can be run in the foreground with debugging
messages printed to stdout as well. This the help output when you run:
% /usr/local/sbin/openwsmand --help
Usage:
openwsmand [OPTION...] WS-Management Server
Help Options:
-?, --help Show help options
Application Options:
-n, --no-plugins Do not load any plugins
-d, --debug Start daemon in foreground and turn on debugging
-s, --syslog=0-6 Set the verbosity of syslog output.
-c, --config-file=<file> Alternate configuration file
Starting from version 0.1.1 a configuration file is needed. you can find an example in the
./etc directory. The configuration file has the following syntax:
[server]
port = 8889
#ssl_port = 8888
ssl_cert_file = /etc/openwsman/servercert.pem
ssl_key_file = /etc/openwsman/serverkey.pem
#digest_password_file = /etc/openwsman/digest_auth.passwd
basic_password_file = /etc/openwsman/simple_auth.passwd
enum_idle_timeout = 5000
min_threads = 1
max_threads = 1
#use_digest is OBSOLETED, see below.
#
# Authentication backend for BASIC authentication. Default is to read a configuration file defined with 'basic_password_file'
#
#basic_authenticator = libwsman_pam_auth.so
#basic_authenticator_arg = openwsman
[client]
port = 8889
agent = openwsman 1.5.9
[cim]
default_cim_namespace = root/cimv2
# The following are in part fake namespaces for some publicly available CIM implementations.
vendor_namespaces = OpenWBEM=http://schema.openwbem.org/wbem/wscim/1/cim-schema/2,Linux=http://sblim.sf.net/wbem/wscim/1/cim-schema/2,OMC=http://schema.omc-project.org/wbem/wscim/1/cim-schema/2,Reef=http://reef.sblim.sf.net/wbem/wscim/1/cim-schema/2,CWS=http://cws.sblim.sf.net/wbem/wscim/1/cim-schema/2
To be able to put the configuration files under /etc/openwsman, run the configure script
with the --sysconfdir option using the value /etc. If this option is not used, the default will
be under PREFIX (/usr/local/etc ).
To run in SSL mode you need to enable the SSL port and create certificates and adapt the configuration
with the correct path to the files.
To start the server in the foreground, run:
% /usr/local/sbin/openwsmand -d
You can also specify the configuration file to be used on the command line using the -c option.
On the client side, which has the following options
% /usr/local/bin/wsman --help-all
Usage:
wsman [Option...] <action> <Resource Uri>
Usage:
wsman [Option...] <action> <Resource Uri>
Help Options
-?, --help
--help-all Show help options
--help-enumeration Enumeration Options
--help-tests Test Cases
--help-cim CIM Options
--help-flags Request Flags
--help-event Subscription Options
Enumeration
-m, --max-elements=<max number of elements> Max Elements Per Pull/Optimized Enumeration
-o, --optimize Optimize enumeration results
-E, --estimate-count Return estimation of total items
-M, --enum-mode=epr|objepr Enumeration Mode
-U, --enum-context=<enum context> Enumeration Context (For use with Pull and Release)
Tests
-f, --from-file=<file name> Send request from file
-R, --print-request print request on stdout
-Q, --request Only output reqest. Not send it.
-S, --step Do not perform multiple operations (do not pull data when enumerating)
CIM
-N, --namespace=<namespace> CIM Namespace (default is root/cimv2)
-B, --binding-enum-mode=none|include|exclude CIM binding Enumeration Mode
-T, --cim-extensions Show CIM Extensions
-W, --references CIM References
-w, --associators CIM Associators
Flags
-x, --filter=<filter> Filter
-D, --dialect=<dialect> Filter Dialect
-t, --operation-timeout=<time in sec> Operation timeout in seconds
-e, --max-envelope-size=<size> maximal envelope size
-F, --fragment=<fragment> Fragment (Supported Dialects: XPATH)
Event subscription
-G, --delivery-mode=<mode> Four delivery modes available: push/pushwithack/events/pull
-Z, --notification-uri=<uri> Where notifications are sent
-r, --subscription-expiry-time=<seconds> subscription expiry time in seconds
-H, --heartbeat=<seconds> Send hearbeat in an interval
-l, --bookmark Send bookmark
-i, --subscription-identifier=<uuid:XXX> Used to specify which subscription
-L, --notify-reference-properties=<xs:anyURI> Notify Reference Properties
Application Options
-d, --debug=1-6 Set the verbosity of debugging output.
-c, --cacert=<filename> Certificate file to verify the peer
-A, --cert=<filename> Certificate file. The certificate must be in PEM format.
-K, --sslkey=<key> SSL Key.
-u, --username=<username> User name
-g, --path=<path> Path
-J, --input=<filename> File with resource for Create and Put operations in XML, can be a SOAP envelope
-p, --password=<password> Password
-h, --hostname=<hostname> Host name
-b, --endpoint=<url> End point
-P, --port=<port> Server Port
-X, --proxy=<proxy> Proxy name
-Y, --proxyauth=<proxyauth> Proxy user:pwd
-y, --auth=<basic|digest|gss> Authentication Method
-a, --method=<custom method> Method (Works only with 'invoke')
-k, --prop=<key=val> Properties with key value pairs (For 'put', 'invoke' and 'create')
-C, --config-file=<file> Alternate configuration file
-O, --out-file=<file> Write output to file
-V, --noverifypeer Not to verify peer certificate
-v, --noverifyhost Not to verify hostname
-I, --transport-timeout=<time in sec> Transport timeout in seconds
To create a password file, use the htpasswd and htdigest utilities from the apache distribution.
You can connect to the server with the following command, which is part of the DMTF WS-Management specification (Draft)
wsman identify -h <hostname> --port 8889 -u wsman --password secret
The above command should give the following result:
<?xml version="1.0" encoding="UTF-8"?>
<s:Envelope xmlns:s="http://www.w3.org/2003/05/soap-envelope" xmlns:wsmid="http://schemas.dmtf.org/wbem/wsman/identity/1/wsmanidentity.xsd">
<s:Header/>
<s:Body>
<wsmid:IdentifyResponse>
<wsmid:ProtocolVersion>http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd</wsmid:ProtocolVersion>
<wsmid:ProductVendor>openwsman</wsmid:ProductVendor>
<wsmid:ProductVersion>2.0.0</wsmid:ProductVersion>
</wsmid:IdentifyResponse>
</s:Body>
</s:Envelope>

View File

@ -0,0 +1,11 @@
diff -up wsmancli-2.3.1/examples/cpp/Makefile.am.orig wsmancli-2.3.1/examples/cpp/Makefile.am
--- wsmancli-2.3.1/examples/cpp/Makefile.am.orig 2014-02-26 12:09:41.686906501 +0100
+++ wsmancli-2.3.1/examples/cpp/Makefile.am 2014-02-26 12:10:09.731982919 +0100
@@ -1,6 +1,6 @@
LDADD = \
- $(OPENWSMAN_LIBS) -lwsman_clientpp
+ $(OPENWSMAN_LIBS) -lpthread -lwsman_clientpp
CXXFLAGS = \
$(OPENWSMAN_CFLAGS)

129
SPECS/wsmancli.spec Normal file
View File

@ -0,0 +1,129 @@
Name: wsmancli
Version: 2.6.0
Release: 8%{?dist}
License: BSD
Url: http://www.openwsman.org/
# You can get this tarball here:
# https://github.com/Openwsman/wsmancli/archive/v%{version}.tar.gz
Source: wsmancli-%{version}.tar.gz
Source1: COPYING
Source2: README
Source3: AUTHORS
BuildRequires: openwsman-devel >= 2.1.0 pkgconfig curl-devel
BuildRequires: autoconf automake libtool
Requires: openwsman curl
Patch0: missing-pthread-symbols.patch
Summary: WS-Management-Command line Interface
%description
Command line interface for managing
systems using Web Services Management protocol.
%prep
%setup -q
%patch0 -p1
cp -fp %SOURCE1 %SOURCE2 %SOURCE3 .;
%build
./bootstrap
%configure --disable-more-warnings
make %{?_smp_flags}
%install
make DESTDIR=%{buildroot} install
%files
%{_bindir}/wsman
%{_bindir}/wseventmgr
%{_mandir}/man1/wsman*
%{_mandir}/man1/wseventmgr*
%doc COPYING README AUTHORS
%changelog
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Oct 18 2017 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.6.0-6
- Fix the dist tag, remove Group
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Tue Jun 16 2015 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.6.0-1
- Update to wsmancli-2.6.0
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Mar 12 2014 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.3.1-1
- Update to wsmancli-2.3.1
* Thu Sep 19 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.3.0-4
- Rebuild because of soname change in openswman
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Nov 12 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.3.0-1
- Update to wsmancli-2.3.0
* Tue Sep 18 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7.1-3
- Fix issues found by fedora-review utility in the spec file
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Wed Jan 11 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7.1-1
- Update to wsmancli-2.2.7.1
* Wed Mar 23 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.5-1
- Update to wsmancli-2.2.5
* Tue Feb 22 2011 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.4-3
- Fix option issue on big endian architectures
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Nov 16 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.4-1
- Update to wsmancli-2.2.4
* Wed Mar 3 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.3-1
- Update to wsmancli-2.2.3
* Mon Jan 25 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.1.0-5
- Fix Source URL
- Use tarball from upstream
- Add COPYING, README and AUTHORS to sources (previously placed in the modified tarball)
* Fri Nov 6 2009 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.1.0-4
- Missing symbols from pthread library.
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Tue Sep 30 2008 <srinivas_ramanatha@dell.com> - 2.1.0-1%{?dist}
- Modified the spec file to adhere to fedora packaging guidelines.