887cbaee0a
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/wpa_supplicant#1ffda691c823c9a62d17671dbea9182bd2ebdc5a
42 lines
1.3 KiB
Diff
42 lines
1.3 KiB
Diff
From 9404f356e394604d1d3d6dbffc52abd54260e4d4 Mon Sep 17 00:00:00 2001
|
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
|
Date: Tue, 27 Oct 2015 08:56:35 +0100
|
|
Subject: [PATCH] wpa_supplicant: allow overriding the names of the Qt4 tools
|
|
|
|
This is useful for distributions that ship different versions of Qt in
|
|
different locations.
|
|
---
|
|
wpa_supplicant/Makefile | 7 +++++--
|
|
1 file changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/wpa_supplicant/Makefile b/wpa_supplicant/Makefile
|
|
index ad9ead9..b19676d 100644
|
|
--- a/wpa_supplicant/Makefile
|
|
+++ b/wpa_supplicant/Makefile
|
|
@@ -11,6 +11,9 @@ export INCDIR ?= /usr/local/include/
|
|
export BINDIR ?= /usr/local/sbin/
|
|
PKG_CONFIG ?= pkg-config
|
|
|
|
+QMAKE ?= qmake
|
|
+LRELEASE ?= lrelease
|
|
+
|
|
CFLAGS += $(EXTRA_CFLAGS)
|
|
CFLAGS += -I$(abspath ../src)
|
|
CFLAGS += -I$(abspath ../src/utils)
|
|
@@ -1787,10 +1790,10 @@ wpa_gui:
|
|
@echo "wpa_gui has been removed - see wpa_gui-qt4 for replacement"
|
|
|
|
wpa_gui-qt4/Makefile:
|
|
- qmake -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro
|
|
+ $(QMAKE) -o wpa_gui-qt4/Makefile wpa_gui-qt4/wpa_gui.pro
|
|
|
|
wpa_gui-qt4/lang/wpa_gui_de.qm: wpa_gui-qt4/lang/wpa_gui_de.ts
|
|
- lrelease wpa_gui-qt4/wpa_gui.pro
|
|
+ $(LRELEASE) wpa_gui-qt4/wpa_gui.pro
|
|
|
|
wpa_gui-qt4: wpa_gui-qt4/Makefile wpa_gui-qt4/lang/wpa_gui_de.qm
|
|
$(MAKE) -C wpa_gui-qt4
|
|
--
|
|
2.6.2
|
|
|