Update to 2.3
This commit is contained in:
parent
05ce9ccd8e
commit
237e32e034
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ wpa_supplicant-0.6.8.tar.gz
|
||||
/wpa_supplicant-1.0-rc2.tar.gz
|
||||
/wpa_supplicant-1.1.tar.gz
|
||||
/wpa_supplicant-2.0.tar.gz
|
||||
/wpa_supplicant-2.3.tar.gz
|
||||
|
@ -1,12 +1,13 @@
|
||||
diff -up wpa_supplicant-1.0-rc2/src/drivers/drivers.mak.foo wpa_supplicant-1.0-rc2/src/drivers/drivers.mak
|
||||
--- wpa_supplicant-1.0-rc2/src/drivers/drivers.mak.foo 2012-03-02 16:11:43.176448714 -0600
|
||||
+++ wpa_supplicant-1.0-rc2/src/drivers/drivers.mak 2012-03-02 16:12:29.759866341 -0600
|
||||
@@ -48,7 +48,7 @@ NEED_RFKILL=y
|
||||
diff --git a/src/drivers/drivers.mak b/src/drivers/drivers.mak
|
||||
index cdb913e..e9fc83c 100644
|
||||
--- a/src/drivers/drivers.mak
|
||||
+++ b/src/drivers/drivers.mak
|
||||
@@ -35,7 +35,7 @@ NEED_RFKILL=y
|
||||
ifdef CONFIG_LIBNL32
|
||||
DRV_LIBS += -lnl-3
|
||||
DRV_LIBS += -lnl-genl-3
|
||||
- DRV_CFLAGS += -DCONFIG_LIBNL20 -I/usr/include/libnl3
|
||||
+ DRV_CFLAGS += -DCONFIG_LIBNL20 `pkg-config --cflags libnl-3.0`
|
||||
else
|
||||
ifdef CONFIG_LIBNL_TINY
|
||||
DRV_LIBS += -lnl-tiny
|
||||
ifdef CONFIG_LIBNL3_ROUTE
|
||||
DRV_LIBS += -lnl-route-3
|
||||
DRV_CFLAGS += -DCONFIG_LIBNL3_ROUTE
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
3be2ebfdcced52e00eda0afe2889839d wpa_supplicant-2.0.tar.gz
|
||||
f2ed8fef72cf63d8d446a2d0a6da630a wpa_supplicant-2.3.tar.gz
|
||||
|
@ -1,7 +1,8 @@
|
||||
From 3de5e59b291b6f58317bb16736f8c0271754378e Mon Sep 17 00:00:00 2001
|
||||
From 818ac0e07c9eaf4bc0026bda7d42718afcf1f92d Mon Sep 17 00:00:00 2001
|
||||
From: Inaky Perez-Gonzalez <inaky.perez-gonzalez@intel.com>
|
||||
Date: Sat, 2 Oct 2010 00:11:51 -0700
|
||||
Subject: [PATCH] eap_peer: create a libeap library, with header files and pkg-config [v2]
|
||||
Subject: [PATCH] eap_peer: create a libeap library, with header files and
|
||||
pkg-config [v2]
|
||||
|
||||
This adds infrastructe in src/eap_peer to make libeap.so and install
|
||||
the needed header files and pkg-config files.
|
||||
@ -30,16 +31,15 @@ term, but serves as an starting point:
|
||||
|
||||
Signed-off-by: Inaky Perez-Gonzalez <inaky.perez-gonzalez@intel.com>
|
||||
---
|
||||
build_release | 12 +++
|
||||
src/eap_peer/Makefile | 191 ++++++++++++++++++++++++++++++++++++++++++--
|
||||
src/eap_peer/eap_methods.c | 114 ++++++++++++++++++++++++++
|
||||
src/eap_peer/eap_methods.h | 1 +
|
||||
src/eap_peer/libeap0.pc | 10 +++
|
||||
5 files changed, 320 insertions(+), 8 deletions(-)
|
||||
src/eap_peer/Makefile | 198 +++++++++++++++++++++++++++++++++++++++++++--
|
||||
src/eap_peer/eap_methods.c | 114 ++++++++++++++++++++++++++
|
||||
src/eap_peer/eap_methods.h | 1 +
|
||||
src/eap_peer/libeap0.pc | 10 +++
|
||||
4 files changed, 315 insertions(+), 8 deletions(-)
|
||||
create mode 100644 src/eap_peer/libeap0.pc
|
||||
|
||||
diff --git a/src/eap_peer/Makefile b/src/eap_peer/Makefile
|
||||
index 3651056..58c067a 100644
|
||||
index f79519b..cedd89f 100644
|
||||
--- a/src/eap_peer/Makefile
|
||||
+++ b/src/eap_peer/Makefile
|
||||
@@ -1,11 +1,193 @@
|
||||
@ -235,8 +235,8 @@ index 3651056..58c067a 100644
|
||||
+ rm -f $(DESTDIR)/usr/$(LIB)/pkgconfig/libeap0.pc
|
||||
|
||||
clean:
|
||||
- rm -f *~ *.o *.so *.d
|
||||
+ rm -f *~ *.o *.so *.d libeap.a $(LIBEAP) $(OBJS_lib)
|
||||
- rm -f *~ *.o *.so *.d *.gcno *.gcda *.gcov
|
||||
+ rm -f *~ *.o *.so *.d *.gcno *.gcda *.gcov libeap.a $(LIBEAP) $(OBJS_lib)
|
||||
|
||||
-install:
|
||||
- if ls *.so >/dev/null 2>&1; then \
|
||||
@ -245,10 +245,10 @@ index 3651056..58c067a 100644
|
||||
- ; fi
|
||||
+-include $(OBJS:%.o=%.d)
|
||||
diff --git a/src/eap_peer/eap_methods.c b/src/eap_peer/eap_methods.c
|
||||
index 3b0af05..092f266 100644
|
||||
index 83a1457..95a41e6 100644
|
||||
--- a/src/eap_peer/eap_methods.c
|
||||
+++ b/src/eap_peer/eap_methods.c
|
||||
@@ -340,6 +340,120 @@ int eap_peer_method_register(struct eap_method *method)
|
||||
@@ -336,6 +336,120 @@ int eap_peer_method_register(struct eap_method *method)
|
||||
|
||||
|
||||
/**
|
||||
@ -370,10 +370,10 @@ index 3b0af05..092f266 100644
|
||||
*
|
||||
* This function is called at program termination to unregister all EAP peer
|
||||
diff --git a/src/eap_peer/eap_methods.h b/src/eap_peer/eap_methods.h
|
||||
index 384c61b..b83a46f 100644
|
||||
index e35c919..da14e42 100644
|
||||
--- a/src/eap_peer/eap_methods.h
|
||||
+++ b/src/eap_peer/eap_methods.h
|
||||
@@ -32,6 +32,7 @@ EapType eap_peer_get_type(const char *name, int *vendor);
|
||||
@@ -26,6 +26,7 @@ EapType eap_peer_get_type(const char *name, int *vendor);
|
||||
const char * eap_get_name(int vendor, EapType type);
|
||||
size_t eap_get_names(char *buf, size_t buflen);
|
||||
char ** eap_get_names_as_string_array(size_t *num);
|
||||
@ -383,7 +383,7 @@ index 384c61b..b83a46f 100644
|
||||
#else /* IEEE8021X_EAPOL */
|
||||
diff --git a/src/eap_peer/libeap0.pc b/src/eap_peer/libeap0.pc
|
||||
new file mode 100644
|
||||
index 0000000..2f8463a
|
||||
index 0000000..594fa2c
|
||||
--- /dev/null
|
||||
+++ b/src/eap_peer/libeap0.pc
|
||||
@@ -0,0 +1,10 @@
|
||||
@ -398,5 +398,5 @@ index 0000000..2f8463a
|
||||
+Libs: -L${libdir} -leap
|
||||
+Cflags: -I${includedir}
|
||||
--
|
||||
1.6.6.1
|
||||
1.9.3
|
||||
|
@ -1,13 +1,18 @@
|
||||
diff -up wpa_supplicant-0.6.7/wpa_supplicant/events.c.scan-results-msg wpa_supplicant-0.6.7/wpa_supplicant/events.c
|
||||
--- wpa_supplicant-0.6.7/wpa_supplicant/events.c.scan-results-msg 2009-01-30 12:08:34.000000000 -0500
|
||||
+++ wpa_supplicant-0.6.7/wpa_supplicant/events.c 2009-01-30 12:08:37.000000000 -0500
|
||||
@@ -911,7 +911,7 @@ static void wpa_supplicant_event_scan_re
|
||||
diff --git a/wpa_supplicant/events.c b/wpa_supplicant/events.c
|
||||
index 49d32c2..f1d1f92 100644
|
||||
--- a/wpa_supplicant/events.c
|
||||
+++ b/wpa_supplicant/events.c
|
||||
@@ -1328,11 +1328,11 @@ static int _wpa_supplicant_event_scan_results(struct wpa_supplicant *wpa_s,
|
||||
wpa_s->own_scan_running, wpa_s->external_scan_running);
|
||||
if (wpa_s->last_scan_req == MANUAL_SCAN_REQ &&
|
||||
wpa_s->manual_scan_use_id && wpa_s->own_scan_running) {
|
||||
- wpa_msg_ctrl(wpa_s, MSG_INFO, WPA_EVENT_SCAN_RESULTS "id=%u",
|
||||
+ wpa_msg_ctrl(wpa_s, MSG_DEBUG, WPA_EVENT_SCAN_RESULTS "id=%u",
|
||||
wpa_s->manual_scan_id);
|
||||
wpa_s->manual_scan_use_id = 0;
|
||||
} else {
|
||||
- wpa_msg_ctrl(wpa_s, MSG_INFO, WPA_EVENT_SCAN_RESULTS);
|
||||
+ wpa_msg_ctrl(wpa_s, MSG_DEBUG, WPA_EVENT_SCAN_RESULTS);
|
||||
}
|
||||
|
||||
wpa_dbg(wpa_s, MSG_DEBUG, "New scan results available");
|
||||
- wpa_msg_ctrl(wpa_s, MSG_INFO, WPA_EVENT_SCAN_RESULTS);
|
||||
+ wpa_msg_ctrl(wpa_s, MSG_DEBUG, WPA_EVENT_SCAN_RESULTS);
|
||||
wpas_notify_scan_results(wpa_s);
|
||||
|
||||
wpas_notify_scan_done(wpa_s, 1);
|
||||
|
||||
|
@ -1,90 +0,0 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
# wpa_supplicant
|
||||
#
|
||||
# chkconfig: - 23 88
|
||||
# description: wpa_supplicant is a WPA Supplicant for Linux, BSD and \
|
||||
# Windows with support for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant \
|
||||
# is the IEEE 802.1X/WPA component that is used in the client stations. \
|
||||
# It implements key negotiation with a WPA Authenticator and it controls \
|
||||
# the roaming and IEEE 802.11 authentication/association of the wlan driver.
|
||||
# processname: wpa_supplicant
|
||||
# config: /etc/wpa_supplicant/wpa_supplicant.conf
|
||||
#
|
||||
### BEGIN INIT INFO
|
||||
# Provides: wpa_supplicant
|
||||
# Required-Start: $local_fs messagebus
|
||||
# Required-Stop: $local_fs messagebus
|
||||
# Default-Start:
|
||||
# Default-Stop: 0 1 6
|
||||
# Short-Description: start and stop wpa_supplicant
|
||||
# Description: wpa_supplicant is a tool for connecting to wireless networks
|
||||
### END INIT INFO
|
||||
|
||||
# Source function library.
|
||||
. /etc/rc.d/init.d/functions
|
||||
|
||||
# Source networking configuration.
|
||||
. /etc/sysconfig/network
|
||||
|
||||
exec="/usr/sbin/wpa_supplicant"
|
||||
prog=$(basename $exec)
|
||||
conf="/etc/wpa_supplicant/wpa_supplicant.conf"
|
||||
lockfile=/var/lock/subsys/$prog
|
||||
|
||||
[ -e /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
|
||||
|
||||
start() {
|
||||
echo -n $"Starting $prog: $conf, $INTERFACES, $DRIVERS"
|
||||
daemon $prog -c $conf $INTERFACES $DRIVERS -B $OTHER_ARGS
|
||||
retval=$?
|
||||
echo
|
||||
[ $retval -eq 0 ] && touch $lockfile
|
||||
return $retval
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo -n $"Stopping $prog: "
|
||||
killproc $prog
|
||||
retval=$?
|
||||
echo
|
||||
[ $retval -eq 0 ] && rm -f $lockfile
|
||||
return $retval
|
||||
}
|
||||
|
||||
restart() {
|
||||
stop
|
||||
start
|
||||
}
|
||||
|
||||
reload() {
|
||||
restart
|
||||
}
|
||||
|
||||
force_reload() {
|
||||
restart
|
||||
}
|
||||
|
||||
fdr_status() {
|
||||
status $prog
|
||||
}
|
||||
|
||||
|
||||
case "$1" in
|
||||
start|stop|restart|reload)
|
||||
$1
|
||||
;;
|
||||
force-reload)
|
||||
force_reload
|
||||
;;
|
||||
status)
|
||||
fdr_status
|
||||
;;
|
||||
condrestart|try-restart)
|
||||
[ -f $lockfile ] && restart
|
||||
;;
|
||||
*)
|
||||
echo $"Usage: $0 {start|stop|status|restart|try-restart|reload|force-reload}"
|
||||
exit 1
|
||||
esac
|
||||
|
@ -6,8 +6,8 @@
|
||||
Summary: WPA/WPA2/IEEE 802.1X Supplicant
|
||||
Name: wpa_supplicant
|
||||
Epoch: 1
|
||||
Version: 2.0
|
||||
Release: 12%{?dist}
|
||||
Version: 2.3
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Base
|
||||
Source0: http://w1.fi/releases/%{name}-%{version}%{rcver}%{snapshot}.tar.gz
|
||||
@ -53,7 +53,7 @@ Patch12: 0002-wpa_cli-Use-os_exec-for-action-script-execution.patch
|
||||
%if %{build_libeap}
|
||||
# Dirty hack for WiMAX
|
||||
# http://linuxwimax.org/Download?action=AttachFile&do=get&target=wpa-1.5-README.txt
|
||||
Patch100: wpa_supplicant-2.0-generate-libeap-peer.patch
|
||||
Patch100: wpa_supplicant-2.3-generate-libeap-peer.patch
|
||||
%endif
|
||||
|
||||
URL: http://w1.fi/wpa_supplicant/
|
||||
@ -119,10 +119,6 @@ Don't use this unless you know what you're doing.
|
||||
%patch6 -p1 -b .qt4
|
||||
%patch7 -p1 -b .libnl3
|
||||
%patch8 -p1 -b .rh837402-less-aggressive-roaming
|
||||
%patch9 -p1 -b .man-page
|
||||
%patch10 -p1 -b .pmksa-clear-fix
|
||||
%patch11 -p1 -b .CVE-2014-3686-1
|
||||
%patch12 -p1 -b .CVE-2014-3686-2
|
||||
|
||||
%build
|
||||
pushd wpa_supplicant
|
||||
@ -141,7 +137,7 @@ pushd wpa_supplicant
|
||||
popd
|
||||
|
||||
pushd wpa_supplicant/doc/docbook
|
||||
make
|
||||
make man
|
||||
popd
|
||||
|
||||
%install
|
||||
@ -270,6 +266,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 30 2014 Lubomir Rintel <lkundrak@v3.sk> - 1:2.3-1
|
||||
- Update to 2.3
|
||||
|
||||
* Wed Oct 22 2014 Dan Williams <dcbw@redhat.com> - 1:2.0-12
|
||||
- Use os_exec() for action script execution (CVE-2014-3686)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user