diff --git a/words.spec b/words.spec
index 025e3dd..c2da3ca 100644
--- a/words.spec
+++ b/words.spec
@@ -22,7 +22,7 @@ passwords.
 %build
 cd mwords
 dos2unix -o *; chmod a+r *
-cat [1-9]*.??? | uniq | grep -E "^[[:alnum:]'&!,./-]+$" | sort --ignore-case > moby
+sort --ignore-case [1-9]*.??? | uniq | grep -E "^[[:alnum:]'&!,./-]+$" > moby
 
 cat <<EOF >license.txt
 On June 1, 1996 Grady Ward announced that the fruits of
@@ -60,6 +60,9 @@ rm -rf $RPM_BUILD_ROOT
 /usr/share/dict/words
 
 %changelog
+* Mon Apr  4 2005 Karel Zak <kzak@redhat.com> 3-3
+- fix uniq command usage
+
 * Tue Mar 29 2005 Karel Zak <kzak@redhat.com> 3-2
 - replace word list with much better Moby Project words list (#61395)
 - revise %%description; ispell/aspell no longer uses words