Update to 1.0.2

This commit is contained in:
Tomas Popela 2017-11-14 07:10:44 +01:00
parent 5b401c4cca
commit b14a0dcbe8
2 changed files with 4 additions and 56 deletions

View File

@ -1,52 +0,0 @@
From 86040accb25e655a5c5617876eaf0878133af7c4 Mon Sep 17 00:00:00 2001
From: Tomas Popela <tpopela@redhat.com>
Date: Mon, 9 Oct 2017 15:27:01 +0200
Subject: [PATCH] Require specific brotli libraries in pkg-config files
---
CMakeLists.txt | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61663bd..68d1c62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -158,7 +158,7 @@ endfunction(generate_pkg_config_path)
function(generate_pkg_config output_file)
set (options)
set (oneValueArgs NAME DESCRIPTION URL VERSION PREFIX LIBDIR INCLUDEDIR)
- set (multiValueArgs DEPENDS_PRIVATE CFLAGS LIBRARIES)
+ set (multiValueArgs DEPENDS DEPENDS_PRIVATE CFLAGS LIBRARIES)
cmake_parse_arguments(GEN_PKG "${options}" "${oneValueArgs}" "${multiValueArgs}" ${ARGN})
unset (options)
unset (oneValueArgs)
@@ -203,6 +203,10 @@ function(generate_pkg_config output_file)
file(APPEND "${output_file}" "Version: ${GEN_PKG_VERSION}\n")
endif()
+ if(GEN_PKG_DEPENDS)
+ file(APPEND "${output_file}" "Requires: ${GEN_PKG_DEPENDS}\n")
+ endif()
+
if(GEN_PKG_DEPENDS_PRIVATE)
file(APPEND "${output_file}" "Requires.private:")
foreach(lib ${GEN_PKG_DEPENDS_PRIVATE})
@@ -242,6 +246,7 @@ generate_pkg_config ("${CMAKE_CURRENT_BINARY_DIR}/libwoff2dec.pc"
DESCRIPTION "WOFF2 decoder library"
URL "https://github.com/google/woff2"
VERSION "${WOFF2_VERSION}"
+ DEPENDS libbrotlidec
DEPENDS_PRIVATE libwoff2common
LIBRARIES woff2dec)
@@ -250,6 +255,7 @@ generate_pkg_config ("${CMAKE_CURRENT_BINARY_DIR}/libwoff2enc.pc"
DESCRIPTION "WOFF2 encoder library"
URL "https://github.com/google/woff2"
VERSION "${WOFF2_VERSION}"
+ DEPENDS libbrotlienc
DEPENDS_PRIVATE libwoff2common
LIBRARIES woff2enc)
--
2.14.2

View File

@ -1,5 +1,5 @@
Name: woff2
Version: 1.0.1
Version: 1.0.2
Release: 1%{?dist}
Summary: Web Open Font Format 2.0 library
@ -7,9 +7,6 @@ License: MIT
URL: https://github.com/google/woff2
Source0: https://github.com/google/woff2/archive/v%{version}/%{name}-%{version}.tar.gz
# https://github.com/google/woff2/pull/95
Patch0: Require-specific-brotli-libraries-in-pkg-config-file.patch
BuildRequires: cmake
BuildRequires: brotli-devel >= 1.0
@ -62,5 +59,8 @@ make %{?_smp_mflags} -C %{_target_platform}
%{_libdir}/pkgconfig/libwoff2enc.pc
%changelog
* Tue Nov 14 2017 Tomas Popela <tpopela@redhat.com> 1.0.2-1
- Update to 1.0.2
* Mon Oct 09 2017 Tomas Popela <tpopela@redhat.com> 1.0.1-1
- Initial import (rhbz#1499676)